Update to 2.18.0
Release notes: https://www.kernel.org/pub/software/scm/git/docs/RelNotes/2.18.0.txt
This commit is contained in:
parent
83950a818e
commit
a66569768e
@ -1,38 +0,0 @@
|
||||
From b611396e97cba09c7e1cf900190cf1a9e922546e Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Linton <lintonrjeremy@gmail.com>
|
||||
Date: Wed, 13 Jun 2018 09:22:07 -0500
|
||||
Subject: [PATCH] packfile: correct zlib buffer handling
|
||||
|
||||
The buffer being passed to zlib includes a NUL terminator that git
|
||||
needs to keep in place. unpack_compressed_entry() attempts to detect
|
||||
the case that the source buffer hasn't been fully consumed by
|
||||
checking to see if the destination buffer has been over consumed.
|
||||
|
||||
This causes a problem, that more recent zlib patches have been
|
||||
poisoning the unconsumed portions of the buffer which overwrites
|
||||
the NUL byte, while correctly returning length and status.
|
||||
|
||||
Let's place the NUL at the end of the buffer after inflate returns
|
||||
to assure that it doesn't result in problems for git even if its
|
||||
been overwritten by zlib.
|
||||
|
||||
Signed-off-by: Jeremy Linton <lintonrjeremy@gmail.com>
|
||||
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||
---
|
||||
packfile.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/packfile.c b/packfile.c
|
||||
index 4a5fe7ab18838..d55569921793e 100644
|
||||
--- a/packfile.c
|
||||
+++ b/packfile.c
|
||||
@@ -1422,6 +1422,9 @@ static void *unpack_compressed_entry(struct packed_git *p,
|
||||
return NULL;
|
||||
}
|
||||
|
||||
+ /* versions of zlib can clobber unconsumed portion of outbuf */
|
||||
+ buffer[size] = '\0';
|
||||
+
|
||||
return buffer;
|
||||
}
|
||||
|
11
git.spec
11
git.spec
@ -79,11 +79,11 @@
|
||||
%endif
|
||||
|
||||
# Define for release candidates
|
||||
%global rcrev .rc2
|
||||
#global rcrev .rc0
|
||||
|
||||
Name: git
|
||||
Version: 2.18.0
|
||||
Release: 0.3%{?rcrev}%{?dist}
|
||||
Release: 1%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
URL: https://git-scm.com/
|
||||
@ -118,10 +118,6 @@ Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
# https://github.com/gitster/git/commit/f2cb01d35
|
||||
# https://public-inbox.org/git/20180601174644.13055-1-phillip.wood@talktalk.net/
|
||||
Patch2: 0001-add-p-fix-counting-empty-context-lines-in-edited-pat.patch
|
||||
# https://bugzilla.redhat.com/1582555
|
||||
# https://github.com/gitster/git/commit/b611396e97.patch
|
||||
# https://public-inbox.org/git/20180525231713.23047-1-lintonrjeremy@gmail.com/
|
||||
Patch3: 0001-packfile-correct-zlib-buffer-handling.patch
|
||||
|
||||
%if %{with docs}
|
||||
BuildRequires: asciidoc >= 8.4.1
|
||||
@ -868,6 +864,9 @@ make test || ./print-failed-test-output
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Wed Jun 20 2018 Todd Zullinger <tmz@pobox.com> - 2.18.0-1
|
||||
- Update to 2.18.0
|
||||
|
||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.18.0-0.3.rc2
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.18.0.rc2.tar.xz) = 928ba97712ac72312445c38fe2313e0908cb0a1896e2b3c826c464431141943e56efe1fcdcdf86b012e3634d9785d255d1b801d1c59fb9011ca0f8558e0383bd
|
||||
SHA512 (git-2.18.0.rc2.tar.sign) = f76f4cd25ba3bf2c990410a8866f670d299cea593d29849e5a92bbe1a0791f645466cb7978f5b18158e292260d71a3aefb48c015b1d4e7c6835883866ad4a521
|
||||
SHA512 (git-2.18.0.tar.xz) = db19363c9c2042248322d49874a27c0614acfb912183725e5d4f0331d6b44cef66a9a7da6a49bd4a17e5d86d30c5fed6bef7527f386494184595a433c4060e46
|
||||
SHA512 (git-2.18.0.tar.sign) = 24826b20ce8e4e1afdb8d84b39f5914d5e29d289be31dfe9083968831294619221787e080c3a395bc105293a1184410527ac3694c465babd447791b0d019cc9b
|
||||
|
Loading…
Reference in New Issue
Block a user