Improve EL-5 compatibility, thanks to Kevin Fenzi for emacs testing
This commit is contained in:
parent
031dd59158
commit
8b78beb4c3
252
git-1.7-el5-emacs-support.patch
Normal file
252
git-1.7-el5-emacs-support.patch
Normal file
@ -0,0 +1,252 @@
|
||||
From 424058e0607b4b3c558d19633090e06e7bd2b851 Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Wed, 2 Feb 2011 21:24:44 -0500
|
||||
Subject: [PATCH] Restore vc-git.el for basic compatibility on EL-5
|
||||
|
||||
This is the vc-git.el from 1.6.4.1, the last version to include it.
|
||||
Most uses will be better served by the vc-git.el which is provided by
|
||||
emacs >= 22.2, but on EL-5 we don't have the luxury of a modern emacs.
|
||||
---
|
||||
contrib/emacs/Makefile | 2 +-
|
||||
contrib/emacs/vc-git.el | 216 +++++++++++++++++++++++++++++++++++++++++++++++
|
||||
2 files changed, 217 insertions(+), 1 deletions(-)
|
||||
create mode 100644 contrib/emacs/vc-git.el
|
||||
|
||||
diff --git a/contrib/emacs/Makefile b/contrib/emacs/Makefile
|
||||
index 24d9312..a48540a 100644
|
||||
--- a/contrib/emacs/Makefile
|
||||
+++ b/contrib/emacs/Makefile
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
EMACS = emacs
|
||||
|
||||
-ELC = git.elc git-blame.elc
|
||||
+ELC = git.elc vc-git.elc git-blame.elc
|
||||
INSTALL ?= install
|
||||
INSTALL_ELC = $(INSTALL) -m 644
|
||||
prefix ?= $(HOME)
|
||||
diff --git a/contrib/emacs/vc-git.el b/contrib/emacs/vc-git.el
|
||||
new file mode 100644
|
||||
index 0000000..b8f6be5
|
||||
--- /dev/null
|
||||
+++ b/contrib/emacs/vc-git.el
|
||||
@@ -0,0 +1,216 @@
|
||||
+;;; vc-git.el --- VC backend for the git version control system
|
||||
+
|
||||
+;; Copyright (C) 2006 Alexandre Julliard
|
||||
+
|
||||
+;; This program is free software; you can redistribute it and/or
|
||||
+;; modify it under the terms of the GNU General Public License as
|
||||
+;; published by the Free Software Foundation; either version 2 of
|
||||
+;; the License, or (at your option) any later version.
|
||||
+;;
|
||||
+;; This program is distributed in the hope that it will be
|
||||
+;; useful, but WITHOUT ANY WARRANTY; without even the implied
|
||||
+;; warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
|
||||
+;; PURPOSE. See the GNU General Public License for more details.
|
||||
+;;
|
||||
+;; You should have received a copy of the GNU General Public
|
||||
+;; License along with this program; if not, write to the Free
|
||||
+;; Software Foundation, Inc., 59 Temple Place, Suite 330, Boston,
|
||||
+;; MA 02111-1307 USA
|
||||
+
|
||||
+;;; Commentary:
|
||||
+
|
||||
+;; This file contains a VC backend for the git version control
|
||||
+;; system.
|
||||
+;;
|
||||
+;; To install: put this file on the load-path and add GIT to the list
|
||||
+;; of supported backends in `vc-handled-backends'; the following line,
|
||||
+;; placed in your ~/.emacs, will accomplish this:
|
||||
+;;
|
||||
+;; (add-to-list 'vc-handled-backends 'GIT)
|
||||
+;;
|
||||
+;; TODO
|
||||
+;; - changelog generation
|
||||
+;; - working with revisions other than HEAD
|
||||
+;;
|
||||
+
|
||||
+(eval-when-compile (require 'cl))
|
||||
+
|
||||
+(defvar git-commits-coding-system 'utf-8
|
||||
+ "Default coding system for git commits.")
|
||||
+
|
||||
+(defun vc-git--run-command-string (file &rest args)
|
||||
+ "Run a git command on FILE and return its output as string."
|
||||
+ (let* ((ok t)
|
||||
+ (str (with-output-to-string
|
||||
+ (with-current-buffer standard-output
|
||||
+ (unless (eq 0 (apply #'call-process "git" nil '(t nil) nil
|
||||
+ (append args (list (file-relative-name file)))))
|
||||
+ (setq ok nil))))))
|
||||
+ (and ok str)))
|
||||
+
|
||||
+(defun vc-git--run-command (file &rest args)
|
||||
+ "Run a git command on FILE, discarding any output."
|
||||
+ (let ((name (file-relative-name file)))
|
||||
+ (eq 0 (apply #'call-process "git" nil (get-buffer "*Messages") nil (append args (list name))))))
|
||||
+
|
||||
+(defun vc-git-registered (file)
|
||||
+ "Check whether FILE is registered with git."
|
||||
+ (with-temp-buffer
|
||||
+ (let* ((dir (file-name-directory file))
|
||||
+ (name (file-relative-name file dir)))
|
||||
+ (and (ignore-errors
|
||||
+ (when dir (cd dir))
|
||||
+ (eq 0 (call-process "git" nil '(t nil) nil "ls-files" "-c" "-z" "--" name)))
|
||||
+ (let ((str (buffer-string)))
|
||||
+ (and (> (length str) (length name))
|
||||
+ (string= (substring str 0 (1+ (length name))) (concat name "\0"))))))))
|
||||
+
|
||||
+(defun vc-git-state (file)
|
||||
+ "git-specific version of `vc-state'."
|
||||
+ (let ((diff (vc-git--run-command-string file "diff-index" "-z" "HEAD" "--")))
|
||||
+ (if (and diff (string-match ":[0-7]\\{6\\} [0-7]\\{6\\} [0-9a-f]\\{40\\} [0-9a-f]\\{40\\} [ADMU]\0[^\0]+\0" diff))
|
||||
+ 'edited
|
||||
+ 'up-to-date)))
|
||||
+
|
||||
+(defun vc-git-workfile-version (file)
|
||||
+ "git-specific version of `vc-workfile-version'."
|
||||
+ (let ((str (with-output-to-string
|
||||
+ (with-current-buffer standard-output
|
||||
+ (call-process "git" nil '(t nil) nil "symbolic-ref" "HEAD")))))
|
||||
+ (if (string-match "^\\(refs/heads/\\)?\\(.+\\)$" str)
|
||||
+ (match-string 2 str)
|
||||
+ str)))
|
||||
+
|
||||
+(defun vc-git-symbolic-commit (commit)
|
||||
+ "Translate COMMIT string into symbolic form.
|
||||
+Returns nil if not possible."
|
||||
+ (and commit
|
||||
+ (with-temp-buffer
|
||||
+ (and
|
||||
+ (zerop
|
||||
+ (call-process "git" nil '(t nil) nil "name-rev"
|
||||
+ "--name-only" "--tags"
|
||||
+ commit))
|
||||
+ (goto-char (point-min))
|
||||
+ (= (forward-line 2) 1)
|
||||
+ (bolp)
|
||||
+ (buffer-substring-no-properties (point-min) (1- (point-max)))))))
|
||||
+
|
||||
+(defun vc-git-previous-version (file rev)
|
||||
+ "git-specific version of `vc-previous-version'."
|
||||
+ (let ((default-directory (file-name-directory (expand-file-name file)))
|
||||
+ (file (file-name-nondirectory file)))
|
||||
+ (vc-git-symbolic-commit
|
||||
+ (with-temp-buffer
|
||||
+ (and
|
||||
+ (zerop
|
||||
+ (call-process "git" nil '(t nil) nil "rev-list"
|
||||
+ "-2" rev "--" file))
|
||||
+ (goto-char (point-max))
|
||||
+ (bolp)
|
||||
+ (zerop (forward-line -1))
|
||||
+ (not (bobp))
|
||||
+ (buffer-substring-no-properties
|
||||
+ (point)
|
||||
+ (1- (point-max))))))))
|
||||
+
|
||||
+(defun vc-git-next-version (file rev)
|
||||
+ "git-specific version of `vc-next-version'."
|
||||
+ (let* ((default-directory (file-name-directory
|
||||
+ (expand-file-name file)))
|
||||
+ (file (file-name-nondirectory file))
|
||||
+ (current-rev
|
||||
+ (with-temp-buffer
|
||||
+ (and
|
||||
+ (zerop
|
||||
+ (call-process "git" nil '(t nil) nil "rev-list"
|
||||
+ "-1" rev "--" file))
|
||||
+ (goto-char (point-max))
|
||||
+ (bolp)
|
||||
+ (zerop (forward-line -1))
|
||||
+ (bobp)
|
||||
+ (buffer-substring-no-properties
|
||||
+ (point)
|
||||
+ (1- (point-max)))))))
|
||||
+ (and current-rev
|
||||
+ (vc-git-symbolic-commit
|
||||
+ (with-temp-buffer
|
||||
+ (and
|
||||
+ (zerop
|
||||
+ (call-process "git" nil '(t nil) nil "rev-list"
|
||||
+ "HEAD" "--" file))
|
||||
+ (goto-char (point-min))
|
||||
+ (search-forward current-rev nil t)
|
||||
+ (zerop (forward-line -1))
|
||||
+ (buffer-substring-no-properties
|
||||
+ (point)
|
||||
+ (progn (forward-line 1) (1- (point))))))))))
|
||||
+
|
||||
+(defun vc-git-revert (file &optional contents-done)
|
||||
+ "Revert FILE to the version stored in the git repository."
|
||||
+ (if contents-done
|
||||
+ (vc-git--run-command file "update-index" "--")
|
||||
+ (vc-git--run-command file "checkout" "HEAD")))
|
||||
+
|
||||
+(defun vc-git-checkout-model (file)
|
||||
+ 'implicit)
|
||||
+
|
||||
+(defun vc-git-workfile-unchanged-p (file)
|
||||
+ (let ((sha1 (vc-git--run-command-string file "hash-object" "--"))
|
||||
+ (head (vc-git--run-command-string file "ls-tree" "-z" "HEAD" "--")))
|
||||
+ (and head
|
||||
+ (string-match "[0-7]\\{6\\} blob \\([0-9a-f]\\{40\\}\\)\t[^\0]+\0" head)
|
||||
+ (string= (car (split-string sha1 "\n")) (match-string 1 head)))))
|
||||
+
|
||||
+(defun vc-git-register (file &optional rev comment)
|
||||
+ "Register FILE into the git version-control system."
|
||||
+ (vc-git--run-command file "update-index" "--add" "--"))
|
||||
+
|
||||
+(defun vc-git-print-log (file &optional buffer)
|
||||
+ (let ((name (file-relative-name file))
|
||||
+ (coding-system-for-read git-commits-coding-system))
|
||||
+ (vc-do-command buffer 'async "git" name "rev-list" "--pretty" "HEAD" "--")))
|
||||
+
|
||||
+(defun vc-git-diff (file &optional rev1 rev2 buffer)
|
||||
+ (let ((name (file-relative-name file))
|
||||
+ (buf (or buffer "*vc-diff*")))
|
||||
+ (if (and rev1 rev2)
|
||||
+ (vc-do-command buf 0 "git" name "diff-tree" "-p" rev1 rev2 "--")
|
||||
+ (vc-do-command buf 0 "git" name "diff-index" "-p" (or rev1 "HEAD") "--"))
|
||||
+ ; git-diff-index doesn't set exit status like diff does
|
||||
+ (if (vc-git-workfile-unchanged-p file) 0 1)))
|
||||
+
|
||||
+(defun vc-git-checkin (file rev comment)
|
||||
+ (let ((coding-system-for-write git-commits-coding-system))
|
||||
+ (vc-git--run-command file "commit" "-m" comment "--only" "--")))
|
||||
+
|
||||
+(defun vc-git-checkout (file &optional editable rev destfile)
|
||||
+ (if destfile
|
||||
+ (let ((fullname (substring
|
||||
+ (vc-git--run-command-string file "ls-files" "-z" "--full-name" "--")
|
||||
+ 0 -1))
|
||||
+ (coding-system-for-read 'no-conversion)
|
||||
+ (coding-system-for-write 'no-conversion))
|
||||
+ (with-temp-file destfile
|
||||
+ (eq 0 (call-process "git" nil t nil "cat-file" "blob"
|
||||
+ (concat (or rev "HEAD") ":" fullname)))))
|
||||
+ (vc-git--run-command file "checkout" (or rev "HEAD"))))
|
||||
+
|
||||
+(defun vc-git-annotate-command (file buf &optional rev)
|
||||
+ ; FIXME: rev is ignored
|
||||
+ (let ((name (file-relative-name file)))
|
||||
+ (call-process "git" nil buf nil "blame" name)))
|
||||
+
|
||||
+(defun vc-git-annotate-time ()
|
||||
+ (and (re-search-forward "[0-9a-f]+ (.* \\([0-9]+\\)-\\([0-9]+\\)-\\([0-9]+\\) \\([0-9]+\\):\\([0-9]+\\):\\([0-9]+\\) \\([-+0-9]+\\) +[0-9]+)" nil t)
|
||||
+ (vc-annotate-convert-time
|
||||
+ (apply #'encode-time (mapcar (lambda (match) (string-to-number (match-string match))) '(6 5 4 3 2 1 7))))))
|
||||
+
|
||||
+;; Not really useful since we can't do anything with the revision yet
|
||||
+;;(defun vc-annotate-extract-revision-at-line ()
|
||||
+;; (save-excursion
|
||||
+;; (move-beginning-of-line 1)
|
||||
+;; (and (looking-at "[0-9a-f]+")
|
||||
+;; (buffer-substring (match-beginning 0) (match-end 0)))))
|
||||
+
|
||||
+(provide 'vc-git)
|
||||
--
|
||||
1.7.3.4
|
||||
|
33
git.spec
33
git.spec
@ -23,11 +23,15 @@ Patch0: git-1.5-gitweb-home-link.patch
|
||||
Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
# https://bugzilla.redhat.com/500137
|
||||
Patch2: git-1.6-update-contrib-hooks-path.patch
|
||||
# https://bugzilla.redhat.com/600411
|
||||
Patch3: git-1.7-el5-emacs-support.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 5
|
||||
BuildRequires: emacs
|
||||
%endif
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
BuildRequires: emacs >= 22.2
|
||||
BuildRequires: libcurl-devel
|
||||
%else
|
||||
BuildRequires: curl-devel
|
||||
@ -81,7 +85,7 @@ Requires: git-gui = %{version}-%{release}
|
||||
Requires: git-svn = %{version}-%{release}
|
||||
Requires: gitk = %{version}-%{release}
|
||||
Requires: perl-Git = %{version}-%{release}
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 5
|
||||
Requires: emacs-git = %{version}-%{release}
|
||||
%endif
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 5
|
||||
@ -202,12 +206,17 @@ Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $versi
|
||||
%description -n perl-Git
|
||||
Perl interface to Git.
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 5
|
||||
%package -n emacs-git
|
||||
Summary: Git version control system support for Emacs
|
||||
Group: Applications/Editors
|
||||
Requires: git = %{version}-%{release}
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
BuildArch: noarch
|
||||
Requires: git = %{version}-%{release}, emacs(bin) >= %{_emacs_version}
|
||||
Requires: emacs(bin) >= %{_emacs_version}
|
||||
%else
|
||||
Requires: emacs-common
|
||||
%endif
|
||||
|
||||
%description -n emacs-git
|
||||
%{summary}.
|
||||
@ -215,7 +224,9 @@ Requires: git = %{version}-%{release}, emacs(bin) >= %{_emacs_version}
|
||||
%package -n emacs-git-el
|
||||
Summary: Elisp source files for git version control system support for Emacs
|
||||
Group: Applications/Editors
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
Requires: emacs-git = %{version}-%{release}
|
||||
|
||||
%description -n emacs-git-el
|
||||
@ -227,6 +238,9 @@ Requires: emacs-git = %{version}-%{release}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%if 0%{?rhel} == 5
|
||||
%patch3 -p1
|
||||
%endif
|
||||
|
||||
# Use these same options for every invocation of 'make'.
|
||||
# Otherwise it will rebuild in %%install due to flags changes.
|
||||
@ -270,7 +284,7 @@ chmod +x %{__perl_requires}
|
||||
%build
|
||||
make %{?_smp_mflags} all %{!?_without_docs: doc}
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 5
|
||||
make -C contrib/emacs
|
||||
%endif
|
||||
|
||||
@ -281,7 +295,11 @@ sed -i '/^#!bash/,+1 d' contrib/completion/git-completion.bash
|
||||
rm -rf %{buildroot}
|
||||
make %{?_smp_mflags} INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 5
|
||||
%if 0%{?rhel} == 5
|
||||
%global _emacs_sitelispdir %{_datadir}/emacs/site-lisp
|
||||
%global _emacs_sitestartdir %{_emacs_sitelispdir}/site-start.d
|
||||
%endif
|
||||
%global elispdir %{_emacs_sitelispdir}/git
|
||||
make -C contrib/emacs install \
|
||||
emacsdir=%{buildroot}%{elispdir}
|
||||
@ -420,7 +438,7 @@ rm -rf %{buildroot}
|
||||
%files -n perl-Git -f perl-files
|
||||
%defattr(-,root,root)
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 5
|
||||
%files -n emacs-git
|
||||
%defattr(-,root,root)
|
||||
%doc contrib/emacs/README
|
||||
@ -456,6 +474,7 @@ rm -rf %{buildroot}
|
||||
%changelog
|
||||
* Sun Feb 13 2011 Todd Zullinger <tmz@pobox.com> - 1.7.4.1-1
|
||||
- Update to 1.7.4.1
|
||||
- Improve EL-5 compatibility, thanks to Kevin Fenzi for emacs testing
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user