Update to 2.43.0
Resolves: RHEL-17100
This commit is contained in:
parent
dbc369af71
commit
79e45c2262
@ -1,16 +1,16 @@
|
||||
diff -ur a/builtin/receive-pack.c b/builtin/receive-pack.c
|
||||
--- a/builtin/receive-pack.c 2022-10-07 06:48:26.000000000 +0200
|
||||
+++ b/builtin/receive-pack.c 2022-11-21 16:34:02.417278135 +0100
|
||||
@@ -30,6 +30,8 @@
|
||||
#include "commit-reach.h"
|
||||
diff -ur b/builtin/receive-pack.c a/builtin/receive-pack.c
|
||||
--- b/builtin/receive-pack.c 2023-11-20 03:07:41.000000000 +0100
|
||||
+++ a/builtin/receive-pack.c 2023-12-06 15:34:28.294170714 +0100
|
||||
@@ -40,6 +40,8 @@
|
||||
#include "worktree.h"
|
||||
#include "shallow.h"
|
||||
#include "parse-options.h"
|
||||
+#include <openssl/hmac.h>
|
||||
+#include <openssl/evp.h>
|
||||
|
||||
static const char * const receive_pack_usage[] = {
|
||||
N_("git receive-pack <git-dir>"),
|
||||
@@ -528,43 +530,11 @@
|
||||
@@ -538,43 +540,11 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -56,10 +56,10 @@ diff -ur a/builtin/receive-pack.c b/builtin/receive-pack.c
|
||||
}
|
||||
|
||||
static char *prepare_push_cert_nonce(const char *path, timestamp_t stamp)
|
||||
diff -ur a/Makefile b/Makefile
|
||||
--- a/Makefile 2022-10-07 06:48:26.000000000 +0200
|
||||
+++ b/Makefile 2022-11-21 16:35:56.986792752 +0100
|
||||
@@ -2008,6 +2008,8 @@
|
||||
diff -ur b/Makefile a/Makefile
|
||||
--- b/Makefile 2023-11-20 03:07:41.000000000 +0100
|
||||
+++ a/Makefile 2023-12-06 15:35:08.506316431 +0100
|
||||
@@ -2123,6 +2123,8 @@
|
||||
EXTLIBS += -lcrypto -lssl
|
||||
endif
|
||||
|
9
git.spec
9
git.spec
@ -99,7 +99,7 @@
|
||||
#global rcrev .rc0
|
||||
|
||||
Name: git
|
||||
Version: 2.39.3
|
||||
Version: 2.43.0
|
||||
Release: 1%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
@ -131,8 +131,9 @@ Source99: print-failed-test-output
|
||||
|
||||
# https://bugzilla.redhat.com/490602
|
||||
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
|
||||
# https://bugzilla.redhat.com/1956345
|
||||
Patch1: git-2.38.1-core-crypto-hmac.patch
|
||||
Patch1: git-2.43.0-core-crypto-hmac.patch
|
||||
|
||||
# https://bugzilla.redhat.com/2114531
|
||||
# tests: try harder to find open ports for apache, git, and svn
|
||||
@ -1117,6 +1118,10 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Wed Dec 06 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.0-1
|
||||
- Update to 2.43.0
|
||||
- Resolves: RHEL-17100
|
||||
|
||||
* Wed Apr 26 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.39.3-1
|
||||
- Update to 2.39.3
|
||||
- Resolves: #2188363, #2188353, #2189872, #2189873
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.39.3.tar.xz) = ddd9f41df9d59aedaddb3a3cd551c105903b5f8c86455d4d05a8342920d67754b358b6ab0d6c10cca743b8e0e621baea16f71a9d6290f4d37297a9c45e8b3763
|
||||
SHA512 (git-2.39.3.tar.sign) = aeb123a7ed4537b58bf97ab46474a28c1f0390a024e37efca30044e4d0ae8b4ae6b65b747581913464fc8f6d23d43466db1b3a874cd41314eb35dbe6ebdc51f5
|
||||
SHA512 (git-2.43.0.tar.xz) = d0c1694ae23ff7d523e617b98d7c9a9753a2ee58f92c21b67a192d1c57398a62ff9c1a34558ae31af8dc8d95122c219f39f654e99a3b4e7cfc3dd07be9e13203
|
||||
SHA512 (git-2.43.0.tar.sign) = 4ff055db9b7100c40427a570f8fb6ec4b5ea943d197597ca8061924afbc6eb46d28aaf46c31679addb8adaf4f672e7efb96e088b789d172b5270420a7e5fde67
|
||||
|
Loading…
Reference in New Issue
Block a user