Update to 1.8.4.2 (#1024497)
This commit is contained in:
parent
6d6415cb30
commit
526bc47a2a
@ -1,4 +1,4 @@
|
|||||||
From 86c3e2b5188579bff1ff981910462ad5e563044b Mon Sep 17 00:00:00 2001
|
From a906459c2a89938e911f1650e6ce22315a1ec84d Mon Sep 17 00:00:00 2001
|
||||||
From: Todd Zullinger <tmz@pobox.com>
|
From: Todd Zullinger <tmz@pobox.com>
|
||||||
Date: Fri, 4 Jan 2013 11:54:21 -0500
|
Date: Fri, 4 Jan 2013 11:54:21 -0500
|
||||||
Subject: [PATCH] git-subtree: Use gitexecdir instead of libexecdir
|
Subject: [PATCH] git-subtree: Use gitexecdir instead of libexecdir
|
||||||
@ -10,11 +10,11 @@ consistently.
|
|||||||
|
|
||||||
Remove the unused gitdir variable as well.
|
Remove the unused gitdir variable as well.
|
||||||
---
|
---
|
||||||
contrib/subtree/Makefile | 5 ++---
|
contrib/subtree/Makefile | 7 +++----
|
||||||
1 files changed, 2 insertions(+), 3 deletions(-)
|
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
diff --git a/contrib/subtree/Makefile b/contrib/subtree/Makefile
|
diff --git a/contrib/subtree/Makefile b/contrib/subtree/Makefile
|
||||||
index 36ae3e4..f87b945 100644
|
index 435b2de..dc8da19 100644
|
||||||
--- a/contrib/subtree/Makefile
|
--- a/contrib/subtree/Makefile
|
||||||
+++ b/contrib/subtree/Makefile
|
+++ b/contrib/subtree/Makefile
|
||||||
@@ -2,9 +2,8 @@
|
@@ -2,9 +2,8 @@
|
||||||
@ -28,15 +28,17 @@ index 36ae3e4..f87b945 100644
|
|||||||
man1dir ?= $(mandir)/man1
|
man1dir ?= $(mandir)/man1
|
||||||
|
|
||||||
gitver ?= $(word 3,$(shell git --version))
|
gitver ?= $(word 3,$(shell git --version))
|
||||||
@@ -30,7 +29,7 @@ $(GIT_SUBTREE): $(GIT_SUBTREE_SH)
|
@@ -30,8 +29,8 @@ $(GIT_SUBTREE): $(GIT_SUBTREE_SH)
|
||||||
doc: $(GIT_SUBTREE_DOC)
|
doc: $(GIT_SUBTREE_DOC)
|
||||||
|
|
||||||
install: $(GIT_SUBTREE)
|
install: $(GIT_SUBTREE)
|
||||||
|
- $(INSTALL) -d -m 755 $(DESTDIR)$(libexecdir)
|
||||||
- $(INSTALL) -m 755 $(GIT_SUBTREE) $(DESTDIR)$(libexecdir)
|
- $(INSTALL) -m 755 $(GIT_SUBTREE) $(DESTDIR)$(libexecdir)
|
||||||
|
+ $(INSTALL) -d -m 755 $(DESTDIR)$(gitexecdir)
|
||||||
+ $(INSTALL) -m 755 $(GIT_SUBTREE) $(DESTDIR)$(gitexecdir)
|
+ $(INSTALL) -m 755 $(GIT_SUBTREE) $(DESTDIR)$(gitexecdir)
|
||||||
|
|
||||||
install-doc: install-man
|
install-doc: install-man
|
||||||
|
|
||||||
--
|
--
|
||||||
1.7.6
|
1.8.3.1
|
||||||
|
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up git-1.7.2/gitweb/gitweb.perl.orig git-1.7.2/gitweb/gitweb.perl
|
|
||||||
--- git-1.7.2/gitweb/gitweb.perl.orig 2010-07-21 23:35:25.000000000 +0200
|
|
||||||
+++ git-1.7.2/gitweb/gitweb.perl 2010-07-22 10:49:50.385707086 +0200
|
|
||||||
@@ -79,7 +79,7 @@ our $projectroot = "++GITWEB_PROJECTROOT
|
|
||||||
our $project_maxdepth = "++GITWEB_PROJECT_MAXDEPTH++";
|
|
||||||
|
|
||||||
# string of the home link on top of all pages
|
|
||||||
-our $home_link_str = "++GITWEB_HOME_LINK_STR++";
|
|
||||||
+our $home_link_str = $ENV{'SERVER_NAME'} ? "git://" . $ENV{'SERVER_NAME'} : "projects";
|
|
||||||
|
|
||||||
# name of your site or organization to appear in page titles
|
|
||||||
# replace this with something more descriptive for clearer bookmarks
|
|
12
git-1.8-gitweb-home-link.patch
Normal file
12
git-1.8-gitweb-home-link.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up git-1.8.4.2/gitweb/gitweb.perl.orig git-1.8.4.2/gitweb/gitweb.perl
|
||||||
|
--- git-1.8.4.2/gitweb/gitweb.perl.orig 2013-10-28 14:17:38.000000000 -0400
|
||||||
|
+++ git-1.8.4.2/gitweb/gitweb.perl 2013-10-29 16:49:07.302747507 -0400
|
||||||
|
@@ -83,7 +83,7 @@ our $projectroot = "++GITWEB_PROJECTROOT
|
||||||
|
our $project_maxdepth = "++GITWEB_PROJECT_MAXDEPTH++";
|
||||||
|
|
||||||
|
# string of the home link on top of all pages
|
||||||
|
-our $home_link_str = "++GITWEB_HOME_LINK_STR++";
|
||||||
|
+our $home_link_str = $ENV{'SERVER_NAME'} ? "git://" . $ENV{'SERVER_NAME'} : "projects";
|
||||||
|
|
||||||
|
# extra breadcrumbs preceding the home link
|
||||||
|
our @extra_breadcrumbs = ();
|
9
git.spec
9
git.spec
@ -50,8 +50,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: git
|
Name: git
|
||||||
Version: 1.8.3.1
|
Version: 1.8.4.2
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Fast Version Control System
|
Summary: Fast Version Control System
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -66,7 +66,7 @@ Source10: http://git-core.googlecode.com/files/%{name}-manpages-%{version}
|
|||||||
Source11: http://git-core.googlecode.com/files/%{name}-htmldocs-%{version}.tar.gz
|
Source11: http://git-core.googlecode.com/files/%{name}-htmldocs-%{version}.tar.gz
|
||||||
Source12: git.service
|
Source12: git.service
|
||||||
Source13: git.socket
|
Source13: git.socket
|
||||||
Patch0: git-1.5-gitweb-home-link.patch
|
Patch0: git-1.8-gitweb-home-link.patch
|
||||||
# https://bugzilla.redhat.com/490602
|
# https://bugzilla.redhat.com/490602
|
||||||
Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||||
# https://bugzilla.redhat.com/600411
|
# https://bugzilla.redhat.com/600411
|
||||||
@ -641,6 +641,9 @@ rm -rf %{buildroot}
|
|||||||
# No files for you!
|
# No files for you!
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 29 2013 Todd Zullinger <tmz@pobox.com> - 1.8.4.2-1
|
||||||
|
- Update to 1.8.4.2 (#1024497)
|
||||||
|
|
||||||
* Sat Oct 05 2013 Todd Zullinger <tmz@pobox.com>
|
* Sat Oct 05 2013 Todd Zullinger <tmz@pobox.com>
|
||||||
- Add mercurial version requirement to git-hg, for those rebuilding on EL
|
- Add mercurial version requirement to git-hg, for those rebuilding on EL
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
35401b410e7f248b13e35a1069aca2e2 git-1.8.3.1.tar.gz
|
6f63d103465b86ca0ebe4189ea54731c git-1.8.4.2.tar.gz
|
||||||
bc031fe54e61c1635eba2b08341ece16 git-htmldocs-1.8.3.1.tar.gz
|
c76a6755d109bd2881da6813dac69153 git-htmldocs-1.8.4.2.tar.gz
|
||||||
3f801cc82a58c2c2ceeab95975114113 git-manpages-1.8.3.1.tar.gz
|
2b4719ec820d845134b689247abe65e8 git-manpages-1.8.4.2.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user