Update to git-1.6.2
- Include contrib/emacs/README in emacs subpackage - Drop upstreamed git-web--browse patch
This commit is contained in:
parent
33e67f8a54
commit
3fb48f5afa
@ -1 +1 @@
|
||||
git-1.6.1.3.tar.bz2
|
||||
git-1.6.2.tar.bz2
|
||||
|
@ -1,33 +0,0 @@
|
||||
From e44161a223e7ec2cfb1f1b71399b995626c2d208 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <e44161a223e7ec2cfb1f1b71399b995626c2d208.1234127422.git.tmz@pobox.com>
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Sun, 8 Feb 2009 14:04:20 -0500
|
||||
Subject: [PATCH 1/2] git-web--browse: Fix check for /bin/start
|
||||
|
||||
The previous check in git-web--browse for /bin/start used test -n
|
||||
/bin/start, which was always true. This lead to "start" being tried
|
||||
first in the browser list. On systems with upstart installed, "start"
|
||||
exists and might be in the PATH, but it makes a poor choice for a web
|
||||
browser. Instead, test that /bin/start exists and is executable.
|
||||
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
git-web--browse.sh | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/git-web--browse.sh b/git-web--browse.sh
|
||||
index 78d236b..7ed0fad 100755
|
||||
--- a/git-web--browse.sh
|
||||
+++ b/git-web--browse.sh
|
||||
@@ -115,7 +115,7 @@ if test -z "$browser" ; then
|
||||
browser_candidates="open $browser_candidates"
|
||||
fi
|
||||
# /bin/start indicates MinGW
|
||||
- if test -n /bin/start; then
|
||||
+ if test -x /bin/start; then
|
||||
browser_candidates="start $browser_candidates"
|
||||
fi
|
||||
|
||||
--
|
||||
1.6.1.3
|
||||
|
13
git.spec
13
git.spec
@ -1,7 +1,7 @@
|
||||
# Pass --without docs to rpmbuild if you don't want the documentation
|
||||
Name: git
|
||||
Version: 1.6.1.3
|
||||
Release: 2%{?dist}
|
||||
Version: 1.6.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Core git tools
|
||||
License: GPLv2
|
||||
Group: Development/Tools
|
||||
@ -11,8 +11,6 @@ Source1: git-init.el
|
||||
Source2: git.xinetd
|
||||
Source3: git.conf.httpd
|
||||
Patch0: git-1.5-gitweb-home-link.patch
|
||||
# Included upstream as f6b98e4, tmz
|
||||
Patch1: 0001-git-web-browse-Fix-check-for-bin-start.patch
|
||||
BuildRequires: zlib-devel >= 1.2, openssl-devel, libcurl-devel, expat-devel, emacs, gettext %{!?_without_docs:, xmlto, asciidoc > 6.0.3}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -142,7 +140,6 @@ Requires: git = %{version}-%{release}, emacs-common
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
# Use these same options for every invocation of 'make'.
|
||||
# Otherwise it will rebuild in %%install due to flags changes.
|
||||
@ -268,6 +265,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files -n emacs-git
|
||||
%defattr(-,root,root)
|
||||
%doc contrib/emacs/README
|
||||
%{_datadir}/emacs/site-lisp/*git*.el*
|
||||
%{_datadir}/emacs/site-lisp/site-start.d/git-init.el
|
||||
|
||||
@ -290,6 +288,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
# No files for you!
|
||||
|
||||
%changelog
|
||||
* Mon Mar 09 2009 Todd Zullinger <tmz@pobox.com> - 1.6.2-1
|
||||
- git-1.6.2
|
||||
- Include contrib/emacs/README in emacs subpackage
|
||||
- Drop upstreamed git-web--browse patch
|
||||
|
||||
* Tue Feb 24 2009 Todd Zullinger <tmz@pobox.com> - 1.6.1.3-2
|
||||
- Require perl(Authen::SASL) in git-email (bug 483062)
|
||||
- Build many of the subpackages as noarch
|
||||
|
Loading…
Reference in New Issue
Block a user