update to 2.42.1
This commit is contained in:
parent
7edc80fb3b
commit
3b9b7132cc
86
0001-send-email-avoid-duplicate-specification-warnings.patch
Normal file
86
0001-send-email-avoid-duplicate-specification-warnings.patch
Normal file
@ -0,0 +1,86 @@
|
||||
From 0fdc014acc342dace179ba698e58fcb138fb86de Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Tue, 14 Nov 2023 11:38:19 -0500
|
||||
Subject: [PATCH] send-email: avoid duplicate specification warnings
|
||||
|
||||
With perl-Getopt-Long >= 2.55, a warning is issued for options which are
|
||||
specified more than once. In addition to causing users to see warnings,
|
||||
this results in test failures which compare the output. An example,
|
||||
from t9001-send-email.37:
|
||||
|
||||
| +++ diff -u expect actual
|
||||
| --- expect 2023-11-14 10:38:23.854346488 +0000
|
||||
| +++ actual 2023-11-14 10:38:23.848346466 +0000
|
||||
| @@ -1,2 +1,7 @@
|
||||
| +Duplicate specification "no-chain-reply-to" for option "no-chain-reply-to"
|
||||
| +Duplicate specification "to-cover|to-cover!" for option "to-cover"
|
||||
| +Duplicate specification "cc-cover|cc-cover!" for option "cc-cover"
|
||||
| +Duplicate specification "no-thread" for option "no-thread"
|
||||
| +Duplicate specification "no-to-cover" for option "no-to-cover"
|
||||
| fatal: longline.patch:35 is longer than 998 characters
|
||||
| warning: no patches were sent
|
||||
| error: last command exited with $?=1
|
||||
| not ok 37 - reject long lines
|
||||
|
||||
Remove the duplicate option specs.
|
||||
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
git-send-email.perl | 16 +++-------------
|
||||
1 file changed, 3 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/git-send-email.perl b/git-send-email.perl
|
||||
index affbb88509..3c678c8998 100755
|
||||
--- a/git-send-email.perl
|
||||
+++ b/git-send-email.perl
|
||||
@@ -503,7 +503,6 @@ sub config_regexp {
|
||||
"bcc=s" => \@getopt_bcc,
|
||||
"no-bcc" => \$no_bcc,
|
||||
"chain-reply-to!" => \$chain_reply_to,
|
||||
- "no-chain-reply-to" => sub {$chain_reply_to = 0},
|
||||
"sendmail-cmd=s" => \$sendmail_cmd,
|
||||
"smtp-server=s" => \$smtp_server,
|
||||
"smtp-server-option=s" => \@smtp_server_options,
|
||||
@@ -518,36 +517,27 @@ sub config_regexp {
|
||||
"smtp-auth=s" => \$smtp_auth,
|
||||
"no-smtp-auth" => sub {$smtp_auth = 'none'},
|
||||
"annotate!" => \$annotate,
|
||||
- "no-annotate" => sub {$annotate = 0},
|
||||
"compose" => \$compose,
|
||||
"quiet" => \$quiet,
|
||||
"cc-cmd=s" => \$cc_cmd,
|
||||
"header-cmd=s" => \$header_cmd,
|
||||
"no-header-cmd" => \$no_header_cmd,
|
||||
"suppress-from!" => \$suppress_from,
|
||||
- "no-suppress-from" => sub {$suppress_from = 0},
|
||||
"suppress-cc=s" => \@suppress_cc,
|
||||
- "signed-off-cc|signed-off-by-cc!" => \$signed_off_by_cc,
|
||||
- "no-signed-off-cc|no-signed-off-by-cc" => sub {$signed_off_by_cc = 0},
|
||||
- "cc-cover|cc-cover!" => \$cover_cc,
|
||||
- "no-cc-cover" => sub {$cover_cc = 0},
|
||||
- "to-cover|to-cover!" => \$cover_to,
|
||||
- "no-to-cover" => sub {$cover_to = 0},
|
||||
+ "signed-off-by-cc!" => \$signed_off_by_cc,
|
||||
+ "cc-cover!" => \$cover_cc,
|
||||
+ "to-cover!" => \$cover_to,
|
||||
"confirm=s" => \$confirm,
|
||||
"dry-run" => \$dry_run,
|
||||
"envelope-sender=s" => \$envelope_sender,
|
||||
"thread!" => \$thread,
|
||||
- "no-thread" => sub {$thread = 0},
|
||||
"validate!" => \$validate,
|
||||
- "no-validate" => sub {$validate = 0},
|
||||
"transfer-encoding=s" => \$target_xfer_encoding,
|
||||
"format-patch!" => \$format_patch,
|
||||
- "no-format-patch" => sub {$format_patch = 0},
|
||||
"8bit-encoding=s" => \$auto_8bit_encoding,
|
||||
"compose-encoding=s" => \$compose_encoding,
|
||||
"force" => \$force,
|
||||
"xmailer!" => \$use_xmailer,
|
||||
- "no-xmailer" => sub {$use_xmailer = 0},
|
||||
"batch-size=i" => \$batch_size,
|
||||
"relogin-delay=i" => \$relogin_delay,
|
||||
"git-completion-helper" => \$git_completion_helper,
|
||||
--
|
||||
2.42.0
|
||||
|
10
git.spec
10
git.spec
@ -77,8 +77,8 @@
|
||||
%global _package_note_file %{_builddir}/%{name}-%{real_version}/.package_note-%{name}-%{version}-%{release}.%{_arch}.ld
|
||||
|
||||
Name: git
|
||||
Version: 2.42.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.42.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: BSD-3-Clause AND GPL-2.0-only AND GPL-2.0-or-later AND LGPL-2.1-or-later AND MIT
|
||||
URL: https://git-scm.com/
|
||||
@ -127,6 +127,9 @@ Patch2: 0002-t-lib-git-daemon-try-harder-to-find-a-port.patch
|
||||
# https://github.com/tmzullinger/git/commit/aa5105dc11
|
||||
Patch3: 0003-t-lib-git-svn-try-harder-to-find-a-port.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2247532#c8
|
||||
Patch4: 0001-send-email-avoid-duplicate-specification-warnings.patch
|
||||
|
||||
%if %{with docs}
|
||||
# pod2man is needed to build Git.3pm
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
@ -1041,6 +1044,9 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Tue Nov 14 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.42.1-1
|
||||
- update to 2.42.1
|
||||
|
||||
* Wed Nov 1 2023 Joe Orton <jorton@redhat.com> - 2.42.0-2
|
||||
- remove explicit BR for apr-util-bdb (#2247532)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.42.0.tar.xz) = afe5bca3c084d4ddd66f20afa820ba10f61007f66846108929e0d4ee7b7eaa896fcf00917dead16881d840f674dec6dd0e353a05e62a31016694af3d7d22a51d
|
||||
SHA512 (git-2.42.0.tar.sign) = 847914db4f035095643cf38af87e53be82b0d10c0fdcb862f5015df01662c15d6d77410e4f4aaa5ad510d9d82c830a0218465d10905f3ec048929b1c02be6d5d
|
||||
SHA512 (git-2.42.1.tar.xz) = 5946699108d4181e14fc3c61e4a4ebadcf8a876248c3f570ca22e6d95d8fea4eeb424d6e0c897d180df5959b8b2e3b0dd4e005d4c38bed2d35a2ed8036e6dc95
|
||||
SHA512 (git-2.42.1.tar.sign) = b4997c809d5b2010d1d5a9383a0546dd07ab3e87ac49a896a53dce0f5467a72db6149c07d36e2b2fdaf1e603937c1fdbff43393dac39ce37693e65e88071162c
|
||||
|
Loading…
Reference in New Issue
Block a user