- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
gitweb rss feeds point be commitdiffs instead of commit
This commit is contained in:
parent
9e5f7a30de
commit
32c593e37d
34
git-gitweb-commitdiff.patch
Normal file
34
git-gitweb-commitdiff.patch
Normal file
@ -0,0 +1,34 @@
|
||||
commit e62a641de17b172ffc4d3a803085c8afbfbec3d1
|
||||
Author: Florian La Roche <laroche@redhat.com>
|
||||
Date: Sun Feb 3 12:38:46 2008 +0100
|
||||
|
||||
gitweb: Make feed entries point to commitdiff view
|
||||
|
||||
Change feeds entries (feeds items) from pointing (linking) to 'commit'
|
||||
view to pointing to 'commitdiff' view.
|
||||
|
||||
First, feed entries have whatchanged-like list of files which were
|
||||
modified in a commit, so 'commitdiff' view more naturally reflects
|
||||
feed entry (is more naturally alternate / extended version of a feed
|
||||
item). Second, this way the patches are shown directly and code review
|
||||
is done more easily via watching feeds.
|
||||
|
||||
[jn: Rewritten commit message]
|
||||
|
||||
Signed-off-by: Florian La Roche <laroche@redhat.com>
|
||||
Signed-off-by: Jakub Narebski <jnareb@gmail.com>
|
||||
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||
|
||||
diff --git a/gitweb/gitweb.perl b/gitweb/gitweb.perl
|
||||
index ae2d057..8ef2735 100755
|
||||
--- a/gitweb/gitweb.perl
|
||||
+++ b/gitweb/gitweb.perl
|
||||
@@ -5565,7 +5565,7 @@ XML
|
||||
or next;
|
||||
|
||||
# print element (entry, item)
|
||||
- my $co_url = href(-full=>1, action=>"commit", hash=>$commit);
|
||||
+ my $co_url = href(-full=>1, action=>"commitdiff", hash=>$commit);
|
||||
if ($format eq 'rss') {
|
||||
print "<item>\n" .
|
||||
"<title>" . esc_html($co{'title'}) . "</title>\n" .
|
8
git.spec
8
git.spec
@ -1,7 +1,7 @@
|
||||
# Pass --without docs to rpmbuild if you don't want the documentation
|
||||
Name: git
|
||||
Version: 1.5.4.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Git core and tools
|
||||
License: GPLv2
|
||||
Group: Development/Tools
|
||||
@ -11,6 +11,7 @@ Source1: git-init.el
|
||||
Source2: git.xinetd
|
||||
Source3: git.conf.httpd
|
||||
Patch0: git-1.5-gitweb-home-link.patch
|
||||
Patch1: git-gitweb-commitdiff.patch
|
||||
BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel, expat-devel, emacs, gettext %{!?_without_docs:, xmlto, asciidoc > 6.0.3}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -122,6 +123,7 @@ Requires: git-core = %{version}-%{release}, emacs-common
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
|
||||
@ -244,6 +246,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{!?_without_docs: %doc Documentation/technical}
|
||||
|
||||
%changelog
|
||||
* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
|
||||
- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
|
||||
gitweb rss feeds point be commitdiffs instead of commit
|
||||
|
||||
* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
|
||||
- git-1.5.4.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user