Fix smart-http test due to changes in cookie sort order in curl-7.61.1
With curl-7.61.1 cookies are sorted by creation-time¹. Sort the output used in the 'cookies stored in http.cookiefile when http.savecookies set' test before comparing it to the expected cookies. ¹ https://github.com/curl/curl/commit/e2ef8d6fa ("cookies: support creation-time attribute for cookies", 2018-08-28)
This commit is contained in:
parent
6bf3ed4a31
commit
2ed8c8c53d
@ -0,0 +1,38 @@
|
|||||||
|
From 0f1a223660db65668b3dcac52228cd2d442d6f53 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Todd Zullinger <tmz@pobox.com>
|
||||||
|
To: Junio C Hamano <gitster@pobox.com>
|
||||||
|
Cc: Jeff King <peff@peff.net>, SZEDER Gábor <szeder.dev@gmail.com>
|
||||||
|
Date: Fri, 7 Sep 2018 17:26:26 -0400
|
||||||
|
Subject: [PATCH] t5551-http-fetch-smart.sh: sort cookies before comparing
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
With curl-7.61.1 cookies are sorted by creation-time¹. Sort the output
|
||||||
|
used in the 'cookies stored in http.cookiefile when http.savecookies
|
||||||
|
set' test before comparing it to the expected cookies.
|
||||||
|
|
||||||
|
¹ https://github.com/curl/curl/commit/e2ef8d6fa ("cookies: support
|
||||||
|
creation-time attribute for cookies", 2018-08-28)
|
||||||
|
|
||||||
|
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||||
|
---
|
||||||
|
t/t5551-http-fetch-smart.sh | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/t/t5551-http-fetch-smart.sh b/t/t5551-http-fetch-smart.sh
|
||||||
|
index 771f36f9ff..538656bfef 100755
|
||||||
|
--- a/t/t5551-http-fetch-smart.sh
|
||||||
|
+++ b/t/t5551-http-fetch-smart.sh
|
||||||
|
@@ -215,7 +215,7 @@ test_expect_success 'cookies stored in http.cookiefile when http.savecookies set
|
||||||
|
git config http.cookiefile cookies.txt &&
|
||||||
|
git config http.savecookies true &&
|
||||||
|
git ls-remote $HTTPD_URL/smart_cookies/repo.git master &&
|
||||||
|
- tail -3 cookies.txt >cookies_tail.txt &&
|
||||||
|
+ tail -3 cookies.txt | sort >cookies_tail.txt &&
|
||||||
|
test_cmp expect_cookies.txt cookies_tail.txt
|
||||||
|
'
|
||||||
|
|
||||||
|
--
|
||||||
|
2.19.0.rc2
|
||||||
|
|
8
git.spec
8
git.spec
@ -83,7 +83,7 @@
|
|||||||
|
|
||||||
Name: git
|
Name: git
|
||||||
Version: 2.19.0
|
Version: 2.19.0
|
||||||
Release: 0.4%{?rcrev}%{?dist}
|
Release: 0.5%{?rcrev}%{?dist}
|
||||||
Summary: Fast Version Control System
|
Summary: Fast Version Control System
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: https://git-scm.com/
|
URL: https://git-scm.com/
|
||||||
@ -115,6 +115,9 @@ Source99: print-failed-test-output
|
|||||||
Patch0: git-1.8-gitweb-home-link.patch
|
Patch0: git-1.8-gitweb-home-link.patch
|
||||||
# https://bugzilla.redhat.com/490602
|
# https://bugzilla.redhat.com/490602
|
||||||
Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||||
|
# curl-7.61.1 changes cookie sort order
|
||||||
|
# https://public-inbox.org/git/20180907232205.31328-1-tmz@pobox.com/
|
||||||
|
Patch2: 0001-t5551-http-fetch-smart.sh-sort-cookies-before-compar.patch
|
||||||
|
|
||||||
%if %{with docs}
|
%if %{with docs}
|
||||||
BuildRequires: asciidoc >= 8.4.1
|
BuildRequires: asciidoc >= 8.4.1
|
||||||
@ -902,6 +905,9 @@ make -C contrib/credential/netrc/ testverbose
|
|||||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 07 2018 Todd Zullinger <tmz@pobox.com> - 2.19.0-0.5.rc2
|
||||||
|
- Fix smart-http test due to changes in cookie sort order in curl-7.61.1
|
||||||
|
|
||||||
* Thu Sep 06 2018 Sebastian Kisela <skisela@redhat.com> - 2.19.0-0.4.rc2
|
* Thu Sep 06 2018 Sebastian Kisela <skisela@redhat.com> - 2.19.0-0.4.rc2
|
||||||
- Move instaweb to a separate subpackage
|
- Move instaweb to a separate subpackage
|
||||||
- Fix builds without docs and without cvs and/or p4
|
- Fix builds without docs and without cvs and/or p4
|
||||||
|
Loading…
Reference in New Issue
Block a user