Update to latest version (#2149792)
This commit is contained in:
parent
b6168b9b1c
commit
fbb3078c51
2
.gitignore
vendored
2
.gitignore
vendored
@ -29,3 +29,5 @@
|
|||||||
/sha256sums-3.1.2.asc
|
/sha256sums-3.1.2.asc
|
||||||
/git-lfs-v3.2.0.tar.gz
|
/git-lfs-v3.2.0.tar.gz
|
||||||
/sha256sums-3.2.0.asc
|
/sha256sums-3.2.0.asc
|
||||||
|
/git-lfs-v3.3.0.tar.gz
|
||||||
|
/sha256sums-3.3.0.asc
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
From a119ca768dfeefef7609b55acbf6400fafb0ee5a Mon Sep 17 00:00:00 2001
|
|
||||||
From: "brian m. carlson" <bk2204@github.com>
|
|
||||||
Date: Mon, 25 Jul 2022 17:29:34 +0000
|
|
||||||
Subject: [PATCH] t: set init.defaultBranch
|
|
||||||
|
|
||||||
Previously, we used a template to set the default HEAD ref to "main" so
|
|
||||||
that our branch would be correct. It appears that Git has changed
|
|
||||||
things so that that no longer works, so set init.defaultBranch as well
|
|
||||||
to make sure we initialize new repositories properly.
|
|
||||||
---
|
|
||||||
t/testhelpers.sh | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/t/testhelpers.sh b/t/testhelpers.sh
|
|
||||||
index 7c921f43e8..ea5dc05c4f 100644
|
|
||||||
--- a/t/testhelpers.sh
|
|
||||||
+++ b/t/testhelpers.sh
|
|
||||||
@@ -607,6 +607,7 @@ setup() {
|
|
||||||
git config --global http.$LFS_CLIENT_CERT_URL/.sslKey "$LFS_CLIENT_KEY_FILE"
|
|
||||||
git config --global http.$LFS_CLIENT_CERT_URL/.sslCert "$LFS_CLIENT_CERT_FILE"
|
|
||||||
git config --global http.$LFS_CLIENT_CERT_URL/.sslVerify "false"
|
|
||||||
+ git config --global init.defaultBranch main
|
|
||||||
fi | sed -e 's/^/# /g'
|
|
||||||
|
|
||||||
# setup the git credential password storage
|
|
28
git-lfs.spec
28
git-lfs.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
# https://github.com/git-lfs/git-lfs
|
# https://github.com/git-lfs/git-lfs
|
||||||
%global goipath github.com/git-lfs/git-lfs/v3
|
%global goipath github.com/git-lfs/git-lfs/v3
|
||||||
Version: 3.2.0
|
Version: 3.3.0
|
||||||
|
|
||||||
%gometa
|
%gometa
|
||||||
|
|
||||||
@ -24,14 +24,11 @@ Source1: https://github.com/git-lfs/git-lfs/releases/download/v%{version}
|
|||||||
Source2: https://api.github.com/repos/git-lfs/git-lfs/tarball/core-gpg-keys#/core-gpg-keys.tar.gz
|
Source2: https://api.github.com/repos/git-lfs/git-lfs/tarball/core-gpg-keys#/core-gpg-keys.tar.gz
|
||||||
Source3: README.Fedora
|
Source3: README.Fedora
|
||||||
|
|
||||||
# Silence git warning about default branch.
|
|
||||||
Patch: https://github.com/git-lfs/git-lfs/commit/11fe8dc62ed2eb158eaec28af90d2f509e7fd91f.patch
|
|
||||||
|
|
||||||
BuildRequires: gnupg2
|
BuildRequires: gnupg2
|
||||||
|
|
||||||
BuildRequires: golang(github.com/dpotapov/go-spnego)
|
BuildRequires: golang(github.com/dpotapov/go-spnego)
|
||||||
BuildRequires: golang(github.com/git-lfs/gitobj/v2) >= 2.1.0
|
BuildRequires: golang(github.com/git-lfs/gitobj/v2) >= 2.1.1
|
||||||
BuildRequires: golang(github.com/git-lfs/gitobj/v2/errors) >= 2.1.0
|
BuildRequires: golang(github.com/git-lfs/gitobj/v2/errors) >= 2.1.1
|
||||||
BuildRequires: golang(github.com/git-lfs/go-netrc/netrc) >= 0-0.13.20220318gitf0c862d
|
BuildRequires: golang(github.com/git-lfs/go-netrc/netrc) >= 0-0.13.20220318gitf0c862d
|
||||||
BuildRequires: golang(github.com/git-lfs/pktline)
|
BuildRequires: golang(github.com/git-lfs/pktline)
|
||||||
BuildRequires: golang(github.com/git-lfs/wildmatch/v2) >= 2.0.1
|
BuildRequires: golang(github.com/git-lfs/wildmatch/v2) >= 2.0.1
|
||||||
@ -46,7 +43,7 @@ BuildRequires: golang(golang.org/x/net/http2)
|
|||||||
BuildRequires: golang(golang.org/x/sync/semaphore)
|
BuildRequires: golang(golang.org/x/sync/semaphore)
|
||||||
|
|
||||||
# Generate man pages
|
# Generate man pages
|
||||||
BuildRequires: /usr/bin/ronn
|
BuildRequires: /usr/bin/asciidoctor
|
||||||
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
# Tests
|
# Tests
|
||||||
@ -128,8 +125,10 @@ sed -i -e 's!^BINPATH=.\+!BINPATH="%{gobuilddir}/bin"!g' t/testenv.sh
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
# Build manpages first (some embedding in the executable is done.)
|
# Build manpages first (some embedding in the executable is done.)
|
||||||
|
# Note that the variables are set here simply to prevent the Makefile from
|
||||||
|
# shelling out to git, but the actual value is unused.
|
||||||
|
make man GIT_LFS_SHA=unused VERSION=unused PREFIX=unused
|
||||||
pushd docs
|
pushd docs
|
||||||
ronn --roff man/*.ronn
|
|
||||||
%gobuild -o %{gobuilddir}/bin/mangen man/mangen.go
|
%gobuild -o %{gobuilddir}/bin/mangen man/mangen.go
|
||||||
%{gobuilddir}/bin/mangen
|
%{gobuilddir}/bin/mangen
|
||||||
popd
|
popd
|
||||||
@ -143,17 +142,17 @@ for cmd in t/cmd/*.go; do
|
|||||||
done
|
done
|
||||||
%gobuild -o "%{gobuilddir}/bin/git-lfs-test-server-api" t/git-lfs-test-server-api/*.go
|
%gobuild -o "%{gobuilddir}/bin/git-lfs-test-server-api" t/git-lfs-test-server-api/*.go
|
||||||
|
|
||||||
# Move man pages out of docs so they don't get installed twice.
|
# Remove man pages from docs so they don't get installed twice.
|
||||||
mv docs/man .
|
rm -r docs/man
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%gopkginstall
|
%gopkginstall
|
||||||
install -Dpm0755 %{gobuilddir}/bin/git-lfs %{buildroot}%{_bindir}/%{name}
|
install -Dpm0755 %{gobuilddir}/bin/git-lfs %{buildroot}%{_bindir}/%{name}
|
||||||
install -d -p %{buildroot}%{_mandir}/man1/
|
for section in 1 5 7; do
|
||||||
install -Dpm0644 man/*.1 %{buildroot}%{_mandir}/man1/
|
install -d -p %{buildroot}%{_mandir}/man${section}/
|
||||||
install -d -p %{buildroot}%{_mandir}/man5/
|
install -Dpm0644 man/man${section}/*.${section} %{buildroot}%{_mandir}/man${section}/
|
||||||
install -Dpm0644 man/*.5 %{buildroot}%{_mandir}/man5/
|
done
|
||||||
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
@ -183,6 +182,7 @@ PATH=%{buildroot}%{_bindir}:%{gobuilddir}/bin:$PATH \
|
|||||||
%{_bindir}/%{name}
|
%{_bindir}/%{name}
|
||||||
%{_mandir}/man1/%{name}*.1*
|
%{_mandir}/man1/%{name}*.1*
|
||||||
%{_mandir}/man5/%{name}*.5*
|
%{_mandir}/man5/%{name}*.5*
|
||||||
|
%{_mandir}/man7/%{name}*.7*
|
||||||
|
|
||||||
%gopkgfiles
|
%gopkgfiles
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (git-lfs-v3.2.0.tar.gz) = c2ba8cecd5b3519a032f446b0c3043352f37f3c67ff3c2304a38beb176f0ae8efd1deaeb8bd54a35d7dd7dcd988da67249c896dffd83fc293b165a3e6bb02d66
|
SHA512 (git-lfs-v3.3.0.tar.gz) = e7454cc995398feb1d2dbe2645a894edbd6832b03b81be368b9623e748d69a3626da7064f3a1d7df084e1ce9fe4c6aac15178a48704520b852ce4c72bd1ddec3
|
||||||
SHA512 (sha256sums-3.2.0.asc) = d140aad15ef13167368b6321f213e1892fe90b7d1acb742fa428f6f9b5252a2a4633cb47ec79f04d3ea7696a542dc66601b0f5ab9dd1eb87707869c5ed25d69d
|
SHA512 (sha256sums-3.3.0.asc) = 248c8027788239dee81f6f7bfbc278dcc9ef0b64c208080fa8753ac12fbc4fc04944eeebc48e8e63f7d6c93d9dabd429fc1af23ad31dbdd1b57bfd9e57be9d37
|
||||||
SHA512 (core-gpg-keys.tar.gz) = 59a4507f45a501e6b579ab70ebd650740b7e098b32e16a346d466c7e73da6ab721447fda44663725dd331fca3f53d2892a9421c8f85385a2bbfde18657f37d49
|
SHA512 (core-gpg-keys.tar.gz) = 59a4507f45a501e6b579ab70ebd650740b7e098b32e16a346d466c7e73da6ab721447fda44663725dd331fca3f53d2892a9421c8f85385a2bbfde18657f37d49
|
||||||
|
Loading…
Reference in New Issue
Block a user