Update to latest version (#2076796)

This commit is contained in:
Elliott Sales de Andrade 2022-10-01 23:29:20 -04:00
parent 93a7a45a98
commit e247c69c7b
4 changed files with 36 additions and 4 deletions

2
.gitignore vendored
View File

@ -27,3 +27,5 @@
/sha256sums-3.0.2.asc
/git-lfs-v3.1.2.tar.gz
/sha256sums-3.1.2.asc
/git-lfs-v3.2.0.tar.gz
/sha256sums-3.2.0.asc

View File

@ -0,0 +1,25 @@
From a119ca768dfeefef7609b55acbf6400fafb0ee5a Mon Sep 17 00:00:00 2001
From: "brian m. carlson" <bk2204@github.com>
Date: Mon, 25 Jul 2022 17:29:34 +0000
Subject: [PATCH] t: set init.defaultBranch
Previously, we used a template to set the default HEAD ref to "main" so
that our branch would be correct. It appears that Git has changed
things so that that no longer works, so set init.defaultBranch as well
to make sure we initialize new repositories properly.
---
t/testhelpers.sh | 1 +
1 file changed, 1 insertion(+)
diff --git a/t/testhelpers.sh b/t/testhelpers.sh
index 7c921f43e8..ea5dc05c4f 100644
--- a/t/testhelpers.sh
+++ b/t/testhelpers.sh
@@ -607,6 +607,7 @@ setup() {
git config --global http.$LFS_CLIENT_CERT_URL/.sslKey "$LFS_CLIENT_KEY_FILE"
git config --global http.$LFS_CLIENT_CERT_URL/.sslCert "$LFS_CLIENT_CERT_FILE"
git config --global http.$LFS_CLIENT_CERT_URL/.sslVerify "false"
+ git config --global init.defaultBranch main
fi | sed -e 's/^/# /g'
# setup the git credential password storage

View File

@ -2,7 +2,7 @@
# https://github.com/git-lfs/git-lfs
%global goipath github.com/git-lfs/git-lfs/v3
Version: 3.1.2
Version: 3.2.0
%gometa
@ -24,6 +24,9 @@ Source1: https://github.com/git-lfs/git-lfs/releases/download/v%{version}
Source2: https://api.github.com/repos/git-lfs/git-lfs/tarball/core-gpg-keys#/core-gpg-keys.tar.gz
Source3: README.Fedora
# Silence git warning about default branch.
Patch: https://github.com/git-lfs/git-lfs/commit/11fe8dc62ed2eb158eaec28af90d2f509e7fd91f.patch
BuildRequires: gnupg2
BuildRequires: golang(github.com/dpotapov/go-spnego)
@ -116,9 +119,11 @@ sha256sum --check --ignore-missing %{SOURCE1}
%goprep
cp -p %SOURCE3 .
%autopatch -p1
# Modify Makefile so that it expects binaries where we build them.
# Modify tests so that they expect binaries where we build them.
sed -i -e 's!\.\./bin/!/%{gobuilddir}/bin/!g' t/Makefile
sed -i -e 's!^BINPATH=.\+!BINPATH="%{gobuilddir}/bin"!g' t/testenv.sh
%build

View File

@ -1,3 +1,3 @@
SHA512 (git-lfs-v3.1.2.tar.gz) = de2b56146b929adf7f6ff1989f07d4aca59bde218a51273c0d443a4cace0ccfcf9d4d72c2458c53f95fe06f092baaf6ccbde304e9ca20691ccb9e7aa56f49ebb
SHA512 (sha256sums-3.1.2.asc) = 09f030f8ea68095bc2aa8b0b024d8de33654f4f1978341755bb31980b04e431a041279e77a3bd0e3a61a2aa436036659751baf55dcb3c6a1db31760c0da3e05c
SHA512 (git-lfs-v3.2.0.tar.gz) = c2ba8cecd5b3519a032f446b0c3043352f37f3c67ff3c2304a38beb176f0ae8efd1deaeb8bd54a35d7dd7dcd988da67249c896dffd83fc293b165a3e6bb02d66
SHA512 (sha256sums-3.2.0.asc) = d140aad15ef13167368b6321f213e1892fe90b7d1acb742fa428f6f9b5252a2a4633cb47ec79f04d3ea7696a542dc66601b0f5ab9dd1eb87707869c5ed25d69d
SHA512 (core-gpg-keys.tar.gz) = 59a4507f45a501e6b579ab70ebd650740b7e098b32e16a346d466c7e73da6ab721447fda44663725dd331fca3f53d2892a9421c8f85385a2bbfde18657f37d49