Auto sync2gitlab import of git-lfs-3.2.0-1.el8.src.rpm
This commit is contained in:
parent
f8ccaf7a51
commit
2e46ee60b1
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/git-lfs-v2.13.3.tar.gz
|
/git-lfs-v2.13.3.tar.gz
|
||||||
/manpages.tgz
|
/manpages.tgz
|
||||||
|
/git-lfs-v3.2.0.tar.gz
|
||||||
|
25
11fe8dc62ed2eb158eaec28af90d2f509e7fd91f.patch
Normal file
25
11fe8dc62ed2eb158eaec28af90d2f509e7fd91f.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From a119ca768dfeefef7609b55acbf6400fafb0ee5a Mon Sep 17 00:00:00 2001
|
||||||
|
From: "brian m. carlson" <bk2204@github.com>
|
||||||
|
Date: Mon, 25 Jul 2022 17:29:34 +0000
|
||||||
|
Subject: [PATCH] t: set init.defaultBranch
|
||||||
|
|
||||||
|
Previously, we used a template to set the default HEAD ref to "main" so
|
||||||
|
that our branch would be correct. It appears that Git has changed
|
||||||
|
things so that that no longer works, so set init.defaultBranch as well
|
||||||
|
to make sure we initialize new repositories properly.
|
||||||
|
---
|
||||||
|
t/testhelpers.sh | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/t/testhelpers.sh b/t/testhelpers.sh
|
||||||
|
index 7c921f43e8..ea5dc05c4f 100644
|
||||||
|
--- a/t/testhelpers.sh
|
||||||
|
+++ b/t/testhelpers.sh
|
||||||
|
@@ -607,6 +607,7 @@ setup() {
|
||||||
|
git config --global http.$LFS_CLIENT_CERT_URL/.sslKey "$LFS_CLIENT_KEY_FILE"
|
||||||
|
git config --global http.$LFS_CLIENT_CERT_URL/.sslCert "$LFS_CLIENT_CERT_FILE"
|
||||||
|
git config --global http.$LFS_CLIENT_CERT_URL/.sslVerify "false"
|
||||||
|
+ git config --global init.defaultBranch main
|
||||||
|
fi | sed -e 's/^/# /g'
|
||||||
|
|
||||||
|
# setup the git credential password storage
|
91
git-lfs.spec
91
git-lfs.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
# https://github.com/git-lfs/git-lfs
|
# https://github.com/git-lfs/git-lfs
|
||||||
%global goipath github.com/git-lfs/git-lfs
|
%global goipath github.com/git-lfs/git-lfs
|
||||||
Version: 2.13.3
|
Version: 3.2.0
|
||||||
|
|
||||||
# golang doesn't ship i686 binaries, we don't need the build
|
# golang doesn't ship i686 binaries, we don't need the build
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1752991#c9
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1752991#c9
|
||||||
@ -19,7 +19,7 @@ Version: 2.13.3
|
|||||||
%global gobuild CGO_CPPFLAGS="-D_FORTIFY_SOURCE=2 -fstack-protector-all" go build -compiler gc -buildmode pie '-tags=rpm_crashtraceback libtrust_openssl ' -ldflags "-linkmode=external -compressdwarf=false ${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n') -extldflags '%__global_ldflags'" -a -v -x %{?**}
|
%global gobuild CGO_CPPFLAGS="-D_FORTIFY_SOURCE=2 -fstack-protector-all" go build -compiler gc -buildmode pie '-tags=rpm_crashtraceback libtrust_openssl ' -ldflags "-linkmode=external -compressdwarf=false ${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n') -extldflags '%__global_ldflags'" -a -v -x %{?**}
|
||||||
|
|
||||||
Name: git-lfs
|
Name: git-lfs
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Git extension for versioning large files
|
Summary: Git extension for versioning large files
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -29,49 +29,55 @@ Source1: manpages.tgz
|
|||||||
# See this script. Generating of manpages is performed on other distros due to some missing numerous dependencies on RHEL
|
# See this script. Generating of manpages is performed on other distros due to some missing numerous dependencies on RHEL
|
||||||
Source2: gen-manpages.sh
|
Source2: gen-manpages.sh
|
||||||
|
|
||||||
Provides: bundled(golang(github.com/alexbrainman/sspi)) = 4729b3d4d8581b2db83864d1018926e4154f9406
|
Patch: https://github.com/git-lfs/git-lfs/commit/11fe8dc62ed2eb158eaec28af90d2f509e7fd91f.patch
|
||||||
Provides: bundled(golang(github.com/avast/retry-go)) = a322e24d96313ab405dec28ad5711f036c6d25a3
|
|
||||||
Provides: bundled(golang(github.com/davecgh/go-spew)) = 8991bc29aa16c548c550c7ff78260e27b9ab7c73
|
# Generated provides by vendor2provides.py
|
||||||
Provides: bundled(golang(github.com/dpotapov/go-spnego)) = c2c609116ad04b25367e2789f273aaf8d1c263da
|
# https://src.fedoraproject.org/rpms/syncthing/blob/603e4e03a92a7d704d199629dd85304018e8279d/f/vendor2provides.py
|
||||||
Provides: bundled(golang(github.com/git-lfs/gitobj)) = cb39e779dc0b7949ea39318ff9345598d030d3b3
|
Provides: bundled(golang(github.com/alexbrainman/sspi)) = 909beea
|
||||||
Provides: bundled(golang(github.com/git-lfs/go-netrc)) = e0e9ca483a183481412e6f5a700ff20a36177503
|
Provides: bundled(golang(github.com/avast/retry-go)) = 2.4.2+incompatible
|
||||||
Provides: bundled(golang(github.com/git-lfs/go-ntlm)) = c5056e7fa0664ea69eed654a9618fa5e342dc347
|
Provides: bundled(golang(github.com/davecgh/go-spew)) = 1.1.1
|
||||||
Provides: bundled(golang(github.com/git-lfs/wildmatch)) = 87c0f52cdf80ddb5b7de681298e5fee5898e8e16
|
Provides: bundled(golang(github.com/dpotapov/go-spnego)) = 298b63a
|
||||||
Provides: bundled(golang(github.com/hashicorp/go-uuid)) = 4f571afc59f3043a65f8fe6bf46d887b10a01d43
|
Provides: bundled(golang(github.com/git-lfs/gitobj/v2)) = 2.1.0
|
||||||
Provides: bundled(golang(github.com/inconshreveable/mousetrap)) = 76626ae9c91c4f2a10f34cad8ce83ea42c93bb75
|
Provides: bundled(golang(github.com/git-lfs/go-netrc)) = f0c862d
|
||||||
Provides: bundled(golang(github.com/jcmturner/gofork)) = dc7c13fece037a4a36e2b3c69db4991498d30692
|
Provides: bundled(golang(github.com/git-lfs/pktline)) = 06e9096
|
||||||
Provides: bundled(golang(github.com/mattn/go-isatty)) = 6ca4dbf54d38eea1a992b3c722a76a5d1c4cb25c
|
Provides: bundled(golang(github.com/git-lfs/wildmatch/v2)) = 2.0.1
|
||||||
Provides: bundled(golang(github.com/olekukonko/ts)) = 78ecb04241c0121483589a30b0814836a746187d
|
Provides: bundled(golang(github.com/hashicorp/go-uuid)) = 1.0.2
|
||||||
Provides: bundled(golang(github.com/pkg/errors)) = c605e284fe17294bda444b34710735b29d1a9d90
|
Provides: bundled(golang(github.com/inconshreveable/mousetrap)) = 1.0.0
|
||||||
Provides: bundled(golang(github.com/pmezard/go-difflib)) = 792786c7400a136282c1664665ae0a8db921c6c2
|
Provides: bundled(golang(github.com/jcmturner/aescts/v2)) = 2.0.0
|
||||||
Provides: bundled(golang(github.com/rubyist/tracerx)) = 787959303086f44a8c361240dfac53d3e9d53ed2
|
Provides: bundled(golang(github.com/jcmturner/dnsutils/v2)) = 2.0.0
|
||||||
Provides: bundled(golang(github.com/spf13/cobra)) = ef82de70bb3f60c65fb8eebacbb2d122ef517385
|
Provides: bundled(golang(github.com/jcmturner/gofork)) = 1.0.0
|
||||||
Provides: bundled(golang(github.com/spf13/pflag)) = 298182f68c66c05229eb03ac171abe6e309ee79a
|
Provides: bundled(golang(github.com/jcmturner/goidentity/v6)) = 6.0.1
|
||||||
Provides: bundled(golang(github.com/ssgelm/cookiejarparser)) = ead01002df3bee9f6d64bfde0c7387bd2368a2e0
|
Provides: bundled(golang(github.com/jcmturner/gokrb5/v8)) = 8.4.2
|
||||||
Provides: bundled(golang(github.com/stretchr/testify)) = 3ebf1ddaeb260c4b1ae502a01c7844fa8c1fa0e9
|
Provides: bundled(golang(github.com/jcmturner/rpc/v2)) = 2.0.3
|
||||||
Provides: bundled(golang(github.com/xeipuuv/gojsonpointer)) = 4e3ac2762d5f479393488629ee9370b50873b3a6
|
Provides: bundled(golang(github.com/leonelquinteros/gotext)) = 1.5.0
|
||||||
Provides: bundled(golang(github.com/xeipuuv/gojsonreference)) = bd5ef7bd5415a7ac448318e64f11a24cd21e594b
|
Provides: bundled(golang(github.com/mattn/go-isatty)) = 0.0.4
|
||||||
Provides: bundled(golang(github.com/xeipuuv/gojsonschema)) = 6b67b3fab74d992bd07f72550006ab2c6907c416
|
Provides: bundled(golang(github.com/olekukonko/ts)) = 78ecb04
|
||||||
Provides: bundled(golang(golang.org/x/crypto)) = 75b288015ac94e66e3d6715fb68a9b41bf046ec2
|
Provides: bundled(golang(github.com/pkg/errors)) = c605e28
|
||||||
Provides: bundled(golang(golang.org/x/net)) = 5f4716e94777e714bc2fb3e3a44599cb40817aac
|
Provides: bundled(golang(github.com/pmezard/go-difflib)) = 1.0.0
|
||||||
Provides: bundled(golang(golang.org/x/sync)) = 67f06af15bc961c363a7260195bcd53487529a21
|
Provides: bundled(golang(github.com/rubyist/tracerx)) = 7879593
|
||||||
Provides: bundled(golang(golang.org/x/sys)) = b64e53b001e413bd5067f36d4e439eded3827374
|
Provides: bundled(golang(github.com/spf13/cobra)) = 0.0.3
|
||||||
Provides: bundled(golang(golang.org/x/text)) = 23ae387dee1f90d29a23c0e87ee0b46038fbed0e
|
Provides: bundled(golang(github.com/spf13/pflag)) = 1.0.3
|
||||||
Provides: bundled(golang(gopkg.in/jcmturner/aescts.v1)) = f6abebb3171c4c1b1fea279cb7c7325020a26290
|
Provides: bundled(golang(github.com/ssgelm/cookiejarparser)) = 1.0.1
|
||||||
Provides: bundled(golang(gopkg.in/jcmturner/dnsutils.v1)) = 13eeb8d49ffb74d7a75784c35e4d900607a3943c
|
Provides: bundled(golang(github.com/stretchr/testify)) = 1.6.1
|
||||||
Provides: bundled(golang(gopkg.in/jcmturner/gokrb5.v5)) = 32ba44ca5b42f17a4a9f33ff4305e70665a1bc0
|
Provides: bundled(golang(github.com/xeipuuv/gojsonpointer)) = 4e3ac27
|
||||||
Provides: bundled(golang(gopkg.in/jcmturner/rpc.v0)) = 4480c480c9cd343b54b0acb5b62261cbd33d7adf
|
Provides: bundled(golang(github.com/xeipuuv/gojsonreference)) = bd5ef7b
|
||||||
Provides: bundled(golang(gopkg.in/yaml.v2)) = 53403b58ad1b561927d19068c655246f2db79d48
|
Provides: bundled(golang(github.com/xeipuuv/gojsonschema)) = 6b67b3f
|
||||||
|
Provides: bundled(golang(golang.org/x/crypto)) = 7b82a4e
|
||||||
|
Provides: bundled(golang(golang.org/x/net)) = 69e39ba
|
||||||
|
Provides: bundled(golang(golang.org/x/sync)) = 036812b
|
||||||
|
Provides: bundled(golang(golang.org/x/sys)) = 665e8c7
|
||||||
|
Provides: bundled(golang(golang.org/x/text)) = 0.3.7
|
||||||
|
Provides: bundled(golang(gopkg.in/yaml.v3)) = 9f266ea
|
||||||
|
|
||||||
%if 0%{?with_check}
|
%if 0%{?with_check}
|
||||||
# For tests
|
# For tests
|
||||||
BuildRequires: perl-Digest-SHA
|
BuildRequires: perl-Digest-SHA
|
||||||
BuildRequires: perl-Test-Harness
|
BuildRequires: perl-Test-Harness
|
||||||
# Tests require full git suite, but not generally needed.
|
# Tests require full git suite, but not generally needed.
|
||||||
BuildRequires: git >= 1.8.5
|
BuildRequires: git >= 2.32.0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Requires: git-core >= 1.8.5
|
Requires: git-core >= 2.32.0
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Git Large File Storage (LFS) replaces large files such as audio samples,
|
Git Large File Storage (LFS) replaces large files such as audio samples,
|
||||||
@ -91,9 +97,9 @@ ln -fs "$(pwd)" "%{gobuilddir}/src/%{goipath}"
|
|||||||
tar -xf %{SOURCE1}
|
tar -xf %{SOURCE1}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Modify Makefile so that it expects binaries where we build them.
|
# Modify tests so that they expect binaries where we build them.
|
||||||
sed -i -e 's!\.\./bin/!/%{gobuilddir}/bin/!g' t/Makefile
|
sed -i -e 's!\.\./bin/!/%{gobuilddir}/bin/!g' t/Makefile
|
||||||
|
sed -i -e 's!^BINPATH=.\+!BINPATH="%{gobuilddir}/bin"!g' t/testenv.sh
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export GOPATH=%{gobuilddir}:%{gopath}
|
export GOPATH=%{gobuilddir}:%{gopath}
|
||||||
@ -143,7 +149,6 @@ exit 0
|
|||||||
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
%check
|
%check
|
||||||
# In Fedora this is done by using %%gochecks
|
|
||||||
PATH=%{buildroot}%{_bindir}:%{gobuilddir}/bin:$PATH \
|
PATH=%{buildroot}%{_bindir}:%{gobuilddir}/bin:$PATH \
|
||||||
make -C t PROVE_EXTRA_ARGS="-j$(getconf _NPROCESSORS_ONLN)"
|
make -C t PROVE_EXTRA_ARGS="-j$(getconf _NPROCESSORS_ONLN)"
|
||||||
%endif
|
%endif
|
||||||
@ -159,9 +164,9 @@ PATH=%{buildroot}%{_bindir}:%{gobuilddir}/bin:$PATH \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Oct 04 2022 Ondrej Pohorelsky <opohorel@redhat.com> - 2.13.3-3
|
* Mon Jan 09 2023 Ondrej Pohorelsky <opohorel@redhat.com> - 3.2.0-1
|
||||||
- Rebuild with new Golang
|
- Update to version 3.2.0
|
||||||
- Resolves: rhbz#2131795
|
- Resolves: #2139382
|
||||||
|
|
||||||
* Mon Jan 17 2022 Ondrej Pohorelsky <opohorel@redhat.com> - 2.13.3-2
|
* Mon Jan 17 2022 Ondrej Pohorelsky <opohorel@redhat.com> - 2.13.3-2
|
||||||
- Define %%gobuild macro with proper ldflags
|
- Define %%gobuild macro with proper ldflags
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (git-lfs-v2.13.3.tar.gz) = 2c9e10e4f2fdb5d6bae8994db5879f50596109f3057e7369a9edca3c13c3f4d77e268e3903a0abca60cf8e342ff54bc4920c01a530f8eb400e3a0cc11a171f74
|
SHA512 (git-lfs-v3.2.0.tar.gz) = c2ba8cecd5b3519a032f446b0c3043352f37f3c67ff3c2304a38beb176f0ae8efd1deaeb8bd54a35d7dd7dcd988da67249c896dffd83fc293b165a3e6bb02d66
|
||||||
SHA512 (manpages.tgz) = 577d64748d531f891a7c586fb30b664824393a92881b76fa2755e3c09132333c280a66ee0cf4e55020cea7011533baf7bb943b1e610770af8fadcae845dc1fa4
|
SHA512 (manpages.tgz) = 87a331bd39c88df06d988fcaa840cab9042395ba210eae6897ac409265efafc480bf4b374ec6c0cf2cfc112376206f50ccf6ecc338a672043c1bfa6d97d56d72
|
||||||
|
Loading…
Reference in New Issue
Block a user