diff --git a/.gitignore b/.gitignore
index ce55d27..1bd7a3f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
 /git-lfs-2.2.1.tar.gz
 /git-lfs-2.3.4.tar.gz
 /git-lfs-2.4.0.tar.gz
+/git-lfs-2.4.1.tar.gz
diff --git a/0001-Use-unique-repo-name-for-tests-that-require-credenti.patch b/0001-Use-unique-repo-name-for-tests-that-require-credenti.patch
deleted file mode 100644
index 4ff6f89..0000000
--- a/0001-Use-unique-repo-name-for-tests-that-require-credenti.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 458d669a2893d1aa4028a8ce9a44cdabfe3ec6e9 Mon Sep 17 00:00:00 2001
-From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
-Date: Tue, 6 Mar 2018 19:03:07 -0500
-Subject: [PATCH] Use unique repo name for tests that require credentials.
-
-Otherwise, when running tests in parallel, they might conflict.
-Fixes #2899.
-
-Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
----
- test/cmd/lfstest-gitserver.go | 2 +-
- test/test-credentials.sh      | 8 ++++----
- test/test-extra-header.sh     | 2 +-
- 3 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/test/cmd/lfstest-gitserver.go b/test/cmd/lfstest-gitserver.go
-index 87a1d4ee..97732995 100644
---- a/test/cmd/lfstest-gitserver.go
-+++ b/test/cmd/lfstest-gitserver.go
-@@ -1246,7 +1246,7 @@ func locksHandler(w http.ResponseWriter, r *http.Request, repo string) {
- }
- 
- func missingRequiredCreds(w http.ResponseWriter, r *http.Request, repo string) bool {
--	if repo != "requirecreds" {
-+	if !strings.HasPrefix(repo, "requirecreds") {
- 		return false
- 	}
- 
-diff --git a/test/test-credentials.sh b/test/test-credentials.sh
-index 0ebf93a2..3efbe6b5 100755
---- a/test/test-credentials.sh
-+++ b/test/test-credentials.sh
-@@ -294,9 +294,9 @@ begin_test "credentials from lfs.url"
- (
-   set -e
- 
--  reponame="requirecreds"
-+  reponame="requirecreds-lfsurl"
-   setup_remote_repo "$reponame"
--  clone_repo "$reponame" requirecreds-lfsurl
-+  clone_repo "$reponame" "$reponame"
- 
-   git lfs track "*.dat"
-   echo "push a" > a.dat
-@@ -335,9 +335,9 @@ begin_test "credentials from remote.origin.url"
- (
-   set -e
- 
--  reponame="requirecreds"
-+  reponame="requirecreds-remoteurl"
-   setup_remote_repo "$reponame"
--  clone_repo "$reponame" requirecreds-remoteurl
-+  clone_repo "$reponame" "$reponame"
- 
-   git lfs track "*.dat"
-   echo "push b" > b.dat
-diff --git a/test/test-extra-header.sh b/test/test-extra-header.sh
-index 823a7d62..1dbcfe30 100755
---- a/test/test-extra-header.sh
-+++ b/test/test-extra-header.sh
-@@ -30,7 +30,7 @@ begin_test "http.<url>.extraHeader with authorization"
- (
-   set -e
- 
--  reponame="requirecreds"
-+  reponame="requirecreds-extraHeader"
-   setup_remote_repo "$reponame"
-   clone_repo "$reponame" "$reponame"
- 
--- 
-2.14.3
-
diff --git a/git-lfs.spec b/git-lfs.spec
index 4e9272d..a316b3b 100644
--- a/git-lfs.spec
+++ b/git-lfs.spec
@@ -32,15 +32,13 @@
 %global shortcommit     %(c=%{commit}; echo ${c:0:7})
 
 Name:           git-lfs
-Version:        2.4.0
-Release:        3%{?dist}
+Version:        2.4.1
+Release:        1%{?dist}
 Summary:        Git extension for versioning large files
 
 License:        MIT
 URL:            https://git-lfs.github.io/
 Source0:        https://%{provider_prefix}/archive/v%{version}/%{name}-%{version}.tar.gz
-# https://github.com/git-lfs/git-lfs/pull/2901
-Patch000:       0001-Use-unique-repo-name-for-tests-that-require-credenti.patch
 
 ExclusiveArch:  %{?go_arches:%{go_arches}}%{!?go_arches:%{ix86} x86_64 %{arm} aarch64 ppc64le s390x}
 BuildRequires:  %{?go_compiler:compiler(go-compiler)}%{!?go_compiler:golang}
@@ -252,6 +250,9 @@ popd
 
 
 %changelog
+* Wed May 23 2018 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.4.1-1
+- Update to latest release
+
 * Mon May 21 2018 Carl George <carl@george.computer> - 2.4.0-3
 - Fix %%preun to correctly remove the lfs filter on uninstall (rhbz#1580357)
 
diff --git a/sources b/sources
index bb730f6..afe2e7c 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (git-lfs-2.4.0.tar.gz) = 1f16d60e54d17bf5829317e95823c4f223510aab3cdd6980e5eac3165bd0b4a98f0cca10fcc43459a42d1c6097f04884fc36bb72ee57c10759d359008fb853a1
+SHA512 (git-lfs-2.4.1.tar.gz) = c17503ab6ff494dc55ce42eb1cc0cdcf4f7f3315432c2e49a73c24bb6d8407fff09aa05fc0062e311108d225ae2e11139b11b570dcc6f4ece2d6cfecb000afd3