Update to latest version.
This commit is contained in:
parent
2cf008143d
commit
1d521ec382
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/git-lfs-2.5.1.tar.gz
|
||||
/git-lfs-2.5.2.tar.gz
|
||||
/git-lfs-2.6.1.tar.gz
|
||||
/git-lfs-2.7.0.tar.gz
|
||||
|
@ -1,72 +0,0 @@
|
||||
From 736c749ed730a1cc2f4c12f34de06ae9810ebe86 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 15 Jan 2019 01:08:23 -0500
|
||||
Subject: [PATCH 1/2] Backport PR 3377 to fix test server.
|
||||
|
||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
---
|
||||
t/git-lfs-test-server-api/main.go | 13 +++++++------
|
||||
t/git-lfs-test-server-api/testupload.go | 2 +-
|
||||
2 files changed, 8 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/t/git-lfs-test-server-api/main.go b/t/git-lfs-test-server-api/main.go
|
||||
index 3635df76..25a1e8ab 100644
|
||||
--- a/t/git-lfs-test-server-api/main.go
|
||||
+++ b/t/git-lfs-test-server-api/main.go
|
||||
@@ -13,6 +13,7 @@ import (
|
||||
"github.com/git-lfs/git-lfs/errors"
|
||||
"github.com/git-lfs/git-lfs/fs"
|
||||
"github.com/git-lfs/git-lfs/lfsapi"
|
||||
+ "github.com/git-lfs/git-lfs/lfshttp"
|
||||
t "github.com/git-lfs/git-lfs/t/cmd/util"
|
||||
"github.com/git-lfs/git-lfs/tasklog"
|
||||
"github.com/git-lfs/git-lfs/tq"
|
||||
@@ -141,7 +142,7 @@ func buildManifest(r *t.Repo) (*tq.Manifest, error) {
|
||||
// Configure the endpoint manually
|
||||
finder := lfsapi.NewEndpointFinder(r)
|
||||
|
||||
- var endp lfsapi.Endpoint
|
||||
+ var endp lfshttp.Endpoint
|
||||
if len(cloneUrl) > 0 {
|
||||
endp = finder.NewEndpointFromCloneURL(cloneUrl)
|
||||
} else {
|
||||
@@ -160,18 +161,18 @@ func buildManifest(r *t.Repo) (*tq.Manifest, error) {
|
||||
}
|
||||
|
||||
type constantEndpoint struct {
|
||||
- e lfsapi.Endpoint
|
||||
+ e lfshttp.Endpoint
|
||||
|
||||
lfsapi.EndpointFinder
|
||||
}
|
||||
|
||||
-func (c *constantEndpoint) NewEndpointFromCloneURL(rawurl string) lfsapi.Endpoint { return c.e }
|
||||
+func (c *constantEndpoint) NewEndpointFromCloneURL(rawurl string) lfshttp.Endpoint { return c.e }
|
||||
|
||||
-func (c *constantEndpoint) NewEndpoint(rawurl string) lfsapi.Endpoint { return c.e }
|
||||
+func (c *constantEndpoint) NewEndpoint(rawurl string) lfshttp.Endpoint { return c.e }
|
||||
|
||||
-func (c *constantEndpoint) Endpoint(operation, remote string) lfsapi.Endpoint { return c.e }
|
||||
+func (c *constantEndpoint) Endpoint(operation, remote string) lfshttp.Endpoint { return c.e }
|
||||
|
||||
-func (c *constantEndpoint) RemoteEndpoint(operation, remote string) lfsapi.Endpoint { return c.e }
|
||||
+func (c *constantEndpoint) RemoteEndpoint(operation, remote string) lfshttp.Endpoint { return c.e }
|
||||
|
||||
func buildTestData(repo *t.Repo, manifest *tq.Manifest) (oidsExist, oidsMissing []TestObject, err error) {
|
||||
const oidCount = 50
|
||||
diff --git a/t/git-lfs-test-server-api/testupload.go b/t/git-lfs-test-server-api/testupload.go
|
||||
index dde5e9ec..3bdbd4ba 100644
|
||||
--- a/t/git-lfs-test-server-api/testupload.go
|
||||
+++ b/t/git-lfs-test-server-api/testupload.go
|
||||
@@ -52,7 +52,7 @@ func uploadAllExists(manifest *tq.Manifest, oidsExist, oidsMissing []TestObject)
|
||||
var errbuf bytes.Buffer
|
||||
for _, o := range retobjs {
|
||||
link, _ := o.Rel("upload")
|
||||
- if link == nil {
|
||||
+ if link != nil {
|
||||
errbuf.WriteString(fmt.Sprintf("Upload link should not exist for %s, was %+v\n", o.Oid, link))
|
||||
}
|
||||
}
|
||||
--
|
||||
2.20.1
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 43e2b130e74390f85e29de1c19da66ceccb9cee2 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 15 Jan 2019 01:10:39 -0500
|
||||
Subject: [PATCH 2/2] Trim security context when checking permissions.
|
||||
|
||||
This fixes the umask tests on a file system that uses security context,
|
||||
as that prints out an extra dot in the permissions.
|
||||
|
||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
---
|
||||
t/t-umask.sh | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/t/t-umask.sh b/t/t-umask.sh
|
||||
index fdbc2386..494d5420 100644
|
||||
--- a/t/t-umask.sh
|
||||
+++ b/t/t-umask.sh
|
||||
@@ -15,7 +15,9 @@ clean_setup () {
|
||||
|
||||
perms_for () {
|
||||
local file=$(echo "$1" | sed "s!^\(..\)\(..\)!.git/lfs/objects/\1/\2/\1\2!")
|
||||
- ls -l "$file" | awk '{print $1}'
|
||||
+ local perms=$(ls -l "$file" | awk '{print $1}')
|
||||
+ # Trim extended attributes:
|
||||
+ echo ${perms:0:10}
|
||||
}
|
||||
|
||||
begin_test "honors umask"
|
||||
--
|
||||
2.20.1
|
||||
|
19
git-lfs.spec
19
git-lfs.spec
@ -1,35 +1,32 @@
|
||||
%global goipath github.com/git-lfs/git-lfs
|
||||
Version: 2.6.1
|
||||
Version: 2.7.0
|
||||
|
||||
%gometa
|
||||
|
||||
Name: git-lfs
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Git extension for versioning large files
|
||||
|
||||
License: MIT
|
||||
URL: https://git-lfs.github.io/
|
||||
Source0: %{gosource}
|
||||
# Simplified somewhat to work as a backport.
|
||||
# https://github.com/git-lfs/git-lfs/pull/3377
|
||||
Patch0001: 0001-Backport-PR-3377-to-fix-test-server.patch
|
||||
# https://github.com/git-lfs/git-lfs/pull/3476
|
||||
Patch0002: 0002-Trim-security-context-when-checking-permissions.patch
|
||||
|
||||
BuildRequires: golang(github.com/ThomsonReutersEikon/go-ntlm/ntlm)
|
||||
BuildRequires: golang(github.com/git-lfs/gitobj) >= 1.1.0
|
||||
BuildRequires: golang(github.com/git-lfs/go-netrc/netrc) >= 0-0.1.20180827gite0e9ca4
|
||||
BuildRequires: golang(github.com/git-lfs/wildmatch) >= 1.0.0
|
||||
BuildRequires: golang(github.com/git-lfs/wildmatch) >= 1.0.2
|
||||
BuildRequires: golang(github.com/kr/pty)
|
||||
BuildRequires: golang(github.com/mattn/go-isatty) >= 0.0.4
|
||||
BuildRequires: golang(github.com/olekukonko/ts)
|
||||
BuildRequires: golang(github.com/pkg/errors)
|
||||
BuildRequires: golang(github.com/rubyist/tracerx)
|
||||
BuildRequires: golang(github.com/spf13/cobra)
|
||||
BuildRequires: golang(github.com/spf13/cobra) >= 0.0.3
|
||||
BuildRequires: golang(golang.org/x/sync/semaphore)
|
||||
# Generate mans
|
||||
BuildRequires: /usr/bin/ronn
|
||||
# For tests
|
||||
BuildRequires: golang(github.com/stretchr/testify/assert)
|
||||
BuildRequires: golang(github.com/stretchr/testify/require)
|
||||
BuildRequires: golang(github.com/stretchr/testify/assert) >= 1.2.2
|
||||
BuildRequires: golang(github.com/stretchr/testify/require) >= 1.2.2
|
||||
BuildRequires: golang(github.com/xeipuuv/gojsonschema)
|
||||
BuildRequires: perl-Digest-SHA
|
||||
BuildRequires: perl-Test-Harness
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (git-lfs-2.6.1.tar.gz) = 1f45d8da4f67d37e85b061c219423863ed41ed4723dd1030e7287e422d84cd615ddd820765bd32a147264c0f4bf9d5e84185970442fd110ae9656be97de78663
|
||||
SHA512 (git-lfs-2.7.0.tar.gz) = 8d3e80d78ccac6f3b136a61abb809d39ec28f2ee3069350d84b6b023f0037d5f910dd7968d0f30dd3e813670f80c1611171eb2d9604e2379b000bca81fe95340
|
||||
|
Loading…
Reference in New Issue
Block a user