Update to 2.10.14
This commit is contained in:
parent
b61cf62cfb
commit
deebada78a
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@ gimp-2.6.10-1-autoreconf.patch.bz2
|
|||||||
/gimp-2.10.8.tar.bz2
|
/gimp-2.10.8.tar.bz2
|
||||||
/gimp-2.10.10.tar.bz2
|
/gimp-2.10.10.tar.bz2
|
||||||
/gimp-2.10.12.tar.bz2
|
/gimp-2.10.12.tar.bz2
|
||||||
|
/gimp-2.10.14.tar.bz2
|
||||||
|
44
0001-Add-missing-lm-to-file-psd-plug-in.patch
Normal file
44
0001-Add-missing-lm-to-file-psd-plug-in.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
From 06b61daa802b80a93009abaafb843f574edcaa63 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pascal Terjan <pterjan@mageia.org>
|
||||||
|
Date: Tue, 29 Oct 2019 10:07:53 +0000
|
||||||
|
Subject: [PATCH] Add missing -lm to file-psd plug-in
|
||||||
|
|
||||||
|
psd-save.c uses RINT which uses floor(). Not sure why this only
|
||||||
|
caused a failure on our armv7hl build and why it used to work
|
||||||
|
but we get:
|
||||||
|
|
||||||
|
libtool: link: gcc -O2 -g -pipe -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Werror=missing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wmissing-format-attribute -Wformat-security -Wlogical-op -Wtype-limits -fno-common -fdiagnostics-show-option -Wreturn-type -Wl,--as-needed -Wl,--no-undefined -Wl,-z -Wl,relro -Wl,-O1 -Wl,--build-id -Wl,--enable-new-dtags -o .libs/file-psd psd.o psd-util.o psd-load.o psd-save.o psd-thumb-load.o psd-image-res-load.o psd-layer-res-load.o -Wl,--export-dynamic -pthread -Wl,--export-dynamic -pthread ../../libgimp/.libs/libgimpui-2.0.so ../../libgimpwidgets/.libs/libgimpwidgets-2.0.so ../../libgimpconfig/.libs/libgimpconfig-2.0.so ../../libgimp/.libs/libgimp-2.0.so ../../libgimpcolor/.libs/libgimpcolor-2.0.so ../../libgimpmath/.libs/libgimpmath-2.0.so ../../libgimpbase/.libs/libgimpbase-2.0.so -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lpango-1.0 -lharfbuzz -lfontconfig -lfreetype -lgegl-0.4 -lgegl-npd-0.4 -lgmodule-2.0 -ljson-glib-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lbabl-0.1 -lz -ljpeg -pthread
|
||||||
|
/usr/bin/ld: psd-save.o: undefined reference to symbol 'floor@@GLIBC_2.4'
|
||||||
|
/usr/bin/ld: /lib/libm.so.6: error adding symbols: DSO missing from command line
|
||||||
|
collect2: error: ld returned 1 exit status
|
||||||
|
make[3]: *** [Makefile:756: file-psd] Error 1
|
||||||
|
|
||||||
|
And adding -lm seems the right thing to do.
|
||||||
|
---
|
||||||
|
plug-ins/file-psd/Makefile.am | 3 +++
|
||||||
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/plug-ins/file-psd/Makefile.am b/plug-ins/file-psd/Makefile.am
|
||||||
|
index d8f4f3577e..10ce6485db 100644
|
||||||
|
--- a/plug-ins/file-psd/Makefile.am
|
||||||
|
+++ b/plug-ins/file-psd/Makefile.am
|
||||||
|
@@ -10,6 +10,8 @@ libgimpmath = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la
|
||||||
|
|
||||||
|
if OS_WIN32
|
||||||
|
mwindows = -mwindows
|
||||||
|
+else
|
||||||
|
+libm = -lm
|
||||||
|
endif
|
||||||
|
|
||||||
|
if HAVE_WINDRES
|
||||||
|
@@ -53,6 +55,7 @@ AM_CPPFLAGS = \
|
||||||
|
-I$(includedir)
|
||||||
|
|
||||||
|
file_psd_LDADD = \
|
||||||
|
+ $(libm) \
|
||||||
|
$(libgimpui) \
|
||||||
|
$(libgimpwidgets) \
|
||||||
|
$(libgimpconfig) \
|
||||||
|
--
|
||||||
|
2.23.0
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
diff -up gimp-2.10.0/etc/gimprc.in.cm-system-monitor-profile-by-default gimp-2.10.0/etc/gimprc.in
|
diff -up gimp-2.10.14/etc/gimprc.in.cm-system-monitor-profile-by-default gimp-2.10.14/etc/gimprc.in
|
||||||
--- gimp-2.10.0/etc/gimprc.in.cm-system-monitor-profile-by-default 2018-04-28 17:21:37.050632773 +0200
|
--- gimp-2.10.14/etc/gimprc.in.cm-system-monitor-profile-by-default 2019-10-26 21:46:48.000000000 +0200
|
||||||
+++ gimp-2.10.0/etc/gimprc.in 2018-04-28 17:22:37.399518036 +0200
|
+++ gimp-2.10.14/etc/gimprc.in 2019-11-04 13:17:23.322750636 +0100
|
||||||
@@ -306,9 +306,9 @@
|
@@ -317,9 +317,9 @@
|
||||||
|
|
||||||
# Defines the color management behavior. This is a parameter list.
|
# Defines the color management behavior. This is a parameter list.
|
||||||
#
|
#
|
||||||
@ -13,10 +13,10 @@ diff -up gimp-2.10.0/etc/gimprc.in.cm-system-monitor-profile-by-default gimp-2.1
|
|||||||
# (display-rendering-intent relative-colorimetric)
|
# (display-rendering-intent relative-colorimetric)
|
||||||
# (display-use-black-point-compensation yes)
|
# (display-use-black-point-compensation yes)
|
||||||
# (display-optimize yes)
|
# (display-optimize yes)
|
||||||
@@ -317,7 +317,8 @@
|
@@ -328,7 +328,8 @@
|
||||||
# (simulation-optimize yes)
|
# (simulation-optimize yes)
|
||||||
# (simulation-gamut-check no)
|
# (simulation-gamut-check no)
|
||||||
# (out-of-gamut-color (color-rgb 1.000000 0.000000 1.000000))
|
# (out-of-gamut-color (color-rgb 1 0 1))
|
||||||
-# (display-module "CdisplayLcms"))
|
-# (display-module "CdisplayLcms"))
|
||||||
+# (display-module "CdisplayLcms")
|
+# (display-module "CdisplayLcms")
|
||||||
+)
|
+)
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
diff --git a/plug-ins/common/file-svg.c b/plug-ins/common/file-svg.c
|
|
||||||
index 570b3632b18e7a663b6ef2b0110941f64123720e..9f3de881d187406fabbc913ee8543a8fee83dcc7 100644
|
|
||||||
--- a/plug-ins/common/file-svg.c
|
|
||||||
+++ b/plug-ins/common/file-svg.c
|
|
||||||
@@ -521,19 +521,24 @@ load_rsvg_size (const gchar *filename,
|
|
||||||
break;
|
|
||||||
case G_IO_STATUS_EOF:
|
|
||||||
success = rsvg_handle_close (handle, error);
|
|
||||||
- break;
|
|
||||||
- case G_IO_STATUS_NORMAL:
|
|
||||||
- success = rsvg_handle_write (handle,
|
|
||||||
- (const guchar *) buf, len, error);
|
|
||||||
- rsvg_handle_get_dimensions (handle, &dim);
|
|
||||||
|
|
||||||
- if (dim.width > 0 && dim.height > 0)
|
|
||||||
+ if (success)
|
|
||||||
{
|
|
||||||
- vals->width = dim.width;
|
|
||||||
- vals->height = dim.height;
|
|
||||||
+ rsvg_handle_get_dimensions (handle, &dim);
|
|
||||||
+
|
|
||||||
+ if (dim.width > 0 && dim.height > 0)
|
|
||||||
+ {
|
|
||||||
+ vals->width = dim.width;
|
|
||||||
+ vals->height = dim.height;
|
|
||||||
|
|
||||||
- done = TRUE;
|
|
||||||
+ done = TRUE;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ break;
|
|
||||||
+ case G_IO_STATUS_NORMAL:
|
|
||||||
+ success = rsvg_handle_write (handle,
|
|
||||||
+ (const guchar *) buf, len, error);
|
|
||||||
break;
|
|
||||||
case G_IO_STATUS_AGAIN:
|
|
||||||
break;
|
|
||||||
|
|
23
gimp.spec
23
gimp.spec
@ -87,8 +87,8 @@ find $bytecode_compilation_path -type f -a -name "*.py" -print0 | xargs -0 $pyth
|
|||||||
Summary: GNU Image Manipulation Program
|
Summary: GNU Image Manipulation Program
|
||||||
Name: gimp
|
Name: gimp
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 2.10.12
|
Version: 2.10.14
|
||||||
%global rel 3
|
%global rel 1
|
||||||
Release: %{?prerelprefix}%{rel}%{dotprerel}%{dotgitrev}%{?dist}
|
Release: %{?prerelprefix}%{rel}%{dotprerel}%{dotgitrev}%{?dist}
|
||||||
|
|
||||||
# Compute some version related macros.
|
# Compute some version related macros.
|
||||||
@ -126,7 +126,7 @@ BuildRequires: aalib-devel
|
|||||||
%endif
|
%endif
|
||||||
BuildRequires: alsa-lib-devel >= 1.0.0
|
BuildRequires: alsa-lib-devel >= 1.0.0
|
||||||
BuildRequires: atk-devel >= 2.2.0
|
BuildRequires: atk-devel >= 2.2.0
|
||||||
BuildRequires: babl-devel >= 0.1.66
|
BuildRequires: babl-devel >= 0.1.72
|
||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
BuildRequires: cairo-devel >= 1.12.2
|
BuildRequires: cairo-devel >= 1.12.2
|
||||||
BuildRequires: fontconfig-devel >= 2.12.4
|
BuildRequires: fontconfig-devel >= 2.12.4
|
||||||
@ -134,7 +134,7 @@ BuildRequires: freetype-devel >= 2.1.7
|
|||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gdk-pixbuf2-devel >= 2.30.8
|
BuildRequires: gdk-pixbuf2-devel >= 2.30.8
|
||||||
BuildRequires: gegl04-tools
|
BuildRequires: gegl04-tools
|
||||||
BuildRequires: gegl04-devel >= 0.4.16
|
BuildRequires: gegl04-devel >= 0.4.18
|
||||||
BuildRequires: libgs-devel
|
BuildRequires: libgs-devel
|
||||||
BuildRequires: glib2-devel >= 2.54.2
|
BuildRequires: glib2-devel >= 2.54.2
|
||||||
BuildRequires: gtk2-devel >= 2.24.32
|
BuildRequires: gtk2-devel >= 2.24.32
|
||||||
@ -164,7 +164,7 @@ BuildRequires: OpenEXR-devel >= 1.6.1
|
|||||||
BuildRequires: openjpeg2-devel >= 2.1.0
|
BuildRequires: openjpeg2-devel >= 2.1.0
|
||||||
BuildRequires: pango-devel >= 1.29.4
|
BuildRequires: pango-devel >= 1.29.4
|
||||||
BuildRequires: perl >= 5.10.0
|
BuildRequires: perl >= 5.10.0
|
||||||
BuildRequires: poppler-glib-devel >= 0.44.0
|
BuildRequires: poppler-glib-devel >= 0.50.0
|
||||||
BuildRequires: poppler-data-devel >= 0.4.7
|
BuildRequires: poppler-data-devel >= 0.4.7
|
||||||
BuildRequires: pycairo-devel >= 1.0.2
|
BuildRequires: pycairo-devel >= 1.0.2
|
||||||
BuildRequires: pygtk2-devel >= 2.10.4
|
BuildRequires: pygtk2-devel >= 2.10.4
|
||||||
@ -189,8 +189,8 @@ BuildRequires: desktop-file-utils
|
|||||||
BuildRequires: ImageMagick
|
BuildRequires: ImageMagick
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Requires: babl%{?_isa} >= 0.1.66
|
Requires: babl%{?_isa} >= 0.1.72
|
||||||
Requires: gegl04%{?_isa} >= 0.4.16
|
Requires: gegl04%{?_isa} >= 0.4.18
|
||||||
Requires: fontconfig >= 2.12.4
|
Requires: fontconfig >= 2.12.4
|
||||||
Requires: freetype >= 2.1.7
|
Requires: freetype >= 2.1.7
|
||||||
Requires: glib2 >= 2.54.2
|
Requires: glib2 >= 2.54.2
|
||||||
@ -225,8 +225,8 @@ Patch0: gimp-%{version}%{dashprerel}-git%{gitrev}.patch.bz2
|
|||||||
# Fedora specific.
|
# Fedora specific.
|
||||||
Patch1: gimp-2.10.0-cm-system-monitor-profile-by-default.patch
|
Patch1: gimp-2.10.0-cm-system-monitor-profile-by-default.patch
|
||||||
|
|
||||||
# bz#1715882
|
# Fix the build on arm. Backported from upstream.
|
||||||
Patch2: gimp-2.10.0-fix-svg-reading.patch
|
Patch2: 0001-Add-missing-lm-to-file-psd-plug-in.patch
|
||||||
|
|
||||||
# bz#1706653
|
# bz#1706653
|
||||||
Patch3: gimp-2.10.12-default-font.patch
|
Patch3: gimp-2.10.12-default-font.patch
|
||||||
@ -321,7 +321,7 @@ EOF
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch1 -p1 -b .cm-system-monitor-profile-by-default
|
%patch1 -p1 -b .cm-system-monitor-profile-by-default
|
||||||
%patch2 -p1 -b .fix-svg
|
%patch2 -p1
|
||||||
%patch3 -p1 -b .font-default
|
%patch3 -p1 -b .font-default
|
||||||
|
|
||||||
%if ! %{with helpbrowser}
|
%if ! %{with helpbrowser}
|
||||||
@ -700,6 +700,9 @@ make check %{?_smp_mflags}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 04 2019 Kalev Lember <klember@redhat.com> - 2:2.10.14-1
|
||||||
|
- Update to 2.10.14
|
||||||
|
|
||||||
* Tue Aug 20 2019 Josef Ridky <jridky@redhat.com> - 2:2.10.12-3
|
* Tue Aug 20 2019 Josef Ridky <jridky@redhat.com> - 2:2.10.12-3
|
||||||
- Fix default configuration for font folders (#1706653)
|
- Fix default configuration for font folders (#1706653)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gimp-2.10.12.tar.bz2) = dd4af3f0fa6fca815d254b7f42aeff15412c38294f1f5bd491563e2b597fcb868e6adff9001b196a68e01cf49bde61cbb153b662b8da1aa1b4b1f7285879659f
|
SHA512 (gimp-2.10.14.tar.bz2) = acbd095361d9211a5a23474693dd170ed76bf4ea5b1df69791f1d975ef5cdaba1e5fb9f5be9f592a360db5826d71eaaf464005075397cb6630070fe32833c030
|
||||||
|
Loading…
Reference in New Issue
Block a user