New upstream release 2.10.16 (#1804449)

This commit is contained in:
Josef Řídký 2020-02-19 12:06:08 +01:00
parent 16026d47a9
commit 968b65c43c
4 changed files with 21 additions and 66 deletions

1
.gitignore vendored
View File

@ -31,3 +31,4 @@ gimp-2.6.10-1-autoreconf.patch.bz2
/gimp-2.10.10.tar.bz2
/gimp-2.10.12.tar.bz2
/gimp-2.10.14.tar.bz2
/gimp-2.10.16.tar.bz2

View File

@ -1,44 +0,0 @@
From 06b61daa802b80a93009abaafb843f574edcaa63 Mon Sep 17 00:00:00 2001
From: Pascal Terjan <pterjan@mageia.org>
Date: Tue, 29 Oct 2019 10:07:53 +0000
Subject: [PATCH] Add missing -lm to file-psd plug-in
psd-save.c uses RINT which uses floor(). Not sure why this only
caused a failure on our armv7hl build and why it used to work
but we get:
libtool: link: gcc -O2 -g -pipe -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Werror=missing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wmissing-format-attribute -Wformat-security -Wlogical-op -Wtype-limits -fno-common -fdiagnostics-show-option -Wreturn-type -Wl,--as-needed -Wl,--no-undefined -Wl,-z -Wl,relro -Wl,-O1 -Wl,--build-id -Wl,--enable-new-dtags -o .libs/file-psd psd.o psd-util.o psd-load.o psd-save.o psd-thumb-load.o psd-image-res-load.o psd-layer-res-load.o -Wl,--export-dynamic -pthread -Wl,--export-dynamic -pthread ../../libgimp/.libs/libgimpui-2.0.so ../../libgimpwidgets/.libs/libgimpwidgets-2.0.so ../../libgimpconfig/.libs/libgimpconfig-2.0.so ../../libgimp/.libs/libgimp-2.0.so ../../libgimpcolor/.libs/libgimpcolor-2.0.so ../../libgimpmath/.libs/libgimpmath-2.0.so ../../libgimpbase/.libs/libgimpbase-2.0.so -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lpango-1.0 -lharfbuzz -lfontconfig -lfreetype -lgegl-0.4 -lgegl-npd-0.4 -lgmodule-2.0 -ljson-glib-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lbabl-0.1 -lz -ljpeg -pthread
/usr/bin/ld: psd-save.o: undefined reference to symbol 'floor@@GLIBC_2.4'
/usr/bin/ld: /lib/libm.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:756: file-psd] Error 1
And adding -lm seems the right thing to do.
---
plug-ins/file-psd/Makefile.am | 3 +++
1 file changed, 3 insertions(+)
diff --git a/plug-ins/file-psd/Makefile.am b/plug-ins/file-psd/Makefile.am
index d8f4f3577e..10ce6485db 100644
--- a/plug-ins/file-psd/Makefile.am
+++ b/plug-ins/file-psd/Makefile.am
@@ -10,6 +10,8 @@ libgimpmath = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la
if OS_WIN32
mwindows = -mwindows
+else
+libm = -lm
endif
if HAVE_WINDRES
@@ -53,6 +55,7 @@ AM_CPPFLAGS = \
-I$(includedir)
file_psd_LDADD = \
+ $(libm) \
$(libgimpui) \
$(libgimpwidgets) \
$(libgimpconfig) \
--
2.23.0

View File

@ -87,8 +87,8 @@ find $bytecode_compilation_path -type f -a -name "*.py" -print0 | xargs -0 $pyth
Summary: GNU Image Manipulation Program
Name: gimp
Epoch: 2
Version: 2.10.14
%global rel 4
Version: 2.10.16
%global rel 1
Release: %{?prerelprefix}%{rel}%{dotprerel}%{dotgitrev}%{?dist}.1
# Compute some version related macros.
@ -216,8 +216,8 @@ Conflicts: %{name}-unstable < %{epoch}:%{major}.%{minor}
%endif
#Demodularizing of gimp (#1772469)
Obsoletes: %{name} < 2:2.10.14-3
Conflicts: %{name} < 2:2.10.14-3
Obsoletes: %{name} < %{epoch}:%{version}-%{release}
Conflicts: %{name} < %{epoch}:%{version}-%{release}
Source0: http://download.gimp.org/pub/gimp/v%{binver}/gimp-%{version}%{dashprerel}.tar.bz2
@ -229,11 +229,8 @@ Patch0: gimp-%{version}%{dashprerel}-git%{gitrev}.patch.bz2
# Fedora specific.
Patch1: gimp-2.10.0-cm-system-monitor-profile-by-default.patch
# Fix the build on arm. Backported from upstream.
Patch2: 0001-Add-missing-lm-to-file-psd-plug-in.patch
# bz#1706653
Patch3: gimp-2.10.12-default-font.patch
Patch2: gimp-2.10.12-default-font.patch
# use external help browser directly if help browser plug-in is not built
Patch100: gimp-2.10.0-external-help-browser.patch
@ -255,8 +252,8 @@ Obsoletes: %{name}-unstable-libs < %{epoch}:%{major}.%{minor}
Conflicts: %{name}-unstable-libs < %{epoch}:%{major}.%{minor}
%endif
#Demodularizing of gimp (#1772469)
Obsoletes: %{name}-libs < 2:2.10.14-3
Conflicts: %{name}-libs < 2:2.10.14-3
Obsoletes: %{name}-libs < %{epoch}:%{version}-%{release}
Conflicts: %{name}-libs < %{epoch}:%{version}-%{release}
%description libs
The %{name}-libs package contains shared libraries needed for the GNU Image
@ -276,8 +273,8 @@ Obsoletes: %{name}-unstable-devel < %{epoch}:%{major}.%{minor}
Conflicts: %{name}-unstable-devel < %{epoch}:%{major}.%{minor}
%endif
#Demodularizing of gimp (#1772469)
Obsoletes: %{name}-devel < 2:2.10.14-3
Conflicts: %{name}-devel < 2:2.10.14-3
Obsoletes: %{name}-devel < %{epoch}:%{version}-%{release}
Conflicts: %{name}-devel < %{epoch}:%{version}-%{release}
%description devel
The %{name}-devel package contains the static libraries and header files
@ -293,8 +290,8 @@ Obsoletes: %{name}-unstable-devel-tools < %{epoch}:%{major}.%{minor}
Conflicts: %{name}-unstable-devel-tools < %{epoch}:%{major}.%{minor}
%endif
#Demodularizing of gimp (#1772469)
Obsoletes: %{name}-devel-tools < 2:2.10.14-3
Conflicts: %{name}-devel-tools < 2:2.10.14-3
Obsoletes: %{name}-devel-tools < %{epoch}:%{version}-%{release}
Conflicts: %{name}-devel-tools < %{epoch}:%{version}-%{release}
%description devel-tools
The %{name}-devel-tools package contains gimptool, a helper program to
@ -310,8 +307,8 @@ Obsoletes: %{name}-unstable-help-browser < %{epoch}:%{major}.%{minor}
Conflicts: %{name}-unstable-help-browser < %{epoch}:%{major}.%{minor}
%endif
#Demodularizing of gimp (#1772469)
Obsoletes: %{name}-help-browser < 2:2.10.14-3
Conflicts: %{name}-help-browser < 2:2.10.14-3
Obsoletes: %{name}-help-browser < %{epoch}:%{version}-%{release}
Conflicts: %{name}-help-browser < %{epoch}:%{version}-%{release}
%description help-browser
The %{name}-help-browser package contains a lightweight help browser plugin for
@ -337,8 +334,7 @@ EOF
%endif
%patch1 -p1 -b .cm-system-monitor-profile-by-default
%patch2 -p1
%patch3 -p1 -b .font-default
%patch2 -p1 -b .font-default
%if ! %{with helpbrowser}
%patch100 -p1 -b .external-help-browser
@ -620,6 +616,7 @@ make check %{?_smp_mflags}
%{_datadir}/gimp/%{lib_api_version}/patterns/
%{_datadir}/gimp/%{lib_api_version}/scripts/
%{_datadir}/gimp/%{lib_api_version}/themes/
%{_datadir}/gimp/%{lib_api_version}/gimp-release
%dir %{_sysconfdir}/gimp
%dir %{_sysconfdir}/gimp/%{lib_api_version}
@ -630,6 +627,7 @@ make check %{?_smp_mflags}
%config(noreplace) %{_sysconfdir}/gimp/%{lib_api_version}/sessionrc
%config(noreplace) %{_sysconfdir}/gimp/%{lib_api_version}/templaterc
%config(noreplace) %{_sysconfdir}/gimp/%{lib_api_version}/menurc
%config(noreplace) %{_sysconfdir}/gimp/%{lib_api_version}/toolrc
%{_bindir}/gimp-%{binver}
%{_bindir}/gimp-console-%{binver}
@ -690,9 +688,6 @@ make check %{?_smp_mflags}
%doc %{_datadir}/gtk-doc
%{_libdir}/*.so
%dir %{_libdir}/gimp
%dir %{_libdir}/gimp/%{lib_api_version}
%dir %{_libdir}/gimp/%{lib_api_version}/modules
%ifnos linux
%{_libdir}/*.la
%{_libdir}/gimp/%{lib_api_version}/modules/*.la
@ -719,6 +714,9 @@ make check %{?_smp_mflags}
%endif
%changelog
* Wed Feb 19 2020 Josef Ridky <jridky@redhat.com> - 2:2.10.16-1
- New upstream release 2.10.16 (#1804449)
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2:2.10.14-4.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (gimp-2.10.14.tar.bz2) = acbd095361d9211a5a23474693dd170ed76bf4ea5b1df69791f1d975ef5cdaba1e5fb9f5be9f592a360db5826d71eaaf464005075397cb6630070fe32833c030
SHA512 (gimp-2.10.16.tar.bz2) = 07e2c3d6a6e0f54fd221b5eb5e29fd22fca4100f57ed7b8c3d5c561cad02167dae2e4892be8fdbacd6fc5ca2f2d6a892af7403444894bb5ea8190cd98e0e4bc4