version 2.6.10 remove obsolete combo-popup patch update script-fu-ipv6
patch
This commit is contained in:
parent
10646e4ea2
commit
38ff93c325
@ -1,2 +1,2 @@
|
||||
gimp-2.6.9.tar.bz2
|
||||
gimp-2.6.9-3-autoreconf.patch.bz2
|
||||
gimp-2.6.10-1-autoreconf.patch.bz2
|
||||
gimp-2.6.10.tar.bz2
|
||||
|
@ -1,29 +1,55 @@
|
||||
diff -up gimp-2.6.9/configure.in.script-fu-ipv6 gimp-2.6.9/configure.in
|
||||
--- gimp-2.6.9/configure.in.script-fu-ipv6 2010-06-21 21:20:20.000000000 +0200
|
||||
+++ gimp-2.6.9/configure.in 2010-06-29 17:28:24.153566227 +0200
|
||||
@@ -602,14 +602,14 @@ AC_CHECK_FUNC(rint, AC_DEFINE(HAVE_RINT,
|
||||
diff -up gimp-2.6.10/configure.in.script-fu-ipv6 gimp-2.6.10/configure.in
|
||||
--- gimp-2.6.10/configure.in.script-fu-ipv6 2010-07-03 00:51:55.000000000 +0200
|
||||
+++ gimp-2.6.10/configure.in 2010-07-09 13:20:33.499983496 +0200
|
||||
@@ -602,14 +602,15 @@ AC_CHECK_FUNC(rint, AC_DEFINE(HAVE_RINT,
|
||||
AC_DEFINE(HAVE_RINT)])])
|
||||
|
||||
|
||||
-######################################################
|
||||
-# Check for extra libs needed for inet_ntoa and socket
|
||||
-######################################################
|
||||
+########################################################
|
||||
+# Check for extra libs needed for getnameinfo and socket
|
||||
+########################################################
|
||||
+#####################################################################
|
||||
+# Check for extra libs needed for getaddrinfo, getnameinfo and socket
|
||||
+#####################################################################
|
||||
|
||||
gimp_save_LIBS=$LIBS
|
||||
LIBS=""
|
||||
|
||||
-AC_CHECK_FUNCS(inet_ntoa, , AC_CHECK_LIB(nsl, inet_ntoa))
|
||||
+AC_CHECK_FUNCS(getaddrinfo, , AC_CHECK_LIB(nsl, getaddrinfo))
|
||||
+AC_CHECK_FUNCS(getnameinfo, , AC_CHECK_LIB(nsl, getnameinfo))
|
||||
AC_CHECK_LIB(socket, socket)
|
||||
|
||||
SOCKET_LIBS="$LIBS"
|
||||
diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.6.9/plug-ins/script-fu/script-fu-server.c
|
||||
--- gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 2009-07-20 22:20:51.000000000 +0200
|
||||
+++ gimp-2.6.9/plug-ins/script-fu/script-fu-server.c 2010-06-29 17:28:24.154289648 +0200
|
||||
@@ -137,7 +137,8 @@ static void server_start (gin
|
||||
diff -up gimp-2.6.10/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.6.10/plug-ins/script-fu/script-fu-server.c
|
||||
--- gimp-2.6.10/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 2010-07-03 00:51:59.000000000 +0200
|
||||
+++ gimp-2.6.10/plug-ins/script-fu/script-fu-server.c 2010-07-09 13:20:33.500982656 +0200
|
||||
@@ -108,7 +108,7 @@
|
||||
#define RSP_LEN_L_BYTE 3
|
||||
|
||||
/*
|
||||
- * Local Structures
|
||||
+ * Local Types
|
||||
*/
|
||||
|
||||
typedef struct
|
||||
@@ -129,6 +129,15 @@ typedef struct
|
||||
gboolean run;
|
||||
} ServerInterface;
|
||||
|
||||
+typedef union
|
||||
+{
|
||||
+ sa_family_t family;
|
||||
+ struct sockaddr_storage ss;
|
||||
+ struct sockaddr sa;
|
||||
+ struct sockaddr_in sa_in;
|
||||
+ struct sockaddr_in6 sa_in6;
|
||||
+} sa_union;
|
||||
+
|
||||
/*
|
||||
* Local Functions
|
||||
*/
|
||||
@@ -137,7 +146,8 @@ static void server_start (gin
|
||||
const gchar *logfile);
|
||||
static gboolean execute_command (SFCommand *cmd);
|
||||
static gint read_from_client (gint filedes);
|
||||
@ -33,7 +59,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
static void server_log (const gchar *format,
|
||||
...) G_GNUC_PRINTF (1, 2);
|
||||
static void server_quit (void);
|
||||
@@ -151,7 +152,10 @@ static void print_socket_api_error
|
||||
@@ -151,7 +161,10 @@ static void print_socket_api_error
|
||||
/*
|
||||
* Local variables
|
||||
*/
|
||||
@ -45,7 +71,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
static GList *command_queue = NULL;
|
||||
static gint queue_length = 0;
|
||||
static gint request_no = 0;
|
||||
@@ -285,6 +289,7 @@ script_fu_server_listen (gint timeout)
|
||||
@@ -285,6 +298,7 @@ script_fu_server_listen (gint timeout)
|
||||
struct timeval tv;
|
||||
struct timeval *tvp = NULL;
|
||||
SELECT_MASK fds;
|
||||
@ -53,7 +79,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
|
||||
/* Set time struct */
|
||||
if (timeout)
|
||||
@@ -295,7 +300,10 @@ script_fu_server_listen (gint timeout)
|
||||
@@ -295,7 +309,10 @@ script_fu_server_listen (gint timeout)
|
||||
}
|
||||
|
||||
FD_ZERO (&fds);
|
||||
@ -65,7 +91,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
g_hash_table_foreach (clients, script_fu_server_add_fd, &fds);
|
||||
|
||||
/* Block until input arrives on one or more active sockets
|
||||
@@ -307,15 +315,25 @@ script_fu_server_listen (gint timeout)
|
||||
@@ -307,15 +324,23 @@ script_fu_server_listen (gint timeout)
|
||||
return;
|
||||
}
|
||||
|
||||
@ -75,9 +101,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
+ for (sockno = 0; sockno < server_socks_used; sockno++)
|
||||
{
|
||||
- struct sockaddr_in clientname;
|
||||
+ struct sockaddr_storage client;
|
||||
+ struct sockaddr_in *client_in;
|
||||
+ struct sockaddr_in6 *client_in6;
|
||||
+ sa_union client;
|
||||
+ gchar clientname[NI_MAXHOST];
|
||||
|
||||
/* Connection request on original socket. */
|
||||
@ -93,11 +117,11 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
+ continue;
|
||||
+ }
|
||||
+
|
||||
+ new = accept (server_socks[sockno], (struct sockaddr *) &client, &size);
|
||||
+ new = accept (server_socks[sockno], &(client.sa), &size);
|
||||
|
||||
if (new < 0)
|
||||
{
|
||||
@@ -324,13 +342,34 @@ script_fu_server_listen (gint timeout)
|
||||
@@ -324,13 +349,32 @@ script_fu_server_listen (gint timeout)
|
||||
}
|
||||
|
||||
/* Associate the client address with the socket */
|
||||
@ -109,22 +133,20 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
+ strncpy (clientname, "(error during host address lookup)", NI_MAXHOST-1);
|
||||
+
|
||||
+ /* Lookup address */
|
||||
+ (void) getnameinfo ((struct sockaddr *) &client, size, clientname,
|
||||
+ sizeof (clientname), NULL, 0, NI_NUMERICHOST);
|
||||
+ (void) getnameinfo (&(client.sa), size, clientname, sizeof (clientname),
|
||||
+ NULL, 0, NI_NUMERICHOST);
|
||||
+
|
||||
+ g_hash_table_insert (clients, GINT_TO_POINTER (new),
|
||||
+ g_strdup (clientname));
|
||||
+
|
||||
+ /* Determine port number */
|
||||
+ switch (client.ss_family)
|
||||
+ switch (client.family)
|
||||
+ {
|
||||
+ case AF_INET:
|
||||
+ client_in = (struct sockaddr_in *) &client;
|
||||
+ portno = (guint) g_ntohs (client_in->sin_port);
|
||||
+ portno = (guint) g_ntohs (client.sa_in.sin_port);
|
||||
+ break;
|
||||
+ case AF_INET6:
|
||||
+ client_in6 = (struct sockaddr_in6 *) &client;
|
||||
+ portno = (guint) g_ntohs (client_in6->sin6_port);
|
||||
+ portno = (guint) g_ntohs (client.sa_in6.sin6_port);
|
||||
+ break;
|
||||
+ default:
|
||||
+ portno = 0;
|
||||
@ -137,7 +159,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
}
|
||||
|
||||
/* Service the client sockets. */
|
||||
@@ -392,18 +431,46 @@ static void
|
||||
@@ -392,18 +436,46 @@ static void
|
||||
server_start (gint port,
|
||||
const gchar *logfile)
|
||||
{
|
||||
@ -191,7 +213,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
/* Setup up the server log file */
|
||||
if (logfile && *logfile)
|
||||
server_log_file = g_fopen (logfile, "a");
|
||||
@@ -592,11 +659,10 @@ read_from_client (gint filedes)
|
||||
@@ -592,11 +664,10 @@ read_from_client (gint filedes)
|
||||
}
|
||||
|
||||
static gint
|
||||
@ -206,7 +228,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
|
||||
/* Win32 needs the winsock library initialized. */
|
||||
#ifdef G_OS_WIN32
|
||||
@@ -620,7 +686,7 @@ make_socket (guint port)
|
||||
@@ -620,7 +691,7 @@ make_socket (guint port)
|
||||
#endif
|
||||
|
||||
/* Create the socket. */
|
||||
@ -215,7 +237,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
if (sock < 0)
|
||||
{
|
||||
print_socket_api_error ("socket");
|
||||
@@ -629,12 +695,20 @@ make_socket (guint port)
|
||||
@@ -629,12 +700,20 @@ make_socket (guint port)
|
||||
|
||||
setsockopt (sock, SOL_SOCKET, SO_REUSEADDR, &v, sizeof(v));
|
||||
|
||||
@ -241,7 +263,7 @@ diff -up gimp-2.6.9/plug-ins/script-fu/script-fu-server.c.script-fu-ipv6 gimp-2.
|
||||
{
|
||||
print_socket_api_error ("bind");
|
||||
gimp_quit ();
|
||||
@@ -672,7 +746,12 @@ script_fu_server_shutdown_fd (gpointer k
|
||||
@@ -672,7 +751,12 @@ script_fu_server_shutdown_fd (gpointer k
|
||||
static void
|
||||
server_quit (void)
|
||||
{
|
@ -1,44 +0,0 @@
|
||||
From ac799274bd9ac1f3cb24624853ad35ee5b860f62 Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Fri, 25 Jun 2010 13:53:04 +0200
|
||||
Subject: [PATCH] patch: combo-popup
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 0d1a4fd3c9bdf86ab71951c63bdf6915b8befd05
|
||||
Author: Michael Natterer <mitch@gimp.org>
|
||||
Date: Thu Jun 24 21:56:41 2010 +0200
|
||||
|
||||
Bug 622608 - GIMP crashes when clicking any scroll bar from combo boxes
|
||||
|
||||
Don't cancel the popup in grab_notify() if the popup's grab was
|
||||
shadowed by one of the widgets in the popup, like the scrollbar.
|
||||
(cherry picked from commit 991210c0f94ed8e88eab7ebf19438bad85931930)
|
||||
---
|
||||
app/widgets/gimpcontainerpopup.c | 10 ++++++++--
|
||||
1 files changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/app/widgets/gimpcontainerpopup.c b/app/widgets/gimpcontainerpopup.c
|
||||
index 50624cc..40cdfce 100644
|
||||
--- a/app/widgets/gimpcontainerpopup.c
|
||||
+++ b/app/widgets/gimpcontainerpopup.c
|
||||
@@ -181,8 +181,14 @@ static void
|
||||
gimp_container_popup_grab_notify (GtkWidget *widget,
|
||||
gboolean was_grabbed)
|
||||
{
|
||||
- if (! was_grabbed)
|
||||
- g_signal_emit (widget, popup_signals[CANCEL], 0);
|
||||
+ if (was_grabbed)
|
||||
+ return;
|
||||
+
|
||||
+ /* ignore grabs on one of our children, like the scrollbar */
|
||||
+ if (gtk_widget_is_ancestor (gtk_grab_get_current (), widget))
|
||||
+ return;
|
||||
+
|
||||
+ g_signal_emit (widget, popup_signals[CANCEL], 0);
|
||||
}
|
||||
|
||||
static gboolean
|
||||
--
|
||||
1.7.0.1
|
||||
|
42
gimp.spec
42
gimp.spec
@ -30,8 +30,8 @@
|
||||
Summary: GNU Image Manipulation Program
|
||||
Name: gimp
|
||||
Epoch: 2
|
||||
Version: 2.6.9
|
||||
Release: 4%{?dist}
|
||||
Version: 2.6.10
|
||||
Release: 1%{?dist}
|
||||
%define binver 2.6
|
||||
%define gimp_lang_ver 20
|
||||
%define interfacever 2.0
|
||||
@ -127,14 +127,12 @@ Patch1: gimp-2.6.7-jpeg-units.patch
|
||||
Patch2: gimp-2.6.6-minimize-dialogs.patch
|
||||
# backport: fix building with "gold" linker
|
||||
Patch3: gimp-2.6.8-gold.patch
|
||||
# backport: GIMP crashes when clicking any scroll bar from combo boxes
|
||||
Patch4: gimp-2.6.9-combo-popup.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=198367
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=623045
|
||||
# make script-fu logging IPv6 aware
|
||||
Patch5: gimp-2.6.9-script-fu-ipv6.patch
|
||||
Patch4: gimp-2.6.10-script-fu-ipv6.patch
|
||||
# files changed by autoreconf after applying the above
|
||||
Patch10: gimp-2.6.9-3-autoreconf.patch.bz2
|
||||
Patch10: gimp-2.6.10-1-autoreconf.patch.bz2
|
||||
|
||||
%description
|
||||
GIMP (GNU Image Manipulation Program) is a powerful image composition and
|
||||
@ -217,8 +215,7 @@ EOF
|
||||
%patch1 -p1 -b .jpeg-units
|
||||
%patch2 -p1 -b .minimize-dialogs
|
||||
%patch3 -p1 -b .gold
|
||||
%patch4 -p1 -b .combo-popup
|
||||
%patch5 -p1 -b .script-fu-ipv6
|
||||
%patch4 -p1 -b .script-fu-ipv6
|
||||
%patch10 -p1 -b .autoreconf
|
||||
|
||||
%build
|
||||
@ -481,6 +478,35 @@ fi
|
||||
%{_libdir}/gimp/%{interfacever}/plug-ins/help-browser
|
||||
|
||||
%changelog
|
||||
* Fri Jul 09 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.10-1
|
||||
- version 2.6.10
|
||||
|
||||
Overview of Changes from GIMP 2.6.9 to GIMP 2.6.10
|
||||
==================================================
|
||||
|
||||
* Bugs fixed:
|
||||
|
||||
613328 - TGA files saved with incorrect header yOrigin data
|
||||
623290 - Save As... does not save Windows Bitmap as default in dialog
|
||||
621363 - CMYK decompose broken
|
||||
595170 - brush - color from gradient works wrong in greyscale
|
||||
613838 - Error in gimp-hue-saturation PDB call
|
||||
622608 - GIMP crashes when clicking any scroll bar from combo boxes
|
||||
565459 - newly opened images are put into the background
|
||||
|
||||
* Updated translations:
|
||||
|
||||
German (de)
|
||||
Italian (it)
|
||||
Romanian (ro)
|
||||
Portuguese (pt)
|
||||
|
||||
- remove obsolete combo-popup patch
|
||||
- update script-fu-ipv6 patch
|
||||
|
||||
* Mon Jul 05 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.9-5
|
||||
- rebuild against libwebkitgtk (instead of libwebkit)
|
||||
|
||||
* Tue Jun 29 2010 Nils Philippsen <nils@redhat.com> - 2:2.6.9-4
|
||||
- script-fu: make rest of server IPv6-aware (#198367)
|
||||
|
||||
|
@ -1 +1,2 @@
|
||||
gimp-2_6_9-1_fc14:F-13:gimp-2.6.9-1.fc14.src.rpm:1277370842
|
||||
gimp-2_6_10-1_fc14:F-13:gimp-2.6.10-1.fc14.src.rpm:1278678066
|
||||
|
Loading…
Reference in New Issue
Block a user