import gimp-2.8.22-15.module+el8+2760+3d7d61b2
This commit is contained in:
commit
01dbfac387
1
.gimp.metadata
Normal file
1
.gimp.metadata
Normal file
@ -0,0 +1 @@
|
||||
c894a0d9a864d418bdbd30a22d698c731583e5c4 SOURCES/gimp-2.8.22.tar.bz2
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/gimp-2.8.22.tar.bz2
|
@ -0,0 +1,48 @@
|
||||
From 9a3f047f90a79e96af54a73090313a670b2685d3 Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon, 19 Nov 2012 18:26:16 +0100
|
||||
Subject: [PATCH] patch: cm-system-monitor-profile-by-default
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 1430096d27ba12566739fadf96302c9a4ce8f98b
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Nov 19 18:25:28 2012 +0100
|
||||
|
||||
color mgmt: fix syntax error
|
||||
|
||||
commit eb78c3a0cfd7ff796110fcd3cd161ca11005fca5
|
||||
Author: Richard Hughes <hughsient@gmail.com>
|
||||
Date: Thu Nov 15 12:12:12 2012 +0100
|
||||
|
||||
color mgmt: try to use the system monitor profile by default
|
||||
---
|
||||
etc/gimprc | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/etc/gimprc b/etc/gimprc
|
||||
index 8306571..1511cd6 100644
|
||||
--- a/etc/gimprc
|
||||
+++ b/etc/gimprc
|
||||
@@ -285,14 +285,15 @@
|
||||
|
||||
# Defines the color management behavior. This is a parameter list.
|
||||
#
|
||||
-# (color-management
|
||||
+(color-management
|
||||
# (mode display)
|
||||
-# (display-profile-from-gdk no)
|
||||
+ (display-profile-from-gdk yes)
|
||||
# (display-rendering-intent perceptual)
|
||||
# (simulation-rendering-intent perceptual)
|
||||
# (simulation-gamut-check no)
|
||||
# (out-of-gamut-color (color-rgb 0.501961 0.501961 0.501961))
|
||||
-# (display-module "CdisplayLcms"))
|
||||
+# (display-module "CdisplayLcms")
|
||||
+)
|
||||
|
||||
# How to handle embedded color profiles when opening a file. Possible values
|
||||
# are ask, keep and convert.
|
||||
--
|
||||
1.7.11.7
|
||||
|
13
SOURCES/gimp-2.8.22-CVE-2017-17784.patch
Normal file
13
SOURCES/gimp-2.8.22-CVE-2017-17784.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -urNp old/plug-ins/common/file-gbr.c new/plug-ins/common/file-gbr.c
|
||||
--- old/plug-ins/common/file-gbr.c 2018-01-04 12:13:17.553757864 +0100
|
||||
+++ new/plug-ins/common/file-gbr.c 2018-01-04 12:18:01.723635742 +0100
|
||||
@@ -443,7 +443,8 @@ load_image (const gchar *filename,
|
||||
{
|
||||
gchar *temp = g_new (gchar, bn_size);
|
||||
|
||||
- if ((read (fd, temp, bn_size)) < bn_size)
|
||||
+ if ((read (fd, temp, bn_size)) < bn_size ||
|
||||
+ temp[bn_size - 1] != '\0')
|
||||
{
|
||||
g_set_error (error, G_FILE_ERROR, G_FILE_ERROR_FAILED,
|
||||
_("Error in GIMP brush file '%s'"),
|
130
SOURCES/gimp-2.8.22-CVE-2017-17785.patch
Normal file
130
SOURCES/gimp-2.8.22-CVE-2017-17785.patch
Normal file
@ -0,0 +1,130 @@
|
||||
diff -urNp old/plug-ins/file-fli/fli.c new/plug-ins/file-fli/fli.c
|
||||
--- old/plug-ins/file-fli/fli.c 2018-01-04 12:19:54.714139464 +0100
|
||||
+++ new/plug-ins/file-fli/fli.c 2018-01-04 12:34:18.568323629 +0100
|
||||
@@ -25,6 +25,8 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
+#include <glib/gstdio.h>
|
||||
+
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
|
||||
@@ -461,23 +463,27 @@ void fli_read_brun(FILE *f, s_fli_header
|
||||
unsigned short yc;
|
||||
unsigned char *pos;
|
||||
for (yc=0; yc < fli_header->height; yc++) {
|
||||
- unsigned short xc, pc, pcnt;
|
||||
+ unsigned short pc, pcnt;
|
||||
+ size_t n, xc;
|
||||
pc=fli_read_char(f);
|
||||
xc=0;
|
||||
pos=framebuf+(fli_header->width * yc);
|
||||
+ n=(size_t)fli_header->width * (fli_header->height-yc);
|
||||
for (pcnt=pc; pcnt>0; pcnt--) {
|
||||
unsigned short ps;
|
||||
ps=fli_read_char(f);
|
||||
if (ps & 0x80) {
|
||||
unsigned short len;
|
||||
- for (len=-(signed char)ps; len>0; len--) {
|
||||
+ for (len=-(signed char)ps; len>0 && xc<n; len--) {
|
||||
pos[xc++]=fli_read_char(f);
|
||||
}
|
||||
} else {
|
||||
unsigned char val;
|
||||
+ size_t len;
|
||||
+ len=MIN(n-xc,ps);
|
||||
val=fli_read_char(f);
|
||||
- memset(&(pos[xc]), val, ps);
|
||||
- xc+=ps;
|
||||
+ memset(&(pos[xc]), val, len);
|
||||
+ xc+=len;
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -564,25 +570,34 @@ void fli_read_lc(FILE *f, s_fli_header *
|
||||
memcpy(framebuf, old_framebuf, fli_header->width * fli_header->height);
|
||||
firstline = fli_read_short(f);
|
||||
numline = fli_read_short(f);
|
||||
+ if (numline > fli_header->height || fli_header->height-numline < firstline)
|
||||
+ return;
|
||||
+
|
||||
for (yc=0; yc < numline; yc++) {
|
||||
- unsigned short xc, pc, pcnt;
|
||||
+ unsigned short pc, pcnt;
|
||||
+ size_t n, xc;
|
||||
pc=fli_read_char(f);
|
||||
xc=0;
|
||||
pos=framebuf+(fli_header->width * (firstline+yc));
|
||||
+ n=(size_t)fli_header->width * (fli_header->height-firstline-yc);
|
||||
for (pcnt=pc; pcnt>0; pcnt--) {
|
||||
unsigned short ps,skip;
|
||||
skip=fli_read_char(f);
|
||||
ps=fli_read_char(f);
|
||||
- xc+=skip;
|
||||
+ xc+=MIN(n-xc,skip);
|
||||
if (ps & 0x80) {
|
||||
unsigned char val;
|
||||
+ size_t len;
|
||||
ps=-(signed char)ps;
|
||||
val=fli_read_char(f);
|
||||
- memset(&(pos[xc]), val, ps);
|
||||
- xc+=ps;
|
||||
+ len=MIN(n-xc,ps);
|
||||
+ memset(&(pos[xc]), val, len);
|
||||
+ xc+=len;
|
||||
} else {
|
||||
- fread(&(pos[xc]), ps, 1, f);
|
||||
- xc+=ps;
|
||||
+ size_t len;
|
||||
+ len=MIN(n-xc,ps);
|
||||
+ fread(&(pos[xc]), len, 1, f);
|
||||
+ xc+=len;
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -689,7 +704,8 @@ void fli_read_lc_2(FILE *f, s_fli_header
|
||||
yc=0;
|
||||
numline = fli_read_short(f);
|
||||
for (lc=0; lc < numline; lc++) {
|
||||
- unsigned short xc, pc, pcnt, lpf, lpn;
|
||||
+ unsigned short pc, pcnt, lpf, lpn;
|
||||
+ size_t n, xc;
|
||||
pc=fli_read_short(f);
|
||||
lpf=0; lpn=0;
|
||||
while (pc & 0x8000) {
|
||||
@@ -700,26 +716,30 @@ void fli_read_lc_2(FILE *f, s_fli_header
|
||||
}
|
||||
pc=fli_read_short(f);
|
||||
}
|
||||
+ yc=MIN(yc, fli_header->height);
|
||||
xc=0;
|
||||
pos=framebuf+(fli_header->width * yc);
|
||||
+ n=(size_t)fli_header->width * (fli_header->height-yc);
|
||||
for (pcnt=pc; pcnt>0; pcnt--) {
|
||||
unsigned short ps,skip;
|
||||
skip=fli_read_char(f);
|
||||
ps=fli_read_char(f);
|
||||
- xc+=skip;
|
||||
+ xc+=MIN(n-xc,skip);
|
||||
if (ps & 0x80) {
|
||||
unsigned char v1,v2;
|
||||
ps=-(signed char)ps;
|
||||
v1=fli_read_char(f);
|
||||
v2=fli_read_char(f);
|
||||
- while (ps>0) {
|
||||
+ while (ps>0 && xc+1<n) {
|
||||
pos[xc++]=v1;
|
||||
pos[xc++]=v2;
|
||||
ps--;
|
||||
}
|
||||
} else {
|
||||
- fread(&(pos[xc]), ps, 2, f);
|
||||
- xc+=ps << 1;
|
||||
+ size_t len;
|
||||
+ len=MIN((n-xc)/2,ps);
|
||||
+ fread(&(pos[xc]), len, 2, f);
|
||||
+ xc+=len << 1;
|
||||
}
|
||||
}
|
||||
if (lpf) pos[xc]=lpn;
|
25
SOURCES/gimp-2.8.22-CVE-2017-17786.patch
Normal file
25
SOURCES/gimp-2.8.22-CVE-2017-17786.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -urNp old/plug-ins/common/file-tga.c new/plug-ins/common/file-tga.c
|
||||
--- old/plug-ins/common/file-tga.c 2018-01-04 12:36:22.333754882 +0100
|
||||
+++ new/plug-ins/common/file-tga.c 2018-01-04 12:40:46.943070295 +0100
|
||||
@@ -564,12 +564,17 @@ load_image (const gchar *filename,
|
||||
}
|
||||
break;
|
||||
case TGA_TYPE_COLOR:
|
||||
- if (info.bpp != 15 && info.bpp != 16 &&
|
||||
- info.bpp != 24 && info.bpp != 32)
|
||||
+ if ((info.bpp != 15 && info.bpp != 16 &&
|
||||
+ info.bpp != 24 && info.bpp != 32) ||
|
||||
+ ((info.bpp == 15 || info.bpp == 24) &&
|
||||
+ info.alphaBits != 0) ||
|
||||
+ (info.bpp == 16 && info.alphaBits != 1 &&
|
||||
+ info.alphaBits != 0) ||
|
||||
+ (info.bpp == 32 && info.alphaBits != 8))
|
||||
{
|
||||
- g_message ("Unhandled sub-format in '%s' (type = %u, bpp = %u)",
|
||||
+ g_message ("Unhandled sub-format in '%s' (type = %u, bpp = %u, alpha = %u)",
|
||||
gimp_filename_to_utf8 (filename),
|
||||
- info.imageType, info.bpp);
|
||||
+ info.imageType, info.bpp, info.alphaBits);
|
||||
return -1;
|
||||
}
|
||||
break;
|
16
SOURCES/gimp-2.8.22-CVE-2017-17787.patch
Normal file
16
SOURCES/gimp-2.8.22-CVE-2017-17787.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -urNp old/plug-ins/common/file-psp.c new/plug-ins/common/file-psp.c
|
||||
--- old/plug-ins/common/file-psp.c 2018-01-04 11:58:46.928253797 +0100
|
||||
+++ new/plug-ins/common/file-psp.c 2018-01-04 12:03:42.141874067 +0100
|
||||
@@ -913,6 +913,12 @@ read_creator_block (FILE *f,
|
||||
g_message ("Error reading creator keyword data");
|
||||
return -1;
|
||||
}
|
||||
+ if (string[length - 1] != '\0')
|
||||
+ {
|
||||
+ g_message ("Creator keyword data not nul-terminated");
|
||||
+ g_free (string);
|
||||
+ return -1;
|
||||
+ }
|
||||
switch (keyword)
|
||||
{
|
||||
case PSP_CRTR_FLD_CRT_DATE:
|
13
SOURCES/gimp-2.8.22-CVE-2017-17788.patch
Normal file
13
SOURCES/gimp-2.8.22-CVE-2017-17788.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -urNp old/app/xcf/xcf.c new/app/xcf/xcf.c
|
||||
--- old/app/xcf/xcf.c 2017-04-30 23:47:39.000000000 +0200
|
||||
+++ new/app/xcf/xcf.c 2018-01-04 11:56:31.399888783 +0100
|
||||
@@ -318,7 +318,8 @@ xcf_load_invoker (GimpProcedure *pr
|
||||
{
|
||||
info.file_version = 0;
|
||||
}
|
||||
- else if (id[9] == 'v')
|
||||
+ else if (id[9] == 'v' &&
|
||||
+ id[13] == '\0')
|
||||
{
|
||||
info.file_version = atoi (id + 10);
|
||||
}
|
19
SOURCES/gimp-2.8.22-CVE-2017-17789.patch
Normal file
19
SOURCES/gimp-2.8.22-CVE-2017-17789.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -urNp old/plug-ins/common/file-psp.c new/plug-ins/common/file-psp.c
|
||||
--- old/plug-ins/common/file-psp.c 2018-01-04 12:04:14.636811394 +0100
|
||||
+++ new/plug-ins/common/file-psp.c 2018-01-04 12:12:41.717877789 +0100
|
||||
@@ -1777,6 +1777,15 @@ load_image (const gchar *filename,
|
||||
{
|
||||
block_start = ftell (f);
|
||||
|
||||
+ if (block_start + block_total_len > st.st_size)
|
||||
+ {
|
||||
+ g_set_error (error, G_FILE_ERROR, G_FILE_ERROR_FAILED,
|
||||
+ _("Could not open '%s' for reading: %s"),
|
||||
+ gimp_filename_to_utf8 (filename),
|
||||
+ _("invalid block size"));
|
||||
+ goto error;
|
||||
+ }
|
||||
+
|
||||
if (id == PSP_IMAGE_BLOCK)
|
||||
{
|
||||
if (block_number != 0)
|
10202
SOURCES/gimp-2.8.22-fix-screenshot-in-wayland.patch
Normal file
10202
SOURCES/gimp-2.8.22-fix-screenshot-in-wayland.patch
Normal file
File diff suppressed because it is too large
Load Diff
163
SOURCES/gimp-2.8.22-python.patch
Normal file
163
SOURCES/gimp-2.8.22-python.patch
Normal file
@ -0,0 +1,163 @@
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/benchmark-foreground-extract.py new/plug-ins/pygimp/plug-ins/benchmark-foreground-extract.py
|
||||
--- old/plug-ins/pygimp/plug-ins/benchmark-foreground-extract.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/benchmark-foreground-extract.py 2018-05-22 13:13:20.132412856 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Foreground Extraction Benchmark
|
||||
# Copyright 2005 Sven Neumann <sven@gimp.org>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/clothify.py new/plug-ins/pygimp/plug-ins/clothify.py
|
||||
--- old/plug-ins/pygimp/plug-ins/clothify.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/clothify.py 2018-05-22 13:13:30.123366531 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 1997 James Henstridge <james@daa.com.au>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/colorxhtml.py new/plug-ins/pygimp/plug-ins/colorxhtml.py
|
||||
--- old/plug-ins/pygimp/plug-ins/colorxhtml.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/colorxhtml.py 2018-05-22 13:11:58.188793396 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 2003, 2005 Manish Singh <yosh@gimp.org>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/file-openraster.py new/plug-ins/pygimp/plug-ins/file-openraster.py
|
||||
--- old/plug-ins/pygimp/plug-ins/file-openraster.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/file-openraster.py 2018-05-22 13:10:57.468076133 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# GIMP Plug-in for the OpenRaster file format
|
||||
# http://create.freedesktop.org/wiki/OpenRaster
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/foggify.py new/plug-ins/pygimp/plug-ins/foggify.py
|
||||
--- old/plug-ins/pygimp/plug-ins/foggify.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/foggify.py 2018-05-22 13:11:44.843855476 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 1997 James Henstridge <james@daa.com.au>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/gradients-save-as-css.py new/plug-ins/pygimp/plug-ins/gradients-save-as-css.py
|
||||
--- old/plug-ins/pygimp/plug-ins/gradients-save-as-css.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/gradients-save-as-css.py 2018-05-22 13:11:34.716902608 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#! /usr/bin/env python
|
||||
+#! /usr/bin/env python2
|
||||
# -*- coding: utf-8 -*-
|
||||
|
||||
# Allows saving (TODO: and loading) CSS gradient files
|
||||
@@ -101,4 +101,4 @@ register(
|
||||
menu="<Gradients>",
|
||||
domain=("gimp20-python", gimp.locale_directory)
|
||||
)
|
||||
-main()
|
||||
\ Chybí znak konce řádku na konci souboru
|
||||
+main()
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/palette-offset.py new/plug-ins/pygimp/plug-ins/palette-offset.py
|
||||
--- old/plug-ins/pygimp/plug-ins/palette-offset.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/palette-offset.py 2018-05-22 13:12:38.003608362 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
# -*- coding: utf-8 -*-
|
||||
# This program is free software: you can redistribute it and/or modify
|
||||
# it under the terms of the GNU General Public License as published by
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/palette-sort.py new/plug-ins/pygimp/plug-ins/palette-sort.py
|
||||
--- old/plug-ins/pygimp/plug-ins/palette-sort.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/palette-sort.py 2018-05-22 13:11:10.469015537 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
#
|
||||
# This program is free software: you can redistribute it and/or modify
|
||||
# it under the terms of the GNU General Public License as published by
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/palette-to-gradient.py new/plug-ins/pygimp/plug-ins/palette-to-gradient.py
|
||||
--- old/plug-ins/pygimp/plug-ins/palette-to-gradient.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/palette-to-gradient.py 2018-05-22 13:10:27.932213923 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
#
|
||||
# This program is free software: you can redistribute it and/or modify
|
||||
# it under the terms of the GNU General Public License as published by
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/py-slice.py new/plug-ins/pygimp/plug-ins/py-slice.py
|
||||
--- old/plug-ins/pygimp/plug-ins/py-slice.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/py-slice.py 2018-05-22 13:10:47.796121235 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
# -*- coding: utf-8 -*-
|
||||
|
||||
#Copyright (c) Manish Singh
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/python-console.py new/plug-ins/pygimp/plug-ins/python-console.py
|
||||
--- old/plug-ins/pygimp/plug-ins/python-console.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/python-console.py 2018-05-22 13:12:08.532745298 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 1997 James Henstridge <james@daa.com.au>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/python-eval.py new/plug-ins/pygimp/plug-ins/python-eval.py
|
||||
--- old/plug-ins/pygimp/plug-ins/python-eval.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/python-eval.py 2018-05-22 13:13:44.059301940 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 2006 Manish Singh <yosh@gimp.org>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/shadow_bevel.py new/plug-ins/pygimp/plug-ins/shadow_bevel.py
|
||||
--- old/plug-ins/pygimp/plug-ins/shadow_bevel.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/shadow_bevel.py 2018-05-22 13:13:56.019246529 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 1997 James Henstridge <james@daa.com.au>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/sphere.py new/plug-ins/pygimp/plug-ins/sphere.py
|
||||
--- old/plug-ins/pygimp/plug-ins/sphere.py 2018-05-22 13:09:58.522351307 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/sphere.py 2018-05-22 13:14:14.564160649 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 1997 James Henstridge <james@daa.com.au>
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/text-brush.py new/plug-ins/pygimp/plug-ins/text-brush.py
|
||||
--- old/plug-ins/pygimp/plug-ins/text-brush.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/text-brush.py 2018-05-22 13:12:49.291555951 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
# coding: utf-8
|
||||
|
||||
# Author: João Sebastião de Oliveira Bueno
|
||||
diff -urNp old/plug-ins/pygimp/plug-ins/whirlpinch.py new/plug-ins/pygimp/plug-ins/whirlpinch.py
|
||||
--- old/plug-ins/pygimp/plug-ins/whirlpinch.py 2018-05-22 13:09:58.521351312 +0200
|
||||
+++ new/plug-ins/pygimp/plug-ins/whirlpinch.py 2018-05-22 13:14:24.092116544 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python2
|
||||
|
||||
# Gimp-Python - allows the writing of Gimp plugins in Python.
|
||||
# Copyright (C) 1997 James Henstridge <james@daa.com.au>
|
||||
diff -urNp old/configure new/configure
|
||||
--- old/configure 2018-06-28 08:44:29.162846929 +0200
|
||||
+++ new/configure 2018-06-28 08:47:06.790148573 +0200
|
||||
@@ -23051,7 +23051,7 @@ if ${am_cv_pathless_PYTHON+:} false; the
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
|
||||
- for am_cv_pathless_PYTHON in python python2 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
|
||||
+ for am_cv_pathless_PYTHON in python2 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
|
||||
test "$am_cv_pathless_PYTHON" = none && break
|
||||
prog="import sys
|
||||
# split strings by '.' and convert to numeric. Append some zeros
|
12
SOURCES/gimp-2.8.6-external-help-browser.patch
Normal file
12
SOURCES/gimp-2.8.6-external-help-browser.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up gimp-2.8.6/etc/gimprc.external-help-browser gimp-2.8.6/etc/gimprc
|
||||
--- gimp-2.8.6/etc/gimprc.external-help-browser 2013-07-02 12:04:11.011774506 +0200
|
||||
+++ gimp-2.8.6/etc/gimprc 2013-07-02 12:04:25.408824028 +0200
|
||||
@@ -671,7 +671,7 @@
|
||||
# Sets the browser used by the help system. Possible values are gimp and
|
||||
# web-browser.
|
||||
#
|
||||
-# (help-browser gimp)
|
||||
+(help-browser web-browser)
|
||||
|
||||
# When enabled, the online user manual will be used by the help system.
|
||||
# Otherwise the locally installed copy is used. Possible values are yes and
|
2422
SPECS/gimp.spec
Normal file
2422
SPECS/gimp.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user