Update to 5.1.8
This commit is contained in:
parent
f811572386
commit
e04ff20350
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ giflib-4.1.6.tar.bz2
|
|||||||
/giflib-5.1.4.tar.bz2
|
/giflib-5.1.4.tar.bz2
|
||||||
/giflib-5.1.6.tar.gz
|
/giflib-5.1.6.tar.gz
|
||||||
/giflib-5.1.7.tar.gz
|
/giflib-5.1.7.tar.gz
|
||||||
|
/giflib-5.1.8.tar.gz
|
||||||
|
10
giflib.spec
10
giflib.spec
@ -1,17 +1,12 @@
|
|||||||
Name: giflib
|
Name: giflib
|
||||||
Summary: A library and utilities for processing GIFs
|
Summary: A library and utilities for processing GIFs
|
||||||
Version: 5.1.7
|
Version: 5.1.8
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.sourceforge.net/projects/%{name}/
|
URL: http://www.sourceforge.net/projects/%{name}/
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# Install *.1 manpages to mandir/man1
|
|
||||||
Patch0: giflib_mandir.patch
|
|
||||||
# Set the shared library soname
|
|
||||||
Patch1: giflib_soname.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: xmlto
|
BuildRequires: xmlto
|
||||||
@ -73,6 +68,9 @@ rm -f %{buildroot}%{_libdir}/libgif.a
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 20 2019 Sandro Mani <manisandro@gmail.com> - 5.1.8-1
|
||||||
|
- Update to 5.1.8
|
||||||
|
|
||||||
* Mon Mar 11 2019 Sandro Mani <manisandro@gmail.com> - 5.1.7-1
|
* Mon Mar 11 2019 Sandro Mani <manisandro@gmail.com> - 5.1.7-1
|
||||||
- Update to 5.1.7
|
- Update to 5.1.7
|
||||||
|
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
diff -rupN giflib-5.1.7/Makefile giflib-5.1.7-new/Makefile
|
|
||||||
--- giflib-5.1.7/Makefile 2019-03-10 20:06:28.000000000 +0100
|
|
||||||
+++ giflib-5.1.7-new/Makefile 2019-03-11 11:37:17.991404481 +0100
|
|
||||||
@@ -96,8 +96,8 @@ install-lib:
|
|
||||||
ln -sf libgif.so.$(LIBVER) "$(DESTDIR)$(LIBDIR)/libgif.so.$(LIBMAJOR)"
|
|
||||||
ln -sf libgif.so.$(LIBMAJOR) "$(DESTDIR)$(LIBDIR)/libgif.so"
|
|
||||||
install-man:
|
|
||||||
- $(INSTALL) -d "$(DESTDIR)$(MANDIR)"
|
|
||||||
- $(INSTALL) -m 644 doc/*.1 "$(DESTDIR)$(MANDIR)"
|
|
||||||
+ $(INSTALL) -d "$(DESTDIR)$(MANDIR)/man1"
|
|
||||||
+ $(INSTALL) -m 644 doc/*.1 "$(DESTDIR)$(MANDIR)/man1"
|
|
||||||
uninstall: uninstall-man uninstall-include uninstall-lib uninstall-bin
|
|
||||||
uninstall-bin:
|
|
||||||
cd "$(DESTDIR)$(BINDIR)" && rm -f $(INSTALLABLE)
|
|
||||||
@@ -107,7 +107,7 @@ uninstall-lib:
|
|
||||||
cd "$(DESTDIR)$(LIBDIR)" && \
|
|
||||||
rm -f libgif.a libgif.so libgif.so.$(LIBMAJOR) libgif.so.$(LIBVER)
|
|
||||||
uninstall-man:
|
|
||||||
- cd "$(DESTDIR)$(MANDIR)" && rm -f $(shell cd doc >/dev/null && echo *.1)
|
|
||||||
+ cd "$(DESTDIR)$(MANDIR)/man1" && rm -f $(shell cd doc >/dev/null && echo *.1)
|
|
||||||
|
|
||||||
# Make distribution tarball
|
|
||||||
#
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -rupN giflib-5.1.7/Makefile giflib-5.1.7-new/Makefile
|
|
||||||
--- giflib-5.1.7/Makefile 2019-03-11 11:37:18.008404458 +0100
|
|
||||||
+++ giflib-5.1.7-new/Makefile 2019-03-11 11:37:18.011404454 +0100
|
|
||||||
@@ -66,7 +66,7 @@ all: libgif.so libgif.a $(UTILS)
|
|
||||||
$(UTILS):: libgif.a
|
|
||||||
|
|
||||||
libgif.so: $(OBJECTS) $(HEADERS)
|
|
||||||
- $(CC) $(CFLAGS) -shared $(OFLAGS) -o libgif.so $(OBJECTS)
|
|
||||||
+ $(CC) $(CFLAGS) -shared $(OFLAGS) -Wl,-soname -Wl,libgif.so.$(LIBMAJOR) -o libgif.so $(OBJECTS)
|
|
||||||
|
|
||||||
libgif.a: $(OBJECTS) $(HEADERS)
|
|
||||||
ar rcs libgif.a $(OBJECTS)
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (giflib-5.1.7.tar.gz) = b30c3707839a6d66a3e54d92607c303e5ca3d04d6a02d2037fdc8b80386f9a7fa4148727705014481c3c167bdfac2e99d7e4db1ff7f277b64bd2d9193a89f8b0
|
SHA512 (giflib-5.1.8.tar.gz) = d390917837a64de1912720ab8968e6b077c6be9f9a2f835faced44420f54d6d55d4e3543b9779ec65d399858856188fea93c170b253d0b83928f15548a14aba3
|
||||||
|
Loading…
Reference in New Issue
Block a user