Fix broken soname

This commit is contained in:
Sandro Mani 2019-02-23 20:08:54 +01:00
parent cec422d17e
commit db1305a891
2 changed files with 19 additions and 2 deletions

View File

@ -1,14 +1,16 @@
Name: giflib
Summary: A library and utilities for processing GIFs
Version: 5.1.6
Release: 1%{?dist}
Release: 2%{?dist}
License: MIT
URL: http://www.sourceforge.net/projects/%{name}/
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
# Instal *.1 manpages to mandir/man1
# Install *.1 manpages to mandir/man1
Patch0: giflib_mandir.patch
# Set the shared library soname
Patch1: giflib_soname.patch
BuildRequires: gcc
BuildRequires: make
@ -71,6 +73,9 @@ rm -f %{buildroot}%{_libdir}/libgif.a
%changelog
* Sat Feb 23 2019 Sandro Mani <manisandro@gmail.com> - 5.1.6-2
- Fix broken soname
* Mon Feb 18 2019 Sandro Mani <manisandro@gmail.com> - 5.1.6-1
- Update to 5.1.6

12
giflib_soname.patch Normal file
View File

@ -0,0 +1,12 @@
diff -rupN giflib-5.1.6/Makefile giflib-5.1.6-new/Makefile
--- giflib-5.1.6/Makefile 2019-02-12 15:26:13.000000000 +0100
+++ giflib-5.1.6-new/Makefile 2019-02-23 20:01:33.846500996 +0100
@@ -66,7 +66,7 @@ all: libgif.so libgif.a $(UTILS)
$(UTILS):: libgif.a
libgif.so: $(OBJECTS) $(HEADERS)
- $(CC) $(CFLAGS) -shared $(OFLAGS) -o libgif.so $(OBJECTS)
+ $(CC) $(CFLAGS) -shared $(OFLAGS) -Wl,-soname -Wl,libgif.so.$(LIBMAJOR) -o libgif.so $(OBJECTS)
libgif.a: $(OBJECTS) $(HEADERS)
ar rcs libgif.a $(OBJECTS)