Update to 5.1.6
This commit is contained in:
parent
3eeb518ee3
commit
cec422d17e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
giflib-4.1.6.tar.bz2
|
giflib-4.1.6.tar.bz2
|
||||||
/giflib-5.1.4.tar.bz2
|
/giflib-5.1.4.tar.bz2
|
||||||
|
/giflib-5.1.6.tar.gz
|
||||||
|
30
giflib.spec
30
giflib.spec
@ -1,11 +1,14 @@
|
|||||||
Name: giflib
|
Name: giflib
|
||||||
Summary: A library and utilities for processing GIFs
|
Summary: A library and utilities for processing GIFs
|
||||||
Version: 5.1.4
|
Version: 5.1.6
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.sourceforge.net/projects/%{name}/
|
URL: http://www.sourceforge.net/projects/%{name}/
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
|
# Instal *.1 manpages to mandir/man1
|
||||||
|
Patch0: giflib_mandir.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -39,27 +42,21 @@ format image files.
|
|||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%make_build CFLAGS="%{optflags} -fPIC" LDFLAGS="%{__global_ldflags}"
|
||||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
|
||||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
|
||||||
%make_build
|
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%make_install
|
%make_install PREFIX="%{_prefix}" LIBDIR="%{_libdir}"
|
||||||
|
|
||||||
# Don't install any static .a and libtool .la files
|
# Drop static library
|
||||||
rm -f %{buildroot}%{_libdir}/*.{a,la}
|
rm -f %{buildroot}%{_libdir}/libgif.a
|
||||||
|
|
||||||
# Remove makefile relics from documentation
|
|
||||||
rm -f doc/Makefile*
|
|
||||||
|
|
||||||
|
|
||||||
%ldconfig_scriptlets
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc AUTHORS ChangeLog NEWS README
|
%doc ChangeLog NEWS README
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%{_libdir}/libgif.so.7*
|
%{_libdir}/libgif.so.7*
|
||||||
|
|
||||||
@ -70,10 +67,13 @@ rm -f doc/Makefile*
|
|||||||
|
|
||||||
%files utils
|
%files utils
|
||||||
%{_bindir}/gif*
|
%{_bindir}/gif*
|
||||||
%{_mandir}/man1/gif*.1*
|
%{_mandir}/man1/*.1*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 18 2019 Sandro Mani <manisandro@gmail.com> - 5.1.6-1
|
||||||
|
- Update to 5.1.6
|
||||||
|
|
||||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.4-3
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.4-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
23
giflib_mandir.patch
Normal file
23
giflib_mandir.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -rupN giflib-5.1.6/Makefile giflib-5.1.6-new/Makefile
|
||||||
|
--- giflib-5.1.6/Makefile 2019-02-12 15:26:13.000000000 +0100
|
||||||
|
+++ giflib-5.1.6-new/Makefile 2019-02-23 18:43:34.425669380 +0100
|
||||||
|
@@ -96,8 +96,8 @@ install-lib:
|
||||||
|
ln -sf libgif.so.$(LIBVER) "$(DESTDIR)$(LIBDIR)/libgif.so.$(LIBMAJOR)"
|
||||||
|
ln -sf libgif.so.$(LIBMAJOR) "$(DESTDIR)$(LIBDIR)/libgif.so"
|
||||||
|
install-man:
|
||||||
|
- $(INSTALL) -d "$(DESTDIR)$(MANDIR)"
|
||||||
|
- $(INSTALL) -m 644 doc/*.1 "$(DESTDIR)$(MANDIR)"
|
||||||
|
+ $(INSTALL) -d "$(DESTDIR)$(MANDIR)/man1"
|
||||||
|
+ $(INSTALL) -m 644 doc/*.1 "$(DESTDIR)$(MANDIR)/man1"
|
||||||
|
uninstall: uninstall-man uninstall-include uninstall-lib uninstall-bin
|
||||||
|
uninstall-bin:
|
||||||
|
cd "$(DESTDIR)$(BINDIR)" && rm -f $(INSTALLABLE)
|
||||||
|
@@ -107,7 +107,7 @@ uninstall-lib:
|
||||||
|
cd "$(DESTDIR)$(LIBDIR)" && \
|
||||||
|
rm -f libgif.a libgif.so libgif.so.$(LIBMAJOR) libgif.so.$(LIBVER)
|
||||||
|
uninstall-man:
|
||||||
|
- cd "$(DESTDIR)$(MANDIR)" && rm -f $(shell cd doc >/dev/null && echo *.1)
|
||||||
|
+ cd "$(DESTDIR)$(MANDIR)/man1" && rm -f $(shell cd doc >/dev/null && echo *.1)
|
||||||
|
|
||||||
|
# Make distribution tarball
|
||||||
|
#
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (giflib-5.1.4.tar.bz2) = 32b5e342056c210e6478e9cb3b6ceec9594dcfaf34feea1eb4dad633a081ed4465bceee578c19165907cb47cb83912ac359ceea666a8e07dbbb5420f9928f96d
|
SHA512 (giflib-5.1.6.tar.gz) = a148e3ebee6ad00ac24eb2241e5d7f51c0a22e6e931ebd751ca57b921a2a3d1a17a6d1e0e949ca0401589b539ec1458a57a9e306fadaf03dcd2ec40c11ca28be
|
||||||
|
Loading…
Reference in New Issue
Block a user