ghostscript/ghostscript-9.22-004-add-without-versioned-path-option.patch
David Kaspar [Dee'Kej] fe7ddccb26 specfile: complete cleanup (according to FPG) & package layout update
The specfile has been completely rewritten from the ground up, to
  comply with Fedora Packaging Guidelines, and to incorporate comments
  from upstream. The subpackage layout was also updated into more sane
  and more granular scheme.

  The changes are described more in detail below:
  (Justifications for them can be found in the specfile's comments.)

  * libijs -- the IJS library has been debundled and is now provided
    as a separate package: https://src.fedoraproject.org/rpms/libijs

  * libgs -- new separate package, created from Ghostscript's shared
    library. It contains all necessary files for other software/packages
    that are build upon Ghostscript's functionality.

  * libgs-devel -- new separate subpackage, for development purposes or
    Fedora's build process. The 'ghostscript-devel' is still provided
    for now as a virtual subpackage.

  * ghostscript -- is no longer a metapackage. It's a regular package
    instead, and it contains Ghostscript's binaries as well as some
    typical conversion scripts people are used to (and expect to have
    installed together with Ghostscript by default).

  * ghostscript-tools-fonts -- new subpackage that contains 3 scripts
    that are useful only for people who are working with AFM, PFB or PFA
    files (conversions usually).

  * ghostscript-tools-printing -- new subpackage that contains only
    utilities for formatting and printing text files using either
    Ghostscript, or BubbleJet, DeskJet, DeskJet 500, & LaserJet printers.

  * ghostscript-core -- has became an empty metapackage for upgrade
    purposes. It will be removed once Fedora 28 is EOL, and all other
    packages has updated their specfiles to require correct subpackages.

  * LPR setup scripts are no longer being shipped. In case people still
    need those, then 'ghostscript-tools-lpr' will be created for it.

  * examples/ from 'ghostscript-doc' are no longer shipped.

  * Support for /usr/share/ghostscript/conf.d/ folder was dropped to use
    Ghostscript's default choice for rendering of CJK glyphs, which is
    Google Droid Sans Fallback font. In case this proves insufficent,
    the conf.d/ folder support will be re-established.

  * Symbolic links for direct resources locations have been added to
    speedup Ghostscript's startup time

  * Ghostscript's search path was updated to include only fonts
    locations, which will be used only as a backup (in case of broken
    symbolic links).

  * Documentation and resources paths no longer contain version string
    inside of them.

  * Ghostscript itself (as a whole) has been completely debundled (to a
    point where it still makes sense). It newly requires these packages:

    https://src.fedoraproject.org/rpms/adobe-mappings-cmap
    https://src.fedoraproject.org/rpms/adobe-mappings-pdf
    https://src.fedoraproject.org/rpms/libijs
    https://src.fedoraproject.org/rpms/urw-base35-fonts

  * As a result of debundling, 'poppler-data' is no longer a requirement
    for Ghostscript, and it is no longer necessary to do a rebuild of
    'poppler-data' when Ghostscript is rebased.
2018-01-09 23:05:45 +01:00

70 lines
2.2 KiB
Diff

From 427fa24afbda44adafe96e74f1c7c350ca98dd73 Mon Sep 17 00:00:00 2001
From: "David Kaspar [Dee'Kej]" <dkaspar@redhat.com>
Date: Wed, 29 Nov 2017 16:42:45 +0100
Subject: [PATCH] configure.ac: --without-versioned-path option introduced
Using this option will result in Ghostscript being installed into a
paths which do not contain its version in them, which can be useful
on some distributions.
As a result of using this option, the Ghostscript's search path will
be updated as well, to include correct files locations.
This option is disabled by default, and configure's help page states
that using this option is dangerous, risky and unsupported.
---
Makefile.in | 4 ++--
configure.ac | 21 +++++++++++++++++++++
2 files changed, 23 insertions(+), 2 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index deed8e6..303a6b7 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -95,8 +95,8 @@ datadir = @datadir@
# The following must be substituted using @datadir@ and @libdir@
# to avoid adding RPM generation paths (CUPS STR #1112)
gsdir = @datadir@/ghostscript
-gsdatadir = $(gsdir)/$(GS_DOT_VERSION)
-gssharedir = @libdir@/ghostscript/$(GS_DOT_VERSION)
+gsdatadir = $(gsdir)@VERSIONED_PATH@
+gssharedir = @libdir@/ghostscript@VERSIONED_PATH@
gsincludedir = @includedir@/ghostscript/
docdir=$(gsdatadir)/doc
diff --git a/configure.ac b/configure.ac
index d0f62d7..5baa9e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2728,6 +2728,27 @@ fi
AC_SUBST(EXEEXT)
+# --------------------------------------------------
+# Check for disabling of versioned path option.
+# By default the versioned path must be enabled!
+# Using this option is user's own risk & responsibility.
+# --------------------------------------------------
+AC_ARG_WITH([versioned-path],
+[ --without-versioned-path
+ Do not use file paths containing the version of GS.
+
+ WARNING: This option is dangerous & unsupported, and
+ you take full responsibility for using it!],
+versioned_path=no)
+
+if test "x$versioned_path" != "xno"; then
+ VERSIONED_PATH='/$(GS_DOT_VERSION)'
+else
+ VERSIONED_PATH=''
+fi
+
+AC_SUBST(VERSIONED_PATH)
+
if test x"$CCAUX" != x"$CC"; then
--
2.9.5