RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/ghostscript#ae1d04c7f4be8724d67b38494bb8c174578fd6e7
This commit is contained in:
parent
d6be73999a
commit
0e79eb5531
60
.gitignore
vendored
60
.gitignore
vendored
@ -0,0 +1,60 @@
|
||||
acro5-cmaps-2001.tar.gz
|
||||
adobe-cmaps-200202.tar.gz
|
||||
eplaser-3.1.4-705.tgz
|
||||
epson740.tgz
|
||||
gdevmd2k-0.2a.tar.gz
|
||||
ghostscript-7.07.tar.bz2
|
||||
gs550j1.tar.gz
|
||||
gs6.51-cjk-M2-R3.tar.gz
|
||||
gs704-j-vlib.zip
|
||||
lexmarkgs990908.tar.gz
|
||||
lxm3200-tweaked-20030501.tar.gz
|
||||
pcl3-3.3.tar.gz
|
||||
espgs-8.15rc3-source.tar.bz2
|
||||
adobe-cmaps-200204.tar.gz
|
||||
espgs-8.15rc4-source.tar.bz2
|
||||
espgs-8.15.1-source.tar.bz2
|
||||
adobe-cmaps-200406.tar.gz
|
||||
espgs-8.15.2-source.tar.bz2
|
||||
espgs-8.15.3-source.tar.bz2
|
||||
espgs-8.15.4-source.tar.bz2
|
||||
ghostscript-8.60-r8117.tar.bz2
|
||||
ghostscript-8.60.tar.bz2
|
||||
ghostscript-8.61.tar.bz2
|
||||
ghostscript-8.62.tar.bz2
|
||||
ghostscript-8.63.tar.bz2
|
||||
ghostscript-8.64.tar.bz2
|
||||
ghostscript-8.70.tar.xz
|
||||
ghostscript-8.71.tar.xz
|
||||
/ghostscript-9.00.tar.xz
|
||||
/ghostscript-9.01.tar.bz2
|
||||
/ghostscript-9.02.tar.bz2
|
||||
/ghostscript-9.04.tar.bz2
|
||||
/ghostscript-9.05.tar.bz2
|
||||
/ghostscript-9.06.tar.bz2
|
||||
/ghostscript-9.06-cleaned.tar.bz2
|
||||
/ghostscript-9.07.tar.bz2
|
||||
/ghostscript-9.07-cleaned.tar.bz2
|
||||
/ghostscript-9.08rc1.tar.gz
|
||||
/ghostscript-9.08.tar.bz2
|
||||
/ghostscript-9.09rc1.tar.gz
|
||||
/ghostscript-9.09.tar.bz2
|
||||
/ghostscript-9.10.tar.bz2
|
||||
/ghostscript-9.10-cleaned.tar.bz2
|
||||
/ghostscript-9.12-cleaned.tar.bz2
|
||||
/ghostscript-9.14-cleaned.tar.bz2
|
||||
/ghostscript-9.14-cleaned-1.tar.bz2
|
||||
/ghostscript-9.15-cleaned.tar.bz2
|
||||
/ghostscript-9.15-cleaned-1.tar.bz2
|
||||
/ghostscript-9.16-cleaned-1.tar.bz2
|
||||
/ghostscript-9.20.tar.xz
|
||||
/ghostscript-9.22.tar.xz
|
||||
/ghostscript-9.23.tar.xz
|
||||
/ghostscript-9.24.tar.xz
|
||||
/ghostscript-9.25.tar.xz
|
||||
/ghostscript-9.26.tar.xz
|
||||
/ghostscript-9.27.tar.xz
|
||||
/ghostscript-9.50.tar.xz
|
||||
/ghostscript-9.52.tar.xz
|
||||
/ghostscript-9.53.1.tar.xz
|
||||
/ghostscript-9.53.3.tar.xz
|
10
ghostscript-9.23-100-run-dvipdf-securely.patch
Normal file
10
ghostscript-9.23-100-run-dvipdf-securely.patch
Normal file
@ -0,0 +1,10 @@
|
||||
diff --git a/lib/dvipdf b/lib/dvipdf
|
||||
index 13e1985..078292b 100755
|
||||
--- a/lib/dvipdf
|
||||
+++ b/lib/dvipdf
|
||||
@@ -43,4 +43,4 @@ fi
|
||||
|
||||
# We have to include the options twice because -I only takes effect if it
|
||||
# appears before other options.
|
||||
-exec dvips -Ppdf $DVIPSOPTIONS -q -f "$infile" | $GS_EXECUTABLE $OPTIONS -q -P- -dSAFER -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -sstdout=%stderr -sOutputFile="$outfile" $OPTIONS -
|
||||
+exec dvips -R -Ppdf $DVIPSOPTIONS -q -f "$infile" | $GS_EXECUTABLE $OPTIONS -q -P- -dSAFER -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -sstdout=%stderr -sOutputFile="$outfile" $OPTIONS -
|
94
ghostscript-9.50-enumerate-all-fonts.patch
Normal file
94
ghostscript-9.50-enumerate-all-fonts.patch
Normal file
@ -0,0 +1,94 @@
|
||||
diff --git a/base/gp_unix.c b/base/gp_unix.c
|
||||
index c576566..4165654 100644
|
||||
--- a/base/gp_unix.c
|
||||
+++ b/base/gp_unix.c
|
||||
@@ -402,42 +402,50 @@ int gp_enumerate_fonts_next(void *enum_state, char **fontname, char **path)
|
||||
return 0; /* gp_enumerate_fonts_init failed for some reason */
|
||||
}
|
||||
|
||||
- if (state->index == state->font_list->nfont) {
|
||||
- return 0; /* we've run out of fonts */
|
||||
- }
|
||||
-
|
||||
- /* Bits of the following were borrowed from Red Hat's
|
||||
- * fontconfig patch for Ghostscript 7 */
|
||||
- font = state->font_list->fonts[state->index];
|
||||
+ /* We use the loop so we can skip over fonts that return errors */
|
||||
+ while(1) {
|
||||
+ if (state->index == state->font_list->nfont) {
|
||||
+ return 0; /* we've run out of fonts */
|
||||
+ }
|
||||
|
||||
- result = FcPatternGetString (font, FC_FAMILY, 0, &family_fc);
|
||||
- if (result != FcResultMatch || family_fc == NULL) {
|
||||
- dmlprintf(state->mem, "DEBUG: FC_FAMILY mismatch\n");
|
||||
- return 0;
|
||||
- }
|
||||
+ /* Bits of the following were borrowed from Red Hat's
|
||||
+ * fontconfig patch for Ghostscript 7 */
|
||||
+ font = state->font_list->fonts[state->index];
|
||||
+ state->index++;
|
||||
+
|
||||
+ /* We do the FC_FILE first because this *should* never fail
|
||||
+ * and it gives us a string to use in later debug prints
|
||||
+ */
|
||||
+ result = FcPatternGetString (font, FC_FILE, 0, &file_fc);
|
||||
+ if (result != FcResultMatch || file_fc == NULL) {
|
||||
+ dmlprintf(state->mem, "DEBUG: FC_FILE mismatch\n");
|
||||
+ continue;
|
||||
+ }
|
||||
|
||||
- result = FcPatternGetString (font, FC_FILE, 0, &file_fc);
|
||||
- if (result != FcResultMatch || file_fc == NULL) {
|
||||
- dmlprintf(state->mem, "DEBUG: FC_FILE mismatch\n");
|
||||
- return 0;
|
||||
- }
|
||||
+ result = FcPatternGetString (font, FC_FAMILY, 0, &family_fc);
|
||||
+ if (result != FcResultMatch || family_fc == NULL) {
|
||||
+ dmlprintf1(state->mem, "DEBUG: FC_FAMILY mismatch in %s\n", (char *)file_fc);
|
||||
+ continue;
|
||||
+ }
|
||||
|
||||
- result = FcPatternGetBool (font, FC_OUTLINE, 0, &outline_fc);
|
||||
- if (result != FcResultMatch) {
|
||||
- dmlprintf1(state->mem, "DEBUG: FC_OUTLINE failed to match on %s\n", (char*)family_fc);
|
||||
- return 0;
|
||||
- }
|
||||
+ result = FcPatternGetBool (font, FC_OUTLINE, 0, &outline_fc);
|
||||
+ if (result != FcResultMatch) {
|
||||
+ dmlprintf2(state->mem, "DEBUG: FC_OUTLINE failed to match on %s in %s\n", (char*)family_fc, (char *)file_fc);
|
||||
+ continue;
|
||||
+ }
|
||||
|
||||
- result = FcPatternGetInteger (font, FC_SLANT, 0, &slant_fc);
|
||||
- if (result != FcResultMatch) {
|
||||
- dmlprintf(state->mem, "DEBUG: FC_SLANT didn't match\n");
|
||||
- return 0;
|
||||
- }
|
||||
+ result = FcPatternGetInteger (font, FC_SLANT, 0, &slant_fc);
|
||||
+ if (result != FcResultMatch) {
|
||||
+ dmlprintf1(state->mem, "DEBUG: FC_SLANT didn't match in %s\n", (char *)file_fc);
|
||||
+ continue;
|
||||
+ }
|
||||
|
||||
- result = FcPatternGetInteger (font, FC_WEIGHT, 0, &weight_fc);
|
||||
- if (result != FcResultMatch) {
|
||||
- dmlprintf(state->mem, "DEBUG: FC_WEIGHT didn't match\n");
|
||||
- return 0;
|
||||
+ result = FcPatternGetInteger (font, FC_WEIGHT, 0, &weight_fc);
|
||||
+ if (result != FcResultMatch) {
|
||||
+ dmlprintf1(state->mem, "DEBUG: FC_WEIGHT didn't match in %s\n", (char *)file_fc);
|
||||
+ continue;
|
||||
+ }
|
||||
+ break;
|
||||
}
|
||||
|
||||
/* Gross hack to work around Fontconfig's inability to tell
|
||||
@@ -450,7 +458,6 @@ int gp_enumerate_fonts_next(void *enum_state, char **fontname, char **path)
|
||||
/* return the font path straight out of fontconfig */
|
||||
*path = (char*)file_fc;
|
||||
|
||||
- state->index ++;
|
||||
return 1;
|
||||
#else
|
||||
return 0;
|
1910
ghostscript.spec
Normal file
1910
ghostscript.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user