ghc package is retired on branch c10s for BAKERY-412
This commit is contained in:
parent
ff8deba8f3
commit
e85d824b79
44
.gitignore
vendored
44
.gitignore
vendored
@ -1,44 +0,0 @@
|
||||
ghc-6.12.3-src.tar.bz2
|
||||
testsuite-6.12.3.tar.bz2
|
||||
/ghc-7.0.1-src.tar.bz2
|
||||
/testsuite-7.0.1.tar.bz2
|
||||
/ghc-7.0.2-src.tar.bz2
|
||||
/ghc-7.0.4-src.tar.bz2
|
||||
/testsuite-7.0.4.tar.bz2
|
||||
/ghc-7.4.1-testsuite.tar.bz2
|
||||
/ghc-7.4.1-src.tar.bz2
|
||||
/ghc-7.4.2-src.tar.bz2
|
||||
/ghc-7.4.2-testsuite.tar.bz2
|
||||
/ghc-7.6.3-src.tar.bz2
|
||||
/ghc-7.6.3-testsuite.tar.bz2
|
||||
/ghc-7.6.3/
|
||||
/ghc-7.8.3-src.tar.xz
|
||||
/ghc-7.8.3-testsuite.tar.xz
|
||||
/ghc-7.8.4-src.tar.xz
|
||||
/ghc-7.8.4-testsuite.tar.xz
|
||||
/ghc-7.8.4/
|
||||
/ghc-7.10.3/
|
||||
/ghc-7.10.3b-src.tar.xz
|
||||
/ghc-7.10.3b-testsuite.tar.xz
|
||||
/ghc-8.0.2-testsuite.tar.xz
|
||||
/ghc-8.0.2-src.tar.xz
|
||||
/ghc-8.0.2/
|
||||
/ghc-8.2.2-src.tar.xz
|
||||
/ghc-8.2.2-testsuite.tar.xz
|
||||
/ghc-8.4.4-src.tar.xz
|
||||
/ghc-8.6.5-src.tar.xz
|
||||
/ghc-8.8.3-src.tar.xz
|
||||
/ghc-8.8.3-src.tar.xz.sig
|
||||
/ghc-8.8.4-src.tar.xz.sig
|
||||
/ghc-8.8.4-src.tar.xz
|
||||
/ghc-8.10.5-src.tar.xz.sig
|
||||
/ghc-8.10.5-src.tar.xz
|
||||
/ghc-8.10.4-src.tar.xz.sig
|
||||
/ghc-8.10.7-src.tar.xz
|
||||
/ghc-8.10.7-src.tar.xz.sig
|
||||
/ghc-9.0.2-src.tar.xz
|
||||
/ghc-9.0.2-src.tar.xz.sig
|
||||
/ghc-9.2.5-src.tar.xz
|
||||
/ghc-9.2.5-src.tar.xz.sig
|
||||
/ghc-9.2.6-src.tar.xz
|
||||
/ghc-9.2.6-src.tar.xz.sig
|
@ -1,44 +0,0 @@
|
||||
From 00dc51060881df81258ba3b3bdf447294618a4de Mon Sep 17 00:00:00 2001
|
||||
From: Matthew Pickering <matthewtpickering@gmail.com>
|
||||
Date: Tue, 3 Jan 2023 15:56:37 +0000
|
||||
Subject: [PATCH] sphinx: Use modern syntax for extlinks
|
||||
|
||||
This fixes the following build error:
|
||||
|
||||
```
|
||||
Command line: /opt/homebrew/opt/sphinx-doc/bin/sphinx-build -b man -d /private/tmp/extra-dir-55768274273/.doctrees-man -n -w /private/tmp/extra-dir-55768274273/.log docs/users_guide /private/tmp/extra-dir-55768274273
|
||||
===> Command failed with error code: 2
|
||||
|
||||
Exception occurred:
|
||||
File "/opt/homebrew/Cellar/sphinx-doc/6.0.0/libexec/lib/python3.11/site-packages/sphinx/ext/extlinks.py", line 101, in role
|
||||
title = caption % part
|
||||
~~~~~~~~^~~~~~
|
||||
TypeError: not all arguments converted during string formatting
|
||||
```
|
||||
|
||||
I tested on Sphinx-5.1.1 and Sphinx-6.0.0
|
||||
|
||||
Thanks for sterni for providing instructions about how to test using
|
||||
sphinx-6.0.0.
|
||||
|
||||
Fixes #22690
|
||||
---
|
||||
docs/users_guide/ghc_config.py.in | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/docs/users_guide/ghc_config.py.in b/docs/users_guide/ghc_config.py.in
|
||||
index dcc7fbaef62..c9888a13adc 100644
|
||||
--- a/docs/users_guide/ghc_config.py.in
|
||||
+++ b/docs/users_guide/ghc_config.py.in
|
||||
@@ -1,6 +1,6 @@
|
||||
extlinks = {
|
||||
- 'ghc-ticket': ('https://gitlab.haskell.org/ghc/ghc/issues/%s', '#'),
|
||||
- 'ghc-wiki': ('https://gitlab.haskell.org/ghc/ghc/wikis/%s', '#'),
|
||||
+ 'ghc-ticket': ('https://gitlab.haskell.org/ghc/ghc/issues/%s', '%s'),
|
||||
+ 'ghc-wiki': ('https://gitlab.haskell.org/ghc/ghc/wikis/%s', '#%s'),
|
||||
}
|
||||
|
||||
libs_base_uri = '../libraries'
|
||||
--
|
||||
GitLab
|
||||
|
2380
10453.patch
2380
10453.patch
File diff suppressed because it is too large
Load Diff
35
5725.patch
35
5725.patch
@ -1,35 +0,0 @@
|
||||
From 7cfa6f3114168797cf1fa7faa4ffe6c06b73f149 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Trommler <ptrommler@acm.org>
|
||||
Date: Tue, 11 May 2021 20:52:01 +0200
|
||||
Subject: [PATCH] Hadrian: Enable SMP on powerpc64{le}
|
||||
|
||||
Fixes #19825
|
||||
---
|
||||
hadrian/src/Oracles/Flag.hs | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/hadrian/src/Oracles/Flag.hs b/hadrian/src/Oracles/Flag.hs
|
||||
index 86521e4aa8a..1b3aff693eb 100644
|
||||
--- a/hadrian/src/Oracles/Flag.hs
|
||||
+++ b/hadrian/src/Oracles/Flag.hs
|
||||
@@ -70,7 +70,16 @@ targetSupportsSMP :: Action Bool
|
||||
targetSupportsSMP = do
|
||||
unreg <- flag GhcUnregisterised
|
||||
armVer <- targetArmVersion
|
||||
- goodArch <- anyTargetArch ["i386", "x86_64", "sparc", "powerpc", "arm", "aarch64", "s390x", "riscv64"]
|
||||
+ goodArch <- anyTargetArch ["i386"
|
||||
+ , "x86_64"
|
||||
+ , "sparc"
|
||||
+ , "powerpc"
|
||||
+ , "powerpc64"
|
||||
+ , "powerpc64le"
|
||||
+ , "arm"
|
||||
+ , "aarch64"
|
||||
+ , "s390x"
|
||||
+ , "riscv64"]
|
||||
if -- The THREADED_RTS requires `BaseReg` to be in a register and the
|
||||
-- Unregisterised mode doesn't allow that.
|
||||
| unreg -> return False
|
||||
--
|
||||
GitLab
|
||||
|
43
9394.patch
43
9394.patch
@ -1,43 +0,0 @@
|
||||
From 480b5d6440bbbd0b89dabdb2dc957333056aa2a7 Mon Sep 17 00:00:00 2001
|
||||
From: Florian Weimer <fweimer@redhat.com>
|
||||
Date: Tue, 22 Nov 2022 15:23:50 +0100
|
||||
Subject: [PATCH] m4/fp_leading_underscore.m4: Avoid implicit exit function
|
||||
declaration
|
||||
|
||||
And switch to a new-style function definition.
|
||||
|
||||
Fixes build issues with compilers that do not accept implicit function
|
||||
declarations.
|
||||
---
|
||||
m4/fp_leading_underscore.m4 | 10 ++++------
|
||||
1 file changed, 4 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/m4/fp_leading_underscore.m4 b/m4/fp_leading_underscore.m4
|
||||
index fde57c7625d..939cee3b69f 100644
|
||||
--- a/m4/fp_leading_underscore.m4
|
||||
+++ b/m4/fp_leading_underscore.m4
|
||||
@@ -32,17 +32,15 @@ struct nlist xYzzY1[] = {{"xYzzY1", 0},{0}};
|
||||
struct nlist xYzzY2[] = {{"_xYzzY2", 0},{0}};
|
||||
#endif
|
||||
|
||||
-int main(argc, argv)
|
||||
-int argc;
|
||||
-char **argv;
|
||||
+int main(int argc, char **argv)
|
||||
{
|
||||
#if defined(HAVE_NLIST_H)
|
||||
if(nlist(argv[0], xYzzY1) == 0 && xYzzY1[0].n_value != 0)
|
||||
- exit(1);
|
||||
+ return 1;
|
||||
if(nlist(argv[0], xYzzY2) == 0 && xYzzY2[0].n_value != 0)
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
#endif
|
||||
- exit(1);
|
||||
+ return 1;
|
||||
}]])],[fptools_cv_leading_underscore=yes],[fptools_cv_leading_underscore=no],[fptools_cv_leading_underscore=no])
|
||||
;;
|
||||
esac]);
|
||||
--
|
||||
GitLab
|
||||
|
@ -1,93 +0,0 @@
|
||||
From 9aace0eaf6279f17368a1753b65afbdc466e8291 Mon Sep 17 00:00:00 2001
|
||||
From: Sylvain Henry <sylvain@haskus.fr>
|
||||
Date: Sat, 10 Apr 2021 14:48:16 +0200
|
||||
Subject: [PATCH] Produce constant file atomically (#19684)
|
||||
|
||||
---
|
||||
utils/deriveConstants/Main.hs | 21 ++++++++++++++++-----
|
||||
utils/deriveConstants/deriveConstants.cabal | 3 ++-
|
||||
2 files changed, 18 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/utils/deriveConstants/Main.hs b/utils/deriveConstants/Main.hs
|
||||
index 8bf8ae7b44d..9db673a9852 100644
|
||||
--- a/utils/deriveConstants/Main.hs
|
||||
+++ b/utils/deriveConstants/Main.hs
|
||||
@@ -34,9 +34,10 @@ import Data.Maybe (catMaybes, mapMaybe, fromMaybe)
|
||||
import Numeric (readHex)
|
||||
import System.Environment (getArgs)
|
||||
import System.Exit (ExitCode(ExitSuccess), exitFailure)
|
||||
-import System.FilePath ((</>))
|
||||
+import System.FilePath ((</>),(<.>))
|
||||
import System.IO (stderr, hPutStrLn)
|
||||
import System.Process (showCommandForUser, readProcess, rawSystem)
|
||||
+import System.Directory (renameFile)
|
||||
|
||||
main :: IO ()
|
||||
main = do opts <- parseArgs
|
||||
@@ -79,6 +80,16 @@ data Options = Options {
|
||||
o_targetOS :: Maybe String
|
||||
}
|
||||
|
||||
+-- | Write a file atomically
|
||||
+--
|
||||
+-- This avoids other processes seeing the file while it is being written into.
|
||||
+atomicWriteFile :: FilePath -> String -> IO ()
|
||||
+atomicWriteFile fn s = do
|
||||
+ let tmp = fn <.> "tmp"
|
||||
+ writeFile tmp s
|
||||
+ renameFile tmp fn
|
||||
+
|
||||
+
|
||||
parseArgs :: IO Options
|
||||
parseArgs = do args <- getArgs
|
||||
opts <- f emptyOptions args
|
||||
@@ -670,7 +681,7 @@ getWanted verbose os tmpdir gccProgram gccFlags nmProgram mobjdumpProgram
|
||||
= do let cStuff = unlines (headers ++ concatMap (doWanted . snd) (wanteds os))
|
||||
cFile = tmpdir </> "tmp.c"
|
||||
oFile = tmpdir </> "tmp.o"
|
||||
- writeFile cFile cStuff
|
||||
+ atomicWriteFile cFile cStuff
|
||||
execute verbose gccProgram (gccFlags ++ ["-c", cFile, "-o", oFile])
|
||||
xs <- case os of
|
||||
"openbsd" -> readProcess objdumpProgam ["--syms", oFile] ""
|
||||
@@ -855,7 +866,7 @@ getWanted verbose os tmpdir gccProgram gccFlags nmProgram mobjdumpProgram
|
||||
= return (w, FieldTypeGcptrMacro name)
|
||||
|
||||
writeHaskellType :: FilePath -> [What Fst] -> IO ()
|
||||
-writeHaskellType fn ws = writeFile fn xs
|
||||
+writeHaskellType fn ws = atomicWriteFile fn xs
|
||||
where xs = unlines [header, body, footer, parser]
|
||||
header = "module GHC.Platform.Constants where\n\n\
|
||||
\import Prelude\n\
|
||||
@@ -920,7 +931,7 @@ writeHaskellType fn ws = writeFile fn xs
|
||||
|
||||
|
||||
writeHaskellValue :: FilePath -> [What Snd] -> IO ()
|
||||
-writeHaskellValue fn rs = writeFile fn xs
|
||||
+writeHaskellValue fn rs = atomicWriteFile fn xs
|
||||
where xs = unlines [header, body, footer]
|
||||
header = "PlatformConstants {"
|
||||
footer = " }"
|
||||
@@ -937,7 +948,7 @@ writeHaskellValue fn rs = writeFile fn xs
|
||||
doWhat (FieldTypeGcptrMacro {}) = []
|
||||
|
||||
writeHeader :: FilePath -> [(Where, What Snd)] -> IO ()
|
||||
-writeHeader fn rs = writeFile fn xs
|
||||
+writeHeader fn rs = atomicWriteFile fn xs
|
||||
where xs = headers ++ hs ++ unlines body
|
||||
headers = "/* This file is created automatically. Do not edit by hand.*/\n\n"
|
||||
haskellRs = fmap snd $ filter (\r -> fst r `elem` [Haskell,Both]) rs
|
||||
diff --git a/utils/deriveConstants/deriveConstants.cabal b/utils/deriveConstants/deriveConstants.cabal
|
||||
index 50b5b695c30..36ba7ebe1f7 100644
|
||||
--- a/utils/deriveConstants/deriveConstants.cabal
|
||||
+++ b/utils/deriveConstants/deriveConstants.cabal
|
||||
@@ -20,4 +20,5 @@ Executable deriveConstants
|
||||
Build-Depends: base >= 4 && < 5,
|
||||
containers,
|
||||
process,
|
||||
- filepath
|
||||
+ filepath,
|
||||
+ directory
|
||||
--
|
||||
GitLab
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- ghc-8.8.0.20190721/libraries/containers/containers/include/containers.h~ 2019-06-26 20:39:26.000000000 +0000
|
||||
+++ ghc-8.8.0.20190721/libraries/containers/containers/include/containers.h 2019-07-27 08:55:10.747060247 +0000
|
||||
@@ -35,7 +35,6 @@
|
||||
|
||||
#ifdef __GLASGOW_HASKELL__
|
||||
# define USE_ST_MONAD 1
|
||||
-# define USE_UNBOXED_ARRAYS 1
|
||||
#endif
|
||||
|
||||
#endif
|
48
abi-check.sh
48
abi-check.sh
@ -1,48 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
[ $# -ne 2 ] && echo "Usage: $(basename $0) ver-rel1 ver-rel2" && exit 1
|
||||
|
||||
if [ "$1" = "$2" ]; then
|
||||
echo "ver-rel's must be different!"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
#set -x
|
||||
|
||||
mkdir -p koji
|
||||
cd koji
|
||||
|
||||
for i in $1 $2; do
|
||||
if [ ! -d "$i" ]; then
|
||||
mkdir -p $i/{x86_64,i686,armv7hl}
|
||||
cd $i
|
||||
for a in x86_64 i686 armv7hl; do
|
||||
cd $a
|
||||
koji download-build --arch=$a ghc-$i
|
||||
cd ..
|
||||
done
|
||||
cd ..
|
||||
fi
|
||||
done
|
||||
|
||||
for a in x86_64 i686 armv7hl; do
|
||||
echo "= $a ="
|
||||
for i in $1/$a/*; do
|
||||
PKGVER=$(rpm -qp --qf "%{name}-%{version}" $i)
|
||||
PKG2=$(ls $2/$a/$PKGVER*.$a.rpm)
|
||||
PROV1=$(rpm -qp --provides $i | grep ^ghc\( | grep -v =)
|
||||
PROV2=$(rpm -qp --provides $PKG2 | grep ^ghc\( | grep -v =)
|
||||
# if [ -n "$PROV1" ]; then
|
||||
# echo $PROV1
|
||||
# else
|
||||
# echo "no provides for $i"
|
||||
# fi
|
||||
if [ -n "$PROV2" ]; then
|
||||
if [ "$PROV1" != "$PROV2" ]; then
|
||||
echo $PROV2
|
||||
fi
|
||||
# else
|
||||
# echo "no provides for $PKG2"
|
||||
fi
|
||||
done
|
||||
done
|
@ -1,87 +0,0 @@
|
||||
Description: Don't include BufPos in interface files
|
||||
Author: Matthew Pickering
|
||||
Origin: https://gitlab.haskell.org/ghc/ghc/-/merge_requests/8972
|
||||
Bug: https://gitlab.haskell.org/ghc/ghc/-/issues/22162
|
||||
Index: b/compiler/GHC/Iface/Ext/Types.hs
|
||||
===================================================================
|
||||
--- a/compiler/GHC/Iface/Ext/Types.hs
|
||||
+++ b/compiler/GHC/Iface/Ext/Types.hs
|
||||
@@ -746,5 +746,5 @@ toHieName name
|
||||
| isKnownKeyName name = KnownKeyName (nameUnique name)
|
||||
| isExternalName name = ExternalName (nameModule name)
|
||||
(nameOccName name)
|
||||
- (nameSrcSpan name)
|
||||
- | otherwise = LocalName (nameOccName name) (nameSrcSpan name)
|
||||
+ (removeBufSpan $ nameSrcSpan name)
|
||||
+ | otherwise = LocalName (nameOccName name) (removeBufSpan $ nameSrcSpan name)
|
||||
Index: b/compiler/GHC/Types/SrcLoc.hs
|
||||
===================================================================
|
||||
--- a/compiler/GHC/Types/SrcLoc.hs
|
||||
+++ b/compiler/GHC/Types/SrcLoc.hs
|
||||
@@ -72,6 +72,7 @@ module GHC.Types.SrcLoc (
|
||||
getBufPos,
|
||||
BufSpan(..),
|
||||
getBufSpan,
|
||||
+ removeBufSpan,
|
||||
|
||||
-- * Located
|
||||
Located,
|
||||
@@ -397,6 +398,10 @@ data UnhelpfulSpanReason
|
||||
| UnhelpfulOther !FastString
|
||||
deriving (Eq, Show)
|
||||
|
||||
+removeBufSpan :: SrcSpan -> SrcSpan
|
||||
+removeBufSpan (RealSrcSpan s _) = RealSrcSpan s Nothing
|
||||
+removeBufSpan s = s
|
||||
+
|
||||
{- Note [Why Maybe BufPos]
|
||||
~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||
In SrcLoc we store (Maybe BufPos); in SrcSpan we store (Maybe BufSpan).
|
||||
Index: b/compiler/GHC/Utils/Binary.hs
|
||||
===================================================================
|
||||
--- a/compiler/GHC/Utils/Binary.hs
|
||||
+++ b/compiler/GHC/Utils/Binary.hs
|
||||
@@ -1444,19 +1444,6 @@ instance Binary RealSrcSpan where
|
||||
return (mkRealSrcSpan (mkRealSrcLoc f sl sc)
|
||||
(mkRealSrcLoc f el ec))
|
||||
|
||||
-instance Binary BufPos where
|
||||
- put_ bh (BufPos i) = put_ bh i
|
||||
- get bh = BufPos <$> get bh
|
||||
-
|
||||
-instance Binary BufSpan where
|
||||
- put_ bh (BufSpan start end) = do
|
||||
- put_ bh start
|
||||
- put_ bh end
|
||||
- get bh = do
|
||||
- start <- get bh
|
||||
- end <- get bh
|
||||
- return (BufSpan start end)
|
||||
-
|
||||
instance Binary UnhelpfulSpanReason where
|
||||
put_ bh r = case r of
|
||||
UnhelpfulNoLocationInfo -> putByte bh 0
|
||||
@@ -1475,10 +1462,11 @@ instance Binary UnhelpfulSpanReason wher
|
||||
_ -> UnhelpfulOther <$> get bh
|
||||
|
||||
instance Binary SrcSpan where
|
||||
- put_ bh (RealSrcSpan ss sb) = do
|
||||
+ put_ bh (RealSrcSpan ss _sb) = do
|
||||
putByte bh 0
|
||||
+ -- BufSpan doesn't ever get serialised because the positions depend
|
||||
+ -- on build location.
|
||||
put_ bh ss
|
||||
- put_ bh sb
|
||||
|
||||
put_ bh (UnhelpfulSpan s) = do
|
||||
putByte bh 1
|
||||
@@ -1488,8 +1476,7 @@ instance Binary SrcSpan where
|
||||
h <- getByte bh
|
||||
case h of
|
||||
0 -> do ss <- get bh
|
||||
- sb <- get bh
|
||||
- return (RealSrcSpan ss sb)
|
||||
+ return (RealSrcSpan ss Nothing)
|
||||
_ -> do s <- get bh
|
||||
return (UnhelpfulSpan s)
|
||||
|
@ -1,24 +0,0 @@
|
||||
Forwarded to https://ghc.haskell.org/trac/ghc/ticket/10424
|
||||
|
||||
Index: b/compiler/GHC/Iface/Recomp.hs
|
||||
===================================================================
|
||||
--- a/compiler/GHC/Iface/Recomp.hs
|
||||
+++ b/compiler/GHC/Iface/Recomp.hs
|
||||
@@ -1071,7 +1071,7 @@ addFingerprints hsc_env iface0
|
||||
iface_hash <- computeFingerprint putNameLiterally
|
||||
(mod_hash,
|
||||
ann_fn (mkVarOcc "module"), -- See mkIfaceAnnCache
|
||||
- mi_usages iface0,
|
||||
+ usages,
|
||||
sorted_deps,
|
||||
mi_hpc iface0)
|
||||
|
||||
@@ -1106,6 +1106,8 @@ addFingerprints hsc_env iface0
|
||||
(non_orph_rules, orph_rules) = mkOrphMap ifRuleOrph (mi_rules iface0)
|
||||
(non_orph_fis, orph_fis) = mkOrphMap ifFamInstOrph (mi_fam_insts iface0)
|
||||
ann_fn = mkIfaceAnnCache (mi_anns iface0)
|
||||
+ -- Do not allow filenames to affect the interface
|
||||
+ usages = [ case u of UsageFile _ fp -> UsageFile "" fp; _ -> u | u <- mi_usages iface0 ]
|
||||
|
||||
-- | Retrieve the orphan hashes 'mi_orphan_hash' for a list of modules
|
||||
-- (in particular, the orphan modules which are transitively imported by the
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
ghc package is retired on branch c10s for BAKERY-412
|
@ -1,9 +0,0 @@
|
||||
--- ghc-9.2.1/hadrian/hadrian.cabal~ 2021-10-29 04:41:34.000000000 +0800
|
||||
+++ ghc-9.2.1/hadrian/hadrian.cabal 2021-11-01 15:02:49.625656704 +0800
|
||||
@@ -162,5 +162,5 @@
|
||||
-- waiting for external processes
|
||||
-- * -qg: Don't use parallel GC as the synchronization
|
||||
-- time tends to eat any benefit.
|
||||
- "-with-rtsopts=-I0 -qg"
|
||||
+ "-with-rtsopts=-I0"
|
||||
-threaded
|
@ -1,12 +0,0 @@
|
||||
--- ghc/libraries/Cabal/Cabal/src/Distribution/Simple/Install.hs~ 2017-05-05 23:51:43.000000000 +0900
|
||||
+++ ghc/libraries/Cabal/Cabal/src/Distribution/Simple/Install.hs 2018-02-27 12:22:13.159432104 +0900
|
||||
@@ -215,8 +215,7 @@
|
||||
++ " in " ++ binPref)
|
||||
inPath <- isInSearchPath binPref
|
||||
when (not inPath) $
|
||||
- warn verbosity ("The directory " ++ binPref
|
||||
- ++ " is not in the system search path.")
|
||||
+ warn verbosity ("Executable installed in " ++ binPref)
|
||||
case compilerFlavor (compiler lbi) of
|
||||
GHC -> GHC.installExe verbosity lbi binPref buildPref progFix pkg_descr exe
|
||||
GHCJS -> GHCJS.installExe verbosity lbi binPref buildPref progFix pkg_descr exe
|
@ -1,11 +0,0 @@
|
||||
--- ghc-7.8.3/aclocal.m4~ 2014-07-10 13:27:16.000000000 +0900
|
||||
+++ ghc-7.8.3/aclocal.m4 2014-11-05 12:19:08.530044128 +0900
|
||||
@@ -408,7 +408,7 @@
|
||||
)],
|
||||
[changequote(, )dnl
|
||||
ARM_ISA=ARMv7
|
||||
- ARM_ISA_EXT="[VFPv3,NEON]"
|
||||
+ ARM_ISA_EXT="[VFPv3D16]"
|
||||
changequote([, ])dnl
|
||||
])
|
||||
])
|
@ -1,10 +0,0 @@
|
||||
--- ghc-7.6.3/libraries/gen_contents_index~ 2013-04-19 06:22:46.000000000 +0900
|
||||
+++ ghc-7.6.3/libraries/gen_contents_index 2013-04-22 12:07:48.922152864 +0900
|
||||
@@ -60,6 +60,6 @@
|
||||
done
|
||||
else
|
||||
- HADDOCK=../../../../../bin/haddock
|
||||
+ HADDOCK=/usr/bin/haddock
|
||||
# We don't want the GHC API to swamp the index
|
||||
HADDOCK_FILES=`ls -1 */*.haddock | grep -v '/ghc\.haddock' | sort`
|
||||
HADDOCK_ARGS="-p prologue.txt"
|
@ -1,11 +0,0 @@
|
||||
--- ghc-8.6.5/libraries/gen_contents_index~ 2020-02-24 15:02:26.318866694 +0800
|
||||
+++ ghc-8.6.5/libraries/gen_contents_index 2020-04-09 18:18:40.290722327 +0800
|
||||
@@ -47,6 +47,8 @@
|
||||
HADDOCK_ARGS="$HADDOCK_ARGS $HADDOCK_ARG"
|
||||
done
|
||||
else
|
||||
+ if ! ls */*.haddock &>/dev/null; then exit 0; fi
|
||||
+
|
||||
HADDOCK=/usr/bin/haddock
|
||||
# We don't want the GHC API to swamp the index
|
||||
HADDOCK_FILES=`ls -1 */*.haddock | grep -v '/ghc\.haddock' | sort`
|
228
ghc-pkg.man
228
ghc-pkg.man
@ -1,228 +0,0 @@
|
||||
.TH ghc-pkg 1 "2010-01-27"
|
||||
.SH NAME
|
||||
ghc-pkg \- GHC Haskell Cabal package manager
|
||||
.SH SYNOPSIS
|
||||
.B ghc-pkg
|
||||
.I action
|
||||
.RI [ OPTION ]...
|
||||
.SH DESCRIPTION
|
||||
A package is a library of Haskell modules known to the compiler. The
|
||||
.B ghc-pkg
|
||||
tool allows adding or removing them from a package database. By
|
||||
default, the system-wide package database is modified, but
|
||||
alternatively the user's local package database or another specified
|
||||
file can be used.
|
||||
.PP
|
||||
To make a package available for
|
||||
.BR ghc ,
|
||||
.B ghc-pkg
|
||||
can be used to register it. Unregistering it removes it from the
|
||||
database. Also, packages can be hidden, to make
|
||||
.B ghc
|
||||
ignore the package by default, without uninstalling it. Exposing a
|
||||
package makes a hidden package available. Additionally,
|
||||
.B ghc-pkg
|
||||
has various commands to query the package database.
|
||||
.PP
|
||||
Where a package name is required, the package can be named in full
|
||||
including the version number (e.g.
|
||||
.BR network-1.0 ),
|
||||
or without the version number. Naming a package without the version
|
||||
number matches all versions of the package; the specified action will
|
||||
be applied to all the matching packages. A package specifier that
|
||||
matches all version of the package can also be written
|
||||
.BR pkg-* ,
|
||||
to make it clearer that multiple packages are being matched.
|
||||
.SH ACTIONS
|
||||
.TP
|
||||
\fBregister\fP \fIfilename\fP|\fB-\fP
|
||||
Register the package using the specified installed package
|
||||
description.
|
||||
.TP
|
||||
\fBupdate\fP \fIfilename\fP|\fB-\fP
|
||||
Register the package, overwriting any other package with the same
|
||||
name.
|
||||
.TP
|
||||
\fBunregister\fP \fIpkg-id\fP
|
||||
Unregister the specified package.
|
||||
.TP
|
||||
\fBexpose\fP \fIpkg-id\fP
|
||||
Expose the specified package.
|
||||
.TP
|
||||
\fBhide\fP \fIpkg-id\fP
|
||||
Hide the specified package
|
||||
.TP
|
||||
\fBlist\fP \fR[\fIpkg\fR]...\fP
|
||||
List registered packages in the global database, and also the user
|
||||
database if
|
||||
.B --user
|
||||
is given. If a package name is given all the registered versions will
|
||||
be listed in ascending order. Accepts the
|
||||
.B --simple-output
|
||||
flag.
|
||||
.TP
|
||||
.B dot
|
||||
Generate a graph of the package dependencies in a form suitable for
|
||||
input for the graphviz tools. For example, to generate a PDF of the
|
||||
dependency graph:
|
||||
.br
|
||||
\fB dot \| tred \| dot -Tpdf >pkgs.pdf\fP
|
||||
.TP
|
||||
\fBfind-module\fP \fImodule\fP
|
||||
List registered packages exposing module
|
||||
.I module
|
||||
in the global database, and also the user database if
|
||||
.B --user
|
||||
is given. All the registered versions will be listed in ascending
|
||||
order. Accepts the
|
||||
.B --simple-output
|
||||
flag.
|
||||
.TP
|
||||
\fBlatest\fP \fIpkg-id\fP
|
||||
Prints the highest registered version of a package.
|
||||
.TP
|
||||
.B check
|
||||
Check the consistency of package dependencies and list broken
|
||||
packages. Accepts the
|
||||
.B --simple-output
|
||||
flag.
|
||||
.TP
|
||||
\fBdescribe\fP \fIpkg\fP
|
||||
Give the registered description for the
|
||||
specified package. The description is returned in precisely the syntax
|
||||
required by ghc-pkg register.
|
||||
.TP
|
||||
\fBfield\fP \fIpkg field\fP
|
||||
Extract the specified field of the package description for the
|
||||
specified package. Accepts comma-separated multiple fields.
|
||||
.TP
|
||||
.B dump
|
||||
Dump the registered description for every package. This is like
|
||||
.BR ghc-pkg\ describe\ '*' ,
|
||||
expect that it is intended to be used by tools that parse the results,
|
||||
rather than humans.
|
||||
.TP
|
||||
.B recache
|
||||
Regenerate the package database cache. This command should only be
|
||||
necessary if you added a package to the database by dropping a file
|
||||
into the database directory manyally. By default, the global DB is
|
||||
recached; to recache a different DB use
|
||||
.B --user
|
||||
or
|
||||
.B --package-conf
|
||||
as appropriate.
|
||||
.SH OPTIONS
|
||||
When asked to modify a database
|
||||
.RB ( register ,\ unregister ,\ update ,\ hide ,\ expose ,\ and\ also\ check ),
|
||||
.B ghc-pkg
|
||||
modifies the global database by
|
||||
default. Specifying
|
||||
.B --user
|
||||
causes it to act on the user database,
|
||||
or
|
||||
.B --package-conf
|
||||
can be used to act on another database
|
||||
entirely. When multiple of these options are given, the rightmost
|
||||
one is used as the database to act upon.
|
||||
.PP
|
||||
Commands that query the package database
|
||||
.RB ( list ,\ latest ,\ describe ,\ field )
|
||||
operate on the list of databases specified by the flags
|
||||
.BR --user ,\ --global ,
|
||||
and
|
||||
.BR --package-conf .
|
||||
If none of these flags are
|
||||
given, the default is
|
||||
.BR --global\ --user .
|
||||
.TP
|
||||
.B --user
|
||||
Use the current user's package database.
|
||||
.TP
|
||||
.B --global
|
||||
Use the global package database.
|
||||
.TP
|
||||
\fB-f\fP \fIFILE\fP, \fB--package-conf=\fIFILE\fP
|
||||
Use the specified package config file.
|
||||
.TP
|
||||
.BI --global-conf= FILE
|
||||
Location of the global package config.
|
||||
.TP
|
||||
.B --force
|
||||
Ignore missing dependencies, directories, and libraries.
|
||||
.TP
|
||||
.B --force-files
|
||||
Ignore missing directories and libraries only.
|
||||
.TP
|
||||
.BR -g ,\ --auto-ghc-libs
|
||||
Automatically build libs for GHCi (with register).
|
||||
.TP
|
||||
.BR -? ,\ --help
|
||||
Display a help message and exit.
|
||||
.TP
|
||||
.BR -V ,\ --version
|
||||
Output version information and exit.
|
||||
.TP
|
||||
.B --simple-output
|
||||
Print output in easy-to-parse format for some commands.
|
||||
.TP
|
||||
.B --names-only
|
||||
Only print package names, not versions; can only be used with
|
||||
.BR list\ --simple-output .
|
||||
.TP
|
||||
.B --ignore-case
|
||||
Ignore case for substring matching.
|
||||
.SH ENVIRONMENT VARIABLES
|
||||
.TP
|
||||
.B GHC_PACKAGE_PATH
|
||||
The
|
||||
.B GHC_PACKAGE_PATH
|
||||
environment variable may be set to a
|
||||
.BR : -separated
|
||||
list of files containing package databases. This list of package
|
||||
databases is used by
|
||||
.B ghc
|
||||
and
|
||||
.BR ghc-pkg ,
|
||||
with earlier databases in the list overriding later ones. This order
|
||||
was chosen to match the behaviour of the
|
||||
.B PATH
|
||||
environment variable; think of it as a list of package databases that
|
||||
are searched left-to-right for packages.
|
||||
|
||||
If
|
||||
.B GHC_PACKAGE_PATH
|
||||
ends in a separator, then the default user and system package
|
||||
databases are appended, in that order. e.g. to augment the usual set
|
||||
of packages with a database of your own, you could say:
|
||||
|
||||
.br
|
||||
\fB export GHC_PACKAGE_PATH=$HOME/.my-ghc-packages.conf:\fP
|
||||
.br
|
||||
|
||||
To check whether your
|
||||
.B GHC_PACKAGE_PATH
|
||||
setting is doing the right thing,
|
||||
.B ghc-pkg list
|
||||
will list all the databases in use, in the reverse order they are
|
||||
searched.
|
||||
.SH FILES
|
||||
Both of these locations are changed for Debian. Upstream still keeps
|
||||
these under
|
||||
.IR /usr .
|
||||
Some programs may refer to that, but look in
|
||||
.I /var
|
||||
instead.
|
||||
.TP
|
||||
.I /var/lib/ghc/package.conf
|
||||
Global package.conf file.
|
||||
.TP
|
||||
.I /var/lib/ghc/package.conf.d/
|
||||
Directory for library specific package.conf files. These are added to
|
||||
the global registry.
|
||||
.SH "SEE ALSO"
|
||||
.BR ghc (1),
|
||||
.BR runghc (1),
|
||||
.BR hugs (1).
|
||||
.SH AUTHOR
|
||||
This manual page was written by Kari Pahula <kaol@debian.org>, for the
|
||||
Debian project (and may be used by others).
|
@ -1,12 +0,0 @@
|
||||
--- ghc-8.4.3/mk/warnings.mk~ 2018-02-04 02:30:11.000000000 +0900
|
||||
+++ ghc-8.4.3/mk/warnings.mk 2018-09-29 14:33:37.607884921 +0900
|
||||
@@ -1,6 +1,6 @@
|
||||
# See Note [Order of warning flags].
|
||||
-SRC_CC_OPTS += -Wall $(WERROR)
|
||||
+#SRC_CC_OPTS += -Wall $(WERROR)
|
||||
SRC_HC_OPTS += -Wall
|
||||
# Don't add -Werror to SRC_HC_OPTS_STAGE0 (or SRC_HC_OPTS), because otherwise
|
||||
# validate may unnecessarily fail when booting with an older compiler.
|
||||
# It would be better to only exclude certain warnings from becoming errors
|
||||
|
||||
Diff finished. Sat Sep 29 14:35:43 2018
|
Loading…
Reference in New Issue
Block a user