update patches for armv7 for ghc-7.8
- LlvmCodeGen-llvm-version-warning patch no needed since 3.4 supported now, but rawhide is now on 3.5! - update no NEON patch
This commit is contained in:
parent
138479e435
commit
cfae44c249
@ -1,7 +1,7 @@
|
|||||||
--- ghc-7.6.3/aclocal.m4~ 2013-04-19 06:22:46.000000000 +0900
|
--- ghc-7.8.3/aclocal.m4~ 2014-07-10 13:27:16.000000000 +0900
|
||||||
+++ ghc-7.6.3/aclocal.m4 2014-07-15 18:22:12.308929288 +0900
|
+++ ghc-7.8.3/aclocal.m4 2014-11-05 12:19:08.530044128 +0900
|
||||||
@@ -349,7 +349,7 @@
|
@@ -408,7 +408,7 @@
|
||||||
],
|
)],
|
||||||
[changequote(, )dnl
|
[changequote(, )dnl
|
||||||
ARM_ISA=ARMv7
|
ARM_ISA=ARMv7
|
||||||
- ARM_ISA_EXT="[VFPv3,NEON]"
|
- ARM_ISA_EXT="[VFPv3,NEON]"
|
24
ghc.spec
24
ghc.spec
@ -44,14 +44,15 @@ Patch1: ghc-gen_contents_index-haddock-path.patch
|
|||||||
#Patch10: ghc-wrapper-libffi-include.patch
|
#Patch10: ghc-wrapper-libffi-include.patch
|
||||||
# stop warnings about unsupported version of llvm
|
# stop warnings about unsupported version of llvm
|
||||||
# NB: value affects ABI hash of libHSghc!
|
# NB: value affects ABI hash of libHSghc!
|
||||||
Patch14: ghc-7.6.3-LlvmCodeGen-llvm-version-warning.patch
|
# will probably be needed again for llvm-3.5
|
||||||
|
#Patch14: ghc-7.6.3-LlvmCodeGen-llvm-version-warning.patch
|
||||||
# unversion library html docdirs
|
# unversion library html docdirs
|
||||||
Patch16: ghc-cabal-unversion-docdir.patch
|
Patch16: ghc-cabal-unversion-docdir.patch
|
||||||
# warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
|
# warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
|
||||||
Patch20: ghc-glibc-2.20_BSD_SOURCE.patch
|
Patch20: ghc-glibc-2.20_BSD_SOURCE.patch
|
||||||
# Debian patch
|
# Debian patch
|
||||||
Patch21: ghc-arm64.patch
|
Patch21: ghc-arm64.patch
|
||||||
Patch22: ghc-7.6.3-armv7-VFPv3D16--NEON.patch
|
Patch22: ghc-armv7-VFPv3D16--NEON.patch
|
||||||
Patch23: ghc-7.8.3-Cabal-install-PATH-warning.patch
|
Patch23: ghc-7.8.3-Cabal-install-PATH-warning.patch
|
||||||
|
|
||||||
%global Cabal_ver 1.18.1.3
|
%global Cabal_ver 1.18.1.3
|
||||||
@ -84,7 +85,8 @@ Patch23: ghc-7.8.3-Cabal-install-PATH-warning.patch
|
|||||||
|
|
||||||
|
|
||||||
# fedora ghc has been bootstrapped on
|
# fedora ghc has been bootstrapped on
|
||||||
# %{ix86} x86_64 ppc alpha sparcv9 ppc64 armv7hl armv5tel s390 s390x
|
# %{ix86} x86_64 ppc ppc64 armv7hl s390 s390x ppc64le aarch64
|
||||||
|
# and retired arches: alpha sparcv9 armv5tel
|
||||||
# see ghc_arches defined in /etc/rpm/macros.ghc-srpm by redhat-rpm-macros
|
# see ghc_arches defined in /etc/rpm/macros.ghc-srpm by redhat-rpm-macros
|
||||||
ExcludeArch: sparc64
|
ExcludeArch: sparc64
|
||||||
Obsoletes: ghc-dph-base < 0.5, ghc-dph-base-devel < 0.5, ghc-dph-base-prof < 0.5
|
Obsoletes: ghc-dph-base < 0.5, ghc-dph-base-devel < 0.5, ghc-dph-base-prof < 0.5
|
||||||
@ -263,7 +265,7 @@ rm -r libffi-tarballs
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifarch armv7hl armv5tel
|
%ifarch armv7hl armv5tel
|
||||||
%patch14 -p1 -b .orig
|
#%%patch14 -p1 -b .orig
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# unversion pkgdoc htmldir
|
# unversion pkgdoc htmldir
|
||||||
@ -323,16 +325,18 @@ BUILD_DOCBOOK_HTML = NO
|
|||||||
#EXTRA_HC_OPTS=-debug
|
#EXTRA_HC_OPTS=-debug
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
|
%ifarch aarch64
|
||||||
|
for i in $(find . -name config.guess -o -name config.sub) ; do
|
||||||
|
[ -f /usr/lib/rpm/redhat/$(basename $i) ] && %{__rm} -f $i && %{__cp} -fv /usr/lib/rpm/redhat/$(basename $i) $i
|
||||||
|
done
|
||||||
|
%endif
|
||||||
|
%ifarch aarch64 armv7hl
|
||||||
|
autoreconf
|
||||||
|
%endif
|
||||||
export CFLAGS="${CFLAGS:-%optflags}"
|
export CFLAGS="${CFLAGS:-%optflags}"
|
||||||
export LDFLAGS="${LDFLAGS:-%__global_ldflags}"
|
export LDFLAGS="${LDFLAGS:-%__global_ldflags}"
|
||||||
# * %%configure induces cross-build due to different target/host/build platform names
|
# * %%configure induces cross-build due to different target/host/build platform names
|
||||||
# * --with-gcc=%{_bindir}/gcc is to avoid ccache hardcoding problem when bootstrapping
|
# * --with-gcc=%{_bindir}/gcc is to avoid ccache hardcoding problem when bootstrapping
|
||||||
%ifarch aarch64 armv7hl
|
|
||||||
for i in $(find . -name config.guess -o -name config.sub) ; do
|
|
||||||
[ -f /usr/lib/rpm/redhat/$(basename $i) ] && %{__rm} -f $i && %{__cp} -fv /usr/lib/rpm/redhat/$(basename $i) $i
|
|
||||||
done
|
|
||||||
autoreconf
|
|
||||||
%endif
|
|
||||||
./configure --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} \
|
./configure --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} \
|
||||||
--bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
|
--bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
|
||||||
--datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} \
|
--datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} \
|
||||||
|
Loading…
Reference in New Issue
Block a user