More build fixes
This commit is contained in:
parent
34b478a7fd
commit
860e5f3f03
@ -9,3 +9,14 @@
|
||||
--haddock-options="--use-contents=../index.html \
|
||||
--use-index=../doc-index.html" \
|
||||
$(FLAGGED_CONFIGURE_ARGS) \
|
||||
--- ghc-6.8.3/libraries/gen_contents_index~ 2008-06-18 20:40:39.000000000 -0700
|
||||
+++ ghc-6.8.3/libraries/gen_contents_index 2008-06-18 20:40:50.000000000 -0700
|
||||
@@ -22,7 +22,7 @@
|
||||
done
|
||||
|
||||
# Now create the combined contents and index pages
|
||||
-haddock --gen-index --gen-contents -o . \
|
||||
+haddock-0.9 --gen-index --gen-contents -o . \
|
||||
-t "Haskell Hierarchical Libraries" \
|
||||
$HADDOCK_ARGS
|
||||
|
||||
|
12
ghc.spec
12
ghc.spec
@ -16,7 +16,7 @@
|
||||
|
||||
Name: ghc
|
||||
Version: 6.8.3
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Glasgow Haskell Compilation system
|
||||
# See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239713
|
||||
ExcludeArch: alpha ppc64
|
||||
@ -130,6 +130,12 @@ pushd ${RPM_BUILD_ROOT}/%{_libexecdir}/%{name}-%{version}
|
||||
strip cgprof ghc-%{version} ghc-pkg.bin hsc2hs-bin unlit
|
||||
popd
|
||||
|
||||
pushd ${RPM_BUILD_ROOT}/%{_libdir}/%{name}-%{version}
|
||||
for i in ../../libexec/%{name}-%{version}/*; do
|
||||
ln -s $i .
|
||||
done
|
||||
popd
|
||||
|
||||
%if %{build_doc}
|
||||
make DESTDIR=${RPM_BUILD_ROOT} XMLDocWays="html" HADDOCK_DOCS=YES install-docs
|
||||
if [ -d ${RPM_BUILD_ROOT}/%{_docdir}/%{name}/libraries ]; then
|
||||
@ -209,6 +215,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 6.8.3-3
|
||||
- Add symlinks from _libdir, where ghc looks, to _libexecdir
|
||||
- Patch libraries/gen_contents_index to use haddock-0.9
|
||||
|
||||
* Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 6.8.3-2
|
||||
- Remove unnecessary dependency on alex
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user