silence warnings about unsupported llvm version (> 3.1) on ARM
+You are using a new version of LLVM that hasn't been tested yet! +We will try though... (ghc-7.6 only officially supports 2.8 <= llvm <= 3.1)
This commit is contained in:
parent
b019f63051
commit
0d40f8dbbf
11
ghc-7.6.3-LlvmCodeGen-no-3.3-warning.patch
Normal file
11
ghc-7.6.3-LlvmCodeGen-no-3.3-warning.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- ghc-7.6.3/compiler/llvmGen/LlvmCodeGen/Base.hs~ 2013-04-19 06:22:46.000000000 +0900
|
||||||
|
+++ ghc-7.6.3/compiler/llvmGen/LlvmCodeGen/Base.hs 2013-07-24 17:05:06.491900335 +0900
|
||||||
|
@@ -151,7 +151,7 @@
|
||||||
|
minSupportLlvmVersion = 28
|
||||||
|
|
||||||
|
maxSupportLlvmVersion :: LlvmVersion
|
||||||
|
-maxSupportLlvmVersion = 31
|
||||||
|
+maxSupportLlvmVersion = 33
|
||||||
|
|
||||||
|
-- ----------------------------------------------------------------------------
|
||||||
|
-- * Environment Handling
|
11
ghc.spec
11
ghc.spec
@ -29,7 +29,7 @@ Version: 7.6.3
|
|||||||
# - release can only be reset if *all* library versions get bumped simultaneously
|
# - release can only be reset if *all* library versions get bumped simultaneously
|
||||||
# (sometimes after a major release)
|
# (sometimes after a major release)
|
||||||
# - minor release numbers for a branch should be incremented monotonically
|
# - minor release numbers for a branch should be incremented monotonically
|
||||||
Release: 16%{?dist}
|
Release: 17%{?dist}
|
||||||
Summary: Glasgow Haskell Compiler
|
Summary: Glasgow Haskell Compiler
|
||||||
|
|
||||||
License: %BSDHaskellReport
|
License: %BSDHaskellReport
|
||||||
@ -52,6 +52,8 @@ Patch10: ghc-wrapper-libffi-include.patch
|
|||||||
Patch12: ghc-7.4.2-Cabal-disable-ghci-libs.patch
|
Patch12: ghc-7.4.2-Cabal-disable-ghci-libs.patch
|
||||||
# fix compilation with llvm-3.3
|
# fix compilation with llvm-3.3
|
||||||
Patch13: ghc-llvmCodeGen-empty-array.patch
|
Patch13: ghc-llvmCodeGen-empty-array.patch
|
||||||
|
# stop warnings about unsupported version of llvm
|
||||||
|
Patch14: ghc-7.6.3-LlvmCodeGen-no-3.3-warning.patch
|
||||||
|
|
||||||
# fedora ghc has been bootstrapped on
|
# fedora ghc has been bootstrapped on
|
||||||
# %{ix86} x86_64 ppc alpha sparcv9 ppc64 armv7hl armv5tel s390 s390x
|
# %{ix86} x86_64 ppc alpha sparcv9 ppc64 armv7hl armv5tel s390 s390x
|
||||||
@ -227,6 +229,10 @@ ln -s $(pkg-config --variable=includedir libffi)/*.h rts/dist/build
|
|||||||
|
|
||||||
%patch13 -p1 -b .orig
|
%patch13 -p1 -b .orig
|
||||||
|
|
||||||
|
%ifarch armv7hl armv5tel
|
||||||
|
%patch14 -p1 -b .orig
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# http://hackage.haskell.org/trac/ghc/wiki/Platforms
|
# http://hackage.haskell.org/trac/ghc/wiki/Platforms
|
||||||
@ -439,6 +445,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 24 2013 Jens Petersen <petersen@redhat.com> - 7.6.3-17
|
||||||
|
- silence warnings about unsupported llvm version (> 3.1) on ARM
|
||||||
|
|
||||||
* Thu Jul 11 2013 Jens Petersen <petersen@redhat.com> - 7.6.3-16
|
* Thu Jul 11 2013 Jens Petersen <petersen@redhat.com> - 7.6.3-16
|
||||||
- revert the executable stack patch since it didn't fully fix the problem
|
- revert the executable stack patch since it didn't fully fix the problem
|
||||||
and yet changed the ghc library hash
|
and yet changed the ghc library hash
|
||||||
|
Loading…
Reference in New Issue
Block a user