import ghc-hslua-0.9.5-2.el8
This commit is contained in:
commit
87606cd665
1
.ghc-hslua.metadata
Normal file
1
.ghc-hslua.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
64cb9000e4ef9562a01cfb9e3bf3309d7f5db019 SOURCES/hslua-0.9.5.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/hslua-0.9.5.tar.gz
|
31
SOURCES/hslua-system-lua.patch
Normal file
31
SOURCES/hslua-system-lua.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
--- hslua-0.9.5/hslua.cabal.orig 2018-01-04 23:32:01.000000000 +0100
|
||||||
|
+++ hslua-0.9.5/hslua.cabal 2018-01-30 00:14:21.052923877 +0100
|
||||||
|
@@ -35,7 +35,8 @@
|
||||||
|
|
||||||
|
flag system-lua
|
||||||
|
description: Use the system-wide Lua instead of the bundled copy.
|
||||||
|
- default: False
|
||||||
|
+ default: True
|
||||||
|
+ manual: True
|
||||||
|
|
||||||
|
flag apicheck
|
||||||
|
description: Compile Lua with -DLUA_USE_APICHECK.
|
||||||
|
@@ -60,6 +61,7 @@
|
||||||
|
flag luajit
|
||||||
|
description: Link with LuaJIT. This implies flag system-lua as well.
|
||||||
|
default: False
|
||||||
|
+ manual: True
|
||||||
|
|
||||||
|
flag lua501
|
||||||
|
description: Build against lua 5.1.
|
||||||
|
@@ -115,7 +116,7 @@
|
||||||
|
if flag(lua502)
|
||||||
|
pkgconfig-depends: lua5.2
|
||||||
|
else
|
||||||
|
- pkgconfig-depends: lua5.3
|
||||||
|
+ pkgconfig-depends: lua
|
||||||
|
else
|
||||||
|
Extra-libraries: lua
|
||||||
|
if !flag(use-pkgconfig)
|
||||||
|
|
||||||
|
Diff finished. Tue Jan 30 00:14:26 2018
|
153
SPECS/ghc-hslua.spec
Normal file
153
SPECS/ghc-hslua.spec
Normal file
@ -0,0 +1,153 @@
|
|||||||
|
# generated by cabal-rpm-0.12.1
|
||||||
|
# https://fedoraproject.org/wiki/Packaging:Haskell
|
||||||
|
|
||||||
|
%global pkg_name hslua
|
||||||
|
%global pkgver %{pkg_name}-%{version}
|
||||||
|
|
||||||
|
%bcond_with tests
|
||||||
|
|
||||||
|
Name: ghc-%{pkg_name}
|
||||||
|
Version: 0.9.5
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: A Lua language interpreter embedding in Haskell
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
Url: https://hackage.haskell.org/package/%{pkg_name}
|
||||||
|
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
|
||||||
|
Patch0: hslua-system-lua.patch
|
||||||
|
|
||||||
|
BuildRequires: ghc-Cabal-devel
|
||||||
|
BuildRequires: ghc-rpm-macros
|
||||||
|
# Begin cabal-rpm deps:
|
||||||
|
BuildRequires: ghc-bytestring-devel
|
||||||
|
BuildRequires: ghc-containers-devel
|
||||||
|
BuildRequires: ghc-exceptions-devel
|
||||||
|
BuildRequires: ghc-mtl-devel
|
||||||
|
BuildRequires: ghc-text-devel
|
||||||
|
BuildRequires: pkgconfig(lua)
|
||||||
|
%if %{with tests}
|
||||||
|
BuildRequires: ghc-QuickCheck-devel
|
||||||
|
BuildRequires: ghc-quickcheck-instances-devel
|
||||||
|
BuildRequires: ghc-tasty-devel
|
||||||
|
BuildRequires: ghc-tasty-expected-failure-devel
|
||||||
|
BuildRequires: ghc-tasty-hunit-devel
|
||||||
|
BuildRequires: ghc-tasty-quickcheck-devel
|
||||||
|
%endif
|
||||||
|
# End cabal-rpm deps
|
||||||
|
|
||||||
|
%description
|
||||||
|
The Scripting.Lua module is a wrapper of the Lua language interpreter described
|
||||||
|
in www.lua.org.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Haskell %{pkg_name} library development files
|
||||||
|
Provides: %{name}-static = %{version}-%{release}
|
||||||
|
Provides: %{name}-doc = %{version}-%{release}
|
||||||
|
%if %{defined ghc_version}
|
||||||
|
Requires: ghc-compiler = %{ghc_version}
|
||||||
|
Requires(post): ghc-compiler = %{ghc_version}
|
||||||
|
Requires(postun): ghc-compiler = %{ghc_version}
|
||||||
|
%endif
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
# Begin cabal-rpm deps:
|
||||||
|
Requires: pkgconfig(lua)
|
||||||
|
# End cabal-rpm deps
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the Haskell %{pkg_name} library development files.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{pkgver}
|
||||||
|
%patch0 -p1 -b .orig
|
||||||
|
sed -i "/fail /d" hslua.cabal
|
||||||
|
#cabal-tweak-drop-dep '\", fail >= 4.9 && < 5\"'
|
||||||
|
rm -r lua-5.3.4
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%define cabal_configure_options -f -luajit -f use-pkgconfig
|
||||||
|
%ghc_lib_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ghc_lib_install
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
%cabal_test
|
||||||
|
|
||||||
|
|
||||||
|
%post devel
|
||||||
|
%ghc_pkg_recache
|
||||||
|
|
||||||
|
|
||||||
|
%postun devel
|
||||||
|
%ghc_pkg_recache
|
||||||
|
|
||||||
|
|
||||||
|
%files -f %{name}.files
|
||||||
|
%license COPYRIGHT
|
||||||
|
|
||||||
|
|
||||||
|
%files devel -f %{name}-devel.files
|
||||||
|
%doc CHANGELOG.md README.md
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 24 2018 Jens Petersen <petersen@redhat.com> - 0.9.5-1
|
||||||
|
- update to 0.9.5
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.1-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 24 2017 Jens Petersen <petersen@redhat.com> - 0.4.1-3
|
||||||
|
- refresh to cabal-rpm-0.11.1
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 23 2016 Jens Petersen <petersen@redhat.com> - 0.4.1-1
|
||||||
|
- update to 0.4.1
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.13-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 19 2015 Jens Petersen <petersen@redhat.com> - 0.3.13-1
|
||||||
|
- update to 0.3.13
|
||||||
|
|
||||||
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.10-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.10-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 22 2014 Jens Petersen <petersen@redhat.com> - 0.3.10-2
|
||||||
|
- hslua needs lua-5.1 so build with compat-lua
|
||||||
|
|
||||||
|
* Wed Jan 22 2014 Jens Petersen <petersen@redhat.com> - 0.3.10-1
|
||||||
|
- update to 0.3.10 (#1009375)
|
||||||
|
- update license to MIT (#1009375)
|
||||||
|
see https://github.com/osa1/hslua/issues/14
|
||||||
|
- system-lua patch is now upstream
|
||||||
|
- tweak summary and description
|
||||||
|
|
||||||
|
* Wed Oct 16 2013 Jens Petersen <petersen@redhat.com> - 0.3.6.1-2
|
||||||
|
- add static provides to devel
|
||||||
|
|
||||||
|
* Wed Sep 18 2013 Jens Petersen <petersen@redhat.com> - 0.3.6.1-1
|
||||||
|
- summary and description
|
||||||
|
- patch to use system lua
|
||||||
|
|
||||||
|
* Wed Sep 18 2013 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.3.6.1-0
|
||||||
|
- spec file generated by cabal-rpm-0.8.3
|
Loading…
Reference in New Issue
Block a user