diff --git a/.gitignore b/.gitignore
index 0548806..39fc4a9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
+/cmark-gfm-0.1.3.tar.gz
+/cmark-gfm-0.2.2.tar.gz
 /cmark-gfm-0.2.3.tar.gz
diff --git a/gating.yaml b/gating.yaml
new file mode 100644
index 0000000..6985029
--- /dev/null
+++ b/gating.yaml
@@ -0,0 +1,6 @@
+--- !Policy
+product_versions:
+  - rhel-8
+decision_context: osci_compose_gate
+rules:
+  - !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
diff --git a/ghc-cmark-gfm.spec b/ghc-cmark-gfm.spec
index 28051b9..7382d6b 100644
--- a/ghc-cmark-gfm.spec
+++ b/ghc-cmark-gfm.spec
@@ -84,7 +84,7 @@ This package provides the Haskell %{pkg_name} library development files.
 * Thu Apr 14 2022 Jens Petersen <petersen@redhat.com> - 0.2.3-1
 - 0.2.3 bundles the C cmark-gfm-0.29.0.gfm.3 library which fixes CVE-2022-24724
   https://github.com/github/cmark-gfm/security/advisories/GHSA-mc3g-88wq-6f4x
-- Resolves: #2074998
+- Resolves: #2060668
 
 * Mon Jan 11 2021 Jens Petersen <petersen@redhat.com> - 0.2.2-2
 - rebuild
diff --git a/tests/tests.yml b/tests/tests.yml
new file mode 100644
index 0000000..fd58a3f
--- /dev/null
+++ b/tests/tests.yml
@@ -0,0 +1,18 @@
+---
+- hosts: localhost
+  tags:
+  - classic
+  roles:
+  - role: standard-test-basic
+    vars:
+    - pkg: "ghc-cmark-gfm"
+    - develpkg: "{{pkg}}-devel"
+    - pkgname: "{{pkg|regex_replace('^ghc-(.*)$', '\\1')}}"
+    required_packages:
+    - "{{develpkg}}"
+    tests:
+    - ghc:
+        run: echo 'main = return ()' > test.hs; ghc -package {{pkgname}} test.hs; ./test
+    - revdeps:
+        run: revdeps=$(dnf -q repoquery --qf "%{name}" --whatrequires={{develpkg}}); if [ -z "${revdeps}" ]; then echo "No valid dependents"; exit 1; else dnf -y install ${revdeps}; fi
+...