diff --git a/.gitignore b/.gitignore
index e69de29..f2854bb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/Glob-0.9.1.tar.gz
+/Glob-0.9.2.tar.gz
+/Glob-0.9.3.tar.gz
+/Glob-0.10.0.tar.gz
diff --git a/Glob-0.10.0.cabal b/Glob-0.10.0.cabal
new file mode 100644
index 0000000..971983a
--- /dev/null
+++ b/Glob-0.10.0.cabal
@@ -0,0 +1,94 @@
+Cabal-Version: >= 1.9.2
+
+Name:        Glob
+Version:     0.10.0
+x-revision: 1
+Homepage:    http://iki.fi/matti.niemenmaa/glob/
+Synopsis:    Globbing library
+Category:    System
+Stability:   provisional
+Description:
+   A library for globbing: matching patterns against file paths.
+
+Author:       Matti Niemenmaa
+Maintainer:   Matti Niemenmaa <matti.niemenmaa+glob@iki.fi>
+License:      BSD3
+License-File: LICENSE.txt
+
+Build-Type: Simple
+
+Extra-Source-Files: CHANGELOG.txt
+                    CREDITS.txt
+                    README.txt
+
+Source-Repository head
+  Type: git
+  Location: https://github.com/Deewiant/glob
+
+Library
+   Build-Depends: base         >= 4 && < 5
+                , containers   <  0.7
+                , directory    <  1.4
+                , dlist        >= 0.4 && < 0.9
+                , filepath     >= 1.1 && < 1.5
+                , transformers >= 0.2 && < 0.6
+                , transformers-compat >= 0.3 && < 0.7
+
+   if impl(ghc < 8.0)
+      Build-Depends: semigroups >= 0.18 && < 0.20
+
+   if os(windows)
+      Build-Depends: Win32 == 2.*
+
+   Exposed-Modules: System.FilePath.Glob
+                    System.FilePath.Glob.Primitive
+   Other-Modules:   System.FilePath.Glob.Base
+                    System.FilePath.Glob.Directory
+                    System.FilePath.Glob.Match
+                    System.FilePath.Glob.Simplify
+                    System.FilePath.Glob.Utils
+
+   GHC-Options: -Wall
+
+Test-Suite glob-tests
+   type: exitcode-stdio-1.0
+
+   hs-source-dirs: ., tests
+   main-is: Main.hs
+
+   Build-Depends: base                       >= 4 && < 5
+                , containers                 <  0.7
+                , directory                  <  1.4
+                , dlist                      >= 0.4 && < 0.9
+                , filepath                   >= 1.1 && < 1.5
+                , transformers               >= 0.2 && < 0.6
+                , transformers-compat        >= 0.3 && < 0.7
+                , HUnit                      >= 1.2 && < 1.7
+                , QuickCheck                 >= 2 && < 3
+                , test-framework             >= 0.2 && < 1
+                , test-framework-hunit       >= 0.2 && < 1
+                , test-framework-quickcheck2 >= 0.3 && < 1
+
+   if impl(ghc < 8.0)
+      Build-Depends: semigroups >= 0.18 && < 0.20
+
+   if os(windows)
+      Build-Depends: Win32 == 2.*
+
+   Other-Modules: System.FilePath.Glob.Base
+                  System.FilePath.Glob.Directory
+                  System.FilePath.Glob.Match
+                  System.FilePath.Glob.Primitive
+                  System.FilePath.Glob.Simplify
+                  System.FilePath.Glob.Utils
+                  Tests.Base
+                  Tests.Compiler
+                  Tests.Directory
+                  Tests.Instances
+                  Tests.Matcher
+                  Tests.Optimizer
+                  Tests.Regression
+                  Tests.Simplifier
+                  Tests.Utils
+
+   GHC-Options: -Wall
diff --git a/ghc-Glob.spec b/ghc-Glob.spec
new file mode 100644
index 0000000..f4ddea5
--- /dev/null
+++ b/ghc-Glob.spec
@@ -0,0 +1,153 @@
+# generated by cabal-rpm-2.0.6
+# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
+
+%global pkg_name Glob
+%global pkgver %{pkg_name}-%{version}
+
+# testsuite missing deps: test-framework test-framework-hunit test-framework-quickcheck2
+
+Name:           ghc-%{pkg_name}
+Version:        0.10.0
+Release:        3%{?dist}
+Summary:        Globbing library
+
+License:        BSD
+Url:            https://hackage.haskell.org/package/%{pkg_name}
+# Begin cabal-rpm sources:
+Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
+# End cabal-rpm sources
+
+# Begin cabal-rpm deps:
+BuildRequires:  ghc-Cabal-devel
+BuildRequires:  ghc-rpm-macros
+BuildRequires:  ghc-base-prof
+BuildRequires:  ghc-containers-prof
+BuildRequires:  ghc-directory-prof
+BuildRequires:  ghc-dlist-prof
+BuildRequires:  ghc-filepath-prof
+BuildRequires:  ghc-transformers-prof
+BuildRequires:  ghc-transformers-compat-prof
+# End cabal-rpm deps
+
+%description
+A library for globbing: matching patterns against file paths.
+
+
+%package devel
+Summary:        Haskell %{pkg_name} library development files
+Provides:       %{name}-static = %{version}-%{release}
+Provides:       %{name}-static%{?_isa} = %{version}-%{release}
+%if %{defined ghc_version}
+Requires:       ghc-compiler = %{ghc_version}
+%endif
+Requires:       %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+This package provides the Haskell %{pkg_name} library development files.
+
+
+%if %{with haddock}
+%package doc
+Summary:        Haskell %{pkg_name} library documentation
+BuildArch:      noarch
+
+%description doc
+This package provides the Haskell %{pkg_name} library documentation.
+%endif
+
+
+%if %{with ghc_prof}
+%package prof
+Summary:        Haskell %{pkg_name} profiling library
+Requires:       %{name}-devel%{?_isa} = %{version}-%{release}
+Supplements:    (%{name}-devel and ghc-prof)
+
+%description prof
+This package provides the Haskell %{pkg_name} profiling library.
+%endif
+
+
+%prep
+# Begin cabal-rpm setup:
+%setup -q -n %{pkgver}
+cp -bp %{SOURCE1} %{pkg_name}.cabal
+chmod a-x CHANGELOG.txt README.txt
+# End cabal-rpm setup
+
+
+%build
+# Begin cabal-rpm build:
+%ghc_lib_build
+# End cabal-rpm build
+
+
+%install
+# Begin cabal-rpm install
+%ghc_lib_install
+# End cabal-rpm install
+
+
+%files -f %{name}.files
+# Begin cabal-rpm files:
+%license LICENSE.txt
+# End cabal-rpm files
+
+
+%files devel -f %{name}-devel.files
+%doc CHANGELOG.txt README.txt
+
+
+%if %{with haddock}
+%files doc -f %{name}-doc.files
+%license LICENSE.txt
+%endif
+
+
+%if %{with ghc_prof}
+%files prof -f %{name}-prof.files
+%endif
+
+
+%changelog
+* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Fri Jul 17 2020 Jens Petersen <petersen@redhat.com> - 0.10.0-2
+- refresh to cabal-rpm-2.0.6
+
+* Sun Feb 09 2020 Jens Petersen <petersen@redhat.com> - 0.10.0-1
+- update to 0.10.0
+
+* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Thu Aug 01 2019 Jens Petersen <petersen@redhat.com> - 0.9.3-3
+- add doc and prof subpackages (cabal-rpm-1.0.0)
+
+* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Thu Feb 21 2019 Jens Petersen <petersen@redhat.com> - 0.9.3-1
+- update to 0.9.3
+
+* Sun Feb 17 2019 Jens Petersen <petersen@redhat.com> - 0.9.2-3
+- refresh to cabal-rpm-0.13
+
+* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Sun Jul 22 2018 Jens Petersen <petersen@redhat.com> - 0.9.2-1
+- update to 0.9.2
+
+* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.1-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Fri Jan 26 2018 Jens Petersen <petersen@redhat.com> - 0.9.1-2
+- rebuild
+
+* Sat Nov 18 2017 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.9.1-1
+- spec file generated by cabal-rpm-0.11.2
diff --git a/sources b/sources
new file mode 100644
index 0000000..debf5f5
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (Glob-0.10.0.tar.gz) = a7e1fe244cc7f4b74fb9cc74712d0d11679597dc5cb2e4f06540b71d3c9999c6e7e4f5243e8f757bcdcfea7c031b82143b522b378e157ad4a5046bc1e6bea88c