import gfs2-utils-3.2.0-4.el8
This commit is contained in:
commit
b0ed60d0fc
1
.gfs2-utils.metadata
Normal file
1
.gfs2-utils.metadata
Normal file
@ -0,0 +1 @@
|
||||
d08266389e4752fb53bd3297810296276ff395e5 SOURCES/gfs2-utils-3.2.0.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/gfs2-utils-3.2.0.tar.gz
|
@ -0,0 +1,130 @@
|
||||
commit 47261faa39aca05d6feb486fdeec26f8ffc3ef15
|
||||
Author: Andrew Price <anprice@redhat.com>
|
||||
Date: Fri Aug 17 12:49:24 2018 +0100
|
||||
|
||||
fsck.gfs2: Don't check fs formats we don't recognise
|
||||
|
||||
Currently fsck.gfs2 will ignore sb_fs_format but in order to support
|
||||
future formats we need to make sure it doesn't try to check filesystems
|
||||
with formats we don't recognise yet. Better late than never.
|
||||
|
||||
Tests included.
|
||||
|
||||
rhbz#1616389
|
||||
rhbz#1622050
|
||||
|
||||
Signed-off-by: Andrew Price <anprice@redhat.com>
|
||||
|
||||
diff --git a/gfs2/fsck/fsck.h b/gfs2/fsck/fsck.h
|
||||
index d3f76352..877448c3 100644
|
||||
--- a/gfs2/fsck/fsck.h
|
||||
+++ b/gfs2/fsck/fsck.h
|
||||
@@ -4,6 +4,8 @@
|
||||
#include "libgfs2.h"
|
||||
#include "osi_tree.h"
|
||||
|
||||
+#define FSCK_MAX_FORMAT (1801)
|
||||
+
|
||||
#define FSCK_HASH_SHIFT (13)
|
||||
#define FSCK_HASH_SIZE (1 << FSCK_HASH_SHIFT)
|
||||
#define FSCK_HASH_MASK (FSCK_HASH_SIZE - 1)
|
||||
diff --git a/gfs2/fsck/initialize.c b/gfs2/fsck/initialize.c
|
||||
index ebe62b9f..d1c620af 100644
|
||||
--- a/gfs2/fsck/initialize.c
|
||||
+++ b/gfs2/fsck/initialize.c
|
||||
@@ -1334,12 +1334,12 @@ static int fill_super_block(struct gfs2_sbd *sdp)
|
||||
if (sizeof(struct gfs2_sb) > sdp->sd_sb.sb_bsize){
|
||||
log_crit( _("GFS superblock is larger than the blocksize!\n"));
|
||||
log_debug("sizeof(struct gfs2_sb) > sdp->sd_sb.sb_bsize\n");
|
||||
- return -1;
|
||||
+ return FSCK_ERROR;
|
||||
}
|
||||
|
||||
if (compute_constants(sdp)) {
|
||||
log_crit("%s\n", _("Failed to compute file system constants"));
|
||||
- exit(FSCK_ERROR);
|
||||
+ return FSCK_ERROR;
|
||||
}
|
||||
ret = read_sb(sdp);
|
||||
if (ret < 0) {
|
||||
@@ -1348,10 +1348,15 @@ static int fill_super_block(struct gfs2_sbd *sdp)
|
||||
/* Now that we've tried to repair it, re-read it. */
|
||||
ret = read_sb(sdp);
|
||||
if (ret < 0)
|
||||
- return -1;
|
||||
+ return FSCK_ERROR;
|
||||
}
|
||||
if (sdp->gfs1)
|
||||
sbd1 = (struct gfs_sb *)&sdp->sd_sb;
|
||||
+ else if (sdp->sd_sb.sb_fs_format > FSCK_MAX_FORMAT) {
|
||||
+ log_crit(_("Unsupported gfs2 format found: %"PRIu32"\n"), sdp->sd_sb.sb_fs_format);
|
||||
+ log_crit(_("A newer fsck.gfs2 is required to check this file system.\n"));
|
||||
+ return FSCK_USAGE;
|
||||
+ }
|
||||
return 0;
|
||||
}
|
||||
|
||||
@@ -1556,6 +1561,7 @@ int initialize(struct gfs2_sbd *sdp, int force_check, int preen,
|
||||
int *all_clean)
|
||||
{
|
||||
int clean_journals = 0, open_flag;
|
||||
+ int err;
|
||||
|
||||
*all_clean = 0;
|
||||
|
||||
@@ -1601,8 +1607,9 @@ int initialize(struct gfs2_sbd *sdp, int force_check, int preen,
|
||||
}
|
||||
|
||||
/* read in sb from disk */
|
||||
- if (fill_super_block(sdp))
|
||||
- return FSCK_ERROR;
|
||||
+ err = fill_super_block(sdp);
|
||||
+ if (err != FSCK_OK)
|
||||
+ return err;
|
||||
|
||||
/* Change lock protocol to be fsck_* instead of lock_* */
|
||||
if (!opts.no && preen_is_safe(sdp, preen, force_check)) {
|
||||
diff --git a/gfs2/libgfs2/super.c b/gfs2/libgfs2/super.c
|
||||
index 6e7d8c23..75925643 100644
|
||||
--- a/gfs2/libgfs2/super.c
|
||||
+++ b/gfs2/libgfs2/super.c
|
||||
@@ -29,11 +29,18 @@ int check_sb(struct gfs2_sb *sb)
|
||||
errno = EIO;
|
||||
return -1;
|
||||
}
|
||||
+ /* Check for gfs1 */
|
||||
if (sb->sb_fs_format == GFS_FORMAT_FS &&
|
||||
sb->sb_header.mh_format == GFS_FORMAT_SB &&
|
||||
sb->sb_multihost_format == GFS_FORMAT_MULTI) {
|
||||
return 1;
|
||||
}
|
||||
+ /* It's gfs2. Check format number is in a sensible range. */
|
||||
+ if (sb->sb_fs_format < GFS2_FORMAT_FS ||
|
||||
+ sb->sb_fs_format > 1899) {
|
||||
+ errno = EINVAL;
|
||||
+ return -1;
|
||||
+ }
|
||||
return 2;
|
||||
}
|
||||
|
||||
diff --git a/tests/fsck.at b/tests/fsck.at
|
||||
index 39a04d04..97a00a90 100644
|
||||
--- a/tests/fsck.at
|
||||
+++ b/tests/fsck.at
|
||||
@@ -54,3 +54,16 @@ AT_CHECK([gfs2_edit -p journal0 field di_header.mh_magic 0 $GFS_TGT], 0, [ignore
|
||||
AT_CHECK([fsck.gfs2 -y $GFS_TGT], 1, [ignore], [ignore])
|
||||
AT_CHECK([fsck.gfs2 -n $GFS_TGT], 0, [ignore], [ignore])
|
||||
AT_CLEANUP
|
||||
+
|
||||
+AT_SETUP([gfs2 format versions])
|
||||
+AT_KEYWORDS(fsck.gfs2 fsck)
|
||||
+GFS_TGT_REGEN
|
||||
+AT_CHECK([mkfs.gfs2 -O -p lock_nolock ${GFS_TGT}], 0, [ignore], [ignore])
|
||||
+AT_CHECK([echo "set sb { sb_fs_format: 1802 }" | gfs2l ${GFS_TGT}], 0, [ignore], [ignore])
|
||||
+# Unsupported format, FSCK_USAGE == 16
|
||||
+AT_CHECK([fsck.gfs2 -y $GFS_TGT], 16, [ignore], [ignore])
|
||||
+# Format out of range
|
||||
+AT_CHECK([echo "set sb { sb_fs_format: 4242 }" | gfs2l ${GFS_TGT}], 0, [ignore], [ignore])
|
||||
+AT_CHECK([fsck.gfs2 -y $GFS_TGT], 1, [ignore], [ignore])
|
||||
+AT_CHECK([fsck.gfs2 -n $GFS_TGT], 0, [ignore], [ignore])
|
||||
+AT_CLEANUP
|
@ -0,0 +1,47 @@
|
||||
commit 57553571df2f33ec45a81fa5599873ddfc890c92
|
||||
Author: Andrew Price <anprice@redhat.com>
|
||||
Date: Thu Sep 6 14:28:19 2018 +0100
|
||||
|
||||
libgfs2: Fix pointer cast byte order issue
|
||||
|
||||
lgfs2_field_assign() currently uses pointer casting to achieve generic
|
||||
integer assignment based on the width of the field, but this is broken
|
||||
as a uin32_t field can be assigned the value from the high bytes of the
|
||||
uint64_t value, for instance. To fix this, store the value into a
|
||||
uint64_t before casting to the narrower types.
|
||||
|
||||
Signed-off-by: Andrew Price <anprice@redhat.com>
|
||||
|
||||
diff --git a/gfs2/libgfs2/meta.c b/gfs2/libgfs2/meta.c
|
||||
index a8289466..e0ea4912 100644
|
||||
--- a/gfs2/libgfs2/meta.c
|
||||
+++ b/gfs2/libgfs2/meta.c
|
||||
@@ -940,6 +940,7 @@ int lgfs2_field_str(char *str, const size_t size, const char *blk, const struct
|
||||
int lgfs2_field_assign(char *blk, const struct lgfs2_metafield *field, const void *val)
|
||||
{
|
||||
char *fieldp = blk + field->offset;
|
||||
+ uint64_t num = *(uint64_t *)val;
|
||||
|
||||
if (field->flags & LGFS2_MFF_UUID) {
|
||||
memcpy(fieldp, val, 16);
|
||||
@@ -959,16 +960,16 @@ int lgfs2_field_assign(char *blk, const struct lgfs2_metafield *field, const voi
|
||||
|
||||
switch(field->length) {
|
||||
case sizeof(uint8_t):
|
||||
- *fieldp = *(uint8_t *)val;
|
||||
+ *fieldp = (uint8_t)num;
|
||||
return 0;
|
||||
case sizeof(uint16_t):
|
||||
- *(uint16_t *)fieldp = cpu_to_be16(*(uint16_t *)val);
|
||||
+ *(uint16_t *)fieldp = cpu_to_be16((uint16_t)num);
|
||||
return 0;
|
||||
case sizeof(uint32_t):
|
||||
- *(uint32_t *)fieldp = cpu_to_be32(*(uint32_t *)val);
|
||||
+ *(uint32_t *)fieldp = cpu_to_be32((uint32_t)num);
|
||||
return 0;
|
||||
case sizeof(uint64_t):
|
||||
- *(uint64_t *)fieldp = cpu_to_be64(*(uint64_t *)val);
|
||||
+ *(uint64_t *)fieldp = cpu_to_be64((uint64_t)num);
|
||||
return 0;
|
||||
default:
|
||||
/* Will never happen */
|
@ -0,0 +1,39 @@
|
||||
commit 7095c5f1ab7ab2d9e02c203c9966b65c09249e1f
|
||||
Author: Bob Peterson <rpeterso@redhat.com>
|
||||
Date: Fri Dec 14 09:16:19 2018 -0500
|
||||
|
||||
gfs2-utils: Wrong hash value used to clean journals
|
||||
|
||||
When fsck.gfs2 sees a dirty journal, (one that does not have a
|
||||
log header with the UNMOUNT flag set at the wrap-point), it replays
|
||||
the journal and writes a log header out to "clean" the journal.
|
||||
Unfortunately, before this patch, it was using the wrong hash value.
|
||||
So every time fsck.gfs2 was run, it would not recognize its own
|
||||
log header because of the wrong hash, and therefore it would always
|
||||
see the journal as dirty with every run (until the file system is
|
||||
mounted and unmounted, which would write a new correct log header).
|
||||
Therefore, multiple runs of fsck.gfs2 would always result in a
|
||||
replay of the journal, which remains "dirty."
|
||||
|
||||
This patch changes function clean_journal so that it uses the
|
||||
correct hash function. Therefore, the journal will be truly clean
|
||||
and consecutive runs (or mounts) will find the journal clean.
|
||||
|
||||
Resolves: rhbz#1659490
|
||||
|
||||
Signed-off-by: Bob Peterson <rpeterso@redhat.com>
|
||||
Signed-off-by: Andrew Price <anprice@redhat.com>
|
||||
|
||||
diff --git a/gfs2/libgfs2/recovery.c b/gfs2/libgfs2/recovery.c
|
||||
index 6b14bf94..06f81116 100644
|
||||
--- a/gfs2/libgfs2/recovery.c
|
||||
+++ b/gfs2/libgfs2/recovery.c
|
||||
@@ -241,7 +241,7 @@ int clean_journal(struct gfs2_inode *ip, struct gfs2_log_header *head)
|
||||
lh->lh_sequence = cpu_to_be64(head->lh_sequence + 1);
|
||||
lh->lh_flags = cpu_to_be32(GFS2_LOG_HEAD_UNMOUNT);
|
||||
lh->lh_blkno = cpu_to_be32(lblock);
|
||||
- hash = gfs2_disk_hash((const char *)lh, sizeof(struct gfs2_log_header));
|
||||
+ hash = lgfs2_log_header_hash(bh->b_data);
|
||||
lh->lh_hash = cpu_to_be32(hash);
|
||||
bmodified(bh);
|
||||
brelse(bh);
|
430
SPECS/gfs2-utils.spec
Normal file
430
SPECS/gfs2-utils.spec
Normal file
@ -0,0 +1,430 @@
|
||||
###############################################################################
|
||||
###############################################################################
|
||||
##
|
||||
## Copyright (C) 2004-2018 Red Hat, Inc. All rights reserved.
|
||||
##
|
||||
## This copyrighted material is made available to anyone wishing to use,
|
||||
## modify, copy, or redistribute it subject to the terms and conditions
|
||||
## of the GNU General Public License v.2.
|
||||
##
|
||||
###############################################################################
|
||||
###############################################################################
|
||||
|
||||
Name: gfs2-utils
|
||||
Version: 3.2.0
|
||||
Release: 4%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Kernel
|
||||
Summary: Utilities for managing the global file system (GFS2)
|
||||
%ifnarch %{arm}
|
||||
%{?fedora:Requires: kmod(gfs2.ko) kmod(dlm.ko)}
|
||||
%endif
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: kernel-headers
|
||||
BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: bison
|
||||
BuildRequires: flex
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: check-devel
|
||||
Requires: lvm2-lockd
|
||||
Source: https://releases.pagure.org/gfs2-utils/gfs2-utils-%{version}.tar.gz
|
||||
URL: https://pagure.io/gfs2-utils
|
||||
Patch0: bz1622050-1-fsck_gfs2_Don_t_check_fs_formats_we_don_t_recognise.patch
|
||||
Patch1: bz1622050-2-libgfs2_Fix_pointer_cast_byte_order_issue.patch
|
||||
Patch2: bz1659490-gfs2_utils_Wrong_hash_value_used_to_clean_journals.patch
|
||||
|
||||
%prep
|
||||
%setup -q -n gfs2-utils-%{version}
|
||||
%patch0 -p1 -b .bz1622050-1-fsck_gfs2_Don_t_check_fs_formats_we_don_t_recognise
|
||||
%patch1 -p1 -b .bz1622050-2-libgfs2_Fix_pointer_cast_byte_order_issue
|
||||
%patch2 -p1 -b .bz1659490-gfs2_utils_Wrong_hash_value_used_to_clean_journals
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure
|
||||
make %{_smp_mflags} V=1
|
||||
|
||||
%check
|
||||
make check || { cat tests/testsuite.log; exit 1; }
|
||||
|
||||
%install
|
||||
make -C gfs2 install DESTDIR=%{buildroot}
|
||||
# Don't ship gfs2_{trace,lockcapture} in this package
|
||||
rm -f %{buildroot}/usr/sbin/gfs2_trace
|
||||
rm -f %{buildroot}/usr/sbin/gfs2_lockcapture
|
||||
rm -f %{buildroot}%{_mandir}/man8/gfs2_trace.8
|
||||
rm -f %{buildroot}%{_mandir}/man8/gfs2_lockcapture.8
|
||||
|
||||
%description
|
||||
The gfs2-utils package contains a number of utilities for creating, checking,
|
||||
modifying, and correcting inconsistencies in GFS2 file systems.
|
||||
|
||||
%files
|
||||
%doc doc/COPYING.* doc/COPYRIGHT doc/*.txt
|
||||
%doc doc/README.contributing doc/README.licence
|
||||
%{_sbindir}/fsck.gfs2
|
||||
%{_sbindir}/gfs2_grow
|
||||
%{_sbindir}/gfs2_jadd
|
||||
%{_sbindir}/mkfs.gfs2
|
||||
%{_sbindir}/gfs2_convert
|
||||
%{_sbindir}/gfs2_edit
|
||||
%{_sbindir}/tunegfs2
|
||||
%{_sbindir}/gfs2_withdraw_helper
|
||||
%{_sbindir}/glocktop
|
||||
%{_mandir}/man8/*gfs2*
|
||||
%{_mandir}/man8/glocktop*
|
||||
%{_mandir}/man5/*
|
||||
%{_prefix}/lib/udev/rules.d/82-gfs2-withdraw.rules
|
||||
|
||||
%changelog
|
||||
* Fri Dec 14 2018 Andrew Price <anprice@redhat.com> - 3.2.0-4
|
||||
- gfs2-utils: Wrong hash value used to clean journals
|
||||
Resolves: rhbz#1659490
|
||||
|
||||
* Thu Nov 01 2018 Andrew Price <anprice@redhat.com> - 3.2.0-3
|
||||
- Require lvm2-lockd
|
||||
Resolves: rhbz#1642272
|
||||
|
||||
* Mon Oct 01 2018 Andrew Price <anprice@redhat.com> - 3.2.0-2
|
||||
- fsck.gfs2: Don't check fs formats we don't recognise
|
||||
- libgfs2: Fix pointer cast byte order issue
|
||||
Resolves: rhbz#1622050
|
||||
|
||||
* Thu May 24 2018 Andrew Price <anprice@redhat.com> - 3.2.0-1
|
||||
- New upstream release
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.10-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Oct 13 2017 Andrew Price <anprice@redhat.com> - 3.1.10-4
|
||||
- Update URL in spec file
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.10-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.10-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Mar 28 2017 Andrew Price <anprice@redhat.com> - 3.1.10-1
|
||||
- New upstream release
|
||||
- Make dependency on libuuid explicit
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jun 07 2016 Andrew Price <anprice@redhat.com> - 3.1.9-1
|
||||
- New upstream release
|
||||
- Drop all patches
|
||||
- Add glocktop to the package
|
||||
|
||||
* Mon Feb 15 2016 Andrew Price <anprice@redhat.com> - 3.1.8-7
|
||||
- libgfs2: Add support for dirent.de_rahead
|
||||
- gfs2_edit: Include dirent.de_rahead in directory listings
|
||||
- gfs2-utils: Add a check for the de_rahead field
|
||||
- libgfs2: Support the new dirent de_cookie field
|
||||
Resolves: bz#1307532
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.8-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Aug 20 2015 Andrew Price <anprice@redhat.com> - 3.1.8-5
|
||||
- Add patches to install the withdraw helper script properly:
|
||||
scripts_rename_gfs2_wd_udev_sh_to_gfs2_withdraw_helper.patch
|
||||
scripts_install_the_withdraw_helper_script.patch
|
||||
scripts_install_the_withdraw_udev_rules_script.patch
|
||||
- Remove the obsolete udev script installation bits
|
||||
|
||||
* Tue Aug 11 2015 Andrew Price <anprice@redhat.com> - 3.1.8-4
|
||||
- gfs2-utils: Fix hang on withdraw
|
||||
- Install udev withdraw handler scripts
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Apr 18 2015 Andrew Price <anprice@redhat.com> - 3.1.8-2
|
||||
- fsck.gfs2: replace recent i_goal fixes with simple logic
|
||||
|
||||
* Tue Apr 07 2015 Andrew Price <anprice@redhat.com> - 3.1.8-1
|
||||
- New upstream release
|
||||
- Remove perl dependency
|
||||
- Update spec per the latest packaging guidelines
|
||||
|
||||
* Mon Sep 08 2014 Andrew Price <anprice@redhat.com> - 3.1.7-1
|
||||
- New upstream release
|
||||
- Drop all patches
|
||||
- gfs2-utils tests: Build unit tests with consistent cpp flags
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.6-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.6-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu May 15 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.1.6-7
|
||||
- Switch to using Requires on individual kernel modules
|
||||
Resolves: bz#1056191
|
||||
|
||||
* Fri Mar 21 2014 Andrew Price <anprice@redhat.com> - 3.1.6-6
|
||||
- gfs2_grow: Don't try to open an empty string
|
||||
- libgfs2: Add lgfs2 open mnt functions
|
||||
- Switch is pathname mounted callers to lgfs2 open mnt
|
||||
- libgfs2 Remove is pathname mounted
|
||||
Resolves: bz#1079286
|
||||
|
||||
* Fri Oct 04 2013 Andrew Price <anprice@redhat.com> - 3.1.6-5
|
||||
- Suppress req on kernel-modules-extra for ARM arches.
|
||||
|
||||
* Tue Sep 17 2013 Andrew Price <anprice@redhat.com> - 3.1.6-4
|
||||
- Don't use README.* for docs (it can pick up some patch files)
|
||||
|
||||
* Wed Aug 21 2013 Andrew Price <anprice@redhat.com> - 3.1.6-3
|
||||
- Install utils into /usr/sbin instead of /sbin
|
||||
Resolves: rhbz#996539
|
||||
|
||||
* Mon Jul 29 2013 Andrew Price <anprice@redhat.com> - 3.1.6-2
|
||||
- Don't install gfs2_lockcapture and gfs2_trace
|
||||
Resolves: rhbz#987019
|
||||
- Run test suite after build (requires check-devel build req)
|
||||
- Install both of the READMEs into doc/
|
||||
|
||||
* Wed Jul 24 2013 Andrew Price <anprice@redhat.com> - 3.1.6-1
|
||||
- New upstream release
|
||||
- Drop 'file' requirement - mkfs.gfs2 now uses libblkid instead
|
||||
- Drop 'ncurses' requirement - dependency is added automatically
|
||||
- Drop requires chkconfig and initscripts - no longer installs daemons
|
||||
- Drop fix_build_on_rawhide.patch - upstream
|
||||
- Add build req on libblkid-devel
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Tue Nov 13 2012 Andrew Price <anprice@redhat.com> - 3.1.5-1
|
||||
- New upstream release
|
||||
Removes mount.gfs2, gfs2_tool, gfs2_quota
|
||||
- Remove rawhide_transition.patch - now obsolete
|
||||
- Update BuildRequires:
|
||||
Change glibc-kernheaders to kernel-headers
|
||||
Add bison and flex
|
||||
- Provide a valid url for Source0
|
||||
- Add fix_build_on_rawhide.patch to fix a circular dep introduced in
|
||||
bison 2.6, and a make -j race between libgfs2 and gfs2l
|
||||
|
||||
* Tue Aug 14 2012 Andrew Price <anprice@redhat.com> - 3.1.4-6
|
||||
- Make the kernel-modules-extra requirement Fedora-specific
|
||||
Resolves bz#847955
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Apr 17 2012 Andrew Price <anprice@redhat.com> - 3.1.4-4
|
||||
- Remove commented-out sections
|
||||
- Clean up some lintian warnings
|
||||
- Add dependency on kernel-modules-extra as per bz#811547
|
||||
|
||||
* Wed Mar 07 2012 Andrew Price <anprice@redhat.com> - 3.1.4-3
|
||||
- Remove redundant postinstall scriptlet
|
||||
|
||||
* Thu Feb 2 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.1.4-2
|
||||
- make sure to Obsolete gfs2-cluster
|
||||
|
||||
* Wed Feb 01 2012 Andrew Price <anprice@redhat.com> - 3.1.4-1
|
||||
- New upstream release
|
||||
Adds gfs2_lockgather script
|
||||
- Remove gfs2-cluster (commented out for now)
|
||||
- Remove dependency on corosynclib-devel and systemd-units
|
||||
- Add rawhide_transition.patch to stop gfs_controld from building
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Dec 15 2011 Andrew Price <anprice@redhat.com> - 3.1.3-1
|
||||
- New upstream release
|
||||
Bugfixes and improvements to fsck.gfs2
|
||||
Fixes various other bugs
|
||||
Improve strings and translation support
|
||||
- Adds gfs2-cluster systemd unit
|
||||
- Removes gfs2* init scripts
|
||||
|
||||
* Wed Jul 06 2011 Andrew Price <anprice@redhat.com> - 3.1.2-1
|
||||
- New upstream release
|
||||
Fixes several bugs
|
||||
Improves translation support
|
||||
Adds savemeta compression
|
||||
- Add zlib-devel to BuildRequires
|
||||
- Add gettext-devel to BuildRequires
|
||||
|
||||
* Wed May 25 2011 Steven Whitehouse <swhiteho@redhat.com> - 3.1.1-3
|
||||
- Update wiki URL
|
||||
- Remove gfs2_tool and gfs2_quota from package
|
||||
|
||||
* Fri Feb 25 2011 Bob Peterson <rpeterso@redhat.com> - 3.1.1-2
|
||||
- Bumping release number to keep upgrades consistent.
|
||||
|
||||
* Wed Feb 23 2011 Bob Peterson <rpeterso@redhat.com> - 3.1.1-1
|
||||
- gfs2_edit savemeta doesn't save all leafs for big directories
|
||||
- gfs2_edit improvements
|
||||
- fsck.gfs2: can't repair rgrps resulting from gfs_grow->gfs2_convert
|
||||
- fsck.gfs2: reports master/root dinodes as unused and fixes bitmap
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Jan 20 2011 Steven Whitehouse <swhiteho@redhat.com> - 3.1.0-4
|
||||
- Drop mount.gfs2 and its man page
|
||||
- Only list gfs2_tool once in the files list
|
||||
|
||||
* Wed Dec 8 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.1.0-3
|
||||
- Drop circular dependency on cman
|
||||
|
||||
* Fri Dec 3 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.1.0-2
|
||||
- gfs2-cluster should Obsoletes/Provides gfs-pcmk
|
||||
|
||||
* Tue Sep 30 2010 Steven Whitehouse <swhiteho@redhat.com> - 3.1.0-1
|
||||
- Bringing this package back for upstream GFS2
|
||||
Addition of gfs2tune to the utils
|
||||
Merge of gfs_controld from cman
|
||||
|
||||
* Thu Jan 22 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.03.11-1
|
||||
- New upstream release
|
||||
Fix several bugs and drastically improve startup errors.
|
||||
|
||||
* Wed Dec 10 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.03.10-1
|
||||
- New upstream release
|
||||
Fix several bugs and port gfs1 code to match 2.6.27 kernel.
|
||||
|
||||
* Fri Oct 31 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.03.09-1
|
||||
- New upstream release
|
||||
Fix rhbz#468966
|
||||
Addresses several security issues similar to CVE-2008-4192 and
|
||||
CVE-2008-4579 after deep code audit from upstream
|
||||
- cleanup patches to match 2.6.26 kernel in F-9
|
||||
|
||||
* Tue Oct 21 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.03.08-1
|
||||
- New upstream release
|
||||
Fix rhbz#460376 CVE-2008-4192
|
||||
Fix rhbz#467386 CVE-2008-4579
|
||||
- cleanup/update patches to match 2.6.26 kernel in F-9
|
||||
|
||||
* Thu Aug 14 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.03.07-1
|
||||
- New upstream release
|
||||
- Fix rgmanager startup locking issues
|
||||
- Apply patch to include kernel headers from 2.6.26 required to build
|
||||
userland. Userland will run in 2.6.25 compatibility mode
|
||||
- Apply patch to keep kernel modules at 2.6.25 (upstream is at 2.6.26)
|
||||
(this patch is purely cosmetic since we don't build kernel modules
|
||||
but keep the source in sync is Good (tm))
|
||||
- Cleanup packaging for installed docs and file permissions
|
||||
|
||||
* Mon Jul 14 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 2.03.05-1
|
||||
- New upstream release
|
||||
- Cleanup installed doc after upstream
|
||||
|
||||
* Wed Jun 11 2008 Fabio M. Di Nitto <fdinitto@redhat.com> 2.03.04-1
|
||||
- New upstream release
|
||||
- Resolves: #446995 #318271 #447378 #445662
|
||||
- Update license tags after major upstream cleanup
|
||||
- Include COPYRIGHT file
|
||||
|
||||
* Fri May 30 2008 Fabio M. Di Nitto <fdinitto@redhat.com> 2.03.03-1
|
||||
- New upstream release
|
||||
- Fix several build warnings
|
||||
- Update spec files to use macros
|
||||
- Update Requires to use packages rather than pointing at files
|
||||
- Drop BR on kernel-devel since it's not required anymore
|
||||
- Update build section to use proper _sysconfdir, libdir and sbindir
|
||||
- Avoid abusing cd when we can ask make to do the work for us
|
||||
- Remove /usr/sbin from file section. We don't have any file there
|
||||
and we can avoid shipping stuff by mistake
|
||||
|
||||
* Mon Apr 14 2008 Steven Whitehouse <swhiteho@redhat.com> 2.03.00-3
|
||||
- Fabbione saves the day. We can get rid of the sed stuff after all
|
||||
|
||||
* Mon Apr 14 2008 Steven Whitehouse <swhiteho@redhat.com> 2.03.00-1
|
||||
- New upstream sources
|
||||
- Eric Sandeen's solution to kernel version dep
|
||||
|
||||
* Wed Apr 09 2008 Steven Whitehouse <swhiteho@redhat.com> 0.1.25.2.02.01-15
|
||||
- Remove obsolete chkconfig patch for initscript
|
||||
- Enable parallel make
|
||||
- Remove obsolete copy of gfs2_ondisk.h (this should be in glibc-kernheaders)
|
||||
|
||||
* Wed Apr 09 2008 Steven Whitehouse <swhiteho@redhat.com> 0.1.25.2.02.01-14
|
||||
- Update URL
|
||||
- Fix license spec
|
||||
|
||||
* Fri Mar 14 2008 Chris Feist <cfeist@redhat.com> 0.1.25.2.02.00-2
|
||||
- New upstream sources.
|
||||
|
||||
* Tue Jan 16 2007 Chris Feist <cfeist@redhat.com> 0.1.24-1
|
||||
- New upstream sources.
|
||||
- Resolves: rhbz#222747
|
||||
|
||||
* Wed Jan 03 2007 Chris Feist <cfeist@redhat.com> 0.1.24-1
|
||||
- Updated sources
|
||||
- Resolves: rhbz#218560
|
||||
|
||||
* Thu Dec 21 2006 Chris Feist <cfeist@redhat.com> 0.1.23-1
|
||||
- Updated sources
|
||||
- Resolves: rhbz#218560
|
||||
|
||||
* Tue Dec 19 2006 Chris Feist <cfeist@redhat.com> 0.1.22-1
|
||||
- New upstream sources.
|
||||
- Resolves: rhbz#219878
|
||||
|
||||
* Tue Dec 04 2006 Chris Feist <cfeist@redhat.com> 0.1.21-1
|
||||
- New upstream sources.
|
||||
- Resolves: rhbz#218134 rhbz#215962
|
||||
|
||||
* Thu Nov 30 2006 Chris Feist <cfeist@redhat.com> 0.1.19-1
|
||||
- New upstream sources.
|
||||
- Resolves: rhbz#217798
|
||||
|
||||
* Wed Nov 29 2006 Chris Feist <cfeist@redhat.com> 0.1.18-1
|
||||
- New upstream sources.
|
||||
- Resolves: rhbz#217460
|
||||
|
||||
* Thu Oct 26 2006 Chris Feist <cfeist@redhat.com> 0.1.14-1
|
||||
- New upstream sources.
|
||||
|
||||
* Fri Oct 13 2006 Chris Feist <cfeist@redhat.com> 0.1.12-1
|
||||
- New Upstream sources.
|
||||
|
||||
* Fri Oct 13 2006 Chris Feist <cfeist@redhat.com> 0.1.10-1
|
||||
- New Upstream sources.
|
||||
|
||||
* Mon Oct 09 2006 Chris Feist <cfeist@redhat.com> 0.1.9-1
|
||||
- New Upstream sources.
|
||||
|
||||
* Mon Sep 25 2006 Chris Feist <cfeist@redhat.com> 0.1.8-1
|
||||
- New Upstream sources.
|
||||
|
||||
* Wed Sep 13 2006 Chris Feist <cfeist@redhat.com> 0.1.7-1
|
||||
- New Upstream sources.
|
||||
|
||||
* Thu Sep 07 2006 Chris Feist <cfeist@redhat.com> 0.1.6-2
|
||||
- Fix typo in uninstall script (turn off gfs2 instead of gfs)
|
||||
|
||||
* Mon Aug 28 2006 Chris Feist <cfeist@redhat.com> 0.1.6-1
|
||||
- New Upstream sources.
|
||||
|
||||
* Tue Aug 22 2006 Chris Feist <cfeist@redhat.com> 0.1.5-1
|
||||
- New Upstream sources.
|
||||
|
||||
* Mon Aug 14 2006 Chris Feist <cfeist@redhat.com> 0.1.3-0
|
||||
- New Upstream sources, use dist tag.
|
||||
|
||||
* Fri Jul 14 2006 Chris Feist <cfeist@redhat.com>
|
||||
- Rebuild with updated sources
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuild
|
||||
|
||||
* Tue Jun 27 2006 Florian La Roche <laroche@redhat.com>
|
||||
- fix typo in preun script
|
||||
|
||||
* Fri Jun 09 2006 Chris Feist <cfeist@redhat.com> - 0.1.0-1.fc6.3
|
||||
- Initial build of gfs-utils.
|
Loading…
Reference in New Issue
Block a user