* Mon Feb 04 2019 Andrew Price <anprice@redhat.com> - 3.2.0-5
- Fix libuuid linking
This commit is contained in:
parent
a04af2238d
commit
a72c2fad78
26
0-Fix_libuuid_linking.patch
Normal file
26
0-Fix_libuuid_linking.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
commit 222e97c23dd015a8fc4bcceb598720cc17337edf
|
||||||
|
Author: Andrew Price <anprice@redhat.com>
|
||||||
|
Date: Mon Feb 4 14:54:34 2019 +0000
|
||||||
|
|
||||||
|
Fix libuuid linking
|
||||||
|
|
||||||
|
Fixes a build failure in Rawhide.
|
||||||
|
|
||||||
|
Signed-off-by: Andrew Price <anprice@redhat.com>
|
||||||
|
|
||||||
|
diff --git a/gfs2/libgfs2/Makefile.am b/gfs2/libgfs2/Makefile.am
|
||||||
|
index 749da85a..76df920e 100644
|
||||||
|
--- a/gfs2/libgfs2/Makefile.am
|
||||||
|
+++ b/gfs2/libgfs2/Makefile.am
|
||||||
|
@@ -54,8 +54,9 @@ libgfs2_la_CPPFLAGS = \
|
||||||
|
$(uuid_CFLAGS)
|
||||||
|
|
||||||
|
gfs2l_SOURCES = gfs2l.c
|
||||||
|
-gfs2l_LDADD = libgfs2.la
|
||||||
|
-gfs2l_LDFLAGS = $(uuid_LIBS)
|
||||||
|
+gfs2l_LDADD = \
|
||||||
|
+ libgfs2.la \
|
||||||
|
+ $(uuid_LIBS)
|
||||||
|
gfs2l_CPPFLAGS = \
|
||||||
|
-I$(top_srcdir)/gfs2/include \
|
||||||
|
-D_FILE_OFFSET_BITS=64
|
159
1-Fix_more_linking_errors.patch
Normal file
159
1-Fix_more_linking_errors.patch
Normal file
@ -0,0 +1,159 @@
|
|||||||
|
commit 1a92a964c8ba87d95b2f43b0adc3d351a7f7ba80
|
||||||
|
Author: Andrew Price <anprice@redhat.com>
|
||||||
|
Date: Mon Feb 4 15:31:33 2019 +0000
|
||||||
|
|
||||||
|
Fix more linking errors
|
||||||
|
|
||||||
|
Signed-off-by: Andrew Price <anprice@redhat.com>
|
||||||
|
|
||||||
|
diff --git a/gfs2/convert/Makefile.am b/gfs2/convert/Makefile.am
|
||||||
|
index 4db643fb..2d61af74 100644
|
||||||
|
--- a/gfs2/convert/Makefile.am
|
||||||
|
+++ b/gfs2/convert/Makefile.am
|
||||||
|
@@ -7,5 +7,6 @@ gfs2_convert_CPPFLAGS = \
|
||||||
|
-I$(top_srcdir)/gfs2/include \
|
||||||
|
-I$(top_srcdir)/gfs2/libgfs2
|
||||||
|
|
||||||
|
-gfs2_convert_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
-gfs2_convert_LDFLAGS = $(uuid_LIBS)
|
||||||
|
+gfs2_convert_LDADD = \
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
+ $(uuid_LIBS)
|
||||||
|
diff --git a/gfs2/edit/Makefile.am b/gfs2/edit/Makefile.am
|
||||||
|
index a9b177e9..4a89502c 100644
|
||||||
|
--- a/gfs2/edit/Makefile.am
|
||||||
|
+++ b/gfs2/edit/Makefile.am
|
||||||
|
@@ -25,9 +25,9 @@ gfs2_edit_CFLAGS = \
|
||||||
|
$(zlib_CFLAGS) \
|
||||||
|
$(uuid_CFLAGS)
|
||||||
|
|
||||||
|
-gfs2_edit_LDFLAGS = \
|
||||||
|
+gfs2_edit_LDADD = \
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
$(ncurses_LIBS) \
|
||||||
|
$(zlib_LIBS) \
|
||||||
|
$(uuid_LIBS)
|
||||||
|
|
||||||
|
-gfs2_edit_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
diff --git a/gfs2/fsck/Makefile.am b/gfs2/fsck/Makefile.am
|
||||||
|
index 97fcd404..1c528051 100644
|
||||||
|
--- a/gfs2/fsck/Makefile.am
|
||||||
|
+++ b/gfs2/fsck/Makefile.am
|
||||||
|
@@ -36,6 +36,5 @@ fsck_gfs2_CPPFLAGS = \
|
||||||
|
-I$(top_srcdir)/gfs2/libgfs2
|
||||||
|
|
||||||
|
fsck_gfs2_LDADD = \
|
||||||
|
- $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
-fsck_gfs2_LDFLAGS = \
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
$(uuid_LIBS)
|
||||||
|
diff --git a/gfs2/glocktop/Makefile.am b/gfs2/glocktop/Makefile.am
|
||||||
|
index 1102c8e2..f5076554 100644
|
||||||
|
--- a/gfs2/glocktop/Makefile.am
|
||||||
|
+++ b/gfs2/glocktop/Makefile.am
|
||||||
|
@@ -9,10 +9,6 @@ glocktop_SOURCES = \
|
||||||
|
glocktop_CFLAGS = \
|
||||||
|
$(ncurses_CFLAGS)
|
||||||
|
|
||||||
|
-glocktop_LDFLAGS = \
|
||||||
|
- $(ncurses_LIBS) \
|
||||||
|
- $(uuid_LIBS)
|
||||||
|
-
|
||||||
|
glocktop_CPPFLAGS = \
|
||||||
|
-D_FILE_OFFSET_BITS=64 \
|
||||||
|
-D_LARGEFILE64_SOURCE \
|
||||||
|
@@ -21,4 +17,6 @@ glocktop_CPPFLAGS = \
|
||||||
|
-I$(top_srcdir)/gfs2/libgfs2
|
||||||
|
|
||||||
|
glocktop_LDADD = \
|
||||||
|
- $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
+ $(ncurses_LIBS) \
|
||||||
|
+ $(uuid_LIBS)
|
||||||
|
diff --git a/gfs2/mkfs/Makefile.am b/gfs2/mkfs/Makefile.am
|
||||||
|
index f0dd961c..fd7145b8 100644
|
||||||
|
--- a/gfs2/mkfs/Makefile.am
|
||||||
|
+++ b/gfs2/mkfs/Makefile.am
|
||||||
|
@@ -25,10 +25,10 @@ mkfs_gfs2_CPPFLAGS = $(COMMON_CPPFLAGS)
|
||||||
|
mkfs_gfs2_CFLAGS = \
|
||||||
|
$(blkid_CFLAGS) \
|
||||||
|
$(uuid_CFLAGS)
|
||||||
|
-mkfs_gfs2_LDFLAGS = \
|
||||||
|
+mkfs_gfs2_LDADD = \
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
$(blkid_LIBS) \
|
||||||
|
$(uuid_LIBS)
|
||||||
|
-mkfs_gfs2_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
|
||||||
|
gfs2_grow_SOURCES = \
|
||||||
|
main_grow.c \
|
||||||
|
@@ -36,16 +36,17 @@ gfs2_grow_SOURCES = \
|
||||||
|
|
||||||
|
gfs2_grow_CPPFLAGS = $(COMMON_CPPFLAGS)
|
||||||
|
gfs2_grow_CFLAGS = $(blkid_CFLAGS)
|
||||||
|
-gfs2_grow_LDFLAGS = \
|
||||||
|
+gfs2_grow_LDADD = \
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
$(blkid_LIBS) \
|
||||||
|
$(uuid_LIBS)
|
||||||
|
-gfs2_grow_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
|
||||||
|
gfs2_jadd_SOURCES = \
|
||||||
|
main_jadd.c \
|
||||||
|
metafs.c
|
||||||
|
|
||||||
|
gfs2_jadd_CPPFLAGS = $(COMMON_CPPFLAGS)
|
||||||
|
-gfs2_jadd_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
-gfs2_jadd_LDFLAGS = $(uuid_LIBS)
|
||||||
|
+gfs2_jadd_LDADD = \
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
+ $(uuid_LIBS)
|
||||||
|
|
||||||
|
diff --git a/gfs2/tune/Makefile.am b/gfs2/tune/Makefile.am
|
||||||
|
index 7628f424..171377d0 100644
|
||||||
|
--- a/gfs2/tune/Makefile.am
|
||||||
|
+++ b/gfs2/tune/Makefile.am
|
||||||
|
@@ -13,5 +13,5 @@ tunegfs2_CPPFLAGS = \
|
||||||
|
-I$(top_srcdir)/group/include
|
||||||
|
tunegfs2_CFLAGS = \
|
||||||
|
$(uuid_CFLAGS)
|
||||||
|
-tunegfs2_LDFLAGS = \
|
||||||
|
+tunegfs2_LDADD = \
|
||||||
|
$(uuid_LIBS)
|
||||||
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||||
|
index 40fcfb47..40b486b0 100644
|
||||||
|
--- a/tests/Makefile.am
|
||||||
|
+++ b/tests/Makefile.am
|
||||||
|
@@ -26,8 +26,7 @@ nukerg_CFLAGS = \
|
||||||
|
-I$(top_srcdir)/gfs2/libgfs2 \
|
||||||
|
-I$(top_srcdir)/gfs2/include
|
||||||
|
nukerg_LDADD = \
|
||||||
|
- $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||||
|
-nukerg_LDFLAGS = \
|
||||||
|
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||||
|
$(uuid_LIBS)
|
||||||
|
|
||||||
|
if HAVE_CHECK
|
||||||
|
@@ -54,16 +53,18 @@ check_meta_SOURCES = \
|
||||||
|
$(UNIT_SOURCES) \
|
||||||
|
check_meta.c
|
||||||
|
check_meta_CFLAGS = $(UNIT_CFLAGS)
|
||||||
|
-check_meta_LDADD = $(UNIT_LDADD)
|
||||||
|
-check_meta_LDFLAGS = $(uuid_LIBS)
|
||||||
|
+check_meta_LDADD = \
|
||||||
|
+ $(UNIT_LDADD) \
|
||||||
|
+ $(uuid_LIBS)
|
||||||
|
check_meta_CPPFLAGS = $(UNIT_CPPFLAGS)
|
||||||
|
|
||||||
|
check_rgrp_SOURCES = \
|
||||||
|
$(UNIT_SOURCES) \
|
||||||
|
check_rgrp.c
|
||||||
|
check_rgrp_CFLAGS = $(UNIT_CFLAGS)
|
||||||
|
-check_rgrp_LDADD = $(UNIT_LDADD)
|
||||||
|
-check_rgrp_LDFLAGS = $(uuid_LIBS)
|
||||||
|
+check_rgrp_LDADD = \
|
||||||
|
+ $(UNIT_LDADD) \
|
||||||
|
+ $(uuid_LIBS)
|
||||||
|
check_rgrp_CPPFLAGS = $(UNIT_CPPFLAGS)
|
||||||
|
endif
|
||||||
|
|
@ -12,7 +12,7 @@
|
|||||||
|
|
||||||
Name: gfs2-utils
|
Name: gfs2-utils
|
||||||
Version: 3.2.0
|
Version: 3.2.0
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
Summary: Utilities for managing the global file system (GFS2)
|
Summary: Utilities for managing the global file system (GFS2)
|
||||||
%ifnarch %{arm}
|
%ifnarch %{arm}
|
||||||
@ -31,9 +31,11 @@ BuildRequires: libuuid-devel
|
|||||||
BuildRequires: check-devel
|
BuildRequires: check-devel
|
||||||
Source: https://releases.pagure.org/gfs2-utils/gfs2-utils-%{version}.tar.gz
|
Source: https://releases.pagure.org/gfs2-utils/gfs2-utils-%{version}.tar.gz
|
||||||
URL: https://pagure.io/gfs2-utils
|
URL: https://pagure.io/gfs2-utils
|
||||||
|
Patch0: 0-Fix_libuuid_linking.patch
|
||||||
|
Patch1: 1-Fix_more_linking_errors.patch
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n gfs2-utils-%{version}
|
%autosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -73,6 +75,9 @@ modifying, and correcting inconsistencies in GFS2 file systems.
|
|||||||
%{_prefix}/lib/udev/rules.d/82-gfs2-withdraw.rules
|
%{_prefix}/lib/udev/rules.d/82-gfs2-withdraw.rules
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 04 2019 Andrew Price <anprice@redhat.com> - 3.2.0-5
|
||||||
|
- Fix libuuid linking
|
||||||
|
|
||||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-4
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user