* Tue Sep 01 2020 Andrew Price <anprice@redhat.com> - 3.3.0-1
- New upstream version - Add dependency on bzip2 - Drop all patches - gfs2_withdraw_helper is now in /usr/libexec/
This commit is contained in:
parent
a65087a00f
commit
9791e7be60
13
.gitignore
vendored
13
.gitignore
vendored
@ -1,12 +1 @@
|
||||
/gfs2-utils-3.1.0.tar.gz
|
||||
/gfs2-utils-3.1.1.tar.gz
|
||||
/gfs2-utils-3.1.2.tar.gz
|
||||
/gfs2-utils-3.1.3.tar.gz
|
||||
/gfs2-utils-3.1.4.tar.gz
|
||||
/gfs2-utils-3.1.5.tar.gz
|
||||
/gfs2-utils-3.1.6.tar.gz
|
||||
/gfs2-utils-3.1.7.tar.gz
|
||||
/gfs2-utils-3.1.8.tar.gz
|
||||
/gfs2-utils-3.1.9.tar.gz
|
||||
/gfs2-utils-3.1.10.tar.gz
|
||||
/gfs2-utils-3.2.0.tar.gz
|
||||
/gfs2-utils-3.3.0.tar.gz
|
||||
|
@ -1,26 +0,0 @@
|
||||
commit 222e97c23dd015a8fc4bcceb598720cc17337edf
|
||||
Author: Andrew Price <anprice@redhat.com>
|
||||
Date: Mon Feb 4 14:54:34 2019 +0000
|
||||
|
||||
Fix libuuid linking
|
||||
|
||||
Fixes a build failure in Rawhide.
|
||||
|
||||
Signed-off-by: Andrew Price <anprice@redhat.com>
|
||||
|
||||
diff --git a/gfs2/libgfs2/Makefile.am b/gfs2/libgfs2/Makefile.am
|
||||
index 749da85a..76df920e 100644
|
||||
--- a/gfs2/libgfs2/Makefile.am
|
||||
+++ b/gfs2/libgfs2/Makefile.am
|
||||
@@ -54,8 +54,9 @@ libgfs2_la_CPPFLAGS = \
|
||||
$(uuid_CFLAGS)
|
||||
|
||||
gfs2l_SOURCES = gfs2l.c
|
||||
-gfs2l_LDADD = libgfs2.la
|
||||
-gfs2l_LDFLAGS = $(uuid_LIBS)
|
||||
+gfs2l_LDADD = \
|
||||
+ libgfs2.la \
|
||||
+ $(uuid_LIBS)
|
||||
gfs2l_CPPFLAGS = \
|
||||
-I$(top_srcdir)/gfs2/include \
|
||||
-D_FILE_OFFSET_BITS=64
|
@ -1,159 +0,0 @@
|
||||
commit 1a92a964c8ba87d95b2f43b0adc3d351a7f7ba80
|
||||
Author: Andrew Price <anprice@redhat.com>
|
||||
Date: Mon Feb 4 15:31:33 2019 +0000
|
||||
|
||||
Fix more linking errors
|
||||
|
||||
Signed-off-by: Andrew Price <anprice@redhat.com>
|
||||
|
||||
diff --git a/gfs2/convert/Makefile.am b/gfs2/convert/Makefile.am
|
||||
index 4db643fb..2d61af74 100644
|
||||
--- a/gfs2/convert/Makefile.am
|
||||
+++ b/gfs2/convert/Makefile.am
|
||||
@@ -7,5 +7,6 @@ gfs2_convert_CPPFLAGS = \
|
||||
-I$(top_srcdir)/gfs2/include \
|
||||
-I$(top_srcdir)/gfs2/libgfs2
|
||||
|
||||
-gfs2_convert_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
-gfs2_convert_LDFLAGS = $(uuid_LIBS)
|
||||
+gfs2_convert_LDADD = \
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
+ $(uuid_LIBS)
|
||||
diff --git a/gfs2/edit/Makefile.am b/gfs2/edit/Makefile.am
|
||||
index a9b177e9..4a89502c 100644
|
||||
--- a/gfs2/edit/Makefile.am
|
||||
+++ b/gfs2/edit/Makefile.am
|
||||
@@ -25,9 +25,9 @@ gfs2_edit_CFLAGS = \
|
||||
$(zlib_CFLAGS) \
|
||||
$(uuid_CFLAGS)
|
||||
|
||||
-gfs2_edit_LDFLAGS = \
|
||||
+gfs2_edit_LDADD = \
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
$(ncurses_LIBS) \
|
||||
$(zlib_LIBS) \
|
||||
$(uuid_LIBS)
|
||||
|
||||
-gfs2_edit_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
diff --git a/gfs2/fsck/Makefile.am b/gfs2/fsck/Makefile.am
|
||||
index 97fcd404..1c528051 100644
|
||||
--- a/gfs2/fsck/Makefile.am
|
||||
+++ b/gfs2/fsck/Makefile.am
|
||||
@@ -36,6 +36,5 @@ fsck_gfs2_CPPFLAGS = \
|
||||
-I$(top_srcdir)/gfs2/libgfs2
|
||||
|
||||
fsck_gfs2_LDADD = \
|
||||
- $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
-fsck_gfs2_LDFLAGS = \
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
$(uuid_LIBS)
|
||||
diff --git a/gfs2/glocktop/Makefile.am b/gfs2/glocktop/Makefile.am
|
||||
index 1102c8e2..f5076554 100644
|
||||
--- a/gfs2/glocktop/Makefile.am
|
||||
+++ b/gfs2/glocktop/Makefile.am
|
||||
@@ -9,10 +9,6 @@ glocktop_SOURCES = \
|
||||
glocktop_CFLAGS = \
|
||||
$(ncurses_CFLAGS)
|
||||
|
||||
-glocktop_LDFLAGS = \
|
||||
- $(ncurses_LIBS) \
|
||||
- $(uuid_LIBS)
|
||||
-
|
||||
glocktop_CPPFLAGS = \
|
||||
-D_FILE_OFFSET_BITS=64 \
|
||||
-D_LARGEFILE64_SOURCE \
|
||||
@@ -21,4 +17,6 @@ glocktop_CPPFLAGS = \
|
||||
-I$(top_srcdir)/gfs2/libgfs2
|
||||
|
||||
glocktop_LDADD = \
|
||||
- $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
+ $(ncurses_LIBS) \
|
||||
+ $(uuid_LIBS)
|
||||
diff --git a/gfs2/mkfs/Makefile.am b/gfs2/mkfs/Makefile.am
|
||||
index f0dd961c..fd7145b8 100644
|
||||
--- a/gfs2/mkfs/Makefile.am
|
||||
+++ b/gfs2/mkfs/Makefile.am
|
||||
@@ -25,10 +25,10 @@ mkfs_gfs2_CPPFLAGS = $(COMMON_CPPFLAGS)
|
||||
mkfs_gfs2_CFLAGS = \
|
||||
$(blkid_CFLAGS) \
|
||||
$(uuid_CFLAGS)
|
||||
-mkfs_gfs2_LDFLAGS = \
|
||||
+mkfs_gfs2_LDADD = \
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
$(blkid_LIBS) \
|
||||
$(uuid_LIBS)
|
||||
-mkfs_gfs2_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
|
||||
gfs2_grow_SOURCES = \
|
||||
main_grow.c \
|
||||
@@ -36,16 +36,17 @@ gfs2_grow_SOURCES = \
|
||||
|
||||
gfs2_grow_CPPFLAGS = $(COMMON_CPPFLAGS)
|
||||
gfs2_grow_CFLAGS = $(blkid_CFLAGS)
|
||||
-gfs2_grow_LDFLAGS = \
|
||||
+gfs2_grow_LDADD = \
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
$(blkid_LIBS) \
|
||||
$(uuid_LIBS)
|
||||
-gfs2_grow_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
|
||||
gfs2_jadd_SOURCES = \
|
||||
main_jadd.c \
|
||||
metafs.c
|
||||
|
||||
gfs2_jadd_CPPFLAGS = $(COMMON_CPPFLAGS)
|
||||
-gfs2_jadd_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
-gfs2_jadd_LDFLAGS = $(uuid_LIBS)
|
||||
+gfs2_jadd_LDADD = \
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
+ $(uuid_LIBS)
|
||||
|
||||
diff --git a/gfs2/tune/Makefile.am b/gfs2/tune/Makefile.am
|
||||
index 7628f424..171377d0 100644
|
||||
--- a/gfs2/tune/Makefile.am
|
||||
+++ b/gfs2/tune/Makefile.am
|
||||
@@ -13,5 +13,5 @@ tunegfs2_CPPFLAGS = \
|
||||
-I$(top_srcdir)/group/include
|
||||
tunegfs2_CFLAGS = \
|
||||
$(uuid_CFLAGS)
|
||||
-tunegfs2_LDFLAGS = \
|
||||
+tunegfs2_LDADD = \
|
||||
$(uuid_LIBS)
|
||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||
index 40fcfb47..40b486b0 100644
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -26,8 +26,7 @@ nukerg_CFLAGS = \
|
||||
-I$(top_srcdir)/gfs2/libgfs2 \
|
||||
-I$(top_srcdir)/gfs2/include
|
||||
nukerg_LDADD = \
|
||||
- $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
-nukerg_LDFLAGS = \
|
||||
+ $(top_builddir)/gfs2/libgfs2/libgfs2.la \
|
||||
$(uuid_LIBS)
|
||||
|
||||
if HAVE_CHECK
|
||||
@@ -54,16 +53,18 @@ check_meta_SOURCES = \
|
||||
$(UNIT_SOURCES) \
|
||||
check_meta.c
|
||||
check_meta_CFLAGS = $(UNIT_CFLAGS)
|
||||
-check_meta_LDADD = $(UNIT_LDADD)
|
||||
-check_meta_LDFLAGS = $(uuid_LIBS)
|
||||
+check_meta_LDADD = \
|
||||
+ $(UNIT_LDADD) \
|
||||
+ $(uuid_LIBS)
|
||||
check_meta_CPPFLAGS = $(UNIT_CPPFLAGS)
|
||||
|
||||
check_rgrp_SOURCES = \
|
||||
$(UNIT_SOURCES) \
|
||||
check_rgrp.c
|
||||
check_rgrp_CFLAGS = $(UNIT_CFLAGS)
|
||||
-check_rgrp_LDADD = $(UNIT_LDADD)
|
||||
-check_rgrp_LDFLAGS = $(uuid_LIBS)
|
||||
+check_rgrp_LDADD = \
|
||||
+ $(UNIT_LDADD) \
|
||||
+ $(uuid_LIBS)
|
||||
check_rgrp_CPPFLAGS = $(UNIT_CPPFLAGS)
|
||||
endif
|
||||
|
@ -1,74 +0,0 @@
|
||||
diff -urN gfs2-utils-3.2.0/tests/check_meta.c gfs2-utils-3.2.0.patched/tests/check_meta.c
|
||||
--- gfs2-utils-3.2.0/tests/check_meta.c 2018-05-23 21:04:16.000000000 +0100
|
||||
+++ gfs2-utils-3.2.0.patched/tests/check_meta.c 2020-07-29 13:19:28.548734314 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
START_TEST(test_lgfs2_meta)
|
||||
{
|
||||
- fail_unless(lgfs2_selfcheck() == 0);
|
||||
+ ck_assert(lgfs2_selfcheck() == 0);
|
||||
}
|
||||
END_TEST
|
||||
|
||||
diff -urN gfs2-utils-3.2.0/tests/check_rgrp.c gfs2-utils-3.2.0.patched/tests/check_rgrp.c
|
||||
--- gfs2-utils-3.2.0/tests/check_rgrp.c 2018-05-23 21:04:16.000000000 +0100
|
||||
+++ gfs2-utils-3.2.0.patched/tests/check_rgrp.c 2020-07-29 13:19:28.548734314 +0100
|
||||
@@ -16,7 +16,7 @@
|
||||
uint32_t rgsize = (1024 << 20) / 4096;
|
||||
|
||||
sdp = calloc(1, sizeof(*sdp));
|
||||
- fail_unless(sdp != NULL);
|
||||
+ ck_assert(sdp != NULL);
|
||||
|
||||
sdp->device.length = rgsize + 20;
|
||||
sdp->device_fd = -1;
|
||||
@@ -24,7 +24,7 @@
|
||||
compute_constants(sdp);
|
||||
|
||||
rgs = lgfs2_rgrps_init(sdp, 0, 0);
|
||||
- fail_unless(rgs != NULL);
|
||||
+ ck_assert(rgs != NULL);
|
||||
|
||||
lgfs2_rgrps_plan(rgs, sdp->device.length - 16, rgsize);
|
||||
|
||||
@@ -32,11 +32,11 @@
|
||||
ck_assert(addr != 0);
|
||||
|
||||
rg = lgfs2_rgrps_append(rgs, &ri, 0);
|
||||
- fail_unless(rg != NULL);
|
||||
+ ck_assert(rg != NULL);
|
||||
|
||||
for (i = 0; i < rg->ri.ri_length; i++) {
|
||||
rg->bits[i].bi_bh = bget(sdp, rg->ri.ri_addr + i);
|
||||
- fail_unless(rg->bits[i].bi_bh != NULL);
|
||||
+ ck_assert(rg->bits[i].bi_bh != NULL);
|
||||
}
|
||||
return rgs;
|
||||
}
|
||||
@@ -44,7 +44,7 @@
|
||||
START_TEST(test_mockup_rgrp)
|
||||
{
|
||||
lgfs2_rgrps_t rgs = mockup_rgrp();
|
||||
- fail_unless(rgs != NULL);
|
||||
+ ck_assert(rgs != NULL);
|
||||
}
|
||||
END_TEST
|
||||
|
||||
@@ -66,7 +66,7 @@
|
||||
ck_assert_int_eq(err, 0);
|
||||
|
||||
addr = lgfs2_rbm_to_block(&rbm);
|
||||
- fail_unless(addr == rbm.rgd->ri.ri_data0);
|
||||
+ ck_assert(addr == rbm.rgd->ri.ri_data0);
|
||||
}
|
||||
}
|
||||
END_TEST
|
||||
@@ -110,7 +110,7 @@
|
||||
ck_assert_int_eq(err, 0);
|
||||
|
||||
addr = lgfs2_rbm_to_block(&rbm);
|
||||
- fail_unless(addr == (rg->ri.ri_data0 + rg->ri.ri_data - 1));
|
||||
+ ck_assert(addr == (rg->ri.ri_data0 + rg->ri.ri_data - 1));
|
||||
}
|
||||
END_TEST
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: gfs2-utils
|
||||
Version: 3.2.0
|
||||
Release: 10%{?dist}
|
||||
Version: 3.3.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Summary: Utilities for managing the global file system (GFS2)
|
||||
%ifnarch %{arm}
|
||||
@ -17,11 +17,9 @@ BuildRequires: flex
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: check-devel
|
||||
BuildRequires: bzip2-devel
|
||||
Source: https://releases.pagure.org/gfs2-utils/gfs2-utils-%{version}.tar.gz
|
||||
URL: https://pagure.io/gfs2-utils
|
||||
Patch0: 0-Fix_libuuid_linking.patch
|
||||
Patch1: 1-Fix_more_linking_errors.patch
|
||||
Patch2: 2-tests_Don_t_use_fail_unless_in_unit_tests.patch
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
@ -56,14 +54,20 @@ modifying, and correcting inconsistencies in GFS2 file systems.
|
||||
%{_sbindir}/gfs2_convert
|
||||
%{_sbindir}/gfs2_edit
|
||||
%{_sbindir}/tunegfs2
|
||||
%{_sbindir}/gfs2_withdraw_helper
|
||||
%{_sbindir}/glocktop
|
||||
%{_libexecdir}/gfs2_withdraw_helper
|
||||
%{_mandir}/man8/*gfs2*
|
||||
%{_mandir}/man8/glocktop*
|
||||
%{_mandir}/man5/*
|
||||
%{_prefix}/lib/udev/rules.d/82-gfs2-withdraw.rules
|
||||
|
||||
%changelog
|
||||
* Tue Sep 01 2020 Andrew Price <anprice@redhat.com> - 3.3.0-1
|
||||
- New upstream version
|
||||
- Add dependency on bzip2
|
||||
- Drop all patches
|
||||
- gfs2_withdraw_helper is now in /usr/libexec/
|
||||
|
||||
* Wed Jul 29 2020 Andrew Price <anprice@redhat.com> - 3.2.0-10
|
||||
- tests: Don't use fail_unless in unit tests
|
||||
Fixes build failures due to a regression in check-devel
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gfs2-utils-3.2.0.tar.gz) = 98ddf07666a7d0b0985e65eafebec455e0926a9bda9350d413f209bfc7af9ef30e23980a516f7375db61ea1b7b55f33934d52685d163ca6cc4a151ac0db5e5fe
|
||||
SHA512 (gfs2-utils-3.3.0.tar.gz) = b5ed1fb91eaf88fd163b682a73a3f54efd000e513206aba90e6286e68d8b13c325373da1bde94c8f48c0d235b60f22f6269f9103c508aebf13b15d9470b745d0
|
||||
|
Loading…
Reference in New Issue
Block a user