- New upstream release (3.1.5)
Removes mount.gfs2, gfs2_tool, gfs2_quota - Remove rawhide_transition.patch - now obsolete - Update BuildRequires: Change glibc-kernheaders to kernel-headers Add bison and flex - Provide a valid url for Source0 - Add fix_build_on_rawhide.patch to fix a circular dep introduced in bison 2.6, and a make -j race between libgfs2 and gfs2l
This commit is contained in:
parent
5a9c469354
commit
020dbfae51
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/gfs2-utils-3.1.2.tar.gz
|
||||
/gfs2-utils-3.1.3.tar.gz
|
||||
/gfs2-utils-3.1.4.tar.gz
|
||||
/gfs2-utils-3.1.5.tar.gz
|
||||
|
25
fix_build_on_rawhide.patch
Normal file
25
fix_build_on_rawhide.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff --git a/gfs2/libgfs2/Makefile.am b/gfs2/libgfs2/Makefile.am
|
||||
index 9c4e96b..b57f6d9 100644
|
||||
--- a/gfs2/libgfs2/Makefile.am
|
||||
+++ b/gfs2/libgfs2/Makefile.am
|
||||
@@ -23,7 +23,7 @@ libgfs2_la_CPPFLAGS = -D_FILE_OFFSET_BITS=64 \
|
||||
|
||||
gfs2l_SOURCES = gfs2l.c
|
||||
gfs2l_CPPFLAGS = -I$(top_srcdir)/gfs2/include
|
||||
-gfs2l_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
+gfs2l_LDADD = libgfs2.la
|
||||
|
||||
# Autotools can't handle header files output by flex so we have to generate it manually
|
||||
lexer.h: lexer.l
|
||||
diff --git a/gfs2/libgfs2/parser.y b/gfs2/libgfs2/parser.y
|
||||
index 084d15e..0321d74 100644
|
||||
--- a/gfs2/libgfs2/parser.y
|
||||
+++ b/gfs2/libgfs2/parser.y
|
||||
@@ -1,3 +1,7 @@
|
||||
+%code requires {
|
||||
+/* Required to break a circular dependency introduced with bison 2.6 */
|
||||
+typedef void* yyscan_t;
|
||||
+}
|
||||
%code top {
|
||||
#include <errno.h>
|
||||
#include "lang.h"
|
@ -11,8 +11,8 @@
|
||||
###############################################################################
|
||||
|
||||
Name: gfs2-utils
|
||||
Version: 3.1.4
|
||||
Release: 6%{?dist}
|
||||
Version: 3.1.5
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Kernel
|
||||
Summary: Utilities for managing the global file system (GFS2)
|
||||
@ -24,12 +24,14 @@ Requires: file
|
||||
%{?fedora:Requires: kernel-modules-extra}
|
||||
Obsoletes: gfs2-cluster < %{version}
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: glibc-kernheaders
|
||||
BuildRequires: kernel-headers
|
||||
BuildRequires: automake
|
||||
BuildRequires: perl
|
||||
BuildRequires: libtool
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: bison
|
||||
BuildRequires: flex
|
||||
URL: https://fedorahosted.org/cluster/wiki/HomePage
|
||||
|
||||
# The source for this package was pulled from the upstream git tree.
|
||||
@ -38,14 +40,14 @@ URL: https://fedorahosted.org/cluster/wiki/HomePage
|
||||
# cd gfs2-utils
|
||||
# ./make-tarball.sh
|
||||
#
|
||||
Source0: gfs2-utils-%{version}.tar.gz
|
||||
Patch0: rawhide_transition.patch
|
||||
Source0: https://fedorahosted.org/released/gfs2-utils/gfs2-utils-%{version}.tar.gz
|
||||
Patch0: fix_build_on_rawhide.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%prep
|
||||
%setup -q -n gfs2-utils
|
||||
%patch0 -p1 -b .rawhide_transition
|
||||
%patch0 -p1 -b .fix_build_on_rawhide
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -56,19 +58,6 @@ make %{_smp_mflags}
|
||||
rm -rf %{buildroot}
|
||||
# gfs and group installed separately to avoid pulling in the docs
|
||||
make -C gfs2 install DESTDIR=%{buildroot}
|
||||
make -C group install DESTDIR=%{buildroot}
|
||||
# Remove gfs2_quota and its man page (temporary)
|
||||
rm -f %{buildroot}%{_mandir}/man8/gfs2_quota.8
|
||||
rm -f %{buildroot}/usr/sbin/gfs2_quota
|
||||
# End of temporary section (until gfs2_quota removed from source)
|
||||
# Remove gfs2_tool and its man page (temporary)
|
||||
rm -f %{buildroot}%{_mandir}/man8/gfs2_tool.8
|
||||
rm -f %{buildroot}/usr/sbin/gfs2_tool
|
||||
# End of temporary section (until gfs2_tool removed from source)
|
||||
# Remove mount.gfs2 and its man page (temporary)
|
||||
rm -f %{buildroot}%{_mandir}/man8/mount.gfs2.8
|
||||
rm -f %{buildroot}/sbin/mount.gfs2
|
||||
# End of temporary section (until mount.gfs2 removed from source)
|
||||
# Remove gfs_control and the gfs_controld man page (temporary)
|
||||
rm -f %{buildroot}%{_mandir}/man8/gfs_controld.8
|
||||
rm -f %{buildroot}/usr/sbin/gfs_control
|
||||
@ -92,6 +81,17 @@ file systems.
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%changelog
|
||||
* Tue Nov 13 2012 Andrew Price <anprice@redhat.com> - 3.1.5-1
|
||||
- New upstream release
|
||||
Removes mount.gfs2, gfs2_tool, gfs2_quota
|
||||
- Remove rawhide_transition.patch - now obsolete
|
||||
- Update BuildRequires:
|
||||
Change glibc-kernheaders to kernel-headers
|
||||
Add bison and flex
|
||||
- Provide a valid url for Source0
|
||||
- Add fix_build_on_rawhide.patch to fix a circular dep introduced in
|
||||
bison 2.6, and a make -j race between libgfs2 and gfs2l
|
||||
|
||||
* Tue Aug 14 2012 Andrew Price <anprice@redhat.com> - 3.1.4-6
|
||||
- Make the kernel-modules-extra requirement Fedora-specific
|
||||
Resolves bz#847955
|
||||
|
@ -1,29 +0,0 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3fe1a49..0637096 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -114,15 +114,6 @@ AC_ARG_WITH([kernel],
|
||||
|
||||
KERNEL_CPPFLAGS="-I$KERNEL_DIR/include"
|
||||
|
||||
-PKG_CHECK_MODULES([corosync],[corosync])
|
||||
-PKG_CHECK_MODULES([cpg],[libcpg])
|
||||
-PKG_CHECK_MODULES([sackpt],[libSaCkpt])
|
||||
-PKG_CHECK_MODULES([logt],[liblogthread])
|
||||
-PKG_CHECK_MODULES([ccs],[libccs])
|
||||
-PKG_CHECK_MODULES([cfg],[libcfg])
|
||||
-PKG_CHECK_MODULES([fenced],[libfenced])
|
||||
-PKG_CHECK_MODULES([dlmcontrol],[libdlmcontrol])
|
||||
-PKG_CHECK_MODULES([quorum],[libquorum])
|
||||
PKG_CHECK_MODULES([zlib],[zlib])
|
||||
|
||||
# old versions of ncurses don't ship pkg-config files
|
||||
diff --git a/group/Makefile.am b/group/Makefile.am
|
||||
index 5b7d0f8..20282f0 100644
|
||||
--- a/group/Makefile.am
|
||||
+++ b/group/Makefile.am
|
||||
@@ -1,3 +1,3 @@
|
||||
MAINTAINERCLEANFILES = Makefile.in
|
||||
|
||||
-SUBDIRS = libgfscontrol gfs_control gfs_controld man include
|
||||
+SUBDIRS = libgfscontrol gfs_control man include
|
Loading…
Reference in New Issue
Block a user