* Wed Jul 24 2013 Andrew Price <anprice@redhat.com> - 3.1.6-1
- New upstream release - Drop 'file' requirement - mkfs.gfs2 now uses libblkid instead - Drop 'ncurses' requirement - dependency is added automatically - Drop requires chkconfig and initscripts - no longer installs daemons - Drop fix_build_on_rawhide.patch - upstream - Add build req on libblkid-devel
This commit is contained in:
parent
8efdaf8a03
commit
0122cb4b2e
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/gfs2-utils-3.1.3.tar.gz
|
||||
/gfs2-utils-3.1.4.tar.gz
|
||||
/gfs2-utils-3.1.5.tar.gz
|
||||
/gfs2-utils-3.1.6.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
diff --git a/gfs2/libgfs2/Makefile.am b/gfs2/libgfs2/Makefile.am
|
||||
index 9c4e96b..b57f6d9 100644
|
||||
--- a/gfs2/libgfs2/Makefile.am
|
||||
+++ b/gfs2/libgfs2/Makefile.am
|
||||
@@ -23,7 +23,7 @@ libgfs2_la_CPPFLAGS = -D_FILE_OFFSET_BITS=64 \
|
||||
|
||||
gfs2l_SOURCES = gfs2l.c
|
||||
gfs2l_CPPFLAGS = -I$(top_srcdir)/gfs2/include
|
||||
-gfs2l_LDADD = $(top_builddir)/gfs2/libgfs2/libgfs2.la
|
||||
+gfs2l_LDADD = libgfs2.la
|
||||
|
||||
# Autotools can't handle header files output by flex so we have to generate it manually
|
||||
lexer.h: lexer.l
|
||||
diff --git a/gfs2/libgfs2/parser.y b/gfs2/libgfs2/parser.y
|
||||
index 084d15e..0321d74 100644
|
||||
--- a/gfs2/libgfs2/parser.y
|
||||
+++ b/gfs2/libgfs2/parser.y
|
||||
@@ -1,3 +1,7 @@
|
||||
+%code requires {
|
||||
+/* Required to break a circular dependency introduced with bison 2.6 */
|
||||
+typedef void* yyscan_t;
|
||||
+}
|
||||
%code top {
|
||||
#include <errno.h>
|
||||
#include "lang.h"
|
@ -11,16 +11,11 @@
|
||||
###############################################################################
|
||||
|
||||
Name: gfs2-utils
|
||||
Version: 3.1.5
|
||||
Release: 2%{?dist}
|
||||
Version: 3.1.6
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Kernel
|
||||
Summary: Utilities for managing the global file system (GFS2)
|
||||
Requires(post): chkconfig
|
||||
Requires(preun): initscripts
|
||||
Requires(preun): chkconfig
|
||||
Requires: ncurses
|
||||
Requires: file
|
||||
%{?fedora:Requires: kernel-modules-extra}
|
||||
Obsoletes: gfs2-cluster < %{version}
|
||||
BuildRequires: ncurses-devel
|
||||
@ -32,6 +27,7 @@ BuildRequires: zlib-devel
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: bison
|
||||
BuildRequires: flex
|
||||
BuildRequires: libblkid-devel
|
||||
URL: https://fedorahosted.org/cluster/wiki/HomePage
|
||||
|
||||
# The source for this package was pulled from the upstream git tree.
|
||||
@ -41,13 +37,11 @@ URL: https://fedorahosted.org/cluster/wiki/HomePage
|
||||
# ./make-tarball.sh
|
||||
#
|
||||
Source0: https://fedorahosted.org/released/gfs2-utils/gfs2-utils-%{version}.tar.gz
|
||||
Patch0: fix_build_on_rawhide.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%prep
|
||||
%setup -q -n gfs2-utils
|
||||
%patch0 -p1 -b .fix_build_on_rawhide
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -56,16 +50,11 @@ make %{_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
# gfs and group installed separately to avoid pulling in the docs
|
||||
make -C gfs2 install DESTDIR=%{buildroot}
|
||||
# Remove gfs_control and the gfs_controld man page (temporary)
|
||||
rm -f %{buildroot}%{_mandir}/man8/gfs_controld.8
|
||||
rm -f %{buildroot}/usr/sbin/gfs_control
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
|
||||
%description -n gfs2-utils
|
||||
The gfs2-utils package contains a number of utilities for creating,
|
||||
checking, modifying, and correcting any inconsistencies in GFS2
|
||||
@ -81,6 +70,14 @@ file systems.
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 24 2013 Andrew Price <anprice@redhat.com> - 3.1.6-1
|
||||
- New upstream release
|
||||
- Drop 'file' requirement - mkfs.gfs2 now uses libblkid instead
|
||||
- Drop 'ncurses' requirement - dependency is added automatically
|
||||
- Drop requires chkconfig and initscripts - no longer installs daemons
|
||||
- Drop fix_build_on_rawhide.patch - upstream
|
||||
- Add build req on libblkid-devel
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user