diff --git a/.cvsignore b/.cvsignore
index e69de29..c511367 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -0,0 +1 @@
+gflags-0.9.tar.gz
diff --git a/gflags.spec b/gflags.spec
new file mode 100644
index 0000000..8e0cf62
--- /dev/null
+++ b/gflags.spec
@@ -0,0 +1,113 @@
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+Name:           gflags
+Version:        0.9
+Release:        6%{?dist}
+Summary:        Library for commandline flag processing
+
+Group:          Development/Tools
+License:        BSD
+URL:            http://code.google.com/p/google-%{name}/
+Source0:        http://google-%{name}.googlecode.com/files/%{name}-%{version}.tar.gz
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires:  python-setuptools-devel
+
+%description
+The gflags package contains a library that implements commandline
+flags processing. As such it's a replacement for getopt(). It has
+increased flexibility, including built-in support for C++ types like
+string, and the ability to define flags in the source file in which
+they're used.
+
+%package devel
+Summary:        Development files for %{name}
+Group:          Development/Libraries
+
+Requires:       %{name} = %{version}-%{release}
+
+%description devel
+This package contains development files for %{name}.
+
+%prep
+%setup -q -n %{name}-%{version}
+
+%build
+%configure --disable-static
+
+# Omit unused direct shared library dependencies.
+sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
+
+make %{?_smp_mflags}
+
+# build python module
+cd python
+CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")' build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
+
+find $RPM_BUILD_ROOT -type f -name "*.la" -delete
+
+# install python module
+cd python
+%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root $RPM_BUILD_ROOT
+
+# executable permission for script
+chmod 755 $RPM_BUILD_ROOT%{python_sitelib}/gflags.py
+
+%check
+# 2 out of 17 tests fail on x86_64
+# disable test suite
+cd python
+#%{__python} %{name}_unittest.py
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+
+%files
+%defattr(-,root,root,-)
+%doc ChangeLog README COPYING
+%{_bindir}/gflags_completions.sh
+%{_bindir}/gflags2man.py
+%{_libdir}/libgflags.so.*
+%{python_sitelib}/gflags.py
+%{python_sitelib}/gflags.pyc
+%{python_sitelib}/gflags.pyo
+%{python_sitelib}/*egg-info
+%exclude %{_bindir}/*.pyc
+%exclude %{_bindir}/*.pyo
+
+
+%files devel
+%defattr(-,root,root,-)
+%doc doc/designstyle.css doc/gflags.html
+%{_libdir}/libgflags.so
+%dir %{_includedir}/google
+%{_includedir}/google/*.h
+
+%changelog
+* Thu Sep 04 2008 Rakesh Pandit <rakesh@fedoraproject.org> 0.9-6
+- fixed for F-8 provide eggs for non setuptools package
+
+* Thu Sep 04 2008 Rakesh Pandit <rakesh@fedoraproject.org> 0.9-5
+- disable test suite because it failed on x86_64 (2/17)
+
+* Thu Aug 26 2008 Rakesh Pandit <rakesh@fedoraproject.org> 0.9-4
+- fixed %%{includedir}
+
+* Thu Aug 14 2008 Rakesh Pandit <rakesh@fedoraproject.org> 0.9-3
+- fixed documentation, timestamp saving
+- removed chrpath & cleaned some unwanted commands
+- included python module
+
+* Sat Aug 09 2008 Rakesh Pandit <rakesh@fedoraproject.org> 0.9-2
+- remove automake and corrected configure option
+
+* Thu Aug 07 2008 Rakesh Pandit <rakesh@fedoraproject.org> 0.9-1
+- Initial build
diff --git a/import.log b/import.log
new file mode 100644
index 0000000..5de1563
--- /dev/null
+++ b/import.log
@@ -0,0 +1 @@
+gflags-0_9-6_fc10:HEAD:gflags-0.9-6.fc10.src.rpm:1222674675
diff --git a/sources b/sources
index e69de29..17e91a5 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+bd4871398e9019b241d89cc21fb62def  gflags-0.9.tar.gz