Add patch (from upstream) for shared library versining.
This commit is contained in:
parent
56f2b5c13e
commit
9ea4579088
@ -0,0 +1,35 @@
|
|||||||
|
From bf889786c2a3a2dab89610d0722634d2eedfc694 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andreas Schuh <andreas.schuh.84@gmail.com>
|
||||||
|
Date: Thu, 1 May 2014 20:16:16 +0100
|
||||||
|
Subject: [PATCH] Set VERSION property of library targets to <major>.<minor>.
|
||||||
|
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 5 +++++
|
||||||
|
1 file changed, 5 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index a4d0f07..7f65563 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -22,6 +22,8 @@ version_numbers (
|
||||||
|
PACKAGE_VERSION_PATCH
|
||||||
|
)
|
||||||
|
|
||||||
|
+set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}")
|
||||||
|
+
|
||||||
|
# ----------------------------------------------------------------------------
|
||||||
|
# options
|
||||||
|
set (GFLAGS_NAMESPACE "${PACKAGE_NAME}" CACHE STRING "C++ namespace identifier of gflags library.")
|
||||||
|
@@ -257,6 +259,9 @@ foreach (TYPE IN ITEMS STATIC SHARED)
|
||||||
|
set_target_properties (
|
||||||
|
gflags${opts}-${type} PROPERTIES COMPILE_DEFINITIONS "${defines}"
|
||||||
|
OUTPUT_NAME "gflags${opts}"
|
||||||
|
+ # Set VERSION instead of SOVERSION such
|
||||||
|
+ # that it is also used on Windows
|
||||||
|
+ VERSION "${PACKAGE_SOVERSION}"
|
||||||
|
)
|
||||||
|
if (HAVE_SHLWAPI_H)
|
||||||
|
target_link_libraries (gflags${opts}-${type} shlwapi.lib)
|
||||||
|
--
|
||||||
|
1.9.0
|
||||||
|
|
13
gflags.spec
13
gflags.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: gflags
|
Name: gflags
|
||||||
Version: 2.1.1
|
Version: 2.1.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Library for commandline flag processing
|
Summary: Library for commandline flag processing
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -10,6 +10,7 @@ License: BSD
|
|||||||
URL: http://code.google.com/p/%{name}
|
URL: http://code.google.com/p/%{name}
|
||||||
Source0: http://github.com/schuhschuh/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: http://github.com/schuhschuh/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
Patch0: gflags-0001-cmake-append-LIB_SUFFIX-to-LIBRARY_INSTALL_DIR.patch
|
Patch0: gflags-0001-cmake-append-LIB_SUFFIX-to-LIBRARY_INSTALL_DIR.patch
|
||||||
|
Patch1: gflags-0001-Set-VERSION-property-of-library-targets-to-major.patch
|
||||||
BuildRequires: python-setuptools-devel
|
BuildRequires: python-setuptools-devel
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
|
|
||||||
@ -32,6 +33,7 @@ This package contains development files for %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .lib_suffix
|
%patch0 -p1 -b .lib_suffix
|
||||||
|
%patch1 -p1 -b .lib_version
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -DBUILD_TESTING:BOOL=ON .
|
%cmake -DBUILD_TESTING:BOOL=ON .
|
||||||
@ -50,17 +52,22 @@ ctest
|
|||||||
%files
|
%files
|
||||||
%doc ChangeLog.txt README.txt COPYING.txt AUTHORS.txt
|
%doc ChangeLog.txt README.txt COPYING.txt AUTHORS.txt
|
||||||
%{_bindir}/gflags_completions.sh
|
%{_bindir}/gflags_completions.sh
|
||||||
%{_libdir}/libgflags.so
|
%{_libdir}/libgflags.so.*
|
||||||
%{_libdir}/libgflags_nothreads.so
|
%{_libdir}/libgflags_nothreads.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%doc doc/designstyle.css doc/gflags.html
|
%doc doc/designstyle.css doc/gflags.html
|
||||||
%dir %{_includedir}/%{name}
|
%dir %{_includedir}/%{name}
|
||||||
%{_includedir}/%{name}/*.h
|
%{_includedir}/%{name}/*.h
|
||||||
|
%{_libdir}/libgflags.so
|
||||||
|
%{_libdir}/libgflags_nothreads.so
|
||||||
%dir %{_libdir}/cmake
|
%dir %{_libdir}/cmake
|
||||||
%{_libdir}/cmake/%{name}
|
%{_libdir}/cmake/%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 01 2014 ivaxer@gmail.com - 2.1.1-3
|
||||||
|
- Add patch (from upstream) for shared library versining.
|
||||||
|
|
||||||
* Wed Apr 30 2014 John Khvatov <ivaxer@fedoraproject.org> - 2.1.1-2
|
* Wed Apr 30 2014 John Khvatov <ivaxer@fedoraproject.org> - 2.1.1-2
|
||||||
- Enable test suite
|
- Enable test suite
|
||||||
- Update SourceURL (upstream moved to github)
|
- Update SourceURL (upstream moved to github)
|
||||||
|
Loading…
Reference in New Issue
Block a user