Update to 2.2.1
Patch1 already upstreamed
This commit is contained in:
parent
44d4d5f287
commit
72f33109d4
@ -1,18 +0,0 @@
|
||||
From: Andreas Schuh <andreas.schuh.84@gmail.com>
|
||||
Date: Thu, 1 May 2014 20:16:16 +0100
|
||||
Subject: [PATCH] Set VERSION property of library targets to <major>.<minor>.
|
||||
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 54b5c35..756ddba 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -34,7 +34,7 @@ version_numbers (
|
||||
PACKAGE_VERSION_PATCH
|
||||
)
|
||||
|
||||
-set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}")
|
||||
+set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}")
|
||||
|
||||
# ----------------------------------------------------------------------------
|
||||
# options
|
23
gflags.spec
23
gflags.spec
@ -1,13 +1,12 @@
|
||||
Name: gflags
|
||||
Version: 2.1.2
|
||||
Release: 8%{?dist}
|
||||
Version: 2.2.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Library for commandline flag processing
|
||||
|
||||
Group: Development/Tools
|
||||
License: BSD
|
||||
URL: https://gflags.github.io/gflags/
|
||||
Source0: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
Patch1: gflags-0001-Set-VERSION-property-of-library-targets-to-major.patch
|
||||
Source0: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: python2-setuptools
|
||||
BuildRequires: cmake
|
||||
@ -30,14 +29,16 @@ This package contains development files for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .lib_version
|
||||
|
||||
%build
|
||||
%cmake -DBUILD_TESTING:BOOL=ON .
|
||||
make %{?_smp_mflags}
|
||||
%cmake -DBUILD_TESTING:BOOL=ON \
|
||||
-DINSTALL_HEADERS:BOOL=ON \
|
||||
-DREGISTER_BUILD_DIR:BOOL=OFF \
|
||||
-DREGISTER_INSTALL_PREFIX:BOOL=OFF .
|
||||
%make_build
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot} INSTALL="install -p"
|
||||
%make_install
|
||||
|
||||
%check
|
||||
ctest
|
||||
@ -54,14 +55,18 @@ ctest
|
||||
%{_libdir}/libgflags_nothreads.so.*
|
||||
|
||||
%files devel
|
||||
%doc doc/designstyle.css doc/index.html
|
||||
%dir %{_includedir}/%{name}
|
||||
%{_includedir}/%{name}/*.h
|
||||
%{_libdir}/libgflags.so
|
||||
%{_libdir}/pkgconfig/gflags.pc
|
||||
%{_libdir}/libgflags_nothreads.so
|
||||
%{_libdir}/cmake/%{name}
|
||||
|
||||
%changelog
|
||||
* Tue Oct 02 2018 Sérgio Basto <sergio@serjux.com> - 2.2.1-1
|
||||
- Update to 2.2.1
|
||||
- Patch1 already upstreamed
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user