Import rpm: c8s
This commit is contained in:
parent
928d27e6b7
commit
4dcf7baf81
3
.gitignore
vendored
3
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/gflags-2.2.2.tar.gz
|
||||
SOURCES/gflags-2.1.2.tar.gz
|
||||
/gflags-2.1.2.tar.gz
|
||||
|
@ -0,0 +1,18 @@
|
||||
From: Andreas Schuh <andreas.schuh.84@gmail.com>
|
||||
Date: Thu, 1 May 2014 20:16:16 +0100
|
||||
Subject: [PATCH] Set VERSION property of library targets to <major>.<minor>.
|
||||
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 54b5c35..756ddba 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -34,7 +34,7 @@ version_numbers (
|
||||
PACKAGE_VERSION_PATCH
|
||||
)
|
||||
|
||||
-set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}")
|
||||
+set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}")
|
||||
|
||||
# ----------------------------------------------------------------------------
|
||||
# options
|
28
gflags.spec
28
gflags.spec
@ -1,20 +1,17 @@
|
||||
Name: gflags
|
||||
Version: 2.2.2
|
||||
Release: 1%{?dist}
|
||||
Version: 2.1.2
|
||||
Release: 7%{?dist}
|
||||
Epoch: 1
|
||||
Summary: Library for commandline flag processing
|
||||
|
||||
Group: Development/Tools
|
||||
License: BSD
|
||||
URL: https://gflags.github.io/gflags/
|
||||
Source0: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# These two are refered from a submodule in 2.2.2 tree, hence they
|
||||
# are not picked by git archive command so thats why we must put
|
||||
# them here:
|
||||
Source1: index.html
|
||||
Source2: designstyle.css
|
||||
Patch0: gflags-fix_pkgconfig.patch
|
||||
Patch0: gflags-0001-Set-VERSION-property-of-library-targets-to-major.patch
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
BuildRequires: python2-setuptools
|
||||
|
||||
%description
|
||||
The gflags package contains a library that implements commandline
|
||||
@ -27,7 +24,7 @@ they're used.
|
||||
Summary: Development files for %{name}
|
||||
Group: Development/Libraries
|
||||
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
This package contains development files for %{name}.
|
||||
@ -35,14 +32,8 @@ This package contains development files for %{name}.
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
cp -v %{SOURCE1} ./doc
|
||||
cp -v %{SOURCE2} ./doc
|
||||
|
||||
%build
|
||||
%cmake -DBUILD_TESTING:BOOL=ON \
|
||||
-DINSTALL_HEADERS:BOOL=ON \
|
||||
-DREGISTER_BUILD_DIR:BOOL=OFF \
|
||||
-DREGISTER_INSTALL_PREFIX:BOOL=OFF
|
||||
%cmake -DBUILD_TESTING:BOOL=ON .
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
@ -65,11 +56,14 @@ cp -v %{SOURCE2} ./doc
|
||||
%dir %{_includedir}/%{name}
|
||||
%{_includedir}/%{name}/*.h
|
||||
%{_libdir}/libgflags.so
|
||||
%{_libdir}/pkgconfig/gflags.pc
|
||||
%{_libdir}/libgflags_nothreads.so
|
||||
%{_libdir}/cmake/%{name}
|
||||
|
||||
%changelog
|
||||
* Wed Feb 23 2022 Jiri Kucera <jkucera@redhat.com> - 1:2.1.2-7
|
||||
- Revert rebase back to 2.1.2
|
||||
Related: #2035143
|
||||
|
||||
* Fri Jan 21 2022 Jiri Kucera <jkucera@redhat.com> - 2.2.2-1
|
||||
- Rebase to gflags v2.2.2
|
||||
Resolves: #2035143
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gflags-2.2.2.tar.gz) = 98c4703aab24e81fe551f7831ab797fb73d0f7dfc516addb34b9ff6d0914e5fd398207889b1ae555bac039537b1d4677067dae403b64903577078d99c1bdb447
|
||||
SHA512 (gflags-2.1.2.tar.gz) = f636023c1150e4d536d2d472e40d643ff0b02d3c96d8cb7f31544df23e6255fa6c4fd927ef94a3660c250d3faeae7d8d78519fc5e856749a577347a78d9d9ab5
|
||||
|
Loading…
Reference in New Issue
Block a user