update to 2.1.1

This commit is contained in:
John Khvatov 2014-05-01 02:43:17 +04:00
parent 0a39ceb8f3
commit 456b07246b
4 changed files with 54 additions and 29 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
gflags-1.3.tar.gz
/gflags-2.1.1.tar.gz

View File

@ -0,0 +1,28 @@
From 251684169627f0aae205c9a316863e0e3f257912 Mon Sep 17 00:00:00 2001
From: John Khvatov <ivaxer@fedoraproject.org>
Date: Thu, 1 May 2014 00:57:04 +0400
Subject: [PATCH] cmake: append LIB_SUFFIX to LIBRARY_INSTALL_DIR
---
CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17d38b4..10c9cca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,9 +280,9 @@ if (OS_WINDOWS)
set (CONFIG_INSTALL_DIR CMake)
else ()
set (RUNTIME_INSTALL_DIR bin)
- set (LIBRARY_INSTALL_DIR lib)
+ set (LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
set (INCLUDE_INSTALL_DIR include)
- set (CONFIG_INSTALL_DIR lib/cmake/${PACKAGE_NAME})
+ set (CONFIG_INSTALL_DIR lib${LIB_SUFFIX}/cmake/${PACKAGE_NAME})
endif ()
file (RELATIVE_PATH INSTALL_PREFIX_REL2CONFIG_DIR "${CMAKE_INSTALL_PREFIX}/${CONFIG_INSTALL_DIR}" "${CMAKE_INSTALL_PREFIX}")
--
1.9.0

View File

@ -1,18 +1,17 @@
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: gflags
Version: 1.3
Release: 8%{?dist}
Version: 2.1.1
Release: 2%{?dist}
Summary: Library for commandline flag processing
Group: Development/Tools
License: BSD
URL: http://code.google.com/p/google-%{name}/
Source0: http://google-%{name}.googlecode.com/files/%{name}-%{version}.tar.gz
URL: http://code.google.com/p/%{name}
Source0: http://github.com/schuhschuh/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
Patch0: gflags-0001-cmake-append-LIB_SUFFIX-to-LIBRARY_INSTALL_DIR.patch
BuildRequires: python-setuptools-devel
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: cmake
%description
The gflags package contains a library that implements commandline
@ -32,50 +31,45 @@ This package contains development files for %{name}.
%prep
%setup -q
rm -f libtool
autoreconf -ivf
%patch0 -p1 -b .lib_suffix
%build
%configure --disable-static
%cmake -DBUILD_TESTING:BOOL=ON .
make %{?_smp_mflags}
%install
make install DESTDIR=%{buildroot} INSTALL="install -p"
find %{buildroot} -type f -name "*.la" -delete
# Remove preinstaled versioned doc-files
rm -rf %{buildroot}/%{_datadir}/doc/%{name}-%{version}
%check
# 2 out of 17 tests fail on x86_64
# disable test suite
ctest
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc AUTHORS ChangeLog README COPYING
%doc ChangeLog.txt README.txt COPYING.txt AUTHORS.txt
%{_bindir}/gflags_completions.sh
%{_libdir}/libgflags.so.*
%{_libdir}/libgflags_nothreads.so.*
%{_libdir}/libgflags.so
%{_libdir}/libgflags_nothreads.so
%files devel
%doc doc/designstyle.css doc/gflags.html
%{_libdir}/libgflags.so
%{_libdir}/libgflags_nothreads.so
%dir %{_includedir}/%{name}
%{_includedir}/%{name}/*.h
%dir %{_includedir}/google
%{_includedir}/google/*.h
%dir %{_libdir}/cmake
%{_libdir}/cmake/%{name}
%changelog
* Wed Apr 30 2014 John Khvatov <ivaxer@fedoraproject.org> - 2.1.1-2
- Enable test suite
- Update SourceURL (upstream moved to github)
- Add patch to use LIB_SUFFIX in cmake configs
- Spec cleanup
* Wed Apr 23 2014 Dan Fuhry <dfuhry@dattobackup.com> - 2.1.1-1
- Updated to 2.1.1
* Sat Aug 31 2013 Peter Lemenkov <lemenkov@gmail.com> - 1.3-8
- Use system-wide libtool
- Autoregen everything

View File

@ -1 +1,3 @@
6da3d3b9cd82c222b521ae686b6cfa8b gflags-1.3.tar.gz
eb260404e5b4c678dd551db651059225 gflags-2.1.1.tar
18acc0ae270672a70a86b33ebbe9761b gflags-2.1.1.tar.gz