Upgrade to the latest upstream release, 2.1.2

This commit is contained in:
Evan Klitzke 2016-02-27 23:56:11 +03:00 committed by Peter Lemenkov
parent 75114f994b
commit 36f56f53ea
5 changed files with 16 additions and 61 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/gflags-2.1.1.tar.gz /gflags-2.1.1.tar.gz
/gflags-2.1.2.tar.gz

View File

@ -1,35 +1,18 @@
From bf889786c2a3a2dab89610d0722634d2eedfc694 Mon Sep 17 00:00:00 2001
From: Andreas Schuh <andreas.schuh.84@gmail.com> From: Andreas Schuh <andreas.schuh.84@gmail.com>
Date: Thu, 1 May 2014 20:16:16 +0100 Date: Thu, 1 May 2014 20:16:16 +0100
Subject: [PATCH] Set VERSION property of library targets to <major>.<minor>. Subject: [PATCH] Set VERSION property of library targets to <major>.<minor>.
---
CMakeLists.txt | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4d0f07..7f65563 100644 index 54b5c35..756ddba 100644
--- a/CMakeLists.txt --- a/CMakeLists.txt
+++ b/CMakeLists.txt +++ b/CMakeLists.txt
@@ -22,6 +22,8 @@ version_numbers ( @@ -34,7 +34,7 @@ version_numbers (
PACKAGE_VERSION_PATCH PACKAGE_VERSION_PATCH
) )
-set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}")
+set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}") +set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}")
+
# ---------------------------------------------------------------------------- # ----------------------------------------------------------------------------
# options # options
set (GFLAGS_NAMESPACE "${PACKAGE_NAME}" CACHE STRING "C++ namespace identifier of gflags library.")
@@ -257,6 +259,9 @@ foreach (TYPE IN ITEMS STATIC SHARED)
set_target_properties (
gflags${opts}-${type} PROPERTIES COMPILE_DEFINITIONS "${defines}"
OUTPUT_NAME "gflags${opts}"
+ # Set VERSION instead of SOVERSION such
+ # that it is also used on Windows
+ VERSION "${PACKAGE_SOVERSION}"
)
if (HAVE_SHLWAPI_H)
target_link_libraries (gflags${opts}-${type} shlwapi.lib)
--
1.9.0

View File

@ -1,28 +0,0 @@
From 251684169627f0aae205c9a316863e0e3f257912 Mon Sep 17 00:00:00 2001
From: John Khvatov <ivaxer@fedoraproject.org>
Date: Thu, 1 May 2014 00:57:04 +0400
Subject: [PATCH] cmake: append LIB_SUFFIX to LIBRARY_INSTALL_DIR
---
CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17d38b4..10c9cca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,9 +280,9 @@ if (OS_WINDOWS)
set (CONFIG_INSTALL_DIR CMake)
else ()
set (RUNTIME_INSTALL_DIR bin)
- set (LIBRARY_INSTALL_DIR lib)
+ set (LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
set (INCLUDE_INSTALL_DIR include)
- set (CONFIG_INSTALL_DIR lib/cmake/${PACKAGE_NAME})
+ set (CONFIG_INSTALL_DIR lib${LIB_SUFFIX}/cmake/${PACKAGE_NAME})
endif ()
file (RELATIVE_PATH INSTALL_PREFIX_REL2CONFIG_DIR "${CMAKE_INSTALL_PREFIX}/${CONFIG_INSTALL_DIR}" "${CMAKE_INSTALL_PREFIX}")
--
1.9.0

View File

@ -1,15 +1,12 @@
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: gflags Name: gflags
Version: 2.1.1 Version: 2.1.2
Release: 9%{?dist} Release: 1%{?dist}
Summary: Library for commandline flag processing Summary: Library for commandline flag processing
Group: Development/Tools Group: Development/Tools
License: BSD License: BSD
URL: http://code.google.com/p/%{name} URL: https://gflags.github.io/gflags/
Source0: http://github.com/schuhschuh/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz Source0: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: gflags-0001-cmake-append-LIB_SUFFIX-to-LIBRARY_INSTALL_DIR.patch
Patch1: gflags-0001-Set-VERSION-property-of-library-targets-to-major.patch Patch1: gflags-0001-Set-VERSION-property-of-library-targets-to-major.patch
BuildRequires: python-setuptools BuildRequires: python-setuptools
BuildRequires: cmake BuildRequires: cmake
@ -32,7 +29,6 @@ This package contains development files for %{name}.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .lib_suffix
%patch1 -p1 -b .lib_version %patch1 -p1 -b .lib_version
%build %build
@ -50,21 +46,24 @@ ctest
%postun -p /sbin/ldconfig %postun -p /sbin/ldconfig
%files %files
%doc ChangeLog.txt README.txt COPYING.txt AUTHORS.txt %license COPYING.txt
%doc AUTHORS.txt ChangeLog.txt README.md
%{_bindir}/gflags_completions.sh %{_bindir}/gflags_completions.sh
%{_libdir}/libgflags.so.* %{_libdir}/libgflags.so.*
%{_libdir}/libgflags_nothreads.so.* %{_libdir}/libgflags_nothreads.so.*
%files devel %files devel
%doc doc/designstyle.css doc/gflags.html %doc doc/designstyle.css doc/index.html
%dir %{_includedir}/%{name} %dir %{_includedir}/%{name}
%{_includedir}/%{name}/*.h %{_includedir}/%{name}/*.h
%{_libdir}/libgflags.so %{_libdir}/libgflags.so
%{_libdir}/libgflags_nothreads.so %{_libdir}/libgflags_nothreads.so
%dir %{_libdir}/cmake
%{_libdir}/cmake/%{name} %{_libdir}/cmake/%{name}
%changelog %changelog
* Sat Feb 27 2016 Evan Klitzke - 2.1.2-1
- Upgrade to the latest upstream release, 2.1.2
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-9 * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

View File

@ -1 +1 @@
18acc0ae270672a70a86b33ebbe9761b gflags-2.1.1.tar.gz ac432de923f9de1e9780b5254884599f gflags-2.1.2.tar.gz