gettext/gettext-xglade-define-xml-major-version-285701.patch
Nils Philippsen 9fae6fa430 remove gettext-xglade-include-expat-285701.patch, add
gettext-xglade-define-xml-major-version-285701.patch to determine
    XML_MAJOR_VERSION from expat.h and define it in config.h (#285701)
2007-09-14 12:19:34 +00:00

27 lines
1.1 KiB
Diff

diff -up gettext-0.16.1/gettext-tools/configure.ac.4-expat~ gettext-0.16.1/gettext-tools/configure.ac
--- gettext-0.16.1/gettext-tools/configure.ac.4-expat~ 2006-11-27 18:02:01.000000000 +0100
+++ gettext-0.16.1/gettext-tools/configure.ac 2007-09-14 13:55:28.000000000 +0200
@@ -238,6 +238,22 @@ case "$host_os" in
LTLIBEXPAT="-ldl"
AC_SUBST(LIBEXPAT)
AC_SUBST(LTLIBEXPAT)
+ AC_CHECK_HEADER([expat.h],[
+ cat > xml_major_version.c << EOF
+#include <stdio.h>
+#include <expat.h>
+int main (void) { printf ("%d\n", XML_MAJOR_VERSION); }
+EOF
+ AC_MSG_CHECKING([for libexpat XML_MAJOR_VERSION])
+ $CC -o xml_major_version xml_major_version.c
+ XML_MAJOR_VERSION=$(./xml_major_version)
+ rm -f ./xml_major_version ./xml_major_version.c
+ AC_MSG_RESULT([$XML_MAJOR_VERSION])
+ AC_SUBST(XML_MAJOR_VERSION)
+ AC_DEFINE([XML_MAJOR_VERSION],$XML_MAJOR_VERSION,[The API version of the expat library found during compilation.])
+ ],[
+ AC_ERROR([cannot determine version of expat library, expat.h is missing])
+ ])
;;
*)
AC_LIB_HAVE_LINKFLAGS([expat], [],