cleanup patch: move LONG_LONG out and remove redundant hardcoded relative

system paths
This commit is contained in:
Jens Petersen 2009-11-27 09:55:33 +00:00
parent 327be7fc5f
commit d6b6f6c25d

View File

@ -1,16 +1,3 @@
diff -up ./gettext-runtime/libasprintf/configure.ac.rpathFix~ ./gettext-runtime/libasprintf/configure.ac
--- ./gettext-runtime/libasprintf/configure.ac.rpathFix~ 2007-10-08 05:37:36.000000000 +1000
+++ ./gettext-runtime/libasprintf/configure.ac 2008-08-28 16:43:18.000000000 +1000
@@ -54,7 +54,8 @@ dnl Checks for header files.
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_INLINE
AC_TYPE_SIZE_T
-gl_AC_TYPE_LONG_LONG
+AC_TYPE_LONG_LONG_INT
+#gl_AC_TYPE_LONG_LONG
gt_TYPE_LONGDOUBLE
gt_TYPE_WCHAR_T
gt_TYPE_WINT_T
diff -up ./gettext-tools/gnulib-tests/Makefile.gnulib.rpathFix~ ./gettext-tools/gnulib-tests/Makefile.gnulib
--- ./gettext-tools/gnulib-tests/Makefile.gnulib.rpathFix~ 2007-10-28 01:39:18.000000000 +1000
+++ ./gettext-tools/gnulib-tests/Makefile.gnulib 2008-08-28 16:43:18.000000000 +1000
@ -19,30 +6,10 @@ diff -up ./gettext-tools/gnulib-tests/Makefile.gnulib.rpathFix~ ./gettext-tools/
SUBDIRS =
TESTS =
-TESTS_ENVIRONMENT =
+TESTS_ENVIRONMENT = LD_LIBRARY_PATH='../intl/.libs:../src/.libs:../.libs:../../../../../lib:../../../../../lib64'
+TESTS_ENVIRONMENT = LD_LIBRARY_PATH='../intl/.libs:../src/.libs:../.libs:'
noinst_PROGRAMS =
check_PROGRAMS =
noinst_HEADERS =
diff -up ./gettext-tools/src/Makefile.am.rpathFix~ ./gettext-tools/src/Makefile.am
--- ./gettext-tools/src/Makefile.am.rpathFix~ 2007-10-08 05:37:38.000000000 +1000
+++ ./gettext-tools/src/Makefile.am 2008-08-28 17:16:45.000000000 +1000
@@ -62,6 +62,7 @@ projectsdir = $(pkgdatadir)/projects
pkglibdir = $(libdir)/gettext
AM_CPPFLAGS = \
+ -I../../../../../../usr/include \
-I. -I$(srcdir) \
-I.. -I$(top_srcdir) \
-I$(top_srcdir)/libgrep \
@@ -82,7 +83,7 @@ LDADD = ../gnulib-lib/libgettextlib.la @
SED = sed
YACC = @YACC@ -d
-GCJ = @GCJ@
+GCJ = gcj
GCJFLAGS = @GCJFLAGS@
JAR = @JAR@
JAVACOMP = $(SHELL) ../javacomp.sh
diff -up ./gettext-tools/tests/Makefile.am.rpathFix~ ./gettext-tools/tests/Makefile.am
--- ./gettext-tools/tests/Makefile.am.rpathFix~ 2007-10-21 07:54:40.000000000 +1000
+++ ./gettext-tools/tests/Makefile.am 2008-08-28 16:43:18.000000000 +1000
@ -50,7 +17,7 @@ diff -up ./gettext-tools/tests/Makefile.am.rpathFix~ ./gettext-tools/tests/Makef
LOCALE_JA='@LOCALE_JA@' \
host_os='@host_os@' \
CONFIG_SHELL='$(SHELL)' \
+ LD_LIBRARY_PATH='../intl/.libs:../src/.libs:../.libs:../../../../../lib:../../../../../lib64' \
+ LD_LIBRARY_PATH='../intl/.libs:../src/.libs:../.libs:' \
$(SHELL)
xg-c-1.ok.po: $(top_srcdir)/src/xgettext.c $(top_srcdir)/src/msgfmt.c