- update to 0.18.1.1 release (#591044)
- gettext-0.17-autopoint-CVS-441481.patch, gettext-0.17-long-long-int-m4.patch gettext-0.17-open-args.patch, and gettext-xgettext-python-unicode-surrogate-473946.patch are upstream - move libintl.jar to lib subpackage to avoid multilib problems (reported by Jim Radford in #595922) - disable java for now - use chrpath to get us out of rpath hell instead of complicated libtool hacks - enable git support
This commit is contained in:
parent
4a263df8ea
commit
ba5423c403
@ -1,24 +0,0 @@
|
||||
2008-04-20 Bruno Haible <bruno@clisp.org>
|
||||
|
||||
* autopoint.in: Check that really all CVS directories are removed.
|
||||
Reported by Jim Meyering <jim@meyering.net>.
|
||||
|
||||
*** gettext-tools/misc/autopoint.in 18 Jan 2008 23:30:16 -0000 1.37
|
||||
--- gettext-tools/misc/autopoint.in 20 Apr 2008 06:06:07 -0000
|
||||
***************
|
||||
*** 426,431 ****
|
||||
--- 426,438 ----
|
||||
cvsver=gettext-`echo "$ver" | sed -e 's/\./_/g'`
|
||||
(cvs checkout -r"$cvsver" archive > /dev/null) 2>&1 | grep -v '^cvs checkout: Updating'
|
||||
find archive -name CVS -type d -print | xargs rm -rf
|
||||
+ # Check that really all CVS directories are gone, otherwise we would overwrite
|
||||
+ # the contents of the user's CVS directories.
|
||||
+ if test `find archive -name CVS -type d -print | wc -l` != 0; then
|
||||
+ cd ..
|
||||
+ rm -rf "$cvs_dir" "$work_dir"
|
||||
+ func_fatal_error "failed to remove all CVS subdirectories"
|
||||
+ fi
|
||||
if test `find archive -type f -print | wc -l` = 0; then
|
||||
cd ..
|
||||
rm -rf "$cvs_dir" "$work_dir"
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -up ./gettext-runtime/libasprintf/configure.ac.rpathFix~ ./gettext-runtime/libasprintf/configure.ac
|
||||
--- ./gettext-runtime/libasprintf/configure.ac.~ 2007-10-08 05:37:36.000000000 +1000
|
||||
+++ ./gettext-runtime/libasprintf/configure.ac 2008-08-28 16:43:18.000000000 +1000
|
||||
@@ -54,7 +54,8 @@ dnl Checks for header files.
|
||||
dnl Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_C_INLINE
|
||||
AC_TYPE_SIZE_T
|
||||
-gl_AC_TYPE_LONG_LONG
|
||||
+AC_TYPE_LONG_LONG_INT
|
||||
+#gl_AC_TYPE_LONG_LONG
|
||||
gt_TYPE_LONGDOUBLE
|
||||
gt_TYPE_WCHAR_T
|
||||
gt_TYPE_WINT_T
|
@ -1,25 +0,0 @@
|
||||
2007-11-07 Jim Meyering <meyering@redhat.com>
|
||||
Bruno Haible <bruno@clisp.org>
|
||||
|
||||
* write-catalog.c (msgdomain_list_print): Fix open() call.
|
||||
|
||||
--- gettext-tools/src/write-catalog.c 7 Oct 2007 19:35:31 -0000 1.4
|
||||
+++ gettext-tools/src/write-catalog.c 7 Nov 2007 11:43:15 -0000
|
||||
@@ -1,5 +1,5 @@
|
||||
/* GNU gettext - internationalization aids
|
||||
- Copyright (C) 1995-1998, 2000-2006 Free Software Foundation, Inc.
|
||||
+ Copyright (C) 1995-1998, 2000-2007 Free Software Foundation, Inc.
|
||||
|
||||
This program is free software: you can redistribute it and/or modify
|
||||
it under the terms of the GNU General Public License as published by
|
||||
@@ -220,7 +220,9 @@
|
||||
/* Open the output file. */
|
||||
if (!to_stdout)
|
||||
{
|
||||
- fd = open (filename, O_WRONLY | O_CREAT);
|
||||
+ fd = open (filename, O_WRONLY | O_CREAT | O_TRUNC,
|
||||
+ /* 0666 in portable POSIX notation: */
|
||||
+ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
|
||||
if (fd < 0)
|
||||
{
|
||||
const char *errno_description = strerror (errno);
|
@ -1,107 +0,0 @@
|
||||
diff -up ./gettext-tools/gnulib-tests/Makefile.gnulib.rpathFix~ ./gettext-tools/gnulib-tests/Makefile.gnulib
|
||||
--- ./gettext-tools/gnulib-tests/Makefile.gnulib.rpathFix~ 2007-10-28 01:39:18.000000000 +1000
|
||||
+++ ./gettext-tools/gnulib-tests/Makefile.gnulib 2008-08-28 16:43:18.000000000 +1000
|
||||
@@ -16,7 +16,7 @@ ACLOCAL_AMFLAGS = -I ../gnulib-m4
|
||||
|
||||
SUBDIRS =
|
||||
TESTS =
|
||||
-TESTS_ENVIRONMENT =
|
||||
+TESTS_ENVIRONMENT = LD_LIBRARY_PATH='../intl/.libs:../src/.libs:../.libs:'
|
||||
noinst_PROGRAMS =
|
||||
check_PROGRAMS =
|
||||
noinst_HEADERS =
|
||||
diff -up ./gettext-tools/tests/Makefile.am.rpathFix~ ./gettext-tools/tests/Makefile.am
|
||||
--- ./gettext-tools/tests/Makefile.am.rpathFix~ 2007-10-21 07:54:40.000000000 +1000
|
||||
+++ ./gettext-tools/tests/Makefile.am 2008-08-28 16:43:18.000000000 +1000
|
||||
@@ -181,6 +181,7 @@ TESTS_ENVIRONMENT = top_srcdir=$(top_src
|
||||
LOCALE_JA='@LOCALE_JA@' \
|
||||
host_os='@host_os@' \
|
||||
CONFIG_SHELL='$(SHELL)' \
|
||||
+ LD_LIBRARY_PATH='../intl/.libs:../src/.libs:../.libs:' \
|
||||
$(SHELL)
|
||||
|
||||
xg-c-1.ok.po: $(top_srcdir)/src/xgettext.c $(top_srcdir)/src/msgfmt.c
|
||||
diff -up ./m4/libtool.m4.rpathFix~ ./m4/libtool.m4
|
||||
--- ./m4/libtool.m4.rpathFix~ 2007-10-27 10:46:10.000000000 +1000
|
||||
+++ ./m4/libtool.m4 2008-08-28 16:43:18.000000000 +1000
|
||||
@@ -1616,7 +1616,7 @@ linux* | k*bsd*-gnu)
|
||||
# This implies no fast_install, which is unacceptable.
|
||||
# Some rework will be needed to allow for fast_install
|
||||
# before this can be enabled.
|
||||
- hardcode_into_libs=yes
|
||||
+ #hardcode_into_libs=yes
|
||||
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
@@ -2872,7 +2872,8 @@ if test "$GXX" = yes; then
|
||||
_LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
|
||||
_LT_AC_TAGVAR(archive_expsym_cmds, $1)='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
|
||||
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath ${wl}$libdir'
|
||||
+# _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath ${wl}$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-L$libdir'
|
||||
_LT_AC_TAGVAR(export_dynamic_flag_spec, $1)='${wl}--export-dynamic'
|
||||
|
||||
# If archive_cmds runs LD, not CC, wlarc should be empty
|
||||
@@ -3340,7 +3341,8 @@ case $host_os in
|
||||
# dependencies.
|
||||
output_verbose_link_cmd='templist=`$CC $CFLAGS -v conftest.$objext -o libconftest$shared_ext 2>&1 | grep "ld"`; rm -f libconftest$shared_ext; list=""; for z in $templist; do case $z in conftest.$objext) list="$list $z";; *.$objext);; *) list="$list $z";;esac; done; echo $list'
|
||||
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath,$libdir'
|
||||
+# _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath,$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-L$libdir'
|
||||
_LT_AC_TAGVAR(export_dynamic_flag_spec, $1)='${wl}--export-dynamic'
|
||||
|
||||
# Archives containing C++ object files must be created using
|
||||
@@ -3368,7 +3370,8 @@ case $host_os in
|
||||
;;
|
||||
esac
|
||||
_LT_AC_TAGVAR(archive_cmds_need_lc, $1)=no
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}-rpath,$libdir'
|
||||
+# _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}-rpath,$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-L$libdir'
|
||||
_LT_AC_TAGVAR(export_dynamic_flag_spec, $1)='${wl}--export-dynamic'
|
||||
_LT_AC_TAGVAR(whole_archive_flag_spec, $1)='${wl}--whole-archive$convenience ${wl}--no-whole-archive'
|
||||
;;
|
||||
@@ -3377,7 +3380,8 @@ case $host_os in
|
||||
_LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname -o $lib'
|
||||
_LT_AC_TAGVAR(archive_expsym_cmds, $1)='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname ${wl}-retain-symbols-file ${wl}$export_symbols -o $lib'
|
||||
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath ${wl}$libdir'
|
||||
+# _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath ${wl}$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-L$libdir'
|
||||
_LT_AC_TAGVAR(export_dynamic_flag_spec, $1)='${wl}--export-dynamic'
|
||||
_LT_AC_TAGVAR(whole_archive_flag_spec, $1)='${wl}--whole-archive`for conv in $convenience\"\"; do test -n \"$conv\" && new_convenience=\"$new_convenience,$conv\"; done; $echo \"$new_convenience\"` ${wl}--no-whole-archive'
|
||||
;;
|
||||
@@ -3387,7 +3391,8 @@ case $host_os in
|
||||
_LT_AC_TAGVAR(archive_expsym_cmds, $1)='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib ${wl}-retain-symbols-file $wl$export_symbols'
|
||||
|
||||
runpath_var=LD_RUN_PATH
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-rpath $libdir'
|
||||
+# _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-rpath $libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-L$libdir'
|
||||
_LT_AC_TAGVAR(hardcode_libdir_separator, $1)=:
|
||||
|
||||
# Commands to make compiler produce verbose output that lists
|
||||
@@ -3584,8 +3589,9 @@ case $host_os in
|
||||
_LT_AC_TAGVAR(allow_undefined_flag, $1)=' ${wl}-expect_unresolved ${wl}\*'
|
||||
_LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared -nostdlib ${allow_undefined_flag} $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-msym ${wl}-soname ${wl}$soname `test -n "$verstring" && echo ${wl}-set_version ${wl}$verstring` ${wl}-update_registry ${wl}${output_objdir}/so_locations -o $lib'
|
||||
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}-rpath ${wl}$libdir'
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_separator, $1)=:
|
||||
+# _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}-rpath ${wl}$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-L$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_separator, $1)=:
|
||||
|
||||
# Commands to make compiler produce verbose output that lists
|
||||
# what "hidden" libraries, object files and flags are used when
|
||||
@@ -5582,7 +5588,8 @@ ifelse([$1],[CXX],[
|
||||
# are reset later if shared libraries are not supported. Putting them
|
||||
# here allows them to be overridden if necessary.
|
||||
runpath_var=LD_RUN_PATH
|
||||
- _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath ${wl}$libdir'
|
||||
+# _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath ${wl}$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-L$libdir'
|
||||
_LT_AC_TAGVAR(export_dynamic_flag_spec, $1)='${wl}--export-dynamic'
|
||||
# ancient GNU ld didn't support --whole-archive et. al.
|
||||
if $LD --help 2>&1 | grep 'no-whole-archive' > /dev/null; then
|
@ -1,23 +0,0 @@
|
||||
2008-08-03 Bruno Haible <bruno@clisp.org>
|
||||
|
||||
* x-python.c (mixed_string_buffer_append): Replace a lone high
|
||||
surrogate with U+FFFD.
|
||||
Reported by Yann <asterix@lagaule.org>
|
||||
via Santiago Vila <sanvila@unex.es>.
|
||||
|
||||
*** gettext-tools/src/x-python.c 20 Apr 2008 05:23:52 -0000 1.32
|
||||
--- gettext-tools/src/x-python.c 3 Aug 2008 19:56:58 -0000
|
||||
***************
|
||||
*** 930,935 ****
|
||||
--- 930,940 ----
|
||||
|
||||
if (c >= UNICODE (0xd800) && c < UNICODE (0xdc00))
|
||||
bp->utf16_surr = UNICODE_VALUE (c);
|
||||
+ else if (c >= UNICODE (0xdc00) && c < UNICODE (0xe000))
|
||||
+ {
|
||||
+ /* A half surrogate is invalid, therefore use U+FFFD instead. */
|
||||
+ mixed_string_buffer_append_unicode (bp, 0xfffd);
|
||||
+ }
|
||||
else
|
||||
mixed_string_buffer_append_unicode (bp, UNICODE_VALUE (c));
|
||||
}
|
69
gettext.spec
69
gettext.spec
@ -1,11 +1,11 @@
|
||||
%bcond_without jar
|
||||
%bcond_without java
|
||||
%bcond_with jar
|
||||
%bcond_with java
|
||||
%bcond_without check
|
||||
|
||||
Summary: GNU libraries and utilities for producing multi-lingual messages
|
||||
Name: gettext
|
||||
Version: 0.17
|
||||
Release: 17%{?dist}
|
||||
Version: 0.18.1.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3 and LGPLv2+
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/gettext/
|
||||
@ -30,16 +30,13 @@ BuildRequires: zip, unzip
|
||||
Buildrequires: expat-devel
|
||||
# for po-mode.el
|
||||
BuildRequires: emacs
|
||||
BuildRequires: git
|
||||
BuildRequires: chrpath
|
||||
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
# for autopoint:
|
||||
Requires: cvs
|
||||
Requires(post): info
|
||||
Requires(preun): info
|
||||
Patch5: gettext-0.17-open-args.patch
|
||||
Patch6: gettext-0.17-autopoint-CVS-441481.patch
|
||||
Patch7: gettext-0.17-rpathFix.patch
|
||||
Patch8: gettext-xgettext-python-unicode-surrogate-473946.patch
|
||||
Patch9: gettext-0.17-long-long-int-m4.patch
|
||||
|
||||
%description
|
||||
The GNU gettext package provides a set of tools and documentation for
|
||||
@ -103,35 +100,25 @@ Emacs.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch5 -p0 -b .5-open-args~
|
||||
%patch6 -p0 -b .6-autopoint~
|
||||
%patch7 -p0 -b .rpathFix~
|
||||
%patch8 -p0 -b .unicode~
|
||||
%patch9 -p0 -b .longlong~
|
||||
|
||||
# necessary for autoconf >= 2.6.2:
|
||||
rm gettext-tools/gnulib-m4/openmp.m4
|
||||
|
||||
./autogen.sh --quick --skip-gnulib
|
||||
|
||||
|
||||
%build
|
||||
[ -f %{_datadir}/automake/depcomp ] && cp -f %{_datadir}/automake/{depcomp,ylwrap} .
|
||||
|
||||
%if %{with java}
|
||||
export JAVAC=gcj
|
||||
%if %{with jar}
|
||||
export JAR=fastjar
|
||||
%endif
|
||||
%endif
|
||||
# --disable-rpath doesn't work properly on lib64
|
||||
%configure --without-included-gettext --enable-nls --disable-static \
|
||||
--enable-shared --with-pic-=yes --disable-csharp \
|
||||
--enable-shared --with-pic-=yes --disable-csharp --disable-rpath \
|
||||
%if %{with java}
|
||||
--enable-java \
|
||||
%else
|
||||
--disable-java --disable-native-java \
|
||||
%endif
|
||||
--disable-rpath
|
||||
--enable-git
|
||||
|
||||
make %{?_smp_mflags} %{?with_java:GCJFLAGS="-findirect-dispatch"}
|
||||
|
||||
|
||||
@ -196,6 +183,13 @@ rm ${RPM_BUILD_ROOT}%{_emacs_sitelispdir}/%{name}/start-po.elc
|
||||
%find_lang %{name}-tools
|
||||
cat %{name}-*.lang > %{name}.lang
|
||||
|
||||
# cleanup rpaths
|
||||
for i in $RPM_BUILD_ROOT%{_bindir}/* `find $RPM_BUILD_ROOT%{_libdir} -type f`; do
|
||||
if file $i | grep "ELF 64-bit" >/dev/null; then
|
||||
chrpath -l $i && chrpath --delete $i
|
||||
fi
|
||||
done
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
@ -203,11 +197,6 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
## For Koji build problem
|
||||
cp ${RPM_BUILD_ROOT}%{_libdir}/libgettext*-%{version}.so ${RPM_BUILD}gettext-tools/src/.libs
|
||||
cp ${RPM_BUILD_ROOT}%{_libdir}/libgettext*-%{version}.so ${RPM_BUILD}gettext-tools/tests/.libs
|
||||
cp ${RPM_BUILD_ROOT}%{_libdir}/libasprintf.so* ${RPM_BUILD}gettext-tools/src/.libs
|
||||
cp ${RPM_BUILD_ROOT}%{_libdir}/libasprintf.so* ${RPM_BUILD}gettext-tools/tests/.libs
|
||||
# this takes quite a lot of time to run
|
||||
make check
|
||||
%endif
|
||||
@ -259,14 +248,10 @@ fi
|
||||
%exclude %{_libdir}/%{name}/gnu.gettext.*
|
||||
%endif
|
||||
%dir %{_datadir}/%{name}
|
||||
%{_datadir}/%{name}/archive.tar.gz
|
||||
%{_datadir}/%{name}/archive.*.tar.gz
|
||||
%{_datadir}/%{name}/intl
|
||||
%{_datadir}/%{name}/po
|
||||
%{_datadir}/%{name}/styles
|
||||
%if %{with jar}
|
||||
%{_datadir}/%{name}/libintl.jar
|
||||
%endif
|
||||
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -294,9 +279,12 @@ fi
|
||||
%files libs
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libasprintf.so.*
|
||||
%{_libdir}/libgettextlib-%{version}.so
|
||||
%{_libdir}/libgettextlib-0.*.so
|
||||
%{_libdir}/libgettextpo.so.*
|
||||
%{_libdir}/libgettextsrc-%{version}.so
|
||||
%{_libdir}/libgettextsrc-0.*.so
|
||||
%if %{with jar}
|
||||
%{_datadir}/%{name}/libintl.jar
|
||||
%endif
|
||||
|
||||
%files -n emacs-%{name}
|
||||
%defattr(-,root,root,-)
|
||||
@ -309,6 +297,17 @@ fi
|
||||
%{_emacs_sitelispdir}/%{name}/*.el
|
||||
|
||||
%changelog
|
||||
* Fri May 21 2010 Jens Petersen <petersen@redhat.com> - 0.18.1.1-1
|
||||
- update to 0.18.1.1 release (#591044)
|
||||
- gettext-0.17-autopoint-CVS-441481.patch, gettext-0.17-long-long-int-m4.patch
|
||||
gettext-0.17-open-args.patch, and
|
||||
gettext-xgettext-python-unicode-surrogate-473946.patch are upstream
|
||||
- move libintl.jar to lib subpackage to avoid multilib problems
|
||||
(reported by Jim Radford in #595922)
|
||||
- disable java for now
|
||||
- use chrpath to get us out of rpath hell instead of complicated libtool hacks
|
||||
- enable git support
|
||||
|
||||
* Fri Apr 23 2010 Jens Petersen <petersen@redhat.com> - 0.17-17
|
||||
- create emacs subpackages for po-mode.el (thanks for patch from
|
||||
Jonathan Underwood, #579452)
|
||||
|
Loading…
Reference in New Issue
Block a user