AC_DEFINE([XML_MAJOR_VERSION], ...) -> AC_DEFINE_UNQUOTED(...)

This commit is contained in:
Nils Philippsen 2007-09-14 13:06:38 +00:00
parent 542a6caf85
commit a4b92ea56d

View File

@ -1,6 +1,6 @@
diff -up gettext-0.16.1/gettext-tools/configure.ac.4-expat~ gettext-0.16.1/gettext-tools/configure.ac
--- gettext-0.16.1/gettext-tools/configure.ac.4-expat~ 2006-11-27 18:02:01.000000000 +0100
+++ gettext-0.16.1/gettext-tools/configure.ac 2007-09-14 13:55:28.000000000 +0200
+++ gettext-0.16.1/gettext-tools/configure.ac 2007-09-14 15:03:43.000000000 +0200
@@ -238,6 +238,22 @@ case "$host_os" in
LTLIBEXPAT="-ldl"
AC_SUBST(LIBEXPAT)
@ -17,7 +17,7 @@ diff -up gettext-0.16.1/gettext-tools/configure.ac.4-expat~ gettext-0.16.1/gette
+ rm -f ./xml_major_version ./xml_major_version.c
+ AC_MSG_RESULT([$XML_MAJOR_VERSION])
+ AC_SUBST(XML_MAJOR_VERSION)
+ AC_DEFINE([XML_MAJOR_VERSION],$XML_MAJOR_VERSION,[The API version of the expat library found during compilation.])
+ AC_DEFINE_UNQUOTED([XML_MAJOR_VERSION],$XML_MAJOR_VERSION,[The API version of the expat library found during compilation.])
+ ],[
+ AC_ERROR([cannot determine version of expat library, expat.h is missing])
+ ])