RHEL 9.0.0 Alpha bootstrap

The content of this branch was automatically imported from Fedora ELN
with the following as its source:
https://src.fedoraproject.org/rpms/gettext#26b1c1422c9c81b394cad698179548d54c197703
This commit is contained in:
Petr Šabata 2020-10-15 00:52:15 +02:00
parent ead4116133
commit 96b3ab176c
9 changed files with 1772 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/gettext-0.*.tar.xz

9
STAGE2-gettext Normal file
View File

@ -0,0 +1,9 @@
#requires bison
#requires libtool
mcd $BUILDDIR/gettext
$SRC/gettext-*/configure $TCONFIGARGS --disable-static --enable-shared --with-pic-=yes --disable-csharp --disable-rpath
make $J
make $J install

View File

@ -0,0 +1,44 @@
From 175e0bc72808d564074c4adcc72aeadb74adfcc6 Mon Sep 17 00:00:00 2001
From: Paul Eggert <eggert@cs.ucla.edu>
Date: Thu, 27 Aug 2020 17:52:58 -0700
Subject: [PATCH] perror, strerror_r: remove unportable tests
Problem reported by Florian Weimer in:
https://lists.gnu.org/r/bug-gnulib/2020-08/msg00220.html
* tests/test-perror2.c (main):
* tests/test-strerror_r.c (main): Omit unportable tests.
---
ChangeLog | 8 ++++++++
tests/test-perror2.c | 3 ---
tests/test-strerror_r.c | 3 ---
3 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/gettext-tools/gnulib-tests/test-perror2.c b/gettext-tools/gnulib-tests/test-perror2.c
index 1d14eda7b..c6214dd25 100644
--- a/gettext-tools/gnulib-tests/test-perror2.c
+++ b/gettext-tools/gnulib-tests/test-perror2.c
@@ -79,9 +79,6 @@ main (void)
errno = -5;
perror ("");
ASSERT (!ferror (stderr));
- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
ASSERT (STREQ (msg4, str4));
free (str1);
diff --git a/gettext-tools/gnulib-tests/test-strerror_r.c b/gettext-tools/gnulib-tests/test-strerror_r.c
index b11d6fd9f..c1dbcf837 100644
--- a/gettext-tools/gnulib-tests/test-strerror_r.c
+++ b/gettext-tools/gnulib-tests/test-strerror_r.c
@@ -165,9 +165,6 @@ main (void)
strerror_r (EACCES, buf, sizeof buf);
strerror_r (-5, buf, sizeof buf);
- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
ASSERT (STREQ (msg4, str4));
free (str1);

View File

@ -0,0 +1,82 @@
From 2336451ed68d91ff4b5ae1acbc1eca30e47a86a9 Mon Sep 17 00:00:00 2001
From: Bruno Haible <bruno@clisp.org>
Date: Sun, 19 May 2019 13:10:06 +0200
Subject: [PATCH] msgmerge: Fix behaviour of --for-msgfmt on PO files with no
translations.
Reported by Don Lawrence <dlawrence@iecok.com>
in <https://lists.freedesktop.org/archives/p11-glue/2019-May/000700.html>
via Daiki Ueno
in <https://lists.gnu.org/archive/html/bug-gettext/2019-05/msg00124.html>.
* gettext-tools/src/msgmerge.c (main): Treat force_po like true if for_msgfmt
is true.
* gettext-tools/tests/msgmerge-26: Add test of PO file with no translations.
---
gettext-tools/src/msgmerge.c | 4 ++--
gettext-tools/tests/msgmerge-26 | 36 ++++++++++++++++++++++++++++++---
2 files changed, 35 insertions(+), 5 deletions(-)
diff --git a/gettext-tools/src/msgmerge.c b/gettext-tools/src/msgmerge.c
index cd762c029..92c9b7a8e 100644
--- a/gettext-tools/src/msgmerge.c
+++ b/gettext-tools/src/msgmerge.c
@@ -520,8 +520,8 @@ There is NO WARRANTY, to the extent permitted by law.\n\
else
{
/* Write the merged message list out. */
- msgdomain_list_print (result, output_file, output_syntax, force_po,
- false);
+ msgdomain_list_print (result, output_file, output_syntax,
+ for_msgfmt || force_po, false);
}
exit (EXIT_SUCCESS);
diff --git a/gettext-tools/tests/msgmerge-26 b/gettext-tools/tests/msgmerge-26
index cd3862e33..b86f7a073 100755
--- a/gettext-tools/tests/msgmerge-26
+++ b/gettext-tools/tests/msgmerge-26
@@ -73,7 +73,37 @@ msgstr "Papaya"
EOF
: ${DIFF=diff}
-${DIFF} mm-test26.ok mm-test26.out
-result=$?
+${DIFF} mm-test26.ok mm-test26.out || Exit 1
-exit $result
+# Test with a PO file that has no translated messages.
+
+cat <<\EOF > mm-test26a.in1
+msgid ""
+msgstr ""
+"Content-Type: text/plain; charset=UTF-8\n"
+
+msgid "Hello world"
+msgstr "Hallo Welt"
+EOF
+
+cat <<\EOF > mm-test26a.in2
+msgid ""
+msgstr ""
+"Content-Type: text/plain; charset=ASCII\n"
+
+msgid "Hello, world!"
+msgstr ""
+EOF
+
+: ${MSGMERGE=msgmerge}
+${MSGMERGE} --for-msgfmt -o mm-test26a.tmp mm-test26a.in1 mm-test26a.in2 \
+ || Exit 1
+LC_ALL=C tr -d '\r' < mm-test26a.tmp > mm-test26a.out || Exit 1
+
+cat <<\EOF > mm-test26a.ok
+msgid ""
+msgstr "Content-Type: text/plain; charset=UTF-8\n"
+EOF
+
+: ${DIFF=diff}
+${DIFF} mm-test26a.ok mm-test26a.out || Exit 1
--
2.21.0

1157
gettext.spec Normal file

File diff suppressed because it is too large Load Diff

45
msghack.1 Normal file
View File

@ -0,0 +1,45 @@
.TH MSGHACK "1" "June 2013" "msghack" "User Commands"
.SH NAME
msghack \- alter PO files in ways
.SH SYNOPSIS
.B msghack
[\fIOPTION\fR] \fIfile.po \fR[\fIref.po\fR]
.SH DESCRIPTION
.PP
This program can be used to alter .po files in ways no sane mind would think about.
.TP
\fB\-o\fR
result will be written to FILE
.TP
\fB\-\-invert\fR
invert a po file by switching msgid and msgstr
.TP
\fB\-\-master\fR
join any number of files in a master\-formatted catalog
.TP
\fB\-\-empty\fR
empty the contents of the .po file, creating a .pot
.TP
\fB\-\-append\fR
append entries from ref.po that don't exist in file.po
.PP
Note: It is just a replacement of msghack for backward support.
.PP
This program can be used to alter .po files in ways no sane mind would think about.
.TP
\fB\-o\fR
result will be written to FILE
.TP
\fB\-\-invert\fR
invert a po file by switching msgid and msgstr
.TP
\fB\-\-master\fR
join any number of files in a master\-formatted catalog
.TP
\fB\-\-empty\fR
empty the contents of the .po file, creating a .pot
.TP
\fB\-\-append\fR
append entries from ref.po that don't exist in file.po
.PP
Note: It is just a replacement of msghack for backward support.

417
msghack.py Executable file
View File

@ -0,0 +1,417 @@
#!/usr/bin/python3
## -*- coding: utf-8 -*-
## Copyright (C) 2001, 2004, 2008, 2012 Red Hat, Inc.
## Copyright (C) 2001 Trond Eivind Glomsrød <teg@redhat.com>
## This program is free software: you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
## the Free Software Foundation, either version 3 of the License, or
## (at your option) any later version.
## This program is distributed in the hope that it will be useful,
## but WITHOUT ANY WARRANTY; without even the implied warranty of
## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
## GNU General Public License for more details.
## You should have received a copy of the GNU General Public License
## along with this program. If not, see <http://www.gnu.org/licenses/>.
"""
A msghack replacement
"""
import sys
class GTMessage:
"""
A class containing a message, its msgid and various references pointing at it
"""
def __init__(self,id=None,message=None,refs=[]):
"""
The constructor for the GTMessage class
@self The object instance
@message The message
@id The messageid associated with the object
"""
self._message=message.strip()
self._id=id.strip()
self._refs=[]
for ref in refs:
self._refs.append(ref)
def __str__(self):
"""
Return a string representation of the object
@self The object instance
"""
res=""
for ref in self._refs:
res=res+ref+"\n"
res=res+"msgid %s\nmsgstr %s\n" % (self._id,self._message)
return res
def invertedStrings(self):
"""
Returns a string representation, but with msgid and msgstr inverted.
Note: Don't invert the "" string
@self The object instance
"""
res=""
for ref in self._refs:
res=res+ref+"\n"
if not self._id=="\"\"":
res=res+"msgid %s\nmsgstr %s\n" % (self._message,self._id)
else:
res=res+"msgid %s\nmsgstr %s\n" % (self._id,self._message)
return res
def emptyMsgStrings(self):
"""
Return a string representation of the object, but leave the msgstr
empty - create a pot file from a po file
Note: Won't remove the "" string
@self The object instance
"""
res=""
for ref in self._refs:
res=res+ref+"\n"
if not self._id=="\"\"":
res=res+"msgid %s\nmsgstr \"\"\n" % (self._id)
else:
res=res+"msgid %s\nmsgstr %s\n" % (self._id,self._message)
return res
def compareMessage(self,msg):
"""
Return if the messages have identical msgids, 0 otherwise
@self The object instance
@msg The message to compare to
"""
if self._id == msg._id:
return 1
return 0
class GTMasterMessage:
"""
A class containing a message, its msgid and various references pointing at it
The difference between GTMessage and GTMasterMessage is that this class
can do less operations, but is able to store multiple msgstrs with identifiers
(usually language, like 'msgst(no)'
"""
def __init__(self,id=None,refs=[]):
"""
The constructor for the GTMessage class
@self The object instance
@id The messageid associated with the object
"""
self._id=id
self._refs=[]
self._messages=[]
for ref in refs:
self._refs.append(ref)
def addMessage(self,message,identifier):
"""
Add a new message and identifier to the GTMasterMessage object
@self The object instance
@message The message to append
@identifier The identifier of the message
"""
self._messages.append((identifier,message))
def __str__(self):
"""
Return a string representation of the object
@self The object instance
"""
res=""
for ref in self._refs:
res=res+ref+"\n"
res=res+"msgid %s\n" % self._id
for message in self._messages:
res=res+"msgstr(%s) %s\n" %(message[0],message[1])
res=res+"\n"
return res
class GTFile:
"""
A class containing the GTMessages contained in a file
"""
def __init__(self,filename):
"""
The constructor of the GTMFile class
@self The object instance
@filename The file to initialize from
"""
self._filename=filename
self._messages=[]
self.readFile(filename)
def __str__(self):
"""
Return a string representation of the object
@self The object instance
"""
res=""
for message in self._messages:
res=res+str(message)+"\n"
return res
def invertedStrings(self):
"""
Return a string representation of the object, with msgid and msgstr
swapped. Will remove duplicates...
@self The object instance
"""
msght={}
msgar=[]
for message in self._messages:
if message._id=='""' and len(msgar)==0:
msgar.append(GTMessage(message._id,message._message,message._refs))
continue
msg=GTMessage(message._message,message._id,message._refs)
if msg._id not in msght:
msght[msg._id]=msg
msgar.append(msg)
else:
msg2=msght[msg._id]
for ref in msg._refs:
msg2._refs.append(ref)
res=""
for message in msgar:
res=res+str(message)+"\n"
return res
def msgidDupes(self):
"""
Search for duplicates in the msgids.
@self The object instance
"""
msgids={}
res=""
for message in self._messages:
msgid=message._id
if msgid in msgids:
res=res+"Duplicate: %s\n" % (msgid)
else:
msgids[msgid]=1
return res
def getMsgstr(self,msgid):
"""
Return the msgstr matching the given id. 'None' if missing
@self The object instance
@msgid The msgid key
"""
for message in self._messages:
if msgid == message._id:
return message._message
return None
def emptyMsgStrings(self):
"""
Return a string representation of the object, but leave the msgstr
empty - create a pot file from a po file
@self The object instance
"""
res=""
for message in self._messages:
res=res+message.emptyMsgStrings()+"\n"
return res
def append(self,B):
"""
Append entries from dictionary B which aren't
already present in this dictionary
@self The object instance
@B the dictionary to append messages from
"""
for message in B._messages:
if not self.getMsgstr(message._id):
self._messages.append(message)
def readFile(self,filename):
"""
Read the contents of a file into the GTFile object
@self The object instance
@filename The name of the file to read
"""
file=open(filename,"r")
msgid=""
msgstr=""
refs=[]
lines=[]
inmsgid=0
inmsgstr=0
templines=file.readlines()
for line in templines:
lines.append(line.strip())
for line in lines:
pos=line.find('"')
pos2=line.rfind('"')
if line and line[0]=="#":
refs.append(line.strip())
if inmsgstr==0 and line[:6]=="msgstr":
msgstr=""
inmsgstr=1
inmsgid=0
if inmsgstr==1:
if pos==-1:
inmsgstr=0
#Handle entries with and without "" consistently
if msgid[:2]=='""' and len(msgid)>4:
msgid=msgid[2:]
if msgstr[:2]=='""' and len(msgstr)>4:
msgstr=msgstr[2:]
message=GTMessage(msgid,msgstr,refs)
self._messages.append(message)
msgstr=""
msgid=""
refs=[]
else:
msgstr=msgstr+line[pos:pos2+1]+"\n"
if inmsgid==0 and line[:5]=="msgid":
msgid=""
inmsgid=1
if inmsgid==1:
if pos==-1:
inmsgid=0
else:
msgid=msgid+line[pos:pos2+1]+"\n"
if msgstr and msgid:
message=GTMessage(msgid,msgstr,refs)
self._messages.append(message)
class GTMaster:
"""
A class containing a master catalogue of gettext dictionaries
"""
def __init__(self,dicts):
"""
The constructor for the GTMaster class
@self The object instance
@dicts An array of dictionaries to merge
"""
self._messages=[]
self.createMaster(dicts)
def createMaster(self,dicts):
"""
Create the master catalogue
@self The object instance
@dicts An array of dictionaries to merge
"""
self._master=dicts[0]
self._dicts=dicts[1:]
for message in self._master._messages:
gtm=GTMasterMessage(message._id,message._refs)
gtm.addMessage(message._message,self._master._filename[:-3])
for dict in self._dicts:
res=dict.getMsgstr(message._id)
if(res):
gtm.addMessage(res,dict._filename[:-3])
self._messages.append(gtm)
def __str__(self):
"""
Return a string representation of the object
@self The object instance
"""
res=""
for message in self._messages:
res=res+str(message)+"\n"
return res
def printUsage():
"Print the usage messages"
print("Usage: " + str(sys.argv[0]) + " [OPTION] file.po [ref.po]\n\
This program can be used to alter .po files in ways no sane mind would think about.\n\
-o result will be written to FILE\n\
--invert invert a po file by switching msgid and msgstr\n\
--master join any number of files in a master-formatted catalog\n\
--empty empty the contents of the .po file, creating a .pot\n\
--append append entries from ref.po that don't exist in file.po\n\
\n\
Note: It is just a replacement of msghack for backward support.\n")
if __name__=="__main__":
output=None
res=None
if("-o") in sys.argv:
if (len(sys.argv)<=sys.argv.index("-o")+1):
print("file.po and ref.po are not specified!\n")
printUsage()
exit(1)
output=sys.argv[sys.argv.index("-o")+1]
sys.argv.remove("-o")
sys.argv.remove(output)
if("--invert") in sys.argv:
if (len(sys.argv)<=sys.argv.index("--invert")+1):
print("file.po is not specified!\n")
printUsage()
exit(1)
file=sys.argv[sys.argv.index("--invert")+1]
gtf=GTFile(file)
res1=gtf.msgidDupes()
if res1:
sys.stderr.write(res1)
sys.exit(1)
res=str(gtf.invertedStrings())
elif("--empty") in sys.argv:
if (len(sys.argv)<=sys.argv.index("--empty")+1):
print("file.po is not specified!\n")
printUsage()
exit(1)
file=sys.argv[sys.argv.index("--empty")+1]
gtf=GTFile(file)
res=str(gtf.emptyMsgStrings())
elif("--master") in sys.argv:
if (len(sys.argv)<=sys.argv.index("--master")+1):
print("file.po is not specified!\n")
printUsage()
exit(1)
loc=sys.argv.index("--master")+1
gtfs=[]
for file in sys.argv[loc:]:
gtfs.append(GTFile(file))
master=GTMaster(gtfs)
res=str(master)
elif("--append") in sys.argv:
if (len(sys.argv)<=sys.argv.index("--append")+2):
print("file.po and/or ref.po are not specified!\n")
printUsage()
exit(1)
file=sys.argv[sys.argv.index("--append")+1]
file2=sys.argv[sys.argv.index("--append")+2]
gtf=GTFile(file)
gtf2=GTFile(file2)
gtf.append(gtf2)
res=str(gtf)
else:
#print("Not implemented: "+str(sys.argv))
printUsage()
sys.exit(1)
if not output:
print(res)
else:
file=open(output,"w")
file.write(res)
sys.exit(0)

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (gettext-0.21.tar.xz) = f7e2968651879f8444d43a176a149db9f9411f4a03132a7f3b37c2ed97e3978ae6888169c995c1953cb78943b6e3573811abcbb8661b6631edbbe067b2699ddf

16
tests/tests.yml Normal file
View File

@ -0,0 +1,16 @@
---
# Tests run on Atomic, Classic and Container
- hosts: localhost
roles:
- role: standard-test-beakerlib
tags:
- atomic
- classic
- container
repositories:
- repo: "https://src.fedoraproject.org/tests/gettext.git"
dest: "gettext"
tests:
- gettext/gettext-tests
required_packages:
- gettext