update to 0.18.2 release
This commit is contained in:
parent
62265d022a
commit
8a2f464e7f
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
gettext-0.18.1.1.tar.gz
|
||||
/gettext-0.18.2.tar.gz
|
||||
|
@ -1,109 +0,0 @@
|
||||
From: Bruno Haible <bruno@clisp.org>
|
||||
Subject: Fix xgettext crash when extracting a message with plural that is excluded.
|
||||
Bug-Debian: http://bugs.debian.org/608181
|
||||
X-Debian-version: 0.18.1.1-4
|
||||
|
||||
--- a/gettext-tools/src/xgettext.c
|
||||
+++ b/gettext-tools/src/xgettext.c
|
||||
@@ -1,5 +1,5 @@
|
||||
/* Extracts strings from C source file to Uniforum style .po file.
|
||||
- Copyright (C) 1995-1998, 2000-2010 Free Software Foundation, Inc.
|
||||
+ Copyright (C) 1995-1998, 2000-2011 Free Software Foundation, Inc.
|
||||
Written by Ulrich Drepper <drepper@gnu.ai.mit.edu>, April 1995.
|
||||
|
||||
This program is free software: you can redistribute it and/or modify
|
||||
@@ -2933,7 +2933,7 @@
|
||||
msgid_context,
|
||||
&best_cp->msgid_pos,
|
||||
NULL, best_cp->msgid_comment);
|
||||
- if (best_cp->msgid_plural != NULL)
|
||||
+ if (mp != NULL && best_cp->msgid_plural != NULL)
|
||||
remember_a_message_plural (mp, best_cp->msgid_plural,
|
||||
msgid_plural_context,
|
||||
&best_cp->msgid_plural_pos,
|
||||
--- a/gettext-tools/src/xgettext.h
|
||||
+++ b/gettext-tools/src/xgettext.h
|
||||
@@ -1,5 +1,5 @@
|
||||
/* xgettext common functions.
|
||||
- Copyright (C) 2001-2003, 2005-2006, 2008-2009 Free Software Foundation, Inc.
|
||||
+ Copyright (C) 2001-2003, 2005-2006, 2008-2009, 2011 Free Software Foundation, Inc.
|
||||
Written by Peter Miller <millerp@canb.auug.org.au>
|
||||
and Bruno Haible <haible@clisp.cons.org>, 2001.
|
||||
|
||||
@@ -247,7 +247,8 @@
|
||||
or NULL.
|
||||
COMMENT may be savable_comment, or it may be a saved copy of savable_comment
|
||||
(then add_reference must be used when saving it, and drop_reference while
|
||||
- dropping it). Clear savable_comment. */
|
||||
+ dropping it). Clear savable_comment.
|
||||
+ Return the new or found message, or NULL if the message is excluded. */
|
||||
extern message_ty *remember_a_message (message_list_ty *mlp,
|
||||
char *msgctxt,
|
||||
char *msgid,
|
||||
--- a/gettext-tools/src/x-smalltalk.c
|
||||
+++ b/gettext-tools/src/x-smalltalk.c
|
||||
@@ -1,5 +1,5 @@
|
||||
/* xgettext Smalltalk backend.
|
||||
- Copyright (C) 2002-2003, 2005-2009 Free Software Foundation, Inc.
|
||||
+ Copyright (C) 2002-2003, 2005-2009, 2011 Free Software Foundation, Inc.
|
||||
|
||||
This file was written by Bruno Haible <haible@clisp.cons.org>, 2002.
|
||||
|
||||
@@ -562,9 +562,10 @@
|
||||
lex_pos_ty pos;
|
||||
pos.file_name = logical_file_name;
|
||||
pos.line_number = token.line_number;
|
||||
- remember_a_message_plural (plural_mp, token.string,
|
||||
- null_context, &pos,
|
||||
- savable_comment);
|
||||
+ if (plural_mp != NULL)
|
||||
+ remember_a_message_plural (plural_mp, token.string,
|
||||
+ null_context, &pos,
|
||||
+ savable_comment);
|
||||
state = 0;
|
||||
break;
|
||||
}
|
||||
--- a/gettext-tools/src/x-ycp.c
|
||||
+++ b/gettext-tools/src/x-ycp.c
|
||||
@@ -1,5 +1,5 @@
|
||||
/* xgettext YCP backend.
|
||||
- Copyright (C) 2001-2003, 2005-2009 Free Software Foundation, Inc.
|
||||
+ Copyright (C) 2001-2003, 2005-2009, 2011 Free Software Foundation, Inc.
|
||||
|
||||
This file was written by Bruno Haible <haible@clisp.cons.org>, 2001.
|
||||
|
||||
@@ -640,6 +640,7 @@
|
||||
bool in_i18n)
|
||||
{
|
||||
int state; /* 1 or 2 inside _( ... ), otherwise 0 */
|
||||
+ int plural_state = 0; /* defined only when in states 1 and 2 */
|
||||
message_ty *plural_mp = NULL; /* defined only when in states 1 and 2 */
|
||||
/* Context iterator that will be used if the next token is a '('. */
|
||||
flag_context_list_iterator_ty next_context_iter =
|
||||
@@ -678,20 +679,22 @@
|
||||
pos.file_name = logical_file_name;
|
||||
pos.line_number = token.line_number;
|
||||
|
||||
- if (plural_mp == NULL)
|
||||
+ if (plural_state == 0)
|
||||
{
|
||||
/* Seen an msgid. */
|
||||
plural_mp = remember_a_message (mlp, NULL, token.string,
|
||||
inner_context, &pos,
|
||||
NULL, token.comment);
|
||||
+ plural_state = 1;
|
||||
state = 2;
|
||||
}
|
||||
else
|
||||
{
|
||||
/* Seen an msgid_plural. */
|
||||
- remember_a_message_plural (plural_mp, token.string,
|
||||
- inner_context, &pos,
|
||||
- token.comment);
|
||||
+ if (plural_mp != NULL)
|
||||
+ remember_a_message_plural (plural_mp, token.string,
|
||||
+ inner_context, &pos,
|
||||
+ token.comment);
|
||||
state = 0;
|
||||
}
|
||||
drop_reference (token.comment);
|
@ -1,13 +0,0 @@
|
||||
--- gnulib-lib/stdio.in.h~ 2010-05-18 04:56:12.000000000 +0900
|
||||
+++ gnulib-lib/stdio.in.h 2012-07-27 17:39:41.812242483 +0900
|
||||
@@ -140,8 +140,10 @@
|
||||
/* It is very rare that the developer ever has full control of stdin,
|
||||
so any use of gets warrants an unconditional warning. Assume it is
|
||||
always declared, since it is required by C89. */
|
||||
+#if defined gets
|
||||
#undef gets
|
||||
_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
+#endif
|
||||
|
||||
#if @GNULIB_FOPEN@
|
||||
# if @REPLACE_FOPEN@
|
@ -1,24 +0,0 @@
|
||||
diff -U 3 -p -r gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-areadlink.h gettext-0.18.1.1/gettext-tools/gnulib-tests/test-areadlink.h
|
||||
--- gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-areadlink.h 2010-02-16 16:32:26.000000000 -0500
|
||||
+++ gettext-0.18.1.1/gettext-tools/gnulib-tests/test-areadlink.h 2011-08-31 16:16:26.325521167 -0400
|
||||
@@ -36,7 +36,7 @@ test_areadlink (char * (*func) (char con
|
||||
ASSERT (errno == ENOENT);
|
||||
errno = 0;
|
||||
ASSERT (func ("", 1) == NULL);
|
||||
- ASSERT (errno == ENOENT);
|
||||
+ ASSERT (errno == ENOENT || errno == EINVAL);
|
||||
errno = 0;
|
||||
ASSERT (func (".", 1) == NULL);
|
||||
ASSERT (errno == EINVAL);
|
||||
diff -U 3 -p -r gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-readlink.h gettext-0.18.1.1/gettext-tools/gnulib-tests/test-readlink.h
|
||||
--- gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-readlink.h 2011-08-31 15:54:15.000000000 -0400
|
||||
+++ gettext-0.18.1.1/gettext-tools/gnulib-tests/test-readlink.h 2011-08-31 16:16:09.325165556 -0400
|
||||
@@ -38,7 +38,7 @@ test_readlink (ssize_t (*func) (char con
|
||||
ASSERT (errno == ENOENT);
|
||||
errno = 0;
|
||||
ASSERT (func ("", buf, sizeof buf) == -1);
|
||||
- ASSERT (errno == ENOENT);
|
||||
+ ASSERT (errno == ENOENT || errno == EINVAL);
|
||||
errno = 0;
|
||||
ASSERT (func (".", buf, sizeof buf) == -1);
|
||||
ASSERT (errno == EINVAL);
|
21
gettext.spec
21
gettext.spec
@ -5,8 +5,8 @@
|
||||
|
||||
Summary: GNU libraries and utilities for producing multi-lingual messages
|
||||
Name: gettext
|
||||
Version: 0.18.1.1
|
||||
Release: 17%{?dist}
|
||||
Version: 0.18.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ and LGPLv2+
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/gettext/
|
||||
@ -48,9 +48,6 @@ Conflicts: filesystem < 3
|
||||
Provides: /bin/gettext
|
||||
# exception for bundled gnulib copylib
|
||||
Provides: bundled(gnulib)
|
||||
Patch1: gettext-readlink-einval.patch
|
||||
Patch2: gettext-0.18.1-fix-xgettext-crash.patch
|
||||
Patch3: gettext-0.18.1.1-stdio-gets.patch
|
||||
|
||||
%description
|
||||
The GNU gettext package provides a set of tools and documentation for
|
||||
@ -136,15 +133,6 @@ Emacs.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .orig
|
||||
%patch2 -p1 -b .crash
|
||||
|
||||
# patch gnulib for deprecated gets()
|
||||
for i in $(find -name stdio.in.h); do
|
||||
cd $(dirname $i)
|
||||
%patch3 -p1 -b .gets
|
||||
cd -
|
||||
done
|
||||
|
||||
|
||||
%build
|
||||
@ -296,7 +284,7 @@ fi
|
||||
%{_datadir}/%{name}/styles
|
||||
|
||||
%files common-devel
|
||||
%{_datadir}/%{name}/archive.*.tar.gz
|
||||
%{_datadir}/%{name}/archive.*.tar.xz
|
||||
|
||||
%files devel
|
||||
%doc gettext-runtime/man/*.3.html ChangeLog
|
||||
@ -339,6 +327,9 @@ fi
|
||||
%{_emacs_sitelispdir}/%{name}/*.el
|
||||
|
||||
%changelog
|
||||
* Wed Dec 26 2012 Daiki Ueno <dueno@redhat.com> - 0.18.2-1
|
||||
- update to 0.18.2 release (based on the spec patch by Jens Petersen)
|
||||
|
||||
* Tue Oct 2 2012 Jens Petersen <petersen@redhat.com> - 0.18.1.1-17
|
||||
- move gettextize to the devel subpackage with its source data files
|
||||
- update msghack to GPL v3
|
||||
|
Loading…
Reference in New Issue
Block a user