Rebuild with gettext-snapshot-20220228 to fix ppc64le and tests
Removed gettext-0.21-gnulib-perror-tests.patch as it is upstreamed. Resolves: rhbz#2045414 Signed-off-by: Sundeep Anand <suanand@redhat.com>
This commit is contained in:
parent
b2e6e951dc
commit
7d0cd2d7e2
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/gettext-0.*.tar.xz
|
/gettext-0.*.tar.xz
|
||||||
|
/gettext-2022-02-28.tar.gz
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
diff --git a/gettext-tools/src/msgl-cat.c b/gettext-tools/src/msgl-cat.c
|
diff --git a/gettext-tools/src/msgl-cat.c b/gettext-tools/src/msgl-cat.c
|
||||||
index 990d39e..9814502 100644
|
index 965cc8c..38c7ca1 100644
|
||||||
--- a/gettext-tools/src/msgl-cat.c
|
--- a/gettext-tools/src/msgl-cat.c
|
||||||
+++ b/gettext-tools/src/msgl-cat.c
|
+++ b/gettext-tools/src/msgl-cat.c
|
||||||
@@ -306,6 +306,7 @@ catenate_msgdomain_list (string_list_ty *file_list,
|
@@ -307,6 +307,7 @@ catenate_msgdomain_list (string_list_ty *file_list,
|
||||||
mp->msgid);
|
mp->msgid);
|
||||||
multiline_error (xstrdup (""),
|
multiline_error (xstrdup (""),
|
||||||
xasprintf ("%s\n", errormsg));
|
xasprintf ("%s\n", errormsg));
|
||||||
@ -11,10 +11,10 @@ index 990d39e..9814502 100644
|
|||||||
}
|
}
|
||||||
else
|
else
|
||||||
diff --git a/gettext-tools/src/x-csharp.c b/gettext-tools/src/x-csharp.c
|
diff --git a/gettext-tools/src/x-csharp.c b/gettext-tools/src/x-csharp.c
|
||||||
index 5cf72ad..7a0e5d3 100644
|
index 13d4a53..669db2f 100644
|
||||||
--- a/gettext-tools/src/x-csharp.c
|
--- a/gettext-tools/src/x-csharp.c
|
||||||
+++ b/gettext-tools/src/x-csharp.c
|
+++ b/gettext-tools/src/x-csharp.c
|
||||||
@@ -560,6 +560,7 @@ comment_line_end (size_t chars_to_remove)
|
@@ -561,6 +561,7 @@ comment_line_end (size_t chars_to_remove)
|
||||||
buffer[buflen] = '\0';
|
buffer[buflen] = '\0';
|
||||||
savable_comment_add (buffer);
|
savable_comment_add (buffer);
|
||||||
lexical_context = lc_outside;
|
lexical_context = lc_outside;
|
||||||
@ -23,10 +23,10 @@ index 5cf72ad..7a0e5d3 100644
|
|||||||
|
|
||||||
|
|
||||||
diff --git a/gettext-tools/src/x-java.c b/gettext-tools/src/x-java.c
|
diff --git a/gettext-tools/src/x-java.c b/gettext-tools/src/x-java.c
|
||||||
index eff1e6f..7e1bb78 100644
|
index e89ab95..6c1b4a7 100644
|
||||||
--- a/gettext-tools/src/x-java.c
|
--- a/gettext-tools/src/x-java.c
|
||||||
+++ b/gettext-tools/src/x-java.c
|
+++ b/gettext-tools/src/x-java.c
|
||||||
@@ -460,6 +460,7 @@ comment_line_end (size_t chars_to_remove)
|
@@ -461,6 +461,7 @@ comment_line_end (size_t chars_to_remove)
|
||||||
--buflen;
|
--buflen;
|
||||||
buffer[buflen] = '\0';
|
buffer[buflen] = '\0';
|
||||||
savable_comment_add (buffer);
|
savable_comment_add (buffer);
|
||||||
@ -35,18 +35,19 @@ index eff1e6f..7e1bb78 100644
|
|||||||
|
|
||||||
|
|
||||||
diff --git a/gettext-tools/src/x-rst.c b/gettext-tools/src/x-rst.c
|
diff --git a/gettext-tools/src/x-rst.c b/gettext-tools/src/x-rst.c
|
||||||
index cde1ee6..fca441e 100644
|
index cde1ee6..82f645f 100644
|
||||||
--- a/gettext-tools/src/x-rst.c
|
--- a/gettext-tools/src/x-rst.c
|
||||||
+++ b/gettext-tools/src/x-rst.c
|
+++ b/gettext-tools/src/x-rst.c
|
||||||
@@ -651,6 +651,7 @@ extract_rsj (FILE *f,
|
@@ -651,6 +651,8 @@ extract_rsj (FILE *f,
|
||||||
else
|
else
|
||||||
goto invalid_rsj;
|
goto invalid_rsj;
|
||||||
|
|
||||||
+ free (s1);
|
+ free (s1);
|
||||||
|
+
|
||||||
/* Parse a comma. */
|
/* Parse a comma. */
|
||||||
c = phase2_getc ();
|
c = phase2_getc ();
|
||||||
if (c == '}')
|
if (c == '}')
|
||||||
@@ -667,6 +668,7 @@ extract_rsj (FILE *f,
|
@@ -667,6 +669,7 @@ extract_rsj (FILE *f,
|
||||||
|
|
||||||
fp = NULL;
|
fp = NULL;
|
||||||
real_file_name = NULL;
|
real_file_name = NULL;
|
||||||
@ -66,3 +67,4 @@ index 06b7076..2189aac 100644
|
|||||||
}
|
}
|
||||||
else
|
else
|
||||||
break;
|
break;
|
||||||
|
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
diff --git a/Makefile.am b/Makefile.am
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
index 815e3c7..e897de7 100644
|
index 764336c..daed715 100644
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -19,7 +19,7 @@
|
@@ -19,7 +19,7 @@
|
||||||
@ -11,16 +11,16 @@ index 815e3c7..e897de7 100644
|
|||||||
|
|
||||||
changelog_etc = \
|
changelog_etc = \
|
||||||
gettext-runtime/ChangeLog.0 \
|
gettext-runtime/ChangeLog.0 \
|
||||||
@@ -123,7 +123,6 @@ distcheck-hook:
|
@@ -85,7 +85,6 @@ distcheck-hook:
|
||||||
test "`sed 1,16d $(srcdir)/gettext-runtime/intl/xsize.h | md5sum`" = "`sed 1,16d $(srcdir)/gettext-tools/gnulib-lib/xsize.h | md5sum`"
|
cmp -s $(srcdir)/gettext-runtime/m4/xsize.m4 $(srcdir)/gettext-tools/gnulib-m4/xsize.m4
|
||||||
cmp -s $(srcdir)/gettext-runtime/man/help2man $(srcdir)/gettext-tools/man/help2man
|
cmp -s $(srcdir)/gettext-runtime/man/help2man $(srcdir)/gettext-tools/man/help2man
|
||||||
cmp -s $(srcdir)/gettext-runtime/man/x-to-1.in $(srcdir)/gettext-tools/man/x-to-1.in
|
cmp -s $(srcdir)/gettext-runtime/man/x-to-1.in $(srcdir)/gettext-tools/man/x-to-1.in
|
||||||
- cmp -s $(srcdir)/libtextstyle/m4/libtextstyle.m4 $(srcdir)/gettext-tools/gnulib-m4/libtextstyle.m4
|
- cmp -s $(srcdir)/libtextstyle/m4/libtextstyle.m4 $(srcdir)/gettext-tools/gnulib-m4/libtextstyle.m4
|
||||||
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.java $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.java
|
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.java $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.java
|
||||||
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.class $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.class
|
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.class $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.class
|
||||||
test "`sed 1,15d $(srcdir)/gnulib-local/lib/alloca.in.h | md5sum`" = "`sed 1,15d $(srcdir)/gettext-runtime/libasprintf/alloca.in.h | md5sum`"
|
# Verify that all files have appropriate copyright headers.
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
index 49689fb..2d23b44 100644
|
index f4e54ea..ff850ae 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -37,7 +37,7 @@ dnl Checks for typedefs, structures, and compiler characteristics.
|
@@ -37,7 +37,7 @@ dnl Checks for typedefs, structures, and compiler characteristics.
|
||||||
@ -42,23 +42,23 @@ index 49689fb..2d23b44 100644
|
|||||||
AC_CONFIG_FILES([Makefile])
|
AC_CONFIG_FILES([Makefile])
|
||||||
|
|
||||||
diff --git a/gettext-tools/Makefile.am b/gettext-tools/Makefile.am
|
diff --git a/gettext-tools/Makefile.am b/gettext-tools/Makefile.am
|
||||||
index 449a797..c5719c2 100644
|
index 90f5548..cdf2834 100644
|
||||||
--- a/gettext-tools/Makefile.am
|
--- a/gettext-tools/Makefile.am
|
||||||
+++ b/gettext-tools/Makefile.am
|
+++ b/gettext-tools/Makefile.am
|
||||||
@@ -19,7 +19,7 @@
|
@@ -19,7 +19,7 @@
|
||||||
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
||||||
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
|
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
|
||||||
|
|
||||||
-SUBDIRS = intl gnulib-lib libgrep src libgettextpo po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
|
-SUBDIRS = gnulib-lib libgrep src libgettextpo po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
|
||||||
+SUBDIRS = intl gnulib-lib libgrep libgettextpo src po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
|
+SUBDIRS = gnulib-lib libgrep libgettextpo src po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
|
||||||
|
|
||||||
EXTRA_DIST = misc/DISCLAIM
|
EXTRA_DIST = misc/DISCLAIM
|
||||||
MOSTLYCLEANFILES = core *.stackdump
|
MOSTLYCLEANFILES = core *.stackdump
|
||||||
diff --git a/gettext-tools/libgettextpo/textstyle.in.h b/gettext-tools/libgettextpo/textstyle.in.h
|
diff --git a/gettext-tools/libgettextpo/textstyle.in.h b/gettext-tools/libgettextpo/textstyle.in.h
|
||||||
index 536b51b..585ce66 100644
|
index 60015bd..ae5f5fb 100644
|
||||||
--- a/gettext-tools/libgettextpo/textstyle.in.h
|
--- a/gettext-tools/libgettextpo/textstyle.in.h
|
||||||
+++ b/gettext-tools/libgettextpo/textstyle.in.h
|
+++ b/gettext-tools/libgettextpo/textstyle.in.h
|
||||||
@@ -213,7 +213,8 @@ typedef ostream_t file_ostream_t;
|
@@ -239,7 +239,8 @@ typedef ostream_t file_ostream_t;
|
||||||
static inline file_ostream_t
|
static inline file_ostream_t
|
||||||
file_ostream_create (FILE *fp)
|
file_ostream_create (FILE *fp)
|
||||||
{
|
{
|
||||||
@ -68,7 +68,7 @@ index 536b51b..585ce66 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* --------------------------- From fd-ostream.h --------------------------- */
|
/* --------------------------- From fd-ostream.h --------------------------- */
|
||||||
@@ -413,6 +414,30 @@ html_styled_ostream_create (ostream_t destination _GL_UNUSED,
|
@@ -439,6 +440,30 @@ html_styled_ostream_create (_GL_ATTRIBUTE_MAYBE_UNUSED ostream_t destination,
|
||||||
return NULL;
|
return NULL;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -100,10 +100,10 @@ index 536b51b..585ce66 100644
|
|||||||
|
|
||||||
#define color_test_mode false
|
#define color_test_mode false
|
||||||
diff --git a/gettext-tools/src/Makefile.am b/gettext-tools/src/Makefile.am
|
diff --git a/gettext-tools/src/Makefile.am b/gettext-tools/src/Makefile.am
|
||||||
index 764ffad..eccfbbd 100644
|
index f5e52ea..a9c9fac 100644
|
||||||
--- a/gettext-tools/src/Makefile.am
|
--- a/gettext-tools/src/Makefile.am
|
||||||
+++ b/gettext-tools/src/Makefile.am
|
+++ b/gettext-tools/src/Makefile.am
|
||||||
@@ -292,19 +292,9 @@ cldr_plurals_SOURCES = cldr-plural.y cldr-plural-exp.c cldr-plurals.c
|
@@ -300,19 +300,9 @@ cldr_plurals_SOURCES = cldr-plural.y cldr-plural-exp.c cldr-plurals.c
|
||||||
cldr_plurals_CFLAGS = $(AM_CFLAGS) $(INCXML)
|
cldr_plurals_CFLAGS = $(AM_CFLAGS) $(INCXML)
|
||||||
cldr_plurals_LDADD = libgettextsrc.la $(LDADD)
|
cldr_plurals_LDADD = libgettextsrc.la $(LDADD)
|
||||||
|
|
||||||
@ -126,3 +126,4 @@ index 764ffad..eccfbbd 100644
|
|||||||
|
|
||||||
# How to build libgettextsrc.la.
|
# How to build libgettextsrc.la.
|
||||||
# Need ../gnulib-lib/libgettextlib.la.
|
# Need ../gnulib-lib/libgettextlib.la.
|
||||||
|
|
||||||
|
@ -1,44 +0,0 @@
|
|||||||
From 175e0bc72808d564074c4adcc72aeadb74adfcc6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Paul Eggert <eggert@cs.ucla.edu>
|
|
||||||
Date: Thu, 27 Aug 2020 17:52:58 -0700
|
|
||||||
Subject: [PATCH] perror, strerror_r: remove unportable tests
|
|
||||||
|
|
||||||
Problem reported by Florian Weimer in:
|
|
||||||
https://lists.gnu.org/r/bug-gnulib/2020-08/msg00220.html
|
|
||||||
* tests/test-perror2.c (main):
|
|
||||||
* tests/test-strerror_r.c (main): Omit unportable tests.
|
|
||||||
---
|
|
||||||
ChangeLog | 8 ++++++++
|
|
||||||
tests/test-perror2.c | 3 ---
|
|
||||||
tests/test-strerror_r.c | 3 ---
|
|
||||||
3 files changed, 8 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/gettext-tools/gnulib-tests/test-perror2.c b/gettext-tools/gnulib-tests/test-perror2.c
|
|
||||||
index 1d14eda7b..c6214dd25 100644
|
|
||||||
--- a/gettext-tools/gnulib-tests/test-perror2.c
|
|
||||||
+++ b/gettext-tools/gnulib-tests/test-perror2.c
|
|
||||||
@@ -79,9 +79,6 @@ main (void)
|
|
||||||
errno = -5;
|
|
||||||
perror ("");
|
|
||||||
ASSERT (!ferror (stderr));
|
|
||||||
- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
|
|
||||||
- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
|
|
||||||
- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
|
|
||||||
ASSERT (STREQ (msg4, str4));
|
|
||||||
|
|
||||||
free (str1);
|
|
||||||
diff --git a/gettext-tools/gnulib-tests/test-strerror_r.c b/gettext-tools/gnulib-tests/test-strerror_r.c
|
|
||||||
index b11d6fd9f..c1dbcf837 100644
|
|
||||||
--- a/gettext-tools/gnulib-tests/test-strerror_r.c
|
|
||||||
+++ b/gettext-tools/gnulib-tests/test-strerror_r.c
|
|
||||||
@@ -165,9 +165,6 @@ main (void)
|
|
||||||
|
|
||||||
strerror_r (EACCES, buf, sizeof buf);
|
|
||||||
strerror_r (-5, buf, sizeof buf);
|
|
||||||
- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
|
|
||||||
- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
|
|
||||||
- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
|
|
||||||
ASSERT (STREQ (msg4, str4));
|
|
||||||
|
|
||||||
free (str1);
|
|
||||||
|
|
29
gettext.spec
29
gettext.spec
@ -1,10 +1,13 @@
|
|||||||
%bcond_with jar
|
%bcond_with jar
|
||||||
%bcond_with java
|
%bcond_with java
|
||||||
|
%global snapshot 2022-02-28
|
||||||
|
|
||||||
Summary: GNU libraries and utilities for producing multi-lingual messages
|
Summary: GNU libraries and utilities for producing multi-lingual messages
|
||||||
Name: gettext
|
Name: gettext
|
||||||
Version: 0.21
|
Version: 0.21
|
||||||
Release: 10%{?dist}
|
# Snapshot date not included in version and in release to avoid build errors.
|
||||||
|
Release: 11%{?dist}.0.20220228
|
||||||
|
|
||||||
# The following are licensed under LGPLv2+:
|
# The following are licensed under LGPLv2+:
|
||||||
# - libintl and its headers
|
# - libintl and its headers
|
||||||
# - libasprintf and its headers
|
# - libasprintf and its headers
|
||||||
@ -20,19 +23,19 @@ Release: 10%{?dist}
|
|||||||
# Everything else is GPLv3+
|
# Everything else is GPLv3+
|
||||||
License: GPLv3+ and LGPLv2+ and GFDL
|
License: GPLv3+ and LGPLv2+ and GFDL
|
||||||
URL: https://www.gnu.org/software/gettext/
|
URL: https://www.gnu.org/software/gettext/
|
||||||
Source: https://ftp.gnu.org/pub/gnu/gettext/%{name}-%{version}.tar.xz
|
# Source tarball has been extracted from below URL.
|
||||||
|
# https://gitlab.com/gnu-gettext/ci-distcheck/-/jobs/artifacts/master/raw/gettext-snapshot.tar?job=check-optimized
|
||||||
|
Source: %{name}-%{snapshot}.tar.gz
|
||||||
Source2: msghack.py
|
Source2: msghack.py
|
||||||
Source3: msghack.1
|
Source3: msghack.1
|
||||||
|
|
||||||
# https://lists.gnu.org/archive/html/bug-gnulib/2020-07/msg00195.html
|
Patch1: gettext-0.21-disable-libtextstyle.patch
|
||||||
Patch1: gettext-0.21-gnulib-perror-tests.patch
|
Patch2: gettext-0.21-covscan.patch
|
||||||
Patch2: gettext-0.21-disable-libtextstyle.patch
|
|
||||||
Patch3: gettext-0.21-covscan.patch
|
|
||||||
|
|
||||||
# for bootstrapping
|
# for bootstrapping
|
||||||
# BuildRequires: autoconf >= 2.62
|
# BuildRequires: autoconf >= 2.62
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
# BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
# BuildRequires: bison
|
# BuildRequires: bison
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -157,10 +160,10 @@ think about.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -S git
|
%autosetup -n %{name}-%{snapshot} -S git
|
||||||
# Refresh autotools files to latest versions
|
# Refresh autotools files to latest versions
|
||||||
# Should be removed after 0.21:
|
# Should be removed after 0.21:
|
||||||
autoreconf --force
|
autoreconf --force --install
|
||||||
|
|
||||||
# Defeat libtextstyle attempt to bundle libxml2. The comments
|
# Defeat libtextstyle attempt to bundle libxml2. The comments
|
||||||
# indicate this is done because the libtextstyle authors do not want
|
# indicate this is done because the libtextstyle authors do not want
|
||||||
@ -353,8 +356,8 @@ make check LIBUNISTRING=-lunistring
|
|||||||
%files libs
|
%files libs
|
||||||
%{_libdir}/libasprintf.so.0*
|
%{_libdir}/libasprintf.so.0*
|
||||||
%{_libdir}/libgettextpo.so.0*
|
%{_libdir}/libgettextpo.so.0*
|
||||||
%{_libdir}/libgettextlib-0.*.so
|
%{_libdir}/libgettextlib-*.so
|
||||||
%{_libdir}/libgettextsrc-0.*.so
|
%{_libdir}/libgettextsrc-*.so
|
||||||
%if %{with jar}
|
%if %{with jar}
|
||||||
%{_datadir}/%{name}/libintl.jar
|
%{_datadir}/%{name}/libintl.jar
|
||||||
%endif
|
%endif
|
||||||
@ -371,6 +374,10 @@ make check LIBUNISTRING=-lunistring
|
|||||||
%{_mandir}/man1/msghack.1*
|
%{_mandir}/man1/msghack.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 3 2022 Sundeep Anand <suanand@redhat.com> - 0.21-11
|
||||||
|
- Rebuild with gettext-snapshot-20220228 to fix ppc64le and tests (#2045414)
|
||||||
|
Removed gettext-0.21-gnulib-perror-tests.patch as it is upstreamed.
|
||||||
|
|
||||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-10
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-10
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gettext-0.21.tar.xz) = f7e2968651879f8444d43a176a149db9f9411f4a03132a7f3b37c2ed97e3978ae6888169c995c1953cb78943b6e3573811abcbb8661b6631edbbe067b2699ddf
|
SHA512 (gettext-2022-02-28.tar.gz) = abfce9e0aa0945ee3dc7fd559da2d475f7efefc3b1d322009fbadd33f1e5853dae749ebfde535b38c09bf00100d47b3709eb258870dbb9b43a7c228b8737c0a2
|
||||||
|
Loading…
Reference in New Issue
Block a user