Port Gnulib test fixes from upstream
This commit is contained in:
parent
e3ec4313fc
commit
26b1c1422c
44
gettext-0.21-gnulib-perror-tests.patch
Normal file
44
gettext-0.21-gnulib-perror-tests.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
From 175e0bc72808d564074c4adcc72aeadb74adfcc6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Paul Eggert <eggert@cs.ucla.edu>
|
||||||
|
Date: Thu, 27 Aug 2020 17:52:58 -0700
|
||||||
|
Subject: [PATCH] perror, strerror_r: remove unportable tests
|
||||||
|
|
||||||
|
Problem reported by Florian Weimer in:
|
||||||
|
https://lists.gnu.org/r/bug-gnulib/2020-08/msg00220.html
|
||||||
|
* tests/test-perror2.c (main):
|
||||||
|
* tests/test-strerror_r.c (main): Omit unportable tests.
|
||||||
|
---
|
||||||
|
ChangeLog | 8 ++++++++
|
||||||
|
tests/test-perror2.c | 3 ---
|
||||||
|
tests/test-strerror_r.c | 3 ---
|
||||||
|
3 files changed, 8 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/gettext-tools/gnulib-tests/test-perror2.c b/gettext-tools/gnulib-tests/test-perror2.c
|
||||||
|
index 1d14eda7b..c6214dd25 100644
|
||||||
|
--- a/gettext-tools/gnulib-tests/test-perror2.c
|
||||||
|
+++ b/gettext-tools/gnulib-tests/test-perror2.c
|
||||||
|
@@ -79,9 +79,6 @@ main (void)
|
||||||
|
errno = -5;
|
||||||
|
perror ("");
|
||||||
|
ASSERT (!ferror (stderr));
|
||||||
|
- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
|
||||||
|
- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
|
||||||
|
- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
|
||||||
|
ASSERT (STREQ (msg4, str4));
|
||||||
|
|
||||||
|
free (str1);
|
||||||
|
diff --git a/gettext-tools/gnulib-tests/test-strerror_r.c b/gettext-tools/gnulib-tests/test-strerror_r.c
|
||||||
|
index b11d6fd9f..c1dbcf837 100644
|
||||||
|
--- a/gettext-tools/gnulib-tests/test-strerror_r.c
|
||||||
|
+++ b/gettext-tools/gnulib-tests/test-strerror_r.c
|
||||||
|
@@ -165,9 +165,6 @@ main (void)
|
||||||
|
|
||||||
|
strerror_r (EACCES, buf, sizeof buf);
|
||||||
|
strerror_r (-5, buf, sizeof buf);
|
||||||
|
- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
|
||||||
|
- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
|
||||||
|
- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
|
||||||
|
ASSERT (STREQ (msg4, str4));
|
||||||
|
|
||||||
|
free (str1);
|
||||||
|
|
11
gettext.spec
11
gettext.spec
@ -4,7 +4,7 @@
|
|||||||
Summary: GNU libraries and utilities for producing multi-lingual messages
|
Summary: GNU libraries and utilities for producing multi-lingual messages
|
||||||
Name: gettext
|
Name: gettext
|
||||||
Version: 0.21
|
Version: 0.21
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
# The following are licensed under LGPLv2+:
|
# The following are licensed under LGPLv2+:
|
||||||
# - libintl and its headers
|
# - libintl and its headers
|
||||||
# - libasprintf and its headers
|
# - libasprintf and its headers
|
||||||
@ -27,6 +27,9 @@ Source3: msghack.1
|
|||||||
# this patch has merged upstream
|
# this patch has merged upstream
|
||||||
# Patch1: gettext-msgmerge-for-msgfmt.patch
|
# Patch1: gettext-msgmerge-for-msgfmt.patch
|
||||||
|
|
||||||
|
# https://lists.gnu.org/archive/html/bug-gnulib/2020-07/msg00195.html
|
||||||
|
Patch1: gettext-0.21-gnulib-perror-tests.patch
|
||||||
|
|
||||||
# for bootstrapping
|
# for bootstrapping
|
||||||
# BuildRequires: autoconf >= 2.62
|
# BuildRequires: autoconf >= 2.62
|
||||||
# BuildRequires: automake
|
# BuildRequires: automake
|
||||||
@ -287,10 +290,7 @@ cat %{name}-*.lang > %{name}.lang
|
|||||||
export LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$PWD/gettext-tools/intl/.libs
|
export LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$PWD/gettext-tools/intl/.libs
|
||||||
|
|
||||||
# override LIBUNISTRING to prevent reordering of lib objects
|
# override LIBUNISTRING to prevent reordering of lib objects
|
||||||
# FIXME: https://lists.gnu.org/archive/html/bug-gnulib/2020-07/msg00195.html
|
|
||||||
%ifnarch armv7hl
|
|
||||||
make check LIBUNISTRING=-lunistring
|
make check LIBUNISTRING=-lunistring
|
||||||
%endif
|
|
||||||
|
|
||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets libs
|
||||||
|
|
||||||
@ -395,6 +395,9 @@ make check LIBUNISTRING=-lunistring
|
|||||||
%{_mandir}/man1/msghack.1*
|
%{_mandir}/man1/msghack.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 7 2020 Sundeep Anand <suanand@redhat.com> - 0.21-3
|
||||||
|
- include patch to fix gnulib perror tests (rhbz#1867021)
|
||||||
|
|
||||||
* Thu Aug 6 2020 Jens Petersen <petersen@redhat.com> - 0.21-2
|
* Thu Aug 6 2020 Jens Petersen <petersen@redhat.com> - 0.21-2
|
||||||
- reenable testsuite except for armv7hl which is failing
|
- reenable testsuite except for armv7hl which is failing
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user