- add buildjar switch for building of libintl.jar
- lots of spec file cleanup (Mamoru Tasaka, #225791): - preserve timestamps of installed files - disable building of static library - use %%find_lang for .mo files - remove examples from -devel package - do not own en@*quot locale dirs - set preloadable_libintl.so executable - add ChangeLog to -devel package - add %%check to run make check - add gettext-tools-tests-lang-gawk-fail.patch to work around gawk test failure
This commit is contained in:
parent
2bbc47f153
commit
1030a52443
30
gettext-tools-tests-lang-gawk-fail.patch
Normal file
30
gettext-tools-tests-lang-gawk-fail.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -u gettext-0.16.1/gettext-tools/tests/lang-gawk~ gettext-0.16.1/gettext-tools/tests/lang-gawk
|
||||||
|
--- gettext-0.16.1/gettext-tools/tests/lang-gawk~ 2007-03-13 14:45:22.000000000 +1000
|
||||||
|
+++ gettext-0.16.1/gettext-tools/tests/lang-gawk 2007-03-13 14:45:22.000000000 +1000
|
||||||
|
@@ -152,16 +152,16 @@
|
||||||
|
EUR remplace FF.
|
||||||
|
EOF
|
||||||
|
|
||||||
|
-: ${LOCALE_FR=fr_FR}
|
||||||
|
-: ${LOCALE_FR_UTF8=fr_FR.UTF-8}
|
||||||
|
-if test $LOCALE_FR != none; then
|
||||||
|
- LANGUAGE= LC_ALL=$LOCALE_FR gawk -v n=2 -f prog.awk > prog.out || exit 1
|
||||||
|
- ${DIFF} prog.ok prog.out || exit 1
|
||||||
|
-fi
|
||||||
|
-if test $LOCALE_FR_UTF8 != none; then
|
||||||
|
- LANGUAGE= LC_ALL=$LOCALE_FR_UTF8 gawk -v n=2 -f prog.awk > prog.out || exit 1
|
||||||
|
- ${DIFF} prog.oku prog.out || exit 1
|
||||||
|
-fi
|
||||||
|
+#: ${LOCALE_FR=fr_FR}
|
||||||
|
+#: ${LOCALE_FR_UTF8=fr_FR.UTF-8}
|
||||||
|
+#if test $LOCALE_FR != none; then
|
||||||
|
+# LANGUAGE= LC_ALL=$LOCALE_FR gawk -v n=2 -f prog.awk > prog.out || exit 1
|
||||||
|
+# ${DIFF} prog.ok prog.out || exit 1
|
||||||
|
+#fi
|
||||||
|
+#if test $LOCALE_FR_UTF8 != none; then
|
||||||
|
+# LANGUAGE= LC_ALL=$LOCALE_FR_UTF8 gawk -v n=2 -f prog.awk > prog.out || exit 1
|
||||||
|
+# ${DIFF} prog.oku prog.out || exit 1
|
||||||
|
+#fi
|
||||||
|
|
||||||
|
rm -fr $tmpfiles
|
||||||
|
|
116
gettext.spec
116
gettext.spec
@ -1,22 +1,29 @@
|
|||||||
Summary: GNU libraries and utilities for producing multi-lingual messages.
|
# libintl.jar now requires gcj >= 4.3 to build
|
||||||
|
%define buildjar 0
|
||||||
|
|
||||||
|
Summary: GNU libraries and utilities for producing multi-lingual messages
|
||||||
Name: gettext
|
Name: gettext
|
||||||
Version: 0.16.1
|
Version: 0.16.1
|
||||||
Release: 5%{?dist}
|
Release: 5.2%{?dist}
|
||||||
License: GPL/LGPL
|
License: GPL/LGPL
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
|
Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
|
||||||
URL: http://www.gnu.org/software/gettext/
|
URL: http://www.gnu.org/software/gettext/
|
||||||
Source1: po-mode-init.el
|
Source1: po-mode-init.el
|
||||||
Source2: msghack.py
|
Source2: msghack.py
|
||||||
Prereq: /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
|
Requires(preun): /sbin/install-info
|
||||||
%ifarch x86_64 ppc64 s390x
|
%ifarch x86_64 ppc64 s390x
|
||||||
BuildRequires: automake >= 1.8, autoconf >= 2.5
|
BuildRequires: automake >= 1.8, autoconf >= 2.5
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: libtool, bison, gcc-c++, gcc-java, libgcj
|
BuildRequires: libtool, bison, gcc-c++, gcc-java, libgcj
|
||||||
|
%if %{buildjar}
|
||||||
BuildRequires: %{_bindir}/fastjar
|
BuildRequires: %{_bindir}/fastjar
|
||||||
# require zip and unzip for brp-java-repack-jars
|
# require zip and unzip for brp-java-repack-jars
|
||||||
BuildRequires: zip, unzip
|
BuildRequires: zip, unzip
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
%endif
|
||||||
|
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
Patch1: gettext-tools-tests-lang-gawk-fail.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The GNU gettext package provides a set of tools and documentation for
|
The GNU gettext package provides a set of tools and documentation for
|
||||||
@ -37,8 +44,9 @@ Group: Development/Tools
|
|||||||
License: LGPL
|
License: LGPL
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: cvs
|
Requires: cvs
|
||||||
Provides: devel(libintl)
|
Requires(post): /sbin/install-info
|
||||||
PreReq: /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
|
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package contains all development related files necessary for
|
This package contains all development related files necessary for
|
||||||
@ -49,21 +57,25 @@ want to add gettext support for your project.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .1-fails~
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
[ -f %{_datadir}/automake/depcomp ] && cp -f %{_datadir}/automake/{depcomp,ylwrap} .
|
[ -f %{_datadir}/automake/depcomp ] && cp -f %{_datadir}/automake/{depcomp,ylwrap} .
|
||||||
|
|
||||||
|
export JAVAC=gcj
|
||||||
|
%if %{buildjar}
|
||||||
export JAR=fastjar
|
export JAR=fastjar
|
||||||
%configure --without-included-gettext --enable-nls \
|
%endif
|
||||||
--enable-shared --with-pic-=yes --disable-csharp --enable-java
|
%configure --without-included-gettext --enable-nls --disable-static \
|
||||||
make
|
--enable-shared --with-pic-=yes --disable-csharp --enable-java
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
make install DESTDIR=${RPM_BUILD_ROOT} INSTALL="%{__install} -p" \
|
||||||
%makeinstall lispdir=${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp \
|
lispdir=${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp \
|
||||||
aclocaldir=${RPM_BUILD_ROOT}%{_datadir}/aclocal
|
aclocaldir=${RPM_BUILD_ROOT}%{_datadir}/aclocal
|
||||||
|
|
||||||
# move gettext to /bin
|
# move gettext to /bin
|
||||||
@ -71,19 +83,10 @@ mkdir -p ${RPM_BUILD_ROOT}/bin
|
|||||||
mv ${RPM_BUILD_ROOT}%{_bindir}/gettext ${RPM_BUILD_ROOT}/bin
|
mv ${RPM_BUILD_ROOT}%{_bindir}/gettext ${RPM_BUILD_ROOT}/bin
|
||||||
ln -s ../../bin/gettext ${RPM_BUILD_ROOT}%{_bindir}/gettext
|
ln -s ../../bin/gettext ${RPM_BUILD_ROOT}%{_bindir}/gettext
|
||||||
|
|
||||||
install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}/%{_bindir}/msghack
|
install -pm 755 %SOURCE2 ${RPM_BUILD_ROOT}/%{_bindir}/msghack
|
||||||
|
|
||||||
rm ${RPM_BUILD_ROOT}%{_infodir}/dir
|
rm ${RPM_BUILD_ROOT}%{_infodir}/dir
|
||||||
|
|
||||||
rm -f $RPM_BUILD_DIR/%{name}-%{version}/trans.list
|
|
||||||
pushd %{buildroot}/%{_datadir}/locale
|
|
||||||
for foo in `find . -maxdepth 1 -mindepth 1 -type d` ; do
|
|
||||||
lang=`echo $foo | cut -c 3-`
|
|
||||||
echo "%lang($lang) %{_datadir}/locale/$foo/*/*" >> \
|
|
||||||
$RPM_BUILD_DIR/%{name}-%{version}/trans.list
|
|
||||||
done
|
|
||||||
popd
|
|
||||||
|
|
||||||
mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/site-start.d
|
mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/site-start.d
|
||||||
install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/site-start.d
|
install -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/site-start.d
|
||||||
|
|
||||||
@ -93,27 +96,41 @@ for i in gettext-runtime/man/*.html; do
|
|||||||
done
|
done
|
||||||
rm -r ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext/javadoc*
|
rm -r ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext/javadoc*
|
||||||
|
|
||||||
rm -rf htmldoc examples
|
rm -rf ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext/examples
|
||||||
|
|
||||||
|
rm -rf htmldoc
|
||||||
mkdir htmldoc
|
mkdir htmldoc
|
||||||
mv ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext/examples examples
|
|
||||||
mv ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext/* ${RPM_BUILD_ROOT}/%{_datadir}/doc/libasprintf/* htmldoc
|
mv ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext/* ${RPM_BUILD_ROOT}/%{_datadir}/doc/libasprintf/* htmldoc
|
||||||
rm -r ${RPM_BUILD_ROOT}%{_datadir}/doc/libasprintf
|
rm -r ${RPM_BUILD_ROOT}%{_datadir}/doc/libasprintf
|
||||||
rm -r ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext
|
rm -r ${RPM_BUILD_ROOT}%{_datadir}/doc/gettext
|
||||||
|
|
||||||
# set examples ChangeLog timestamp for brp-java-repack-jars
|
## note libintl.jar is not actually built now with gcj < 4.3
|
||||||
|
## since it would not be fully portable
|
||||||
|
%if %{buildjar}
|
||||||
|
## this is probably no longer needed if examples not packaged
|
||||||
|
# set timestamp of examples ChangeLog timestamp for brp-java-repack-jars
|
||||||
for i in `find ${RPM_BUILD_ROOT} examples -newer ChangeLog -type f -name ChangeLog`; do
|
for i in `find ${RPM_BUILD_ROOT} examples -newer ChangeLog -type f -name ChangeLog`; do
|
||||||
touch -r ChangeLog $i
|
touch -r ChangeLog $i
|
||||||
done
|
done
|
||||||
|
%endif
|
||||||
|
|
||||||
# remove unpackaged files from the buildroot
|
# remove unpackaged files from the buildroot
|
||||||
rm -r ${RPM_BUILD_ROOT}%{_datadir}/emacs
|
rm -r ${RPM_BUILD_ROOT}%{_datadir}/emacs
|
||||||
rm ${RPM_BUILD_ROOT}%{_libdir}/lib*.la
|
rm ${RPM_BUILD_ROOT}%{_libdir}/lib*.la
|
||||||
|
|
||||||
|
%find_lang %{name}-runtime
|
||||||
|
%find_lang %{name}-tools
|
||||||
|
cat %{name}-*.lang > %{name}.lang
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
make check
|
||||||
|
|
||||||
|
|
||||||
%define install_info /sbin/install-info
|
%define install_info /sbin/install-info
|
||||||
%define remove_install_info /sbin/install-info --delete
|
%define remove_install_info /sbin/install-info --delete
|
||||||
|
|
||||||
@ -130,8 +147,7 @@ fi
|
|||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
|
|
||||||
%postun
|
%postun -p /sbin/ldconfig
|
||||||
/sbin/ldconfig
|
|
||||||
|
|
||||||
|
|
||||||
%post devel
|
%post devel
|
||||||
@ -145,12 +161,11 @@ if [ "$1" = 0 ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
||||||
%postun devel
|
%postun devel -p /sbin/ldconfig
|
||||||
/sbin/ldconfig
|
|
||||||
|
|
||||||
|
|
||||||
%files -f trans.list
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
|
%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
|
||||||
%doc COPYING gettext-tools/misc/DISCLAIM README
|
%doc COPYING gettext-tools/misc/DISCLAIM README
|
||||||
%doc NEWS THANKS
|
%doc NEWS THANKS
|
||||||
@ -160,28 +175,23 @@ fi
|
|||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
%exclude %{_bindir}/autopoint
|
%exclude %{_bindir}/autopoint
|
||||||
%exclude %{_bindir}/gettextize
|
%exclude %{_bindir}/gettextize
|
||||||
|
|
||||||
# These aren't in glibc...
|
|
||||||
%dir %{_datadir}/locale/en@boldquot
|
|
||||||
%dir %{_datadir}/locale/en@boldquot/LC_MESSAGES
|
|
||||||
%dir %{_datadir}/locale/en@quot
|
|
||||||
%dir %{_datadir}/locale/en@quot/LC_MESSAGES
|
|
||||||
|
|
||||||
%{_libdir}/libgettextlib-%{version}.so
|
%{_libdir}/libgettextlib-%{version}.so
|
||||||
%{_libdir}/libgettextsrc-%{version}.so
|
%{_libdir}/libgettextsrc-%{version}.so
|
||||||
%{_libdir}/preloadable_libintl.so
|
%attr(755,root,root) %{_libdir}/preloadable_libintl.so
|
||||||
%{_infodir}/gettext*
|
%{_infodir}/gettext*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%exclude %{_mandir}/man1/gettextize.1.gz
|
%exclude %{_mandir}/man1/gettextize.1.gz
|
||||||
%exclude %{_mandir}/man1/autopoint.1.gz
|
%exclude %{_mandir}/man1/autopoint.1.gz
|
||||||
#%config %{_libdir}/charset.alias
|
|
||||||
%{_libdir}/%{name}
|
%{_libdir}/%{name}
|
||||||
%exclude %{_libdir}/%{name}/gnu.gettext.*
|
%exclude %{_libdir}/%{name}/gnu.gettext.*
|
||||||
#%%{_datadir}/%{name}/libintl.jar
|
%if %{buildjar}
|
||||||
|
%{_datadir}/%{name}/libintl.jar
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%doc gettext-runtime/man/*.3.html examples
|
%doc gettext-runtime/man/*.3.html ChangeLog
|
||||||
%dir %{_datadir}/%{name}
|
%dir %{_datadir}/%{name}
|
||||||
%dir %{_datadir}/%{name}/projects
|
%dir %{_datadir}/%{name}/projects
|
||||||
%{_bindir}/gettextize
|
%{_bindir}/gettextize
|
||||||
@ -197,7 +207,6 @@ fi
|
|||||||
%{_datadir}/aclocal/*
|
%{_datadir}/aclocal/*
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_infodir}/autosprintf*
|
%{_infodir}/autosprintf*
|
||||||
%{_libdir}/lib*.a
|
|
||||||
%{_libdir}/libasprintf.so*
|
%{_libdir}/libasprintf.so*
|
||||||
%{_libdir}/libgettextpo.so*
|
%{_libdir}/libgettextpo.so*
|
||||||
%{_libdir}/libgettextlib.so
|
%{_libdir}/libgettextlib.so
|
||||||
@ -211,6 +220,19 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 13 2007 Jens Petersen <petersen@redhat.com> - 0.16.1-6
|
||||||
|
- add buildjar switch for building of libintl.jar
|
||||||
|
- lots of spec file cleanup (Mamoru Tasaka, #225791):
|
||||||
|
- preserve timestamps of installed files
|
||||||
|
- disable building of static library
|
||||||
|
- use %%find_lang for .mo files
|
||||||
|
- remove examples from -devel package
|
||||||
|
- do not own en@*quot locale dirs
|
||||||
|
- set preloadable_libintl.so executable
|
||||||
|
- add ChangeLog to -devel package
|
||||||
|
- add %%check to run make check
|
||||||
|
- add gettext-tools-tests-lang-gawk-fail.patch to work around gawk test failure
|
||||||
|
|
||||||
* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 0.16.1-5
|
* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 0.16.1-5
|
||||||
- rebuild to pick up dependency on libgcj.so.8rh instead libgcj.so.7rh
|
- rebuild to pick up dependency on libgcj.so.8rh instead libgcj.so.7rh
|
||||||
|
|
||||||
@ -291,14 +313,14 @@ fi
|
|||||||
|
|
||||||
* Wed Dec 01 2004 Leon Ho <llch@redhat.com>
|
* Wed Dec 01 2004 Leon Ho <llch@redhat.com>
|
||||||
- Add env var to redirect use fastjar instead of jar
|
- Add env var to redirect use fastjar instead of jar
|
||||||
- BuildRequires %{_bindir}/fastjar and libgcj
|
- BuildRequires fastjar and libgcj
|
||||||
|
|
||||||
* Mon Nov 01 2004 Leon Ho <llch@redhat.com>
|
* Mon Nov 01 2004 Leon Ho <llch@redhat.com>
|
||||||
- fix call on phase0_getc()
|
- fix call on phase0_getc()
|
||||||
- fix temp file issue (#136323 - CAN-2004-0966 - mjc)
|
- fix temp file issue (#136323 - CAN-2004-0966 - mjc)
|
||||||
|
|
||||||
* Sun Oct 03 2004 Leon Ho <llch@redhat.com>
|
* Sun Oct 03 2004 Leon Ho <llch@redhat.com>
|
||||||
- fixed typo on %preun on -devel
|
- fixed typo on %%preun on -devel
|
||||||
|
|
||||||
* Fri Oct 01 2004 Leon Ho <llch@redhat.com>
|
* Fri Oct 01 2004 Leon Ho <llch@redhat.com>
|
||||||
- fix install_info
|
- fix install_info
|
||||||
@ -455,7 +477,7 @@ fi
|
|||||||
at Japanese locale.
|
at Japanese locale.
|
||||||
|
|
||||||
* Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
|
* Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
|
||||||
- fixed the %lang generator to not have "./" in the lang
|
- fixed the %%lang generator to not have "./" in the lang
|
||||||
|
|
||||||
* Sun Jan 14 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
* Sun Jan 14 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||||
- add an init file for the emacs po-mode
|
- add an init file for the emacs po-mode
|
||||||
@ -463,7 +485,7 @@ fi
|
|||||||
|
|
||||||
* Thu Jan 11 2001 Bill Nottingham <notting@redhat.com>
|
* Thu Jan 11 2001 Bill Nottingham <notting@redhat.com>
|
||||||
- put gettext in /bin for initscripts use
|
- put gettext in /bin for initscripts use
|
||||||
- %langify
|
- %%langify
|
||||||
|
|
||||||
* Fri Dec 29 2000 Bill Nottingham <notting@redhat.com>
|
* Fri Dec 29 2000 Bill Nottingham <notting@redhat.com>
|
||||||
- prereq /sbin/install-info
|
- prereq /sbin/install-info
|
||||||
|
Loading…
Reference in New Issue
Block a user