fix EINVAL issue on recent kernels and add some optional BRs
This commit is contained in:
parent
519c6c9021
commit
0d49b3fc37
24
gettext-readlink-einval.patch
Normal file
24
gettext-readlink-einval.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -U 3 -p -r gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-areadlink.h gettext-0.18.1.1/gettext-tools/gnulib-tests/test-areadlink.h
|
||||
--- gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-areadlink.h 2010-02-16 16:32:26.000000000 -0500
|
||||
+++ gettext-0.18.1.1/gettext-tools/gnulib-tests/test-areadlink.h 2011-08-31 16:16:26.325521167 -0400
|
||||
@@ -36,7 +36,7 @@ test_areadlink (char * (*func) (char con
|
||||
ASSERT (errno == ENOENT);
|
||||
errno = 0;
|
||||
ASSERT (func ("", 1) == NULL);
|
||||
- ASSERT (errno == ENOENT);
|
||||
+ ASSERT (errno == ENOENT || errno == EINVAL);
|
||||
errno = 0;
|
||||
ASSERT (func (".", 1) == NULL);
|
||||
ASSERT (errno == EINVAL);
|
||||
diff -U 3 -p -r gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-readlink.h gettext-0.18.1.1/gettext-tools/gnulib-tests/test-readlink.h
|
||||
--- gettext-0.18.1.1.orig/gettext-tools/gnulib-tests/test-readlink.h 2011-08-31 15:54:15.000000000 -0400
|
||||
+++ gettext-0.18.1.1/gettext-tools/gnulib-tests/test-readlink.h 2011-08-31 16:16:09.325165556 -0400
|
||||
@@ -38,7 +38,7 @@ test_readlink (ssize_t (*func) (char con
|
||||
ASSERT (errno == ENOENT);
|
||||
errno = 0;
|
||||
ASSERT (func ("", buf, sizeof buf) == -1);
|
||||
- ASSERT (errno == ENOENT);
|
||||
+ ASSERT (errno == ENOENT || errno == EINVAL);
|
||||
errno = 0;
|
||||
ASSERT (func (".", buf, sizeof buf) == -1);
|
||||
ASSERT (errno == EINVAL);
|
18
gettext.spec
18
gettext.spec
@ -27,8 +27,6 @@ BuildRequires: %{_bindir}/fastjar
|
||||
BuildRequires: zip, unzip
|
||||
%endif
|
||||
%endif
|
||||
# need expat for xgettext on glade
|
||||
Buildrequires: expat-devel
|
||||
# for po-mode.el
|
||||
BuildRequires: emacs
|
||||
%if %{with git}
|
||||
@ -36,10 +34,16 @@ BuildRequires: emacs
|
||||
BuildRequires: git
|
||||
%endif
|
||||
BuildRequires: chrpath
|
||||
#build requires gtk2 its pulled in automatically on some arches but not all.
|
||||
BuildRequires: gtk2
|
||||
# following suggested by DEPENDENCIES:
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: expat-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libcroco-devel
|
||||
BuildRequires: libunistring-devel
|
||||
Requires(post): info
|
||||
Requires(preun): info
|
||||
Patch1: gettext-readlink-einval.patch
|
||||
|
||||
%description
|
||||
The GNU gettext package provides a set of tools and documentation for
|
||||
@ -125,6 +129,7 @@ Emacs.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .orig
|
||||
|
||||
|
||||
%build
|
||||
@ -328,8 +333,9 @@ fi
|
||||
%{_emacs_sitelispdir}/%{name}/*.el
|
||||
|
||||
%changelog
|
||||
* Wed Jun 08 2011 Dennis Gilmore <dennis@ausil.us> - 0.18.1.1-8
|
||||
- explicitly BuildRequire gtk2
|
||||
* Wed Sep 28 2011 Jens Petersen <petersen@redhat.com> - 0.18.1.1-8
|
||||
- add gettext-readlink-einval.patch to fix build on kernel >= 2.6.39 (#739188)
|
||||
- add optional buildrequires suggested in the DEPENDENCIES file
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18.1.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user